Loading ...
Sorry, an error occurred while loading the content.

postfix/sasl: sql_select option missing - wtf?

Expand Messages
  • Christian Parpart
    Hi all, I really don t know what sql is related here, but I neither a uncommented sql string in the main.cf nor /etc/sasl/smtpd.conf, although, I don t know
    Message 1 of 2 , May 31, 2007
    • 0 Attachment
      Hi all,

      I really don't know what sql is related here, but I neither a uncommented sql
      string in the main.cf nor /etc/sasl/smtpd.conf, although, I don't know who
      exactly is complaining here. is it because SASL wants to load the sql plugin,
      or is it postfix (didn't know it has one).

      However, when trying to google for this error messsage, I can find alot, but
      nothing related to me, as I definitely want NOT to use sql in any of these
      cases, but I still keep getting this error (don't know how to suppress):

      May 31 13:28:42 sparta postfix/smtpd[13371]: sql_select option missing
      May 31 13:28:42 sparta postfix/smtpd[13371]: _sasl_plugin_load failed on
      sasl_auxprop_plug_init for plugin: sql

      of course, "sql_select" statement is missing because I did not specify it
      somewhere - in fact, do don't even want to load the sql plugin get loaded it
      tries to load anyway. But where is it specified? can't find any hint
      (unfortunately).

      Please let me know if you need some configs to help me tracking down this
      issue...

      Many thanks,
      Christian Parpart.
    • Patrick Ben Koetter
      ... Remove libsql from the /usr/lib/sasl2 directory. p@rick ... -- The Book of Postfix saslfinger (debugging SMTP AUTH):
      Message 2 of 2 , May 31, 2007
      • 0 Attachment
        * Christian Parpart <trapni@...>:
        > Hi all,
        >
        > I really don't know what sql is related here, but I neither a uncommented sql
        > string in the main.cf nor /etc/sasl/smtpd.conf, although, I don't know who
        > exactly is complaining here. is it because SASL wants to load the sql plugin,
        > or is it postfix (didn't know it has one).
        >
        > However, when trying to google for this error messsage, I can find alot, but
        > nothing related to me, as I definitely want NOT to use sql in any of these
        > cases, but I still keep getting this error (don't know how to suppress):
        >
        > May 31 13:28:42 sparta postfix/smtpd[13371]: sql_select option missing
        > May 31 13:28:42 sparta postfix/smtpd[13371]: _sasl_plugin_load failed on
        > sasl_auxprop_plug_init for plugin: sql

        Remove libsql from the /usr/lib/sasl2 directory.

        p@rick



        >
        > of course, "sql_select" statement is missing because I did not specify it
        > somewhere - in fact, do don't even want to load the sql plugin get loaded it
        > tries to load anyway. But where is it specified? can't find any hint
        > (unfortunately).
        >
        > Please let me know if you need some configs to help me tracking down this
        > issue...
        >
        > Many thanks,
        > Christian Parpart.



        --
        The Book of Postfix
        <http://www.postfix-book.com>
        saslfinger (debugging SMTP AUTH):
        <http://postfix.state-of-mind.de/patrick.koetter/saslfinger/>
      Your message has been successfully submitted and would be delivered to recipients shortly.