Loading ...
Sorry, an error occurred while loading the content.

Correct smtp auth config...

Expand Messages
  • Charles Marcus
    Hello, I just want to be sure I am clear on this... smtpd_sasl_auth is for incoming connections (ie, if one of my users wants to be able to send mail remotely
    Message 1 of 2 , May 1, 2007
    • 0 Attachment
      Hello,

      I just want to be sure I am clear on this...

      smtpd_sasl_auth is for incoming connections (ie, if one of my users
      wants to be able to send mail remotely from their home connections), and

      smtp_sasl_auth is for postfix's outgoing/relay capability, ie, if I want
      to relay outgoing mail through my ISPs smtp server and they require
      authentication

      Is this correct?

      Also, am I correct that in order to switch from using a relayhost that
      doesn't require auth (specified just as:

      relayhost = [smtp.domain.com]

      I would:

      1. comment out the relayhost setting in main.cf

      2. enable:

      smtp_sasl_auth_enable = yes
      smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd

      3. Put the necessary entries in sasl_passwd

      4. postmap the file, then

      5. reload postfix?

      --

      Best regards,

      Charles
    • Magnus Bäck
      On Tuesday, May 01, 2007 at 18:07 CEST, ... Yes. ... Yes, that s the procedure to disable the relayhost and enable client-side SMTP authentication. Question
      Message 2 of 2 , May 1, 2007
      • 0 Attachment
        On Tuesday, May 01, 2007 at 18:07 CEST,
        Charles Marcus <CMarcus@...> wrote:

        > I just want to be sure I am clear on this...
        >
        > smtpd_sasl_auth is for incoming connections (ie, if one of my users
        > wants to be able to send mail remotely from their home connections), and
        >
        > smtp_sasl_auth is for postfix's outgoing/relay capability, ie, if I
        > want to relay outgoing mail through my ISPs smtp server and they
        > require authentication
        >
        > Is this correct?

        Yes.

        > Also, am I correct that in order to switch from using a relayhost that
        > doesn't require auth (specified just as:
        >
        > relayhost = [smtp.domain.com]
        >
        > I would:
        >
        > 1. comment out the relayhost setting in main.cf
        >
        > 2. enable:
        >
        > smtp_sasl_auth_enable = yes
        > smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
        >
        > 3. Put the necessary entries in sasl_passwd
        >
        > 4. postmap the file, then
        >
        > 5. reload postfix?

        Yes, that's the procedure to disable the relayhost and enable
        client-side SMTP authentication. Question is, is that really
        what you want to do? Why would you disable the relayhost?
        smtp_sasl_password_maps only sets the username/password when
        Postfix has chosen to route the message to a certain host.
        You still need to set relayhost if you want to relay messages
        via your ISP.

        --
        Magnus Bäck
        magnus@...
      Your message has been successfully submitted and would be delivered to recipients shortly.