Loading ...
Sorry, an error occurred while loading the content.

Re: "lost connection with domain while sending end of data -- message may be sent more than once"

Expand Messages
  • Wietse Venema
    ... On Solaris you don t need the patch. Postfix keepalives are already turned on to work around kernel bugs. However 7200000 milliseconds is two hours and
    Message 1 of 10 , May 1, 2007
    • 0 Attachment
      Hargis, Mandy:
      > > ndd -get /dev/tcp tcp_keepalive_interval
      > 7200000

      On Solaris you don't need the patch. Postfix keepalives are already
      turned on to work around kernel bugs.

      However 7200000 milliseconds is two hours and that won't make a
      difference of the problem is caused by NAT boxes with too short
      timeouts. Try 10s and see if it makes a difference.

      ndd -set /dev/tcp tcp_keepalive_interval 10000

      > I have not installed the Postfix patch that you provided in the separate
      > message. I'm just wondering how my inbound SMTP servers could have been
      > running for three + years without this patch or problem. How could it
      > be necessary all of a sudden?

      I suppose that if Postfix didn't change, then something else did.
      Either this, or the problem already existed and you just didn't
      know about it....

      If you experience this problem with many sites, then it is
      very likely that the problem is at your end of the world.

      This is another reason why I suspect that something in your
      infrastructure was changed recently.

      Wietse
    Your message has been successfully submitted and would be delivered to recipients shortly.