Loading ...
Sorry, an error occurred while loading the content.

Re: Setting up to send mail

Expand Messages
  • Charles Marcus
    ... (I ve been trying to help him privately, both because of the help I received from this list when I first started with postfix, and for my own learning
    Message 1 of 15 , May 1 3:24 AM
    • 0 Attachment
      Wietse Venema wrote:
      > Wade Smart:
      >> relayhost = [smtpout.secureserver.net]:3535

      > Why are you sending mail for yahoo etc. to smtpout.secureserver.net?

      (I've been trying to help him privately, both because of the help I
      received from this list when I first started with postfix, and for my
      own learning experience)

      He has a different setup...

      1. His mail is hosted by Godaddy. Godaddy is authoritative for his
      domain, wadesmart.com

      2. His local postfix box is also what he uses as his workstation.

      3. He uses fetchmail to retrieve mail from his hosted Godaddy mail
      server to his local server/workstation, running postfix (and dovecot for
      providing imap access).

      So, again, his local machine that is running postfix is *not* the
      authoritative server for his domain - he is using fetchmail/postfix
      (I've never used fetchmail either, so not sure what is required in
      postfix config to make them work together either) to grab all of his
      email from where it is hosted at Godaddy.

      This setup is not something I've ever even done/thought about, so I'm
      not sure how to help him...

      He wants his local postfix, which is running on his workstation machine,
      to be able to relay all outbound mail being sent locally through
      Godaddys smtp server. smtp.secureserver.net is the host Godaddy gave him
      for sending mail using their smtp server remotely, so I assumed that he
      should set it up like mine is here, since we do the same thing and it is
      working fine - as the relayhost.

      > That machine doesn't want such mail.

      It should - it is what he was given to use for sending mail remotely.

      >> Apr 30 17:18:56 wadesmart postfix/smtp[18874]: B0E5F14284D1:
      >> to=<wadesmart@...>,
      >> orig_to=<wade@...>,
      >> relay=smtpout.secureserver.net[64.202.165.58]:3535,

      > List mail.wadesmart.com in main.cf:mydestination.

      But wouldn't he only do that if this box was authoritative for that domain?

      I'm confused by this, since he is essentially only using this postfix as
      a relay for outbound mail.

      --

      Best regards,

      Charles
    • Charles Marcus
      ... Also - DNSStuff is showing problems with his MX records: WARN MX records are not CNAMEs WARNING: When I looked up your MX record, your DNS server returned
      Message 2 of 15 , May 1 3:34 AM
      • 0 Attachment
        > Apr 30 17:18:56 wadesmart postfix/smtp[18874]: B0E5F14284D1:
        > to=<wadesmart@...>,
        > orig_to=<wade@...>,
        > relay=smtpout.secureserver.net[64.202.165.58]:3535,

        Also - DNSStuff is showing problems with his MX records:

        WARN MX records are not CNAMEs WARNING: When I looked up your MX record,
        your DNS server returned a CNAME. This is an unusual situation, and I
        can't handle it -- the following MX tests may not work properly. The
        problem is:
        smtp.secureserver.net.->smtp.where.secureserver.net.
        FAIL MX A lookups have no CNAMEs WARNING: One or more of your MX records
        points to a CNAME. CNAMEs are prohibited in MX records, according to
        RFC974, RFC1034 3.6.2, RFC1912 2.4, and RFC2181 10.3. The problem MX
        record(s) are:
        smtp.secureserver.net.->smtp.where.secureserver.net.->64.202.166.12

        Remember, secureserver.net is apparently Godaddys servers...

        --

        Best regards,

        Charles
      • Wietse Venema
        Charles Marcus: [ Charset ISO-8859-1 unsupported, converting... ] ... Good luck helping him, am I not going to try to interfere with invisible off-list
        Message 3 of 15 , May 1 4:06 AM
        • 0 Attachment
          Charles Marcus:
          [ Charset ISO-8859-1 unsupported, converting... ]
          > Wietse Venema wrote:
          > > Wade Smart:
          > >> relayhost = [smtpout.secureserver.net]:3535
          >
          > > Why are you sending mail for yahoo etc. to smtpout.secureserver.net?
          >
          > (I've been trying to help him privately, both because of the help I
          > received from this list when I first started with postfix, and for my
          > own learning experience)
          >
          > He has a different setup...
          >
          > 1. His mail is hosted by Godaddy. Godaddy is authoritative for his
          > domain, wadesmart.com
          >
          > 2. His local postfix box is also what he uses as his workstation.
          >
          > 3. He uses fetchmail to retrieve mail from his hosted Godaddy mail
          > server to his local server/workstation, running postfix (and dovecot for
          > providing imap access).
          >
          > So, again, his local machine that is running postfix is *not* the
          > authoritative server for his domain - he is using fetchmail/postfix
          > (I've never used fetchmail either, so not sure what is required in
          > postfix config to make them work together either) to grab all of his
          > email from where it is hosted at Godaddy.
          >
          > This setup is not something I've ever even done/thought about, so I'm
          > not sure how to help him...
          >
          > He wants his local postfix, which is running on his workstation machine,
          > to be able to relay all outbound mail being sent locally through
          > Godaddys smtp server. smtp.secureserver.net is the host Godaddy gave him
          > for sending mail using their smtp server remotely, so I assumed that he
          > should set it up like mine is here, since we do the same thing and it is
          > working fine - as the relayhost.
          >
          > > That machine doesn't want such mail.
          >
          > It should - it is what he was given to use for sending mail remotely.
          >
          > >> Apr 30 17:18:56 wadesmart postfix/smtp[18874]: B0E5F14284D1:
          > >> to=<wadesmart@...>,
          > >> orig_to=<wade@...>,
          > >> relay=smtpout.secureserver.net[64.202.165.58]:3535,
          >
          > > List mail.wadesmart.com in main.cf:mydestination.
          >
          > But wouldn't he only do that if this box was authoritative for that domain?
          >
          > I'm confused by this, since he is essentially only using this postfix as
          > a relay for outbound mail.

          Good luck helping him, am I not going to try to interfere
          with invisible off-list assistance.

          Wietse
        • Charles Marcus
          ... I went off-list with him because of the chilly reception he got when he first posted here. I posted his details because he didn t do a very good job, even
          Message 4 of 15 , May 1 5:40 AM
          • 0 Attachment
            > Good luck helping him, am I not going to try to interfere with
            > invisible off-list assistance.

            I went off-list with him because of the chilly reception he got when he
            first posted here.

            I posted his details because he didn't do a very good job, even the
            second time. He didn't seem to be aware that the way he is trying to use
            postfix isn't a standard setup.

            I did this in the hopes that someone here might actually take a minute
            and point him (or me) in the right direction.

            Sometimes you (and others on this list) are a bit arrogant in your
            treatment of people who don't exhibit an acceptably (to you) advanced
            level of knowledge and expertise, but that is your right, and I'm not
            complaining about it.

            Is there a postfix support list that is a little more forgiving, and
            willing to help people new to postfix (specifically), and mail server
            administration (in general)?

            If not, I guess we'll just keep plugging away, and hopefully eventually
            get there.

            --

            Best regards,

            Charles
          • Wietse Venema
            ... Apparently I am too demanding when I expect that people follow simple step-by-step instructions when reporting a problem. ... Again, good luck. Don t let
            Message 5 of 15 , May 1 6:12 AM
            • 0 Attachment
              Charles Marcus:
              > > Good luck helping him, am I not going to try to interfere with
              > > invisible off-list assistance.
              >
              > I went off-list with him because of the chilly reception he got when he
              > first posted here.
              >
              > I posted his details because he didn't do a very good job, even the
              > second time. He didn't seem to be aware that the way he is trying to use
              > postfix isn't a standard setup.
              >
              > I did this in the hopes that someone here might actually take a minute
              > and point him (or me) in the right direction.

              Apparently I am too demanding when I expect that people follow
              simple step-by-step instructions when reporting a problem.

              > Sometimes you (and others on this list) are a bit arrogant in your
              > treatment of people who don't exhibit an acceptably (to you) advanced
              > level of knowledge and expertise, but that is your right, and I'm not
              > complaining about it.
              >
              > Is there a postfix support list that is a little more forgiving, and
              > willing to help people new to postfix (specifically), and mail server
              > administration (in general)?
              >
              > If not, I guess we'll just keep plugging away, and hopefully eventually
              > get there.

              Again, good luck. Don't let my arrogance get in the way.

              Wietse
            • Jorey Bump
              ... If the list is unforgiving, it has as much to do with the topic matter as anything else. It turns out that running a mail server *does* require an advanced
              Message 6 of 15 , May 1 6:13 AM
              • 0 Attachment
                Charles Marcus wrote:

                > Sometimes you (and others on this list) are a bit arrogant in your
                > treatment of people who don't exhibit an acceptably (to you) advanced
                > level of knowledge and expertise, but that is your right, and I'm not
                > complaining about it.
                >
                > Is there a postfix support list that is a little more forgiving, and
                > willing to help people new to postfix (specifically), and mail server
                > administration (in general)?

                If the list is unforgiving, it has as much to do with the topic matter
                as anything else. It turns out that running a mail server *does* require
                an advanced level of knowledge and expertise, and perhaps novices are
                roughly encouraged to get up to speed before assuming the responsibility
                of managing a public server, especially if they want a solution 'Today'.
                Sadly, a poorly managed mail server soon becomes a problem for the
                rest of us, and there is no acceptable level of 'almost working'. So,
                put on your bulletproof vest, show that you are doing your research
                (submitting proper error reports indicates you've read the
                documentation), and you'll benefit from the knowledge base available on
                this list (I know I do). You're unlikely to find the same level of
                quality anywhere else on the topic of Postfix, or even general
                SMTP-related issues. The developers actively participate and even
                provide patches (!) to solve proven issues. You don't often see that
                level of dedication in a project, free or not.
              • Wade Smart
                OK WOOOO. This is getting crazy. This isnt a public server. Its my own private computer. And as stated, I have been reading material attempting to get up to
                Message 7 of 15 , May 1 7:32 AM
                • 0 Attachment
                  OK WOOOO. This is getting crazy.

                  This isnt a public server. Its my own private computer.
                  And as stated, I have been reading material attempting to get up to speed.
                  And this hasnt been an overnight deal but a year long deal.

                  Everyone just needs to chill out. Cool off.

                  Did I submit improper error reports?

                  I know you expect everyone to know exactly how to do something just
                  because they moved to linux, but its just not the fact. Im reading the
                  error logs, Im looking for problems, Im reading the documentation, Im
                  asking for help, Im getting help but I am still having problems.

                  Ill restate my problem so its clear.
                  My HOME machine I use just for my own email, I want to setup postfix on.
                  I am running into problems sending mail.
                  Charles helped me before I got on the list.
                  I added mail.wadesmart.com to my main.cf file.
                  I contacted GoDaddy about the DNS issue.
                  My connection to the net is through my cable company.
                  My domain name is wadesmart.com
                  My computer name is wadesmart.
                  I use fetchmail to get the mail.

                  wade


                  On 5/1/07, Jorey Bump <list@...> wrote:
                  > Charles Marcus wrote:
                  >
                  > > Sometimes you (and others on this list) are a bit arrogant in your
                  > > treatment of people who don't exhibit an acceptably (to you) advanced
                  > > level of knowledge and expertise, but that is your right, and I'm not
                  > > complaining about it.
                  > >
                  > > Is there a postfix support list that is a little more forgiving, and
                  > > willing to help people new to postfix (specifically), and mail server
                  > > administration (in general)?
                  >
                  > If the list is unforgiving, it has as much to do with the topic matter
                  > as anything else. It turns out that running a mail server *does* require
                  > an advanced level of knowledge and expertise, and perhaps novices are
                  > roughly encouraged to get up to speed before assuming the responsibility
                  > of managing a public server, especially if they want a solution 'Today'.
                  > Sadly, a poorly managed mail server soon becomes a problem for the
                  > rest of us, and there is no acceptable level of 'almost working'. So,
                  > put on your bulletproof vest, show that you are doing your research
                  > (submitting proper error reports indicates you've read the
                  > documentation), and you'll benefit from the knowledge base available on
                  > this list (I know I do). You're unlikely to find the same level of
                  > quality anywhere else on the topic of Postfix, or even general
                  > SMTP-related issues. The developers actively participate and even
                  > provide patches (!) to solve proven issues. You don't often see that
                  > level of dedication in a project, free or not.
                  >
                  >
                • Charles Marcus
                  ... Thats not what I meant. If I thought so, I wouldn t still be here. I didn t have access to his logs, so I couldn t provide them, and I thought he had
                  Message 8 of 15 , May 1 7:38 AM
                  • 0 Attachment
                    >> Sometimes you (and others on this list) are a bit arrogant in your
                    >> treatment of people who don't exhibit an acceptably (to you)
                    >> advanced level of knowledge and expertise, but that is your right,
                    >> and I'm not complaining about it.
                    >>
                    >> Is there a postfix support list that is a little more forgiving,
                    >> and willing to help people new to postfix (specifically), and mail
                    >> server administration (in general)?

                    > Apparently I am too demanding when I expect that people follow simple
                    > step-by-step instructions when reporting a problem.

                    Thats not what I meant. If I thought so, I wouldn't still be here.

                    I didn't have access to his logs, so I couldn't provide them, and I
                    thought he had already provided postconf -n output.

                    What I did provide was specific details on how he is using/trying to use
                    postfix, which I thought might be enough for someone to simply say 'you
                    need to read up on how to configure postfix as xyz', which is all I wanted.

                    >> If not, I guess we'll just keep plugging away, and hopefully
                    >> eventually get there.

                    > Again, good luck. Don't let my arrogance get in the way.

                    Whether you believe it or not, I didn't mean that comment as an insult.
                    Your (minimal/occasional) arrogance is well-deserved, and I wouldn't
                    expect you to waste your time holding mine or anyone else's hand - I'd
                    much prefer that you spend your time making postfix better.

                    :)

                    That said, you could just ignore requests/posts that you don't want to
                    respond to, rather than taking jabs at someone. But, it is your list, so
                    I have never complained about it till now...

                    > If the list is unforgiving, it has as much to do with the topic matter
                    > as anything else. It turns out that running a mail server *does* require
                    > an advanced level of knowledge and expertise, and perhaps novices are
                    > roughly encouraged to get up to speed before assuming the responsibility
                    > of managing a public server, especially if they want a solution 'Today'.

                    I agree. The reality is, though, that some people want to run one now,
                    and don't want to spend months or years 'coming up to speed' to the
                    point that they will submit perfect error reports, or properly absorb
                    every detail in a well-commented config file.

                    For that, I guess I'll have to rely more on distro-centric support lists
                    rather than the biggie, and only come here when I'm unable to get an
                    answer anywhere else, and just be prepared to not post my
                    question/problem until I have all relevant/pertinent details on hand.

                    > Sadly, a poorly managed mail server soon becomes a problem for the rest
                    > of us, and there is no acceptable level of 'almost working'. So, put on
                    > your bulletproof vest, show that you are doing your research (submitting
                    > proper error reports indicates you've read the documentation), and
                    > you'll benefit from the knowledge base available on this list (I know I
                    > do).

                    Agreed, and is what I've done for my own server. Thankfully, my current
                    needs are fairly simple, so getting a secure, correctly configured
                    server was relatively easy.

                    > You're unlikely to find the same level of quality anywhere else on
                    > the topic of Postfix, or even general SMTP-related issues. The
                    > developers actively participate and even provide patches (!) to solve
                    > proven issues. You don't often see that level of dedication in a
                    > project, free or not.

                    Agreed again - I've no complaints, aside from the fact that, when
                    someone posts without rtfm (whether out of haste or laziness), sometimes
                    gruffness (sometimes to the point of rudeness) is offered, rather than
                    silence, which is what I would do if it were me.

                    Anyway, enough said - I'll work with Wade on the Ubuntu list and see if
                    we both can't learn something.

                    Thanks,

                    --

                    Best regards,

                    Charles
                  • mouss
                    ... so you have smtpout.secureserver.net as your relayhost (as seen in postconf -n), but they don t accept to relay for you. ask them what to do to be able to
                    Message 9 of 15 , May 1 7:43 AM
                    • 0 Attachment
                      Wade Smart wrote:
                      > My System: Ubuntu 7.04
                      > Use fetchmail / postfix / dovecot for mail
                      > My domain name: wadesmart.com
                      > Hosted by: GoDaddy
                      > My computer name: wadesmart
                      >
                      > Summary of Problem
                      >
                      > Im trying to complete setup of my email system to send mail. I
                      > originally in my mail client setup to use "sendmail" as server type.
                      > When I was doing that I get the error produced below. I was told in
                      > another forum to change that to smtp. When I did my mail client does
                      > not send the mail. It just hangs, like it cant connect.
                      >
                      > I have been reading through the documentation but I think Im just
                      > going in circles because all as I make changes I noticed that now Im
                      > getting emails that are coming in bounced.
                      >
                      > What I want is to just get my mail, read it, send it back, all on my
                      > own system. I would really appreciate any help.
                      >
                      > wade
                      >
                      >
                      > Complete Error Messages
                      >
                      > Cant send error message:
                      >
                      > Apr 30 17:18:56 wadesmart postfix/smtp[18874]: B0E5F14284D1:
                      > to=<wadesmart@...>,
                      > orig_to=<wade@...>,
                      > relay=smtpout.secureserver.net[64.202.165.58]:3535,
                      > delay=0.5,
                      > delays=0.02/0.06/0.29/0.12,
                      > dsn=5.0.0,
                      > status=bounced (host smtpout.secureserver.net[64.202.165.58]
                      > said: 553 Sorry, that domain isn't in my list of allowed rcpthosts.
                      > (in reply to RCPT TO command))
                      >
                      > Losing email error message:
                      >
                      > Apr 30 12:34:08 wadesmart postfix/smtp[7697]: 7826714284BD:
                      > to=<PositiveDiscussions@yahoogroups.com>,
                      > relay=smtpout.secureserver.net[64.202.165.58]:3535,
                      > delay=0.63,
                      > delays=0.13/0/0.35/0.15, dsn=5.0.0,
                      > status=bounced (host smtpout.secureserver.net[64.202.165.58]
                      > said: 553 Sorry, that domain isn't in my list of allowed rcpthosts.
                      > (in reply to RCPT TO command))

                      so you have smtpout.secureserver.net as your relayhost (as seen in
                      postconf -n), but they don't accept to relay for you. ask them what to
                      do to be able to relay via their server. if they gave you yoy a
                      login/passwd, then you'll need to setup sasl. see the SASL_README. look
                      for the part with "sasl client" or so, and to smtp_sasl_* variables (not
                      smtpd_sasl_*).

                      >
                      > Apr 30 12:34:08 wadesmart postfix/qmgr[5402]: 7826714284BD: removed
                      >
                      >
                      >
                      > Output from "postconf -n"
                      >
                      > wadesmart@wadesmart:~$ postconf -n
                      > alias_database = hash:/etc/aliases
                      > alias_maps = hash:/etc/aliases
                      > append_dot_mydomain = no
                      > biff = no
                      > config_directory = /etc/postfix
                      > home_mailbox = Maildir/
                      > inet_interfaces = all
                      > inet_protocols = all
                      > mailbox_command =
                      > mailbox_size_limit = 0
                      > mydestination = wadesmart, wadesmart.com, localhost.localdomain,
                      > localhost
                      > mydomain = wadesmart.com
                      > myhostname = mail.wadesmart.com
                      > mynetworks = 192.168.0.0/24 127.0.0.0/8
                      > recipient_delimiter = +
                      > relayhost = [smtpout.secureserver.net]:3535
                      > smtp_sasl_password_maps = hash:/etc/postfix/saslpass
                      > smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
                      > smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
                      > smtpd_sasl_auth_enable = yes
                      > smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
                      > smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
                      > smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
                      > smtpd_use_tls = yes
                      > wadesmart@wadesmart:~$
                      >
                      >
                      > Mail Client Setup:
                      >
                      > Sending Email:
                      > Server type: smtp
                      > server: mail.wadesmart.com
                      >
                      > Receiving Email:
                      > Server type: IMAP
                      > Server: 127.0.0.1
                      >
                    • Charles Marcus
                      ... Which reminds me of a question I had earlier, but I ended up not needing to enable smtp auth, so it wasn t urgent... Am I correct that in order to switch
                      Message 10 of 15 , May 1 7:58 AM
                      • 0 Attachment
                        > so you have smtpout.secureserver.net as your relayhost (as seen in
                        > postconf -n), but they don't accept to relay for you. ask them what to
                        > do to be able to relay via their server. if they gave you yoy a
                        > login/passwd, then you'll need to setup sasl. see the SASL_README. look
                        > for the part with "sasl client" or so, and to smtp_sasl_* variables (not
                        > smtpd_sasl_*).

                        Which reminds me of a question I had earlier, but I ended up not needing
                        to enable smtp auth, so it wasn't urgent...

                        Am I correct that in order to switch from using a relayhost that doesn't
                        require auth, I would:

                        1. comment out the relayhost setting in main.cf

                        2. enable:

                        smtp_sasl_auth_enable = yes
                        smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd

                        3. Put the necessary entries in sasl_passwd

                        4. postmap the file, then

                        5. reload postfix?

                        --

                        Best regards,

                        Charles
                      • mouss
                        ... No. leave it. otherwise, you system will send directly to MXes. this would work, except if the recipient MX blocks you (block resedential IPs). ... don t
                        Message 11 of 15 , May 1 11:41 AM
                        • 0 Attachment
                          Charles Marcus wrote:
                          >> so you have smtpout.secureserver.net as your relayhost (as seen in
                          >> postconf -n), but they don't accept to relay for you. ask them what
                          >> to do to be able to relay via their server. if they gave you yoy a
                          >> login/passwd, then you'll need to setup sasl. see the SASL_README.
                          >> look for the part with "sasl client" or so, and to smtp_sasl_*
                          >> variables (not smtpd_sasl_*).
                          >
                          > Which reminds me of a question I had earlier, but I ended up not
                          > needing to enable smtp auth, so it wasn't urgent...
                          >
                          > Am I correct that in order to switch from using a relayhost that
                          > doesn't require auth, I would:
                          >
                          > 1. comment out the relayhost setting in main.cf

                          No. leave it. otherwise, you system will send directly to MXes. this
                          would work, except if the recipient MX blocks you (block "resedential"
                          IPs).
                          >
                          > 2. enable:
                          >
                          > smtp_sasl_auth_enable = yes
                          > smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
                          >
                          > 3. Put the necessary entries in sasl_passwd
                          don't forget the square brackets around the host.
                          >
                          > 4. postmap the file, then
                          >
                          > 5. reload postfix?
                          >
                          yes
                        • Charles Marcus
                          Thanks mouss & Magnus... -- Best regards, Charles
                          Message 12 of 15 , May 1 12:27 PM
                          • 0 Attachment
                            Thanks mouss & Magnus...

                            --

                            Best regards,

                            Charles
                          Your message has been successfully submitted and would be delivered to recipients shortly.