Loading ...
Sorry, an error occurred while loading the content.
 

hostname configuration question

Expand Messages
  • Dennis Putnam
    I have a Linux box on which I am trying to configure postfix. The problem is that it is on a DSL line so there is no FDQN or static IP. The crux of my problem
    Message 1 of 7 , Mar 29 8:59 AM
      I have a Linux box on which I am trying to configure postfix. The problem is that it is on a DSL line so there is no FDQN or static IP. The crux of my problem is that I need to have postfix identify itself with a specific hostname when it connects to my ISP's SMTP server. I have tried changing parameters in sendmail.cf to do masquerading but I guess it is postfix that really needs to be changed. What parameter do I add or modify to force postfix to use a specific FQDN rather then the apparently self generated one it uses now (dap002.localdomain)? Thanks.

      Dennis Putnam
      Sr. IT Systems Administrator
      AIM Systems, Inc.
      11675 Rainwater Dr., Suite 200
      Alpharetta, GA  30004
      Phone: 678-240-4112
      Main Phone: 678-297-0700
      FAX: 678-297-2666 or 770-576-1000
      The information contained in this e-mail and any attachments is strictly confidential. If you are not the intended recipient, any use, dissemination, distribution, or duplication of any part of this e-mail or any attachment is prohibited. If you are not the intended recipient, please notify the sender by return e-mail and delete all copies, including the attachments.


    • Victor Duchovni
      ... http://www.postfix.org/STANDARD_CONFIGURATION_README.html#fantasy http://www.postfix.org/ADDRESS_REWRITING_README.html#generic -- Viktor. Disclaimer:
      Message 2 of 7 , Mar 29 9:08 AM
        On Thu, Mar 29, 2007 at 11:59:34AM -0400, Dennis Putnam wrote:

        > I have a Linux box on which I am trying to configure postfix. The
        > problem is that it is on a DSL line so there is no FDQN or static IP.
        > The crux of my problem is that I need to have postfix identify itself
        > with a specific hostname when it connects to my ISP's SMTP server. I
        > have tried changing parameters in sendmail.cf to do masquerading but
        > I guess it is postfix that really needs to be changed. What parameter
        > do I add or modify to force postfix to use a specific FQDN rather
        > then the apparently self generated one it uses now
        > (dap002.localdomain)? Thanks.

        http://www.postfix.org/STANDARD_CONFIGURATION_README.html#fantasy
        http://www.postfix.org/ADDRESS_REWRITING_README.html#generic

        --
        Viktor.

        Disclaimer: off-list followups get on-list replies or get ignored.
        Please do not ignore the "Reply-To" header.

        To unsubscribe from the postfix-users list, visit
        http://www.postfix.org/lists.html or click the link below:
        <mailto:majordomo@...?body=unsubscribe%20postfix-users>

        If my response solves your problem, the best way to thank me is to not
        send an "it worked, thanks" follow-up. If you must respond, please put
        "It worked, thanks" in the "Subject" so I can delete these quickly.
      • Dennis Putnam
        Thanks. I scoured the docs for this and came up empty. I guess I didn t come up with the right key words in my search. ... Dennis Putnam Sr. IT Systems
        Message 3 of 7 , Mar 29 10:10 AM
          Thanks. I scoured the docs for this and came up empty. I guess I didn't come up with the right key words in my search.

          On Mar 29, 2007, at 12:08 PM, Victor Duchovni wrote:

          On Thu, Mar 29, 2007 at 11:59:34AM -0400, Dennis Putnam wrote:

          I have a Linux box on which I am trying to configure postfix. The  
          problem is that it is on a DSL line so there is no FDQN or static IP.  
          The crux of my problem is that I need to have postfix identify itself  
          with a specific hostname when it connects to my ISP's SMTP server. I  
          have tried changing parameters in sendmail.cf to do masquerading but  
          I guess it is postfix that really needs to be changed. What parameter  
          do I add or modify to force postfix to use a specific FQDN rather  
          then the apparently self generated one it uses now  
          (dap002.localdomain)? Thanks.


          -- 
          Viktor.

          Disclaimer: off-list followups get on-list replies or get ignored.
          Please do not ignore the "Reply-To" header.

          To unsubscribe from the postfix-users list, visit
          http://www.postfix.org/lists.html or click the link below:

          If my response solves your problem, the best way to thank me is to not
          send an "it worked, thanks" follow-up. If you must respond, please put
          "It worked, thanks" in the "Subject" so I can delete these quickly.




          Dennis Putnam
          Sr. IT Systems Administrator
          AIM Systems, Inc.
          11675 Rainwater Dr., Suite 200
          Alpharetta, GA  30004
          Phone: 678-240-4112
          Main Phone: 678-297-0700
          FAX: 678-297-2666 or 770-576-1000
          The information contained in this e-mail and any attachments is strictly confidential. If you are not the intended recipient, any use, dissemination, distribution, or duplication of any part of this e-mail or any attachment is prohibited. If you are not the intended recipient, please notify the sender by return e-mail and delete all copies, including the attachments.


        • Victor Duchovni
          ... Sometimes checking the table of contents at the top of the tutorial is a good idea. Check BASIC_CONFIGURATION_README and STANDARD_CONFIGURATION_README ,
          Message 4 of 7 , Mar 29 10:14 AM
            On Thu, Mar 29, 2007 at 01:10:07PM -0400, Dennis Putnam wrote:

            > Thanks. I scoured the docs for this and came up empty. I guess I
            > didn't come up with the right key words in my search.
            >

            Sometimes checking the table of contents at the top of the
            tutorial is a good idea. Check "BASIC_CONFIGURATION_README" and
            "STANDARD_CONFIGURATION_README", before looking elsewhere.

            --
            Viktor.

            Disclaimer: off-list followups get on-list replies or get ignored.
            Please do not ignore the "Reply-To" header.

            To unsubscribe from the postfix-users list, visit
            http://www.postfix.org/lists.html or click the link below:
            <mailto:majordomo@...?body=unsubscribe%20postfix-users>

            If my response solves your problem, the best way to thank me is to not
            send an "it worked, thanks" follow-up. If you must respond, please put
            "It worked, thanks" in the "Subject" so I can delete these quickly.
          • Dennis Putnam
            Sorry, I guess I was not clear about my problem. After reading this closer it is obvious you though I was talking about email address mapping when my real
            Message 5 of 7 , Mar 29 8:13 PM
              Sorry, I guess I was not clear about my problem. After reading this closer it is obvious you though I was talking about email address mapping when my real problem is host name representation. I guess my mention of masquerading in 'sendmail.cf' was misleading. When postfix connects to my ISP's SMTP server, it identifies itself as myhost.localdomain.local. This is rejected by my ISP's SMTP server. What I need is a way to change that name to a valid FDQN. In this case I need postfix has to say it is 'home.myisp.com'. Thanks.

              On Mar 29, 2007, at 12:08 PM, Victor Duchovni wrote:

              On Thu, Mar 29, 2007 at 11:59:34AM -0400, Dennis Putnam wrote:

              I have a Linux box on which I am trying to configure postfix. The  
              problem is that it is on a DSL line so there is no FDQN or static IP.  
              The crux of my problem is that I need to have postfix identify itself  
              with a specific hostname when it connects to my ISP's SMTP server. I  
              have tried changing parameters in sendmail.cf to do masquerading but  
              I guess it is postfix that really needs to be changed. What parameter  
              do I add or modify to force postfix to use a specific FQDN rather  
              then the apparently self generated one it uses now  
              (dap002.localdomain)? Thanks.


              -- 
              Viktor.

              Disclaimer: off-list followups get on-list replies or get ignored.
              Please do not ignore the "Reply-To" header.

              To unsubscribe from the postfix-users list, visit
              http://www.postfix.org/lists.html or click the link below:

              If my response solves your problem, the best way to thank me is to not
              send an "it worked, thanks" follow-up. If you must respond, please put
              "It worked, thanks" in the "Subject" so I can delete these quickly.




              Dennis Putnam
              Sr. IT Systems Administrator
              AIM Systems, Inc.
              11675 Rainwater Dr., Suite 200
              Alpharetta, GA  30004
              Phone: 678-240-4112
              Main Phone: 678-297-0700
              FAX: 678-297-2666 or 770-576-1000
              The information contained in this e-mail and any attachments is strictly confidential. If you are not the intended recipient, any use, dissemination, distribution, or duplication of any part of this e-mail or any attachment is prohibited. If you are not the intended recipient, please notify the sender by return e-mail and delete all copies, including the attachments.


            • Michael Wang
              ... Look up the following main.cf parameters: myhostname mydomain myorigin -- Michael Wang
              Message 6 of 7 , Mar 29 9:03 PM
                Dennis Putnam wrote:
                > Sorry, I guess I was not clear about my problem. After reading this
                > closer it is obvious you though I was talking about email address
                > mapping when my real problem is host name representation. I guess my
                > mention of masquerading in 'sendmail.cf' was misleading. When postfix
                > connects to my ISP's SMTP server, it identifies itself as
                > myhost.localdomain.local. This is rejected by my ISP's SMTP server. What
                > I need is a way to change that name to a valid FDQN. In this case I need
                > postfix has to say it is 'home.myisp.com'. Thanks.

                Look up the following main.cf parameters:

                myhostname
                mydomain
                myorigin


                --
                Michael Wang
              • mouss
                ... if you don t want to change your hostname, then http://www.postfix.org/postconf.5.html#smtp_helo_name you d better use a name that resolves to an IP
                Message 7 of 7 , Mar 30 6:17 AM
                  Dennis Putnam wrote:
                  > Sorry, I guess I was not clear about my problem. After reading this
                  > closer it is obvious you though I was talking about email address
                  > mapping when my real problem is host name representation. I guess my
                  > mention of masquerading in 'sendmail.cf' was misleading. When postfix
                  > connects to my ISP's SMTP server, it identifies itself as
                  > myhost.localdomain.local. This is rejected by my ISP's SMTP server.
                  > What I need is a way to change that name to a valid FDQN. In this case
                  > I need postfix has to say it is 'home.myisp.com'. Thanks.

                  if you don't want to change your hostname, then
                  http://www.postfix.org/postconf.5.html#smtp_helo_name


                  you'd better use a name that resolves to an IP (better yet: that
                  resolves back to your IP, but this may be harder with dynamic IPs).
                Your message has been successfully submitted and would be delivered to recipients shortly.