Loading ...
Sorry, an error occurred while loading the content.

Re: Name service error for name=localhost type=A: Host not found

Expand Messages
  • Pierre Lebrun
    ... Thank you for your link to the Postfix Debug cook book. I found the solution with debugging infos. Pierre
    Message 1 of 4 , Mar 1, 2007
    • 0 Attachment
      Kai Fürstenberg a écrit :
      > Hello Pierre,
      >
      > Pierre Lebrun wrote:
      >> Hello,
      >>
      >> I'm new to postfix and have a problem
      >> when sending a message from a machine
      >> of my network to root@... on
      >> the postfix server.
      >>
      >> What I understand is that postfix tries
      >> to resolve localhost.
      >>
      >> My postfix is postfix-2.2.10-1.RHEL4.2
      >>
      >> Feb 28 09:12:19 antispam postfix/smtp[27549]: 3D44D64077:
      >> to=<root@...>, relay=none, delay=0, status=bounced (Host or
      >> domain name not found. Name service error for name=localhost type=A:
      >> Host not found)
      >>
      >> Where did I do the misconfiguration ?
      >
      > You should provide a bit more information than "something's wrong, what
      > is it?"
      >
      > See http://www.postfix.org/DEBUG_README.html#mail
      >
      > Otherwise we can only guess:
      > - check your /etc/hosts file for an entry
      > 127.0.0.1 localhost
      > - check your /etc/resolv.conf for an entry `order host,bind` or something
      >
      Thank you for your link to the Postfix Debug cook book.
      I found the solution with debugging infos.

      Pierre
    Your message has been successfully submitted and would be delivered to recipients shortly.