Loading ...
Sorry, an error occurred while loading the content.
 

mynetworks

Expand Messages
  • Tom Allison
    mynetworks = 168.100.189.0/28, 127.0.0.0/8 You can also specify the absolute pathname of a pattern file instead of listing the patterns in the main.cf file.
    Message 1 of 20 , Dec 30, 2006
      mynetworks = 168.100.189.0/28, 127.0.0.0/8

      "You can also specify the absolute pathname of a pattern file instead of listing
      the patterns in the main.cf file."

      What is the format of the this pattern file?

      mynetworks = /etc/postfix/mynetworks

      /etc/postfix/mynetworks:
      127.0.0.0/8
      168.100.189.0/28

      ????

      What's the token word to look for if I want to set up an outbound relay
      (mynetworks) where I don't know the IP address but I do know the domain name of
      the IP address? I'm trying to get an outbound relay established for a dynamip
      IP broadband connection.
    • Magnus Bäck
      On Sunday, December 31, 2006 at 03:41 CET, ... Correct. ... Your question isn t quite clear. What does outbound relay have to do with mynetworks? What host has
      Message 2 of 20 , Dec 31, 2006
        On Sunday, December 31, 2006 at 03:41 CET,
        Tom Allison <tom@...> wrote:

        > mynetworks = 168.100.189.0/28, 127.0.0.0/8
        >
        > "You can also specify the absolute pathname of a pattern file instead of
        > listing the patterns in the main.cf file."
        >
        > What is the format of the this pattern file?
        >
        > mynetworks = /etc/postfix/mynetworks
        >
        > /etc/postfix/mynetworks:
        > 127.0.0.0/8
        > 168.100.189.0/28
        >
        > ????

        Correct.

        > What's the token word to look for if I want to set up an outbound
        > relay (mynetworks) where I don't know the IP address but I do know the
        > domain name of the IP address? I'm trying to get an outbound relay
        > established for a dynamip IP broadband connection.

        Your question isn't quite clear. What does outbound relay have to do
        with mynetworks? What host has a dynamic IP address and which host
        should use what as relay?

        The relayhost parameter accepts hostnames in addition
        to IP addresses, if that helps. Remember to surround hostnames with
        square brackets unless you want them to be subject to MX lookups.

        --
        Magnus Bäck
        magnus@...
      • mouss
        ... you don t want to allow a whole ISP to relay through your server? Note that dyndns won t work, because rDNS must match (otherwise, the hostname is
        Message 3 of 20 , Dec 31, 2006
          Tom Allison wrote:
          > mynetworks = 168.100.189.0/28, 127.0.0.0/8
          >
          > "You can also specify the absolute pathname of a pattern file instead
          > of listing the patterns in the main.cf file."
          >
          > What is the format of the this pattern file?
          >
          > mynetworks = /etc/postfix/mynetworks
          >
          > /etc/postfix/mynetworks:
          > 127.0.0.0/8
          > 168.100.189.0/28
          >
          > ????
          >
          > What's the token word to look for if I want to set up an outbound
          > relay (mynetworks) where I don't know the IP address but I do know the
          > domain name of the IP address? I'm trying to get an outbound relay
          > established for a dynamip IP broadband connection.
          >

          you don't want to allow a whole ISP to relay through your server?
          Note that dyndns won't work, because rDNS must match (otherwise, the
          hostname is "unknown").

          Setup SASL and use permit_sasl_authenticated.
        • Tom Allison
          ... The relayhost parameter tells where to send all the email delivery -- like a gateway/firewall. For my current set-up, I relayhost to my ISP mail server
          Message 4 of 20 , Dec 31, 2006
            >> What's the token word to look for if I want to set up an outbound
            >> relay (mynetworks) where I don't know the IP address but I do know the
            >> domain name of the IP address? I'm trying to get an outbound relay
            >> established for a dynamip IP broadband connection.
            >
            > Your question isn't quite clear. What does outbound relay have to do
            > with mynetworks? What host has a dynamic IP address and which host
            > should use what as relay?
            >
            > The relayhost parameter accepts hostnames in addition
            > to IP addresses, if that helps. Remember to surround hostnames with
            > square brackets unless you want them to be subject to MX lookups.

            The relayhost parameter tells where to send all the email delivery -- like a
            gateway/firewall. For my current set-up, I relayhost to my ISP mail server
            because I have a dynamic ISP. Technically I use the transport table to direct
            all of my outbound email to this server (DNS).

            However, my ISP is configured to accept all email from my subnet.

            I want to circumvent my ISP and deliver directly out through a different box.
            Currently I relay from my dynamic IP to this box by specifying the currently
            assigned IP address in the mynetwork parameter. Every time I change IP
            addresses (not frequent) I have to change the mynetwork parameter. If I set
            mynetwork to include my entire ISP's subnet -- that would be bad...

            Much of this is a proactive process of figuring out what to do after they decide
            to block all outbound port 25 traffic. This might not affect me. But I've also
            run into problems with the 1,000 emails a day limitation (mailing lists, not spam).
          • Tom Allison
            ... So that s how you do it? Too bad... I m having no joy with SASL on whatever I do. Was really hoping I could avoid it for a while yet... Maybe I ll get
            Message 5 of 20 , Dec 31, 2006
              mouss wrote:
              > you don't want to allow a whole ISP to relay through your server?
              > Note that dyndns won't work, because rDNS must match (otherwise, the
              > hostname is "unknown").
              >
              > Setup SASL and use permit_sasl_authenticated.

              So that's how you do it?

              Too bad... I'm having "no joy" with SASL on whatever I do.
              Was really hoping I could avoid it for a while yet...

              Maybe I'll get back to it.
            • mouss
              ... you can also use TLS if you want. Or you can use fetchmail to get the mail from the dynamic IP server. but SASL and/or TLS may be better. PS. I am getting
              Message 6 of 20 , Jan 1, 2007
                Tom Allison wrote:
                > mouss wrote:
                >> you don't want to allow a whole ISP to relay through your server?
                >> Note that dyndns won't work, because rDNS must match (otherwise, the
                >> hostname is "unknown").
                >>
                >> Setup SASL and use permit_sasl_authenticated.
                >
                > So that's how you do it?
                >
                > Too bad... I'm having "no joy" with SASL on whatever I do.
                > Was really hoping I could avoid it for a while yet...
                >
                > Maybe I'll get back to it.
                >

                you can also use TLS if you want.
                Or you can use fetchmail to get the mail from the dynamic IP server. but
                SASL and/or TLS may be better.

                PS. I am getting this from your server. you may want to fix your
                configuration.

                <tom@...>: host janus.tacocat.net[69.133.95.10] said: 554 5.7.1
                <ouzoud.netoyen.net>: Helo command rejected: Access denied (in reply to
                RCPT TO command)


                I am still CC-ing you to see if this changed.
              • AMP Admin
                Maybe a dumb question but I can t seem to change mynetworks in main.cf. I change it to something like: mynetworks = 127.0.0.0/8, xx.xx.xx.0/8, xx.xx.xxx.xxx,
                Message 7 of 20 , Aug 3, 2009

                  Maybe a dumb question but I can’t seem to change mynetworks in main.cf.

                   

                  I change it to something like:

                  mynetworks = 127.0.0.0/8, xx.xx.xx.0/8, xx.xx.xxx.xxx, xx.xx.xxx.xxx

                  # mynetworks_style = subnet

                   

                  Then I restart postfix and run  postconf –d and I get this:

                  mynetworks = 127.0.0.0/8 127.0.0.1/32 xx.xx.xxx.xxx/32

                  mynetworks_style = subnet

                   

                  any thoughts?

                   

                   

                • Sahil Tandon
                  ... Yes, RTFM. Hint: d for DEFAULT.
                  Message 8 of 20 , Aug 3, 2009
                    On Aug 3, 2009, at 5:03 PM, "AMP Admin" <admin@...> wrote:

                    > Maybe a dumb question but I can’t seem to change mynetworks in main.
                    > cf.
                    >
                    >
                    >
                    > I change it to something like:
                    >
                    > mynetworks = 127.0.0.0/8, xx.xx.xx.0/8, xx.xx.xxx.xxx, xx.xx.xxx.xxx
                    >
                    > # mynetworks_style = subnet
                    >
                    >
                    >
                    > Then I restart postfix and run postconf –d and I get this:
                    >
                    > mynetworks = 127.0.0.0/8 127.0.0.1/32 xx.xx.xxx.xxx/32
                    >
                    > mynetworks_style = subnet
                    >
                    >
                    >
                    > any thoughts?
                    >
                    Yes, RTFM. Hint: 'd' for DEFAULT.
                  • AMP Admin
                    OH! So when I do it w/o the -d it shows my current config?! I do see mynetworks is correct now w/o the -d!!! Thank you so much... sometimes it s the little
                    Message 9 of 20 , Aug 3, 2009
                      OH! So when I do it w/o the -d it shows my current config?! I do see mynetworks is correct now w/o the -d!!!

                      Thank you so much... sometimes it's the little things that make us happy. I'm obviously new to postfix. :)

                      -----Original Message-----
                      From: owner-postfix-users@... [mailto:owner-postfix-users@...] On Behalf Of Sahil Tandon
                      Sent: Monday, August 03, 2009 4:28 PM
                      To: AMP Admin
                      Cc: <postfix-users@...>
                      Subject: Re: mynetworks

                      On Aug 3, 2009, at 5:03 PM, "AMP Admin" <admin@...> wrote:

                      > Maybe a dumb question but I can’t seem to change mynetworks in main.
                      > cf.
                      >
                      >
                      >
                      > I change it to something like:
                      >
                      > mynetworks = 127.0.0.0/8, xx.xx.xx.0/8, xx.xx.xxx.xxx, xx.xx.xxx.xxx
                      >
                      > # mynetworks_style = subnet
                      >
                      >
                      >
                      > Then I restart postfix and run postconf –d and I get this:
                      >
                      > mynetworks = 127.0.0.0/8 127.0.0.1/32 xx.xx.xxx.xxx/32
                      >
                      > mynetworks_style = subnet
                      >
                      >
                      >
                      > any thoughts?
                      >
                      Yes, RTFM. Hint: 'd' for DEFAULT.
                    • Sahil Tandon
                      ... Yes, read the postconf(1) manual to understand the meaning of -d and other flags. ... Welcome. Please stop top-posting. If you are not familiar with
                      Message 10 of 20 , Aug 3, 2009
                        On Mon, 03 Aug 2009, AMP Admin wrote:

                        > OH! So when I do it w/o the -d it shows my current config?! I do see
                        > mynetworks is correct now w/o the -d!!!

                        Yes, read the postconf(1) manual to understand the meaning of '-d' and other
                        flags.

                        > Thank you so much... sometimes it's the little things that make us happy.
                        > I'm obviously new to postfix. :)

                        Welcome. Please stop top-posting. If you are not familiar with this term,
                        google it.

                        --
                        Sahil Tandon <sahil@...>
                      • LuKreme
                        ... run postconf -n for your settings minus the default. This is generally all you care about. Also, read man postconf And lastly, don t top post. -- And the
                        Message 11 of 20 , Aug 3, 2009
                          On 3-Aug-2009, at 16:03, AMP Admin wrote:
                          > OH! So when I do it w/o the -d it shows my current config?! I do
                          > see mynetworks is correct now w/o the -d!!!

                          run postconf -n for your settings minus the default. This is generally
                          all you care about.

                          Also, read man postconf

                          And lastly, don't top post.

                          --
                          And the three men I admire most, the father son and the holly ghost
                          they caught the last train for the coast...
                        Your message has been successfully submitted and would be delivered to recipients shortly.