Loading ...
Sorry, an error occurred while loading the content.

Requires valid sender domain?

Expand Messages
  • Evan Platt
    Not sure if this is postfix related at all... Mail is sent from my localcomputer to postfix, then via smtpauth to my DSL providers SMTP server: relayhost =
    Message 1 of 8 , Nov 30, 2006
    • 0 Attachment
      Not sure if this is postfix related at all...

      Mail is sent from my localcomputer to postfix, then via smtpauth to
      my DSL providers SMTP server:
      relayhost = smtp.dslextreme.com

      Sent a e-mail to a comcast user and got a e-mail bounce:

      204.127.225.26 does not like recipient.
      Remote host said: 550 [PERMFAIL] comcast.net requires valid sender domain
      Giving up on 204.127.225.26.

      Is this on my end or comcast's end?

      (No other problems sending mail)

      Full postconf -n:
      alias_database = hash:/etc/postfix/aliases
      alias_maps = hash:/etc/postfix/aliases
      body_checks = regexp:/etc/postfix/body_checks
      command_directory = /usr/sbin
      config_directory = /sw/etc/postfix
      daemon_directory = /usr/libexec/postfix
      debug_peer_level = 2
      header_checks = regexp:/etc/postfix/header_checks
      inet_interfaces = all
      mail_owner = postfix
      mailq_path = /usr/bin/mailq
      manpage_directory = /usr/share/man
      message_size_limit = 0
      mydomain = espphotography.com
      myhostname = espphotography.com
      mynetworks_style = subnet
      newaliases_path = /usr/bin/newaliases
      parent_domain_matches_subdomains =
      debug_peer_list,fast_flush_domains,mynetworks,permit_mx_backup_networks,qmqpd_authorized_clients,relay_domains,smtpd_access_maps,smtpd_client_restrictions
      queue_directory = /private/var/spool/postfix
      readme_directory = /usr/share/doc/postfix
      relayhost = smtp.dslextreme.com
      sample_directory = /usr/share/doc/postfix/examples
      sendmail_path = /usr/sbin/sendmail
      setgid_group = postdrop
      smtpd_banner = $myhostname ESMTP
      wouldnt.you.like.to.know.what.software.this.is.running
      smtpd_client_restrictions = check_client_access
      hash:/etc/postfix/rbl_access, permit_mynetworks,
      reject_rbl_client bl.spamcop.net, reject_rbl_client
      sbl-xbl.spamhaus.org, reject_rbl_client
      korea.services.net, reject_rbl_client
      dynablock.njabl.org, reject_rbl_client
      cbl.abuseat.org, reject_rbl_client
      bl.csma.biz, reject_rbl_client relays.ordb.org permit
      smtpd_sender_restrictions = check_sender_access hash:/etc/postfix/access
      smtpd_tls_cert_file = /System/Library/OpenSSL/certs/smtpd.pem
      smtpd_tls_key_file = $smtpd_tls_cert_file
      smtpd_use_tls = yes
      unknown_local_recipient_reject_code = 550


      Thanks.

      Evan
    • Noel Jones
      ... If your mail had a valid sender domain, it would be their problem. Maybe a temporary DNS error, give it another try. (but they shouldn t 550 reject on a
      Message 2 of 8 , Dec 1, 2006
      • 0 Attachment
        At 01:25 AM 12/1/2006, Evan Platt wrote:
        >Not sure if this is postfix related at all...
        >
        >Mail is sent from my localcomputer to postfix, then via
        >smtpauth to my DSL providers SMTP server:
        >relayhost = smtp.dslextreme.com
        >
        >Sent a e-mail to a comcast user and got a e-mail bounce:
        >
        >204.127.225.26 does not like recipient.
        >Remote host said: 550 [PERMFAIL] comcast.net requires
        >valid sender domain
        >Giving up on 204.127.225.26.
        >
        >Is this on my end or comcast's end?

        If your mail had a valid sender domain, it would be their
        problem. Maybe a temporary DNS error, give it another try.
        (but they shouldn't 550 reject on a temporary
        error). Check your dns at dnsreport.com.

        --
        Noel Jones
      • Evan Platt
        ... Same as what I sent to the group, evan@espphotography.com Evan
        Message 3 of 8 , Dec 1, 2006
        • 0 Attachment
          At 03:37 PM 12/1/2006, you wrote:
          >Evan Platt wrote:
          >>Not sure if this is postfix related at all...
          >>
          >>Mail is sent from my localcomputer to postfix, then via smtpauth to
          >>my DSL providers SMTP server:
          >>relayhost = smtp.dslextreme.com
          >>
          >>Sent a e-mail to a comcast user and got a e-mail bounce:
          >>
          >>204.127.225.26 does not like recipient.
          >>Remote host said: 550 [PERMFAIL] comcast.net requires valid sender domain
          >>Giving up on 204.127.225.26.
          >
          >and what is the sender address?

          Same as what I sent to the group, evan@...

          Evan
        • mouss
          ... and what is the sender address?
          Message 4 of 8 , Dec 1, 2006
          • 0 Attachment
            Evan Platt wrote:
            > Not sure if this is postfix related at all...
            >
            > Mail is sent from my localcomputer to postfix, then via smtpauth to my
            > DSL providers SMTP server:
            > relayhost = smtp.dslextreme.com
            >
            > Sent a e-mail to a comcast user and got a e-mail bounce:
            >
            > 204.127.225.26 does not like recipient.
            > Remote host said: 550 [PERMFAIL] comcast.net requires valid sender domain
            > Giving up on 204.127.225.26.

            and what is the sender address?
          • Harvey Smith
            ... There doesn t appear to be an A record for espphotography.com ; DiG 9.2.4 espphotography.com ;; global options: printcmd ;; Got answer: ;;
            Message 5 of 8 , Dec 1, 2006
            • 0 Attachment
              On Fri, Dec 01, 2006 at 03:34:53PM -0800, Evan Platt wrote:
              > At 03:37 PM 12/1/2006, you wrote:
              > >Evan Platt wrote:
              > >>Not sure if this is postfix related at all...
              > >>
              > >>Mail is sent from my localcomputer to postfix, then via smtpauth to
              > >>my DSL providers SMTP server:
              > >>relayhost = smtp.dslextreme.com
              > >>
              > >>Sent a e-mail to a comcast user and got a e-mail bounce:
              > >>
              > >>204.127.225.26 does not like recipient.
              > >>Remote host said: 550 [PERMFAIL] comcast.net requires valid sender domain
              > >>Giving up on 204.127.225.26.
              > >
              > >and what is the sender address?
              >
              > Same as what I sent to the group, evan@...

              There doesn't appear to be an A record for espphotography.com

              ; <<>> DiG 9.2.4 <<>> espphotography.com
              ;; global options: printcmd
              ;; Got answer:
              ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 39378
              ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

              ;; QUESTION SECTION:
              ;espphotography.com. IN A

              ;; Query time: 99 msec
              ;; SERVER: 192.168.13.2#53(192.168.13.2)
              ;; WHEN: Fri Dec 1 19:10:00 2006
              ;; MSG SIZE rcvd: 36

              So you need to set and A record for your espphotography.com domain.

              --
              Harvey
            • Jorey Bump
              ... This is not true. There is an MX record for espphotography.com, so an A record is not required. $ host espphotography.com espphotography.com mail is
              Message 6 of 8 , Dec 1, 2006
              • 0 Attachment
                Harvey Smith wrote:
                > On Fri, Dec 01, 2006 at 03:34:53PM -0800, Evan Platt wrote:
                >> At 03:37 PM 12/1/2006, you wrote:
                >>> Evan Platt wrote:
                >>>> Not sure if this is postfix related at all...
                >>>>
                >>>> Mail is sent from my localcomputer to postfix, then via smtpauth to
                >>>> my DSL providers SMTP server:
                >>>> relayhost = smtp.dslextreme.com
                >>>>
                >>>> Sent a e-mail to a comcast user and got a e-mail bounce:
                >>>>
                >>>> 204.127.225.26 does not like recipient.
                >>>> Remote host said: 550 [PERMFAIL] comcast.net requires valid sender domain
                >>>> Giving up on 204.127.225.26.
                >>> and what is the sender address?
                >> Same as what I sent to the group, evan@...
                >
                > There doesn't appear to be an A record for espphotography.com
                >
                > ; <<>> DiG 9.2.4 <<>> espphotography.com
                > ;; global options: printcmd
                > ;; Got answer:
                > ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 39378
                > ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
                >
                > ;; QUESTION SECTION:
                > ;espphotography.com. IN A
                >
                > ;; Query time: 99 msec
                > ;; SERVER: 192.168.13.2#53(192.168.13.2)
                > ;; WHEN: Fri Dec 1 19:10:00 2006
                > ;; MSG SIZE rcvd: 36
                >
                > So you need to set and A record for your espphotography.com domain.

                This is not true. There is an MX record for espphotography.com, so an A
                record is not required.

                $ host espphotography.com
                espphotography.com mail is handled by 10 ns1.peskin.org.
                espphotography.com mail is handled by 5 phirephoto.dyndns.org.


                Maybe this is related to the use of dyndns.org, which is really a bad
                idea for an MX.
              • Harvey Smith
                ... You re correct of course, my bad.
                Message 7 of 8 , Dec 1, 2006
                • 0 Attachment
                  On Fri, Dec 01, 2006 at 08:15:06PM -0500, Jorey Bump wrote:
                  > Harvey Smith wrote:
                  > >
                  > >So you need to set and A record for your espphotography.com domain.
                  >
                  > This is not true. There is an MX record for espphotography.com, so an A
                  > record is not required.
                  >
                  > $ host espphotography.com
                  > espphotography.com mail is handled by 10 ns1.peskin.org.
                  > espphotography.com mail is handled by 5 phirephoto.dyndns.org.

                  You're correct of course, my bad.
                • mouss
                  ... If this address is not modified by relay, then the problem is probably at comcast side. seems like an access control check (would they block domains with
                  Message 8 of 8 , Dec 2, 2006
                  • 0 Attachment
                    Evan Platt wrote:
                    > At 03:37 PM 12/1/2006, you wrote:
                    >> Evan Platt wrote:
                    >>> Not sure if this is postfix related at all...
                    >>>
                    >>> Mail is sent from my localcomputer to postfix, then via smtpauth to
                    >>> my DSL providers SMTP server:
                    >>> relayhost = smtp.dslextreme.com
                    >>>
                    >>> Sent a e-mail to a comcast user and got a e-mail bounce:
                    >>>
                    >>> 204.127.225.26 does not like recipient.
                    >>> Remote host said: 550 [PERMFAIL] comcast.net requires valid sender
                    >>> domain
                    >>> Giving up on 204.127.225.26.
                    >>
                    >> and what is the sender address?
                    >
                    > Same as what I sent to the group, evan@...
                    >
                    > Evan
                    >

                    If this address is not modified by relay, then the problem is probably
                    at comcast side. seems like an access control check (would they block
                    domains with an MX at dyndns?)
                  Your message has been successfully submitted and would be delivered to recipients shortly.