Loading ...
Sorry, an error occurred while loading the content.

problems with virtual maps after upgrading to Postfix 2.3

Expand Messages
  • Joe Auty
    Hello, After upgrading from 2.2 to 2.3, my virtual maps no longer seem to work, even after running a postmap maps on my maps file to recreate this DB. What
    Message 1 of 11 , Oct 29, 2006
    • 0 Attachment
      Hello,

      After upgrading from 2.2 to 2.3, my virtual maps no longer seem to work, even after running a "postmap maps" on my maps file to recreate this DB.

      What sorts of steps and precautions are necessary from upgrading from 2.2 to 2.3 and ensuring that my virtual maps will remain functional? The online documentation indicates that the only change to the way maps work involves case sensitivity, but I'm not using any case sensitive/upper case mappings.

      Any theories as to what might be going on here, and how I can resolve this issue?


      For now, I've downgraded back to Postfix 2.2.x...




      -----------

      Joe Auty

      NetMusician: web publishing software for musicians

      http://www.netmusician.org

      joe@...



    • Wietse Venema
      ... See line 10 of the mailing list welcome. Wietse 1 Welcome to the postfix-users mailing list. 2 3 This list is for questions and discussions concerning the
      Message 2 of 11 , Oct 29, 2006
      • 0 Attachment
        Joe Auty:
        > Hello,
        >
        > After upgrading from 2.2 to 2.3, my virtual maps no longer seem to
        > work, even after running a "postmap maps" on my maps file to recreate
        > this DB.
        >
        > What sorts of steps and precautions are necessary from upgrading from
        > 2.2 to 2.3 and ensuring that my virtual maps will remain functional?
        > The online documentation indicates that the only change to the way
        > maps work involves case sensitivity, but I'm not using any case
        > sensitive/upper case mappings.
        >
        > Any theories as to what might be going on here, and how I can resolve
        > this issue?
        >
        >
        > For now, I've downgraded back to Postfix 2.2.x...

        See line 10 of the mailing list welcome.

        Wietse

        1 Welcome to the postfix-users mailing list.
        2
        3 This list is for questions and discussions concerning the installation,
        4 configuration and operation of the Postfix mail system.
        5
        6 =================================================================
        7 IMPORTANT INFORMATION IMPORTANT INFORMATION IMPORTANT INFORMATION
        8 =================================================================
        9
        10 To report trouble, see http://www.postfix.org/DEBUG_README.html#mail
        11
        12 To unsubscribe, see http://www.postfix.org/lists.html
        13
        14 =================================================================
        15 IMPORTANT INFORMATION IMPORTANT INFORMATION IMPORTANT INFORMATION
        16 =================================================================
        17
        18 Thank you for using Postfix.
      • Joe Auty
        Hello, After upgrading from 2.2 to 2.3, my virtual maps no longer seem to work, even after running a postmap maps on my maps file to recreate this DB. What
        Message 3 of 11 , Oct 31, 2006
        • 0 Attachment
          Hello,

          After upgrading from 2.2 to 2.3, my virtual maps no longer seem to work, even after running a "postmap maps" on my maps file to recreate this DB.

          What sorts of steps and precautions are necessary from upgrading from 2.2 to 2.3 and ensuring that my virtual maps will remain functional? The online documentation indicates that the only change to the way maps work involves case sensitivity, but I'm not using any case sensitive/upper case mappings.

          Any theories as to what might be going on here, and how I can resolve this issue?


          For now, I've downgraded back to Postfix 2.2.x...


          Here is a sample of Postfix log output when this occurred (the Postfix server's domain is "netmusician.org")

          Oct 29 15:01:09 machinename postfix/smtpd[82246]: A80467E8F4: client=localhost[127.0.0.1]
          Oct 29 15:01:09 machinename postfix/cleanup[82242]: A80467E8F4: message-id=<c6e.3afaede.32766012@...>
          Oct 29 15:01:09 machinename postfix/qmgr[82225]: A80467E8F4: from=AAAAAA@...>, size=2536, nrcpt=1 (queue active)
          Oct 29 15:01:09 machinename amavis[71307]: (71307-03) Passed CLEAN, [64.12.137.9] <AAAAAA@...> -> <diane@...>, Message-ID: <c6e.3afaede.32766012@...>, mail_id: nKHnRh-NJerA, Hits: 0.45, queued_as: A80467E8F4, 514 ms
          Oct 29 15:01:09 jauty postfix/smtp[82243]: 2CAA37E8F3: to=<diane@...>, orig_to=<diane@...>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.83, delays=0.27/0.02/0.01/0.53, dsn=2.6.0, status=sent (250 2.6.0 Ok, id=71307-03, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as A80467E8F4)


          Mail to diane@... (where "dianedomain" is a dummy domain for privacy reasons) should have not been mapped out to diane@.... I have no idea where the "org.org" comes from...


          Postfinger output:


          postfinger - postfix configuration on Tue Oct 31 16:41:20 EST 2006
          version: 1.30

          Warning: postfinger output may show private configuration information,
          such as ip addresses and/or domain names which you do not want to show
          to the public.  If this is the case it is your responsibility to modify
          the output to hide this private information.  [Remove this warning with
          the --nowarn option.]

          --System Parameters--
          mail_version = 2.2.11
          hostname = mymachine
          uname = FreeBSD mymachine 5.4-RELEASE-p14 FreeBSD 5.4-RELEASE-p14 #0: Mon May  8 16:03:23 EDT 2006     root@mymachine:/usr/obj/usr/src/sys/5_x  i386

          --Packaging information--
          looks like this postfix comes from BSD package: postfix-2.2.11,1

          --main.cf non-default parameters--
          alias_maps = hash:/etc/aliases, hash:/usr/local/mailman/data/aliases
          broken_sasl_auth_clients = yes
          command_directory = /usr/local/sbin
          content_filter = smtp-amavis:[127.0.0.1]:10024
          daemon_directory = /usr/local/libexec/postfix
          home_mailbox = Maildir/
          inet_interfaces = $myhostname, localhost
          local_recipient_maps = unix:passwd.byname $alias_maps
          mailbox_size_limit = 0
          mailq_path = /usr/local/bin/mailq
          mydestination = $myhostname, localhost.$mydomain, localhost,  mydomain.org
          myhostname =  mydomain.org
          mynetworks_style = host
          myorigin = $mydomain
          newaliases_path = /usr/local/bin/newaliases
          relay_domains = $mydestination, lists.mydomain.org
          sendmail_path = /usr/local/sbin/sendmail
          smtp_tls_CAfile = /etc/postfix/ssl/mydomain-ca.crt
          smtp_tls_cert_file = /etc/postfix/ssl/mydomain.crt
          smtp_tls_key_file = /etc/postfix/ssl/mydomain.key
          smtp_tls_note_starttls_offer = yes
          smtp_use_tls = yes
          smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unknown_sender_domain, reject_unauth_destination, check_recipient_access hash:/etc/mail/virtual/access, check_sender_access hash:/etc/postfix/sender_access, check_policy_service inet:127.0.0.1:10023, reject_rbl_client sbl-xbl.spamhaus.org
          smtpd_sasl_auth_enable = yes
          smtpd_sasl_local_domain = $myhostname
          smtpd_tls_CAfile = /etc/postfix/ssl/mydomain-ca.crt
          smtpd_tls_auth_only = yes
          smtpd_tls_cert_file = /etc/postfix/ssl/mydomain.crt
          smtpd_tls_key_file = /etc/postfix/ssl/mydomain.key
          smtpd_tls_loglevel = 3
          smtpd_tls_received_header = yes
          smtpd_use_tls = yes
          transport_maps = hash:/etc/postfix/transport
          virtual_alias_domains = /etc/mail/virtual/domains
          virtual_alias_maps = hash:/etc/mail/virtual/maps

          --master.cf--
          smtp      inet  n       -       n       -       -       smtpd
          2525      inet  n       -       n       -       -       smtpd
          2526      inet  n       -       n       -       -       smtpd -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
          mailman unix  -       n       n       -       -       pipe
                flags=FR user=mailman:mailman
                argv=/usr/local/mailman/postfix.py ${nexthop} ${user}
          pickup    fifo  n       -       n       60      1       pickup
          cleanup   unix  n       -       n       -       0       cleanup
          qmgr      fifo  n       -       n       300     1       qmgr
          rewrite   unix  -       -       n       -       -       trivial-rewrite
          bounce    unix  -       -       n       -       0       bounce
          defer     unix  -       -       n       -       0       bounce
          trace     unix  -       -       n       -       0       bounce
          verify    unix  -       -       n       -       1       verify
          flush     unix  n       -       n       1000?   0       flush
          proxymap  unix  -       -       n       -       -       proxymap
          smtp      unix  -       -       n       -       -       smtp
          relay     unix  -       -       n       -       -       smtp
          showq     unix  n       -       n       -       -       showq
          error     unix  -       -       n       -       -       error
          local     unix  -       n       n       -       -       local
          virtual   unix  -       n       n       -       -       virtual
          lmtp      unix  -       -       n       -       -       lmtp
          anvil     unix  -       -       n       -       1       anvil
          maildrop  unix  -       n       n       -       -       pipe
            flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
          old-cyrus unix  -       n       n       -       -       pipe
            flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
          cyrus     unix  -       n       n       -       -       pipe
            user=cyrus argv=/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
          uucp      unix  -       n       n       -       -       pipe
            flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
          ifmail    unix  -       n       n       -       -       pipe
            flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
          bsmtp     unix  -       n       n       -       -       pipe
            flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
          smtp-amavis unix -      -       -     -       2  smtp
            -o smtp_data_done_timeout=1200
            -o disable_dns_lookups=yes
          127.0.0.1:10025 inet n  -       -     -       -  smtpd
            -o content_filter=
            -o local_recipient_maps=
            -o relay_recipient_maps=
            -o smtpd_restriction_classes=
            -o smtpd_client_restrictions=
            -o smtpd_helo_restrictions=
            -o smtpd_sender_restrictions=
            -o smtpd_recipient_restrictions=permit_mynetworks,reject
            -o mynetworks=127.0.0.0/8
            -o strict_rfc821_envelopes=yes
          scache    unix  -       -       n       -       1       scache
          discard   unix  -       -       n       -       -       discard
          tlsmgr    unix  -       -       n       1000?   1       tlsmgr

          -- end of postfinger output --





          Thanks in advance for your help!




          -----------
          Joe Auty
          NetMusician: web publishing software for musicians



        • Victor Duchovni
          ... With RPM upgrades don t let rpm -U move your main.cf/master.cf files aside as mumble.rpmsave . Don t inadvertantly disable virtual rewriting with
          Message 4 of 11 , Oct 31, 2006
          • 0 Attachment
            On Tue, Oct 31, 2006 at 04:45:10PM -0500, Joe Auty wrote:

            > Hello,
            >
            > After upgrading from 2.2 to 2.3, my virtual maps no longer seem to
            > work, even after running a "postmap maps" on my maps file to recreate
            > this DB.
            >
            > What sorts of steps and precautions are necessary from upgrading from
            > 2.2 to 2.3 and ensuring that my virtual maps will remain functional?
            > The online documentation indicates that the only change to the way
            > maps work involves case sensitivity, but I'm not using any case
            > sensitive/upper case mappings.
            >
            > Any theories as to what might be going on here, and how I can resolve
            > this issue?
            >

            With RPM upgrades don't let "rpm -U" move your main.cf/master.cf files
            aside as "mumble.rpmsave".

            Don't inadvertantly disable virtual rewriting with receive_override_options=...

            --
            Viktor.

            Disclaimer: off-list followups get on-list replies or get ignored.
            Please do not ignore the "Reply-To" header.

            To unsubscribe from the postfix-users list, visit
            http://www.postfix.org/lists.html or click the link below:
            <mailto:majordomo@...?body=unsubscribe%20postfix-users>

            If my response solves your problem, the best way to thank me is to not
            send an "it worked, thanks" follow-up. If you must respond, please put
            "It worked, thanks" in the "Subject" so I can delete these quickly.
          • Joe Auty
            ... Hmmm.... I don t have any receive_override_options set, and I m running this under FreeBSD (not an RPM install).... Any other ideas?
            Message 5 of 11 , Nov 1, 2006
            • 0 Attachment
              On Oct 31, 2006, at 5:05 PM, Victor Duchovni wrote:

              > On Tue, Oct 31, 2006 at 04:45:10PM -0500, Joe Auty wrote:
              >
              >> Hello,
              >>
              >> After upgrading from 2.2 to 2.3, my virtual maps no longer seem to
              >> work, even after running a "postmap maps" on my maps file to recreate
              >> this DB.
              >>
              >> What sorts of steps and precautions are necessary from upgrading from
              >> 2.2 to 2.3 and ensuring that my virtual maps will remain functional?
              >> The online documentation indicates that the only change to the way
              >> maps work involves case sensitivity, but I'm not using any case
              >> sensitive/upper case mappings.
              >>
              >> Any theories as to what might be going on here, and how I can resolve
              >> this issue?
              >>
              >
              > With RPM upgrades don't let "rpm -U" move your main.cf/master.cf files
              > aside as "mumble.rpmsave".
              >
              > Don't inadvertantly disable virtual rewriting with
              > receive_override_options=...
              >

              Hmmm.... I don't have any receive_override_options set, and I'm
              running this under FreeBSD (not an RPM install)....

              Any other ideas?



              > --
              > Viktor.
              >
              > Disclaimer: off-list followups get on-list replies or get ignored.
              > Please do not ignore the "Reply-To" header.
              >
              > To unsubscribe from the postfix-users list, visit
              > http://www.postfix.org/lists.html or click the link below:
              > <mailto:majordomo@...?body=unsubscribe%20postfix-users>
              >
              > If my response solves your problem, the best way to thank me is to not
              > send an "it worked, thanks" follow-up. If you must respond, please put
              > "It worked, thanks" in the "Subject" so I can delete these quickly.
            • mouss
              ... check your maps (virtual_alias_maps, alias_maps) using postmap -q. for _var in alias_maps virtual_alias_maps; do maps=`postconf -h $_var | sed /,/ / `;
              Message 6 of 11 , Nov 1, 2006
              • 0 Attachment
                Joe Auty wrote:
                > Hmmm.... I don't have any receive_override_options set, and I'm
                > running this under FreeBSD (not an RPM install)....
                >
                > Any other ideas?

                check your maps (virtual_alias_maps, alias_maps) using postmap -q.

                for _var in alias_maps virtual_alias_maps; do
                maps=`postconf -h $_var | sed '/,/ /'`;
                for _map in $maps; do
                echo checking in $_map
                postmap -q diane@... $_map
                done
                done


                PS. Please obey the Reply-To header (If you don't see what I mean, check
                your last post and that of Viktor).
              • Joe Auty
                ... Hash: SHA1 ... I m not using my alias_maps, but I did double check... my virtual_alias_maps are used, and I don t see a single problem with them. Remember,
                Message 7 of 11 , Nov 2, 2006
                • 0 Attachment
                  -----BEGIN PGP SIGNED MESSAGE-----
                  Hash: SHA1


                  On Nov 1, 2006, at 5:56 PM, mouss wrote:

                  > Joe Auty wrote:
                  >> Hmmm.... I don't have any receive_override_options set, and I'm
                  >> running this under FreeBSD (not an RPM install)....
                  >>
                  >> Any other ideas?
                  >
                  > check your maps (virtual_alias_maps, alias_maps) using postmap -q.
                  >
                  > for _var in alias_maps virtual_alias_maps; do
                  > maps=`postconf -h $_var | sed '/,/ /'`;
                  > for _map in $maps; do
                  > echo checking in $_map
                  > postmap -q diane@... $_map
                  > done
                  > done
                  >
                  >
                  > PS. Please obey the Reply-To header (If you don't see what I mean,
                  > check your last post and that of Viktor).


                  I'm not using my alias_maps, but I did double check... my
                  virtual_alias_maps are used, and I don't see a single problem with
                  them. Remember, this same map file worked under Postfix 2.2.x... here
                  is a sample of that file:

                  example.com DOMAIN
                  diane@... diane
                  info@... diane

                  example2.com DOMAIN
                  #steve@... username@...
                  steve@... steve


                  Of course, I've tried recreating this map file with the usual
                  "postmap maps"...

                  I'm assuming that by obeying the reply-to header you mean not to
                  alter it... In your case, your personal email was in your reply-to,
                  so this email will be sent to both the list and your personal address.


                  Thanks very much in advance, I'd like to get Postfix 2.3 working,
                  your help is appreciated!









                  - -----------
                  Joe Auty
                  NetMusician: web publishing software for musicians
                  http://www.netmusician.org
                  joe@...


                  -----BEGIN PGP SIGNATURE-----
                  Version: GnuPG v1.4.5 (Darwin)

                  iD8DBQFFStCgCgdfeCwsL5ERAmLEAJ90GwqDRrT3zX8ani6g5xh8dWKq5QCfSmWN
                  vTF6QKxpit4BBIUNXIr6p8A=
                  =K5mj
                  -----END PGP SIGNATURE-----
                • mouss
                  ... To avoid surprises, always use fqdn addresses. diane will be rewritten to diane@$myorigin. Note that your setup doesn t define mydomain, but myhostname =
                  Message 8 of 11 , Nov 5, 2006
                  • 0 Attachment
                    Joe Auty wrote:
                    >
                    > I'm not using my alias_maps, but I did double check... my
                    > virtual_alias_maps are used, and I don't see a single problem with
                    > them. Remember, this same map file worked under Postfix 2.2.x... here
                    > is a sample of that file:
                    >
                    > example.com DOMAIN
                    > diane@... diane
                    > info@... diane

                    To avoid surprises, always use fqdn addresses. "diane" will be rewritten
                    to diane@$myorigin.

                    Note that your setup doesn't define mydomain, but myhostname =
                    mydomain.org. This sounds buggy (see how mydomain is deduced from
                    myhostname). again, for less surprises, define mydomain explicitly.

                    > [snip]
                    > I'm assuming that by obeying the reply-to header you mean not to alter
                    > it... In your case, your personal email was in your reply-to, so this
                    > email will be sent to both the list and your personal address.
                    >

                    I was refering to that of Viktor. you CC'ed his From address. see
                    Viktor's sig.
                  • Joe Auty
                    Sorry for my late response, I was out of town... ... I actually have defined mydomain explicitly: # postconf | grep mydomain append_dot_mydomain = yes
                    Message 9 of 11 , Nov 10, 2006
                    • 0 Attachment
                      Sorry for my late response, I was out of town...

                      On Nov 5, 2006, at 2:34 PM, mouss wrote:

                      > Joe Auty wrote:
                      >>
                      >> I'm not using my alias_maps, but I did double check... my
                      >> virtual_alias_maps are used, and I don't see a single problem with
                      >> them. Remember, this same map file worked under Postfix 2.2.x...
                      >> here is a sample of that file:
                      >>
                      >> example.com DOMAIN
                      >> diane@... diane
                      >> info@... diane
                      >
                      > To avoid surprises, always use fqdn addresses. "diane" will be
                      > rewritten to diane@$myorigin.
                      >
                      > Note that your setup doesn't define mydomain, but myhostname =
                      > mydomain.org. This sounds buggy (see how mydomain is deduced from
                      > myhostname). again, for less surprises, define mydomain explicitly.


                      I actually have defined mydomain explicitly:

                      # postconf | grep mydomain
                      append_dot_mydomain = yes
                      mydestination = $myhostname, localhost.$mydomain, localhost,
                      netmusician.org
                      mydomain = netmusician.org
                      myorigin = $mydomain


                      Is it possible that "diane" is not defaulting to diane@$myorigin, and
                      this is the problem?

                      I'm not sure why Postfix would be picking up

                      diane@...

                      But I can certainly test things by adding the $mydomain suffix to my
                      map file if you think this would be worth trying....


                      >> [snip]
                      >> I'm assuming that by obeying the reply-to header you mean not to
                      >> alter it... In your case, your personal email was in your reply-
                      >> to, so this email will be sent to both the list and your personal
                      >> address.
                      >>
                      >
                      > I was refering to that of Viktor. you CC'ed his From address. see
                      > Viktor's sig.
                    • mouss
                      ... I spoke from the snippets you sent. Please send unaltered output of postconf -n if you want help (you can hide private infos, but do that in coherent
                      Message 10 of 11 , Nov 10, 2006
                      • 0 Attachment
                        Joe Auty wrote:
                        >> Note that your setup doesn't define mydomain, but myhostname =
                        >> mydomain.org. This sounds buggy (see how mydomain is deduced from
                        >> myhostname). again, for less surprises, define mydomain explicitly.
                        >
                        >
                        > I actually have defined mydomain explicitly:

                        I spoke from the snippets you sent. Please send unaltered output of
                        'postconf -n' if you want help (you can hide private infos, but do that
                        in coherent manner). see the DEBUG_README for more on this.
                        >
                        > # postconf | grep mydomain
                        > append_dot_mydomain = yes
                        > mydestination = $myhostname, localhost.$mydomain, localhost,
                        > netmusician.org
                        > mydomain = netmusician.org
                        > myorigin = $mydomain
                        >

                        Please, oh please send output of 'postconf -n' and not snippets from
                        main.cf or postconf.

                        >
                        > Is it possible that "diane" is not defaulting to diane@$myorigin, and
                        > this is the problem?
                        >
                        > I'm not sure why Postfix would be picking up
                        >
                        > diane@...
                        >
                        > But I can certainly test things by adding the $mydomain suffix to my
                        > map file if you think this would be worth trying....

                        do not add $mydomain. Add 'netmusician.org'.
                      • Joe Auty
                        ... I ve updated my maps file to add the netmusician.org suffix, rebuilt all of my maps, and this problem has gone away... Thanks for all of your help, and
                        Message 11 of 11 , Nov 17, 2006
                        • 0 Attachment

                          On Nov 10, 2006, at 3:59 PM, mouss wrote:

                          Joe Auty wrote:
                          Note that your setup doesn't define mydomain, but myhostname = mydomain.org. This sounds buggy (see how mydomain is deduced from myhostname). again, for less surprises, define mydomain explicitly.


                          I actually have defined mydomain explicitly:

                          I spoke from the snippets you sent. Please send unaltered output of 'postconf -n' if you want help (you can hide private infos, but do that in coherent manner). see the DEBUG_README for more on this.

                          # postconf | grep mydomain
                          append_dot_mydomain = yes
                          mydestination = $myhostname, localhost.$mydomain, localhost, netmusician.org
                          mydomain = netmusician.org
                          myorigin = $mydomain


                          Please, oh please send output of 'postconf -n' and not snippets from main.cf or postconf.


                          Is it possible that "diane" is not defaulting to diane@$myorigin, and this is the problem?

                          I'm not sure why Postfix would be picking up


                          But I can certainly test things by adding the $mydomain suffix to my map file if you think this would be worth trying....

                          do not add $mydomain. Add 'netmusician.org'.



                          I've updated my maps file to add the netmusician.org suffix, rebuilt all of my maps, and this problem has gone away... 

                          Thanks for all of your help, and sorry for my slow responses in following up here.

                          Let me know if you'd still like to see my config, I'd be happy to share. It still seems problematic that the mapping domain wouldn't default to $mydomain, but for now I'm just happy to have figured out how to complete my upgrade... =)





                          -----------
                          Joe Auty
                          NetMusician: web publishing software for musicians


                        Your message has been successfully submitted and would be delivered to recipients shortly.