Loading ...
Sorry, an error occurred while loading the content.

can't send/receive e-mail to internet

Expand Messages
  • mrk krm
    Hi everybody, i followed the instructions on this manual http://workaround.org/articles/ispmail-sarge/ to install postfix in debian sarge. Everything seems to
    Message 1 of 8 , Oct 1, 2006
    • 0 Attachment
      Hi everybody,

      i followed the instructions on this manual http://workaround.org/articles/ispmail-sarge/ to install postfix in debian sarge. Everything seems to work, i can send and receive e-mail between localhost users/domains, but i can't send or receive outside (internet). My router has the port 25 open and my domain is subsolo.no-ip.org (dynamic dns).

      I look for configuration files and everything looks ok. Even my /etc/reolves.conf is ok. I run postfix
      chrooted, but the files needed are in the right directory.

      my log file reports this:
      > Sep 28 23:33:57 debian postfix/smtp[17578]: F2CCFA3755:
      > to=<mrk_0@...>, relay=none, delay=57, >status=deferred
      > (Host or domain name not found. Name service error for
      > name=linuxmail.org type=MX: Host >not found, try again)

      what could be the error? I searched for 3 days and now i come here to ask your help.
      thank you a lot.

      mark


      --
      _______________________________________________
      Get your free email from http://www.linuxmail.org

      Powered by Outblaze
    • Wietse Venema
      ... 1) See line 10 of the welcome message, repeated below. 2) Test if you as an unprivileged user can do the MX lookup. 3) See
      Message 2 of 8 , Oct 1, 2006
      • 0 Attachment
        mrk krm:
        > Hi everybody,
        >
        > i followed the instructions on this manual http://workaround.org/articles/ispmail-sarge/ to install postfix in debian sarge. Everything seems to work, i can send and receive e-mail between localhost users/domains, but i can't send or receive outside (internet). My router has the port 25 open and my domain is subsolo.no-ip.org (dynamic dns).
        >
        > I look for configuration files and everything looks ok. Even my /etc/reolves.conf is ok. I run postfix
        > chrooted, but the files needed are in the right directory.
        >
        > my log file reports this:
        > > Sep 28 23:33:57 debian postfix/smtp[17578]: F2CCFA3755:
        > > to=<mrk_0@...>, relay=none, delay=57, >status=deferred
        > > (Host or domain name not found. Name service error for
        > > name=linuxmail.org type=MX: Host >not found, try again)
        >
        > what could be the error? I searched for 3 days and now i come here to ask your help.
        > thank you a lot.
        >

        1) See line 10 of the welcome message, repeated below.
        2) Test if you as an unprivileged user can do the MX lookup.
        3) See http://www.postfix.org/DEBUG_README.html#no_chroot
        4) See http://www.postfix.org/faq.html#dns-again

        Wietse

        1 Welcome to the postfix-users mailing list.
        2
        3 This list is for questions and discussions concerning the installation,
        4 configuration and operation of the Postfix mail system.
        5
        6 =================================================================
        7 IMPORTANT INFORMATION IMPORTANT INFORMATION IMPORTANT INFORMATION
        8 =================================================================
        9
        10 To report trouble, see http://www.postfix.org/DEBUG_README.html#mail
        11
        12 To unsubscribe, see http://www.postfix.org/lists.html
        13
        14 =================================================================
        15 IMPORTANT INFORMATION IMPORTANT INFORMATION IMPORTANT INFORMATION
        16 =================================================================
        17
        18 Thank you for using Postfix.
      • Magnus Bäck
        On Sunday, October 01, 2006 at 23:02 CEST, ... You can t run a reliable SMTP service with a dynamic IP address. ... Until Postfix is working, take it out of
        Message 3 of 8 , Oct 1, 2006
        • 0 Attachment
          On Sunday, October 01, 2006 at 23:02 CEST,
          mrk krm <mrk_0@...> wrote:

          > i followed the instructions on this manual
          > http://workaround.org/articles/ispmail-sarge/ to install postfix in
          > debian sarge. Everything seems to work, i can send and receive e-mail
          > between localhost users/domains, but i can't send or receive outside
          > (internet). My router has the port 25 open and my domain is
          > subsolo.no-ip.org (dynamic dns).

          You can't run a reliable SMTP service with a dynamic IP address.

          > I look for configuration files and everything looks ok. Even my
          > /etc/reolves.conf is ok. I run postfix chrooted, but the files
          > needed are in the right directory.

          Until Postfix is working, take it out of the chroot. Don't introduce
          more complexity than needed.

          > my log file reports this:
          > > Sep 28 23:33:57 debian postfix/smtp[17578]: F2CCFA3755:
          > > to=<mrk_0@...>, relay=none, delay=57, >status=deferred
          > > (Host or domain name not found. Name service error for
          > > name=linuxmail.org type=MX: Host >not found, try again)
          >
          > what could be the error? I searched for 3 days and now i come here to
          > ask your help.

          Can you manually look up the MX record of linuxmail.org with e.g. dig(1)
          or nslookup(1)?

          Regarding receiving mail, how is your DNS set up? Can you connect to
          port 25 from the outside. Etc. Be systematic, and do report "postconf -n"
          output.

          --
          Magnus Bäck
          magnus@...
        • /dev/rob0
          ... One small addendum: $ telnet subsolo.no-ip.org 25 Trying 82.154.74.37... telnet: connect to address 82.154.74.37: Connection timed out You re not reachable
          Message 4 of 8 , Oct 1, 2006
          • 0 Attachment
            On Sunday 01 October 2006 16:02, mrk krm wrote:
            > between localhost users/domains, but i can't send or receive outside
            > (internet). My router has the port 25 open and my domain is
            > subsolo.no-ip.org (dynamic dns).

            One small addendum:

            $ telnet subsolo.no-ip.org 25
            Trying 82.154.74.37...
            telnet: connect to address 82.154.74.37: Connection timed out

            You're not reachable from the outside.

            > my log file reports this:
            > > Sep 28 23:33:57 debian postfix/smtp[17578]: F2CCFA3755:
            > > to=<mrk_0@...>, relay=none, delay=57, >status=deferred
            > > (Host or domain name not found. Name service error for
            > > name=linuxmail.org type=MX: Host >not found, try again)
            >
            > what could be the error? I searched for 3 days and now i come here to
            > ask your help. thank you a lot.

            Some cheap consumer-grade routers don't support protocols that their
            manufacturers didn't understand, such as DNS. Perhaps your router is
            one of those, only able to retrieve "A" records, unable to retrieve
            other RR types.
            --
            Offlist mail to this address is discarded unless
            "/dev/rob0" or "not-spam" is in Subject: header
          • mrk krm
            Hi Wietse, thank you for your help. i m able to do the MX lookup as an umprivileged user. But when a do a MX lookup ($dig MX www.hotmail.com) i got the message
            Message 5 of 8 , Oct 1, 2006
            • 0 Attachment
              Hi Wietse,

              thank you for your help.

              i'm able to do the MX lookup as an umprivileged user. But when a do a MX lookup ($dig MX www.hotmail.com) i got the message "connection timed out; no servers could be reached"

              My /etc/resolv.conf has read permissions for all users.

              I turned off the chroot operation in master.conf and i still got the same error.





              > ----- Original Message -----
              > From: wietse@...
              > To: "Postfix users" <postfix-users@...>
              > Subject: Re: can't send/receive e-mail to internet
              > Date: Sun, 1 Oct 2006 17:13:47 -0400 (EDT)
              >
              >
              > mrk krm:
              > > Hi everybody,
              > >
              > > i followed the instructions on this manual
              > > http://workaround.org/articles/ispmail-sarge/ to install postfix
              > > in debian sarge. Everything seems to work, i can send and receive
              > > e-mail between localhost users/domains, but i can't send or
              > > receive outside (internet). My router has the port 25 open and my
              > > domain is subsolo.no-ip.org (dynamic dns). I look for
              > > configuration files and everything looks ok. Even my
              > > /etc/reolves.conf is ok. I run postfix
              > > chrooted, but the files needed are in the right directory.
              > >
              > > my log file reports this:
              > > > Sep 28 23:33:57 debian postfix/smtp[17578]: F2CCFA3755: >
              > > to=<mrk_0@...>, relay=none, delay=57, >status=deferred
              > > > (Host or domain name not found. Name service error for >
              > > name=linuxmail.org type=MX: Host >not found, try again)
              > >
              > > what could be the error? I searched for 3 days and now i come
              > > here to ask your help.
              > > thank you a lot.
              > >
              >
              > 1) See line 10 of the welcome message, repeated below.
              > 2) Test if you as an unprivileged user can do the MX lookup.
              > 3) See http://www.postfix.org/DEBUG_README.html#no_chroot
              > 4) See http://www.postfix.org/faq.html#dns-again
              >
              > Wietse
              >
              > 1 Welcome to the postfix-users mailing list.
              > 2
              > 3 This list is for questions and discussions concerning the installation,
              > 4 configuration and operation of the Postfix mail system.
              > 5
              > 6 =================================================================
              > 7 IMPORTANT INFORMATION IMPORTANT INFORMATION IMPORTANT INFORMATION
              > 8 =================================================================
              > 9
              > 10 To report trouble, see http://www.postfix.org/DEBUG_README.html#mail
              > 11
              > 12 To unsubscribe, see http://www.postfix.org/lists.html
              > 13
              > 14 =================================================================
              > 15 IMPORTANT INFORMATION IMPORTANT INFORMATION IMPORTANT INFORMATION
              > 16 =================================================================
              > 17
              > 18 Thank you for using Postfix.

              >


              --
              _______________________________________________
              Get your free email from http://www.linuxmail.org

              Powered by Outblaze
            • Wietse Venema
              ... What is in /etc/resolv.conf? Wietse
              Message 6 of 8 , Oct 1, 2006
              • 0 Attachment
                mrk krm:
                > Hi Wietse,
                >
                > thank you for your help.
                >
                > i'm able to do the MX lookup as an umprivileged user. But when
                > a do a MX lookup ($dig MX www.hotmail.com) i got the message
                > "connection timed out; no servers could be reached"

                What is in /etc/resolv.conf?

                Wietse
              • mrk krm
                thank you a lot for your help. Now i cand receive e-mail from internet (i couldn t beacause the no-ip.org took 4 days to update the mx record that i set last
                Message 7 of 8 , Oct 3, 2006
                • 0 Attachment
                  thank you a lot for your help. Now i cand receive e-mail from internet (i couldn't beacause the no-ip.org took 4 days to update the mx record that i set last thursday).

                  But i still not being able to send mail.
                  Now i changed the relayhost to the smtp host of my isp. I configured the relayhost with autentication (username/password). But i still have the same error when i send messages:

                  "Oct 3 13:20:23 debian postfix/postfix-script: stopping the Postfix mail system
                  Oct 3 13:20:23 debian postfix/master[21412]: terminating on signal 15
                  Oct 3 13:20:23 debian postfix/postfix-script: starting the Postfix mail system
                  Oct 3 13:20:23 debian postfix/master[23538]: daemon started -- version 2.1.5
                  Oct 3 13:20:36 debian postfix/pickup[23541]: DA63AA3730: uid=5000 from=<discordia@...-ip.org>
                  Oct 3 13:20:36 debian postfix/cleanup[23551]: DA63AA3730: message-id=<20061003122036.DA63AA3730@...-ip.org>
                  Oct 3 13:20:36 debian postfix/qmgr[23542]: DA63AA3730: from=<discordia@...-ip.org>, size=402, nrcpt=1 (queue active)
                  Oct 3 13:21:16 debian postfix/smtp[23558]: DA63AA3730: to=<mrk_0@...>, relay=none, delay=40, status=deferred (Host or domain name not found. Name service error for name=smtp.sapo.pt type=MX: Host not found, try again)"

                  The domain host "smtp.sapo.pt" is the host of my isp server.


                  My resolv.conf file is like this:

                  #nameserver 192.168.1.1
                  nameserver 194.65.100.117
                  nameserver 192.65.5.2

                  - These are the dns servers of my isp

                  - My postconf -n output is:

                  alias_database = hash:/etc/aliases
                  alias_maps = hash:/etc/aliases
                  append_dot_mydomain = no
                  biff = no
                  broken_sasl_auth_clients = yes
                  config_directory = /etc/postfix
                  inet_interfaces = all
                  mailbox_command = procmail -a "$EXTENSION"
                  mailbox_size_limit = 0
                  mydestination = localhost
                  mydomain = subsolo.no-ip.org
                  myhostname = debian.subsolo.no-ip.org
                  mynetworks = 127.0.0.0/8, 192.168.1.0/24
                  myorigin = /etc/mailname
                  recipient_delimiter = +
                  relayhost = smtp.sapo.pt
                  smtp_sasl_auth_enable = yes
                  smtp_sasl_password_maps = hash:/etc/postfix/relay_password
                  smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
                  smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
                  smtpd_sasl_auth_enable = yes
                  smtpd_tls_cert_file = /etc/postfix/smtpd.cert
                  smtpd_tls_key_file = /etc/postfix/smtpd.key
                  smtpd_use_tls = yes
                  virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
                  virtual_gid_maps = static:5000
                  virtual_mailbox_base = /home/vmail
                  virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_domains.cf
                  virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailboxes.cf
                  virtual_uid_maps = static:5000


                  > ----- Original Message -----
                  > From: wietse@...
                  > To: "Postfix users" <postfix-users@...>
                  > Subject: Re: can't send/receive e-mail to internet
                  > Date: Sun, 1 Oct 2006 20:09:42 -0400 (EDT)
                  >
                  >
                  > mrk krm:
                  > > Hi Wietse,
                  > >
                  > > thank you for your help. i'm able to do the MX lookup as an
                  > > umprivileged user. But when
                  > > a do a MX lookup ($dig MX www.hotmail.com) i got the message
                  > > "connection timed out; no servers could be reached"
                  >
                  > What is in /etc/resolv.conf?
                  >
                  > Wietse

                  >


                  --
                  _______________________________________________
                  Get your free email from http://www.linuxmail.org

                  Powered by Outblaze
                • Wietse Venema
                  ... Should be: relayhost = [smtp.sapo.pt]
                  Message 8 of 8 , Oct 3, 2006
                  • 0 Attachment
                    mrk krm:
                    > Oct 3 13:21:16 debian postfix/smtp[23558]: DA63AA3730: to=<mrk_0@...>, relay=none, delay=40, status=deferred (Host or domain name not found. Name service error for name=smtp.sapo.pt type=MX: Host not found, try again)"
                    ...
                    > relayhost = smtp.sapo.pt

                    Should be:

                    relayhost = [smtp.sapo.pt]
                  Your message has been successfully submitted and would be delivered to recipients shortly.