Loading ...
Sorry, an error occurred while loading the content.
 

Procmail transport connection refused

Expand Messages
  • postfix@mistersquid.com
    I ve been running postfix on Mac OS X (stock binary) for about a year now and added postgrey, spamassassin, and procmail as services in June of this year.
    Message 1 of 5 , Sep 30, 2006
      I've been running postfix on Mac OS X (stock binary) for about a year
      now and added postgrey, spamassassin, and procmail as services in
      June of this year. After following these instructions

      http://www.macosxhints.com/article.php?story=20060820100312135

      and then undoing the damage, postfix complains to /var/log/mail.log
      once every minute. I can't figure out what's wrong and my next step,
      after asking you good people your advice, is to revert to my last
      system backup. (If you want to skip the following preliminaries jump
      ahead to [PROBLEM], below.)

      Procmail seems to be refusing a connection from postfix, which seems
      odd because procmail is working and /var/log/procmail.log indicates
      no problems. (That is, procmail is running its recipes and delivering
      mail to my users successfully after receiving mail from postfix.)

      /etc/postfix/main.cf has not changed. It does contain the line

      mailbox_command = /usr/bin/procmail

      /etc/postfix/master.cf did change, but I reverted it. There are no
      references to procamil in /etc/postfix/master.cf.

      This is what /var/log/mail.log contains after a fresh reboot

      Sep 30 18:38:23 localhost postgrey[89]: Process Backgrounded\n
      Sep 30 18:38:23 localhost postgrey[89]: 2006/09/30-18:38:23 postgrey
      (type Net::Server::Multiplex) starting! pid(89)\n
      Sep 30 18:38:23 localhost postgrey[89]: Binding to TCP port 10023 on
      host localhost\n\n
      Sep 30 18:38:23 localhost postgrey[89]: Setting gid to "25 25"\n
      Sep 30 18:38:23 localhost postgrey[89]: Setting uid to "25"\n
      Sep 30 18:39:00 lefty postfix/smtpd[339]: connect from py-
      out-1112.google.com[64.233.166.183]
      Sep 30 18:39:03 lefty postfix/smtpd[339]: NOQUEUE: reject: RCPT from
      py-out-1112.google.com[64.233.166.183]: 450 <mail@...>:
      Recipient address rejected: Greylisted for 300 seconds (see http://
      isg.ee.ethz.ch/tools/postgrey/help/AAAAAAAAA.net.html);
      from=<AAAAA.AAAA+caf_=mail=AAAAAAAAA.net@...>
      to=<mail@...> proto=ESMTP helo=<py-out-1112.google.com>
      Sep 30 18:39:03 lefty postfix/smtpd[339]: disconnect from py-
      out-1112.google.com[64.233.166.183]
      [... greylisting in effect ...]
      Sep 30 18:48:49 lefty postfix/smtpd[491]: connect from nf-
      out-0910.google.com[64.233.182.191]
      Sep 30 18:48:50 lefty postgrey[89]: delayed 409 seconds: client=nf-
      out-0910.google.com, from=AAAAAAAAAAA@...,
      to=AAAAAAAAAAA@...\n
      Sep 30 18:48:51 lefty postfix/smtpd[491]: 552DA7ABBC6: client=nf-
      out-0910.google.com[64.233.182.191]
      Sep 30 18:48:51 lefty postfix/cleanup[493]: 552DA7ABBC6: message-
      id=<36e140f90609301542g699efeb4o852507add94b31dd@...>
      Sep 30 18:48:51 lefty postfix/qmgr[494]: 552DA7ABBC6:
      from=<AAAAAAAAAAA@...>, size=1384, nrcpt=1 (queue active)
      Sep 30 18:48:51 lefty postfix/qmgr[494]: C0A7A6BDA13:
      from=<AAAAAAAAAAA@...>, size=1381, nrcpt=1 (queue active)
      Sep 30 18:48:51 lefty postfix/qmgr[494]: warning: connect to
      transport procmail: Connection refused
      Sep 30 18:48:57 lefty postfix/pipe[495]: 552DA7ABBC6:
      to=<AAAAAAA@...>,
      orig_to=<AAAAAAAAAAA@...>, relay=spamassassin, delay=8,
      status=sent (mail.dreamyskies.net)
      Sep 30 18:48:57 lefty postfix/qmgr[494]: 552DA7ABBC6: removed
      Sep 30 18:48:57 lefty postfix/pickup[500]: 7435C7ABBE3: uid=401
      from=<AAAAAAAAAAA@...>
      Sep 30 18:48:57 lefty postfix/cleanup[493]: 7435C7ABBE3: message-
      id=<36e140f90609301542g699efeb4o852507add94b31dd@...>
      Sep 30 18:48:57 lefty postfix/qmgr[494]: 7435C7ABBE3:
      from=<AAAAAAAAAAA@...>, size=1680, nrcpt=1 (queue active)
      Sep 30 18:48:58 lefty postfix/local[501]: 7435C7ABBE3:
      to=<AAAAAAA@...>, relay=local, delay=1, status=sent
      (delivered to command: /usr/bin/procmail)
      Sep 30 18:48:58 lefty postfix/qmgr[494]: 7435C7ABBE3: removed
      Sep 30 18:49:21 lefty postfix/smtpd[491]: disconnect from nf-
      out-0910.google.com[64.233.182.191]
      Sep 30 18:49:51 lefty postfix/qmgr[494]: warning: connect to
      transport procmail: Connection refused
      [... user checks mail ...]
      [PROBLEM]
      Sep 30 18:50:51 lefty postfix/qmgr[494]: warning: connect to
      transport procmail: Connection refused
      Sep 30 18:51:51 lefty postfix/qmgr[494]: warning: connect to
      transport procmail: Connection refused
      Sep 30 18:52:51 lefty postfix/qmgr[494]: warning: connect to
      transport procmail: Connection refused
      Sep 30 18:53:51 lefty postfix/qmgr[494]: warning: connect to
      transport procmail: Connection refused
      [... etc ...]

      I don't know what's causing this warning and I can't figure out what
      postfix is asking procmail to do that it hadn't been asking before.
      Besides adding 40,000 lines to /var/log/mail.log every month, I
      suppose this isn't that much of a problem, but any pointers or advice
      would greatly be appreciated.

      Thank you for reading this far and, in advance, for any tips you
      might have.

      Johnnie Wilcox
      aka mistersquid
    • Victor Duchovni
      ... This a command executed by the local transport instead of delivering mail for a system user to the user s mailbox directly. ... This is Postfix trying to
      Message 2 of 5 , Sep 30, 2006
        On Sat, Sep 30, 2006 at 07:35:22PM -0400, postfix@... wrote:

        > /etc/postfix/main.cf has not changed. It does contain the line
        >
        > mailbox_command = /usr/bin/procmail

        This a command executed by the local transport instead of delivering
        mail for a system user to the user's mailbox directly.

        > [PROBLEM]
        > Sep 30 18:50:51 lefty postfix/qmgr[494]: warning: connect to
        > transport procmail: Connection refused

        This is Postfix trying to route a message to a non-existent "procmail"
        transport. Something in your configuration is selecting "procmail"
        as a transport:

        - mailbox_transport = procmail
        - content_filter = procmail
        - default_transport = procmail
        - relay_transport = procmail
        - virtual_transport = procmail
        - local_transport = procmail
        - transport_maps = hash:/etc/postfix/transport
        transport:
        some.domain procmail

        --
        Viktor.

        Disclaimer: off-list followups get on-list replies or get ignored.
        Please do not ignore the "Reply-To" header.

        To unsubscribe from the postfix-users list, visit
        http://www.postfix.org/lists.html or click the link below:
        <mailto:majordomo@...?body=unsubscribe%20postfix-users>

        If my response solves your problem, the best way to thank me is to not
        send an "it worked, thanks" follow-up. If you must respond, please put
        "It worked, thanks" in the "Subject" so I can delete these quickly.
      • postfix@mistersquid.com
        Viktor, Thank you for your reply. /etc/postfix/main.cf mailbox_command = /usr/bin/procmail is intentional on my part. Procmail seems to work fine except for
        Message 3 of 5 , Sep 30, 2006
          Viktor,

          Thank you for your reply.

          /etc/postfix/main.cf
          mailbox_command = /usr/bin/procmail

          is intentional on my part. Procmail seems to work fine except for
          those postfix complaints. There are NO OTHER uncommented references
          to procmail in /etc/postfix/main.cf. Here is another quirk. If I
          comment the line to get

          /etc/postfix/main.cf
          #mailbox_command = /usr/bin/procmail

          and then reload postfix, the error messages *keep coming*. How is
          this possible? I don't believe I have any references to procmail in
          master.cf either.

          Considering rolling back one step,

          Johnnie

          On 30 Sep 2006, at 8:53 PM, Victor Duchovni wrote:

          > On Sat, Sep 30, 2006 at 07:35:22PM -0400, postfix@...
          > wrote:
          >
          >> /etc/postfix/main.cf has not changed. It does contain the line
          >>
          >> mailbox_command = /usr/bin/procmail
          >
          > This a command executed by the local transport instead of delivering
          > mail for a system user to the user's mailbox directly.
          >
          >> [PROBLEM]
          >> Sep 30 18:50:51 lefty postfix/qmgr[494]: warning: connect to
          >> transport procmail: Connection refused
          >
          > This is Postfix trying to route a message to a non-existent "procmail"
          > transport. Something in your configuration is selecting "procmail"
          > as a transport:
          >
          > - mailbox_transport = procmail
          > - content_filter = procmail
          > - default_transport = procmail
          > - relay_transport = procmail
          > - virtual_transport = procmail
          > - local_transport = procmail
          > - transport_maps = hash:/etc/postfix/transport
          > transport:
          > some.domain procmail
          >
          > --
          > Viktor.
          ................
        • /dev/rob0
          Please don t top-post; it makes the thread much harder to follow. ... Right. ... Right. ... Consider rereading below. ... snip ... That means it s not in
          Message 4 of 5 , Sep 30, 2006
            Please don't top-post; it makes the thread much harder to follow.

            On Saturday 30 September 2006 20:37, postfix@... wrote:
            > /etc/postfix/main.cf
            > mailbox_command = /usr/bin/procmail
            >
            > is intentional on my part. Procmail seems to work fine except for
            > those postfix complaints. There are NO OTHER uncommented references
            > to procmail in /etc/postfix/main.cf. Here is another quirk. If I
            > comment the line to get
            >
            > /etc/postfix/main.cf
            > #mailbox_command = /usr/bin/procmail
            >
            > and then reload postfix, the error messages *keep coming*. How is

            Right.

            > this possible? I don't believe I have any references to procmail in
            > master.cf either.

            Right.

            > Considering rolling back one step,

            Consider rereading below.

            > On 30 Sep 2006, at 8:53 PM, Victor Duchovni wrote:
            snip
            > >> Sep 30 18:50:51 lefty postfix/qmgr[494]: warning: connect to
            > >> transport procmail: Connection refused
            > >
            > > This is Postfix trying to route a message to a non-existent
            > > "procmail" transport.

            That means it's not in master.cf.

            > > Something in your configuration is selecting
            > > "procmail" as a transport:
            > >
            > > - mailbox_transport = procmail
            > > - content_filter = procmail
            > > - default_transport = procmail
            > > - relay_transport = procmail
            > > - virtual_transport = procmail
            > > - local_transport = procmail

            Any of those would have to be listed in main.cf.

            > > - transport_maps = hash:/etc/postfix/transport

            But *this* doesn't directly mention procmail in main.cf.

            > > transport:
            > > some.domain procmail

            At this time you will have to see DEBUG_README.html#mail before
            proceeding. Something in your configuration is attempting to route
            messages to a "procmail" transport. Perhaps you just changed it, and
            these are previously queued ... *we don't have enough information* !
            --
            Offlist mail to this address is discarded unless
            "/dev/rob0" or "not-spam" is in Subject: header
          • Victor Duchovni
            ... Yes, I said this is fine. ... Then check master.cf and the transport table, and messages in the queue with stale content filter settings (postsuper -r ALL
            Message 5 of 5 , Oct 1, 2006
              On Sat, Sep 30, 2006 at 09:37:08PM -0400, postfix@... wrote:

              > Viktor,
              >
              > Thank you for your reply.
              >
              > /etc/postfix/main.cf
              > mailbox_command = /usr/bin/procmail
              >
              > is intentional on my part. Procmail seems to work fine except for
              > those postfix complaints.

              Yes, I said this is fine.

              > There are NO OTHER uncommented references
              > to procmail in /etc/postfix/main.cf.

              Then check master.cf and the transport table, and messages in the
              queue with stale content filter settings (postsuper -r ALL to fix).

              > Here is another quirk. If I
              > comment the line to get
              >
              > /etc/postfix/main.cf
              > #mailbox_command = /usr/bin/procmail

              You did not read/understand my previous message.

              > and then reload postfix, the error messages *keep coming*. How is
              > this possible? I don't believe I have any references to procmail in
              > master.cf either.
              >

              You are using "procmail" as a TRANSPORT! (quite different from
              mailbox_command). Find out where this is set, and disable.

              --
              Viktor.

              Disclaimer: off-list followups get on-list replies or get ignored.
              Please do not ignore the "Reply-To" header.

              To unsubscribe from the postfix-users list, visit
              http://www.postfix.org/lists.html or click the link below:
              <mailto:majordomo@...?body=unsubscribe%20postfix-users>

              If my response solves your problem, the best way to thank me is to not
              send an "it worked, thanks" follow-up. If you must respond, please put
              "It worked, thanks" in the "Subject" so I can delete these quickly.
            Your message has been successfully submitted and would be delivered to recipients shortly.