Loading ...
Sorry, an error occurred while loading the content.

Postfix overload on a Debian Server

Expand Messages
  • Huby franck
    Hello, We use postfix as MTA to send mails informations to our customers. We send 2 000 ~ 4 000 mails per day. Recently our debian server fall regularly by
    Message 1 of 25 , Sep 29, 2006
    • 0 Attachment
      Hello,

      We use postfix as MTA to send mails informations to our customers.

      We send 2'000 ~ 4'000 mails per day.

      Recently our debian server fall regularly by overload and the processes
      that make this overload are always smtp/smtpd.

      Load average of our server can go up to 245 when we send the
      informations mails .... normally our server didnt support more than 8 in
      load average.... so we need to hard-reboot this server 2~3 times per day
      for sending all our mails ...

      I've tried to perform an optimisation of postfix configuration but it
      does not work.
      I've tried the Postfix Performance Tuning show on the postfix website.
      But after tunning postfix don't let me send mails (unique or mass).

      is there anybody's got an idea ?
      --
      Franck Huby
      Développeur Informatique
      HOSPIMEDIA
      T. : + 33 (0)3 20 32 52 32
      F. : + 33 (0)3 20 32 62 35
      www.hospimedia.fr www.staffsante.fr
    • Ralf Hildebrandt
      ... That s not much. ... How many are running? How s the load? Is the machine swapping? -- Ralf Hildebrandt (Ralf.Hildebrandt@charite.de)
      Message 2 of 25 , Sep 29, 2006
      • 0 Attachment
        * Huby franck <franck.huby@...>:
        > Hello,
        >
        > We use postfix as MTA to send mails informations to our customers.
        >
        > We send 2'000 ~ 4'000 mails per day.

        That's not much.

        > Recently our debian server fall regularly by overload and the processes
        > that make this overload are always smtp/smtpd.

        How many are running? How's the load? Is the machine swapping?

        --
        Ralf Hildebrandt (Ralf.Hildebrandt@...) spamtrap@...
        Postfix - Einrichtung, Betrieb und Wartung Tel. +49 (0)30-450 570-155
        http://www.postfix-buch.com
        Quoted-Printable : a standard for mangling Internet messages
        Quoted-Unreadable : the result of applying said standard
        Unquoted-Unprintable: the comments from the recipients of the above
      • Huby franck
        ... yep i think so ! ... in normaly run : - running 24~25 smtp+smtpd processes. for a load average of ~0.40. the server didn t swapping for an active queue of
        Message 3 of 25 , Sep 29, 2006
        • 0 Attachment
          Le vendredi 29 septembre 2006 à 10:30 +0200, Ralf Hildebrandt a écrit :
          > * Huby franck <franck.huby@...>:
          > > Hello,
          > >
          > > We use postfix as MTA to send mails informations to our customers.
          > >
          > > We send 2'000 ~ 4'000 mails per day.
          >
          > That's not much.
          yep i think so !

          >
          > > Recently our debian server fall regularly by overload and the processes
          > > that make this overload are always smtp/smtpd.
          >
          > How many are running? How's the load? Is the machine swapping?
          >
          in normaly run :
          - running 24~25 smtp+smtpd processes. for a load average of ~0.40. the
          server didn't swapping
          for an active queue of 2'000 ~ 4'000 mails

          when the server overload :
          - running up than 1'000 smtp+smtpd processes.
          - postfix (2.1.5 debian stable package) seems to be unable to close
          smtp processes
          - Load sundently goes up to 240 and still increase untill server didn't
          ping or respond by RPC. mails didn't go out
          - server swapping on.
          - server start to stop respond on services (ssh or web or all others)
          after a load up to 10.
          - informations is get by RPC.
          The last chance we add at this point is to make an "hard-reboot" to
          restart all services.
          sometimes overload start with only 700 mails or less in active queue !!

          --
          Franck Huby
          Développeur Informatique
          HOSPIMEDIA
          T. : + 33 (0)3 20 32 52 32
          F. : + 33 (0)3 20 32 62 35
          www.hospimedia.fr www.staffsante.fr
        • Ralf Hildebrandt
          ... Well, why did you set the process limits to a value higher than your machine can handle? Show master.cf, show postconf -n output. -- Ralf Hildebrandt
          Message 4 of 25 , Sep 29, 2006
          • 0 Attachment
            * Huby franck <franck.huby@...>:
            > > How many are running? How's the load? Is the machine swapping?
            > >
            > in normaly run :
            > - running 24~25 smtp+smtpd processes. for a load average of ~0.40. the
            > server didn't swapping
            > for an active queue of 2'000 ~ 4'000 mails
            >
            > when the server overload :
            > - running up than 1'000 smtp+smtpd processes.

            Well, why did you set the process limits to a value higher than your
            machine can handle?

            Show master.cf, show "postconf -n" output.

            --
            Ralf Hildebrandt (Ralf.Hildebrandt@...) spamtrap@...
            Postfix - Einrichtung, Betrieb und Wartung Tel. +49 (0)30-450 570-155
            http://www.postfix-buch.com
            Why you can't find your system administrators:
            They are hiding under the stairs
          • Huby franck
            ... I didn t ! ... Others values in master.cf (I ve tried 10 in smtp s entity) makes postfix rejet mail sending and freeze the queue. master.cf : #
            Message 5 of 25 , Sep 29, 2006
            • 0 Attachment
              Le vendredi 29 septembre 2006 à 11:16 +0200, Ralf Hildebrandt a écrit :
              > * Huby franck <franck.huby@...>:
              > > > How many are running? How's the load? Is the machine swapping?
              > > >
              > > in normaly run :
              > > - running 24~25 smtp+smtpd processes. for a load average of ~0.40. the
              > > server didn't swapping
              > > for an active queue of 2'000 ~ 4'000 mails
              > >
              > > when the server overload :
              > > - running up than 1'000 smtp+smtpd processes.
              >
              > Well, why did you set the process limits to a value higher than your
              > machine can handle?
              I didn't !

              >
              > Show master.cf, show "postconf -n" output.
              >
              Others values in master.cf (I've tried 10 in smtp's entity) makes
              postfix rejet mail sending and freeze the queue.

              master.cf :

              #
              ==========================================================================
              # service type private unpriv chroot wakeup maxproc command + args
              # (yes) (yes) (yes) (never) (100)
              #
              ==========================================================================
              smtp inet n - - - 50 smtpd
              pickup fifo n - - 60 1 pickup
              cleanup unix n - - - 0 cleanup
              qmgr fifo n - - 300 1 qmgr
              #qmgr fifo n - - 300 1 oqmgr
              rewrite unix - - - - - trivial-rewrite
              bounce unix - - - - 0 bounce
              defer unix - - - - 0 bounce
              trace unix - - - - 0 bounce
              verify unix - - - - 1 verify
              flush unix n - - 1000? 0 flush
              proxymap unix - - n - - proxymap
              smtp unix - - - - 50 smtp
              relay unix - - - - 50 smtp
              -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
              showq unix n - - - - showq
              error unix - - - - - error
              local unix - n n - - local
              virtual unix - n n - - virtual
              lmtp unix - - n - - lmtp
              anvil unix - - n - 1 anvil
              maildrop unix - n n - - pipe
              flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
              uucp unix - n n - - pipe
              flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail
              ($recipient)
              ifmail unix - n n - - pipe
              flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
              bsmtp unix - n n - - pipe
              flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -d -t$nexthop -f$sender
              $recipient
              scalemail-backend unix - n n - 2 pipe
              flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store
              ${nexthop} ${user} ${extension}
              tlsmgr unix - - - 1000? 1 tlsmgr
              scache unix - - - - 1 scache
              discard unix - - - - - discard

              -----------
              less default_process_limit makes postfix didn't work!

              postconf -n :

              alias_database = hash:/etc/aliases
              alias_maps = hash:/etc/aliases
              append_dot_mydomain = no
              biff = no
              broken_sasl_auth_clients = yes
              config_directory = /etc/postfix
              default_process_limit = 10
              inet_interfaces = all
              mailbox_size_limit = 102400000
              mydestination = [..], localhost.ovh.net, localhost
              myhostname = [..]
              myorigin = /etc/mailname
              recipient_delimiter = +
              relayhost =
              smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
              smtpd_helo_required = yes
              smtpd_recipient_restrictions = reject_unknown_sender_domain,
              reject_unknown_recipient_domain, permit_mynetworks,
              permit_sasl_authenticated, check_client_access
              hash:/etc/postfix/access reject_unauth_destination,
              permit
              smtpd_reject_unlisted_sender = yes
              smtpd_sasl_auth_enable = yes
              smtpd_sasl_security_options = noanonymous, noplaintext
              smtpd_tls_cert_file = /etc/courier/pop3d.pem
              smtpd_use_tls = yes
              virtual_alias_maps = hash:/etc/postfix/virtual
              virtual_gid_maps = static:103
              virtual_mailbox_base = /home/postfix
              virtual_mailbox_domains = [..], [..], [..], [..], [..], [..], [..], [..]
              virtual_mailbox_maps = hash:/etc/postfix/vmailbox
              virtual_minimum_uid = 100
              virtual_uid_maps = static:102

              --
              Franck Huby
              Développeur Informatique
              HOSPIMEDIA
              T. : + 33 (0)3 20 32 52 32
              F. : + 33 (0)3 20 32 62 35
              www.hospimedia.fr www.staffsante.fr
            • Ralf Hildebrandt
              ... This looks OK, but is not used for sending, but receiving. ... This looks OK, too. ... Since you set them explicitly in master.cf! Hmm, I can t spot an
              Message 6 of 25 , Sep 29, 2006
              • 0 Attachment
                * Huby franck <franck.huby@...>:

                > #
                > ==========================================================================
                > # service type private unpriv chroot wakeup maxproc command + args
                > # (yes) (yes) (yes) (never) (100)
                > #
                > ==========================================================================
                > smtp inet n - - - 50 smtpd

                This looks OK, but is not used for sending, but receiving.

                > pickup fifo n - - 60 1 pickup
                > cleanup unix n - - - 0 cleanup
                > qmgr fifo n - - 300 1 qmgr
                > #qmgr fifo n - - 300 1 oqmgr
                > rewrite unix - - - - - trivial-rewrite
                > bounce unix - - - - 0 bounce
                > defer unix - - - - 0 bounce
                > trace unix - - - - 0 bounce
                > verify unix - - - - 1 verify
                > flush unix n - - 1000? 0 flush
                > proxymap unix - - n - - proxymap

                > smtp unix - - - - 50 smtp
                > relay unix - - - - 50 smtp
                > -o smtp_helo_timeout=5 -o smtp_connect_timeout=5

                This looks OK, too.

                > less default_process_limit makes postfix didn't work!

                Since you set them explicitly in master.cf!

                Hmm, I can't spot an error.

                --
                Ralf Hildebrandt (Ralf.Hildebrandt@...) spamtrap@...
                Postfix - Einrichtung, Betrieb und Wartung Tel. +49 (0)30-450 570-155
                http://www.postfix-buch.com
                Disclaimer:
                By sending an email to ANY of my addresses you are agreeing that:
                1. I am by definition, "the intended recipient"
                2. All information in the email is mine to do with as I see fit and
                make such financial profit, political mileage, or good joke as it
                lends itself to. In particular, I may quote it on usenet.
                3. I may take the contents as representing the views of your company.
                4. This overrides any disclaimer or statement of confidentiality that
                may be included on your message.
              • Huby franck
                ... yep i feel the same ! thanks for trying -- Franck Huby Développeur Informatique HOSPIMEDIA T. : + 33 (0)3 20 32 52 32 F. : + 33 (0)3 20 32 62 35
                Message 7 of 25 , Sep 29, 2006
                • 0 Attachment
                  Le vendredi 29 septembre 2006 à 11:33 +0200, Ralf Hildebrandt a écrit :
                  > Hmm, I can't spot an error.
                  yep i feel the same !

                  thanks for trying
                  --
                  Franck Huby
                  Développeur Informatique
                  HOSPIMEDIA
                  T. : + 33 (0)3 20 32 52 32
                  F. : + 33 (0)3 20 32 62 35
                  www.hospimedia.fr www.staffsante.fr
                • Wietse Venema
                  ... That is not possible with the DEFAULT settings which allow no more than 100 of each service type. Undo your Postfix modifications, do postfix reload , and
                  Message 8 of 25 , Sep 29, 2006
                  • 0 Attachment
                    Huby franck:
                    > > > when the server overload :
                    > > > - running up than 1'000 smtp+smtpd processes.

                    That is not possible with the DEFAULT settings which allow no more
                    than 100 of each service type.

                    Undo your Postfix modifications, do "postfix reload", and demonstrate
                    that the process count exceeds the configured count.

                    Wietse
                  • lst_hoe01@kwsoft.de
                    ... What is in the logs????? Regards Andreas
                    Message 9 of 25 , Sep 29, 2006
                    • 0 Attachment
                      Zitat von Huby franck <franck.huby@...>:

                      > Hello,
                      >
                      > We use postfix as MTA to send mails informations to our customers.
                      >
                      > We send 2'000 ~ 4'000 mails per day.
                      >
                      > Recently our debian server fall regularly by overload and the processes
                      > that make this overload are always smtp/smtpd.
                      >
                      > Load average of our server can go up to 245 when we send the
                      > informations mails .... normally our server didnt support more than 8 in
                      > load average.... so we need to hard-reboot this server 2~3 times per day
                      > for sending all our mails ...
                      >
                      > I've tried to perform an optimisation of postfix configuration but it
                      > does not work.
                      > I've tried the Postfix Performance Tuning show on the postfix website.
                      > But after tunning postfix don't let me send mails (unique or mass).
                      >
                      > is there anybody's got an idea ?



                      What is in the logs?????

                      Regards

                      Andreas
                    • Huby franck
                      Le vendredi 29 septembre 2006 à 13:47 +0200, lst_hoe01@kwsoft.de a ... in the syslog : nothing else relay denied from others mta. (in mass yep see above an
                      Message 10 of 25 , Sep 29, 2006
                      • 0 Attachment
                        Le vendredi 29 septembre 2006 à 13:47 +0200, lst_hoe01@... a
                        écrit :
                        > Zitat von Huby franck <franck.huby@...>:
                        >
                        > > Hello,
                        > >
                        > > We use postfix as MTA to send mails informations to our customers.
                        > >
                        > > We send 2'000 ~ 4'000 mails per day.
                        > >
                        > > Recently our debian server fall regularly by overload and the processes
                        > > that make this overload are always smtp/smtpd.
                        > >
                        > > Load average of our server can go up to 245 when we send the
                        > > informations mails .... normally our server didnt support more than 8 in
                        > > load average.... so we need to hard-reboot this server 2~3 times per day
                        > > for sending all our mails ...
                        > >
                        > > I've tried to perform an optimisation of postfix configuration but it
                        > > does not work.
                        > > I've tried the Postfix Performance Tuning show on the postfix website.
                        > > But after tunning postfix don't let me send mails (unique or mass).
                        > >
                        > > is there anybody's got an idea ?
                        >
                        >
                        >
                        > What is in the logs?????
                        in the syslog : nothing else relay denied from others mta. (in mass yep
                        see above an example but stop to be logged when overload starts).

                        in mail.log : nothing else ordinary work of postfix (ininteruptive logs
                        around the faillure time)

                        in mail.err : nothing around the overload time (blackhole around the
                        boot time)

                        in mail.info : Blackhole about 3 minutes before the boot time (the exact
                        duration of the last overload this morning at 08:16 AM)

                        in mail.warn : nothing else user passwords faillures... but not at the
                        overload time

                        and there's no "postfix" named logs.

                        server is generally not able to write logs when it overloads..

                        >
                        > Regards
                        >
                        > Andreas
                        >
                        >
                        >

                        Syslog infos :

                        Sep 29 08:10:03 [..] postfix/smtp[22607]: 525AF75AA9: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:04 [..] postfix/smtp[1221]: 334F575AA9: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:04 [..] postfix/smtp[1221]: 334F575AA9: to=<...>,
                        relay=[..][..], delay=0, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:05 [..] postfix/smtp[3550]: E933F75AA8: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:05 [..] postfix/smtp[3550]: E933F75AA8: to=<...>,
                        relay=[..][..], delay=1, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:05 [..] postfix/smtp[4970]: AF5EA75AAA: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:05 [..] postfix/smtp[4970]: AF5EA75AAA: to=<...>,
                        relay=[..][..], delay=1, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:11 [..] postfix/smtp[19335]: 06F9475AAE: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:11 [..] postfix/smtp[19335]: 06F9475AAE: to=<...>,
                        relay=[..][..], delay=0, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:12 [..] postfix/smtp[1221]: C50EF75AB0: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:12 [..] postfix/smtp[1221]: C50EF75AB0: to=<...>,
                        relay=[..][..], delay=1, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:20 [..] postfix/smtp[32518]: C5FEA75AB4: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:20 [..] postfix/smtp[32518]: C5FEA75AB4: to=<...>,
                        relay=[..][..], delay=1, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:21 [..] postfix/smtp[19335]: D8B8075AB3: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:21 [..] postfix/smtp[19335]: D8B8075AB3: to=<...>,
                        relay=[..][..], delay=1, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:22 [..] postfix/smtp[10834]: 1FA1A75AB1: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:22 [..] postfix/smtp[10834]: 1FA1A75AB1: to=<...>,
                        relay=[..][..], delay=0, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:22 [..] postfix/smtp[19871]: EE8F175AB6: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:22 [..] postfix/smtp[19871]: EE8F175AB6: to=<...>,
                        relay=[..][..], delay=1, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:23 [..] postfix/smtp[16532]: 5C0AA75AB5: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:23 [..] postfix/smtp[16532]: 5C0AA75AB5: to=<...>,
                        relay=[..][..], delay=0, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:24 [..] postfix/smtp[1295]: 4619875ABA: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:24 [..] postfix/smtp[1295]: 4619875ABA: to=<...>,
                        relay=[..][..], delay=0, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:24 [..] postfix/smtp[25475]: 1F7AE75AAD: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:24 [..] postfix/smtp[25475]: 1F7AE75AAD: to=<...>,
                        relay=[..][..], delay=0, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:26 [..] postfix/smtp[32518]: F38E775AB7: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:26 [..] postfix/smtp[32518]: F38E775AB7: to=<...>,
                        relay=[..][..], delay=1, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:27 [..] postfix/smtp[18935]: 7BEC475ABD: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:27 [..] postfix/smtp[18935]: 7BEC475ABD: to=<...>,
                        relay=[..][..], delay=0, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:28 [..] postfix/smtp[16532]: A074475ABF: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:28 [..] postfix/smtp[16532]: A074475ABF: to=<...>,
                        relay=[..][..], delay=1, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:28 [..] postfix/smtp[9156]: C524F75AC0: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:28 [..] postfix/smtp[9156]: C524F75AC0: to=<...>,
                        relay=[..][..], delay=1, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:44 [..] postfix/smtp[25475]: 23E6E75ABB: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:44 [..] postfix/smtp[25475]: 23E6E75ABB: to=<...>,
                        relay=[..][..], delay=0, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:45 [..] postfix/smtp[1283]: 60FBD75AB9: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:45 [..] postfix/smtp[1283]: 60FBD75AB9: to=<...>,
                        relay=[..][..], delay=0, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:47 [..] postfix/smtp[22607]: 15AFB75AC1: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:47 [..] postfix/smtp[22607]: 15AFB75AC1: to=<...>,
                        relay=[..][..], delay=0, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:47 [..] postfix/smtp[24863]: 6665075AC6: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:47 [..] postfix/smtp[24863]: 6665075AC6: to=<...>,
                        relay=[..][..], delay=0, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:47 [..] postfix/smtp[27006]: 3F1F675AC5: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:47 [..] postfix/smtp[27006]: 3F1F675AC5: to=<...>,
                        relay=[..][..], delay=0, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:49 [..] postfix/smtp[12139]: D1BCB75AC8: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:49 [..] postfix/smtp[12139]: D1BCB75AC8: to=<...>,
                        relay=[..][..], delay=1, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:10:59 [..] postfix/smtp[1267]: A06D175AB2: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:10:59 [..] postfix/smtp[1267]: A06D175AB2: to=<...>,
                        relay=[..][..], delay=1, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:11:00 [..] postfix/smtp[1283]: 6387D75AD9: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:11:00 [..] postfix/smtp[1283]: 6387D75AD9: to=<...>,
                        relay=[..][..], delay=0, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:11:02 [..] postfix/smtp[1267]: 0651875AD5: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:11:02 [..] postfix/smtp[1267]: 0651875AD5: to=<...>,
                        relay=[..][..], delay=1, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:11:04 [..] postfix/smtp[4970]: A7FFF75AAF: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:11:04 [..] postfix/smtp[4970]: A7FFF75AAF: to=<...>,
                        relay=[..][..], delay=1, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:11:05 [..] postfix/smtp[3713]: F3927758AA: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:11:05 [..] postfix/smtp[3713]: F3927758AA: to=<...>,
                        relay=[..][..], delay=1, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:11:11 [..] postfix/smtp[12139]: BDCAB758C4: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:11:11 [..] postfix/smtp[12139]: BDCAB758C4: to=<...>,
                        relay=[..][..], delay=1, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:12:12 [..] postfix/smtp[1267]: E819B75B0B: to=<...>,
                        relay=smtp.oleane.net[194.2.8.83], delay=25, status=sent (250 2.0.0
                        k8T6CFDp019330 Message accepted for delivery)
                        Sep 29 08:12:24 [..] postfix/smtp[5856]: DCDDD75AE7: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:12:24 [..] postfix/smtp[5856]: DCDDD75AE7: to=<...>,
                        relay=[..][..], delay=18, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:12:26 [..] postfix/smtp[5856]: 04B0575AFF: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:12:26 [..] postfix/smtp[5856]: 04B0575AFF: to=<...>,
                        relay=[..][..], delay=18, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:12:26 [..] postfix/smtp[5856]: AA75375B2D: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:12:26 [..] postfix/smtp[5856]: AA75375B2D: to=<...>,
                        relay=[..][..], delay=19, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)
                        Sep 29 08:12:54 [..] postfix/smtp[28769]: 083D7758AE: host [..][..]
                        refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                        connections
                        Sep 29 08:12:54 [..] postfix/smtp[28769]: 083D7758AE: to=<...>,
                        relay=[..][..], delay=1, status=deferred (host [..][..] refused to talk
                        to me: 421 <[..][..]>: Client host rejected: too many connections)


                        --
                        Franck Huby
                        Développeur Informatique
                        HOSPIMEDIA
                        T. : + 33 (0)3 20 32 52 32
                        F. : + 33 (0)3 20 32 62 35
                        www.hospimedia.fr www.staffsante.fr
                      • Wietse Venema
                        ... That is nonsense, Postfix NEVER freezes a process. If you freeze processes by hand, then you are interfering with the mail system s operation in an
                        Message 11 of 25 , Sep 29, 2006
                        • 0 Attachment
                          Huby franck:
                          > Le vendredi 29 septembre 2006 ? 07:43 -0400, Wietse Venema a ?crit :
                          > > Huby franck:
                          > > > > > when the server overload :
                          > > > > > - running up than 1'000 smtp+smtpd processes.
                          > >
                          > > That is not possible with the DEFAULT settings which allow no more
                          > > than 100 of each service type.
                          > >
                          > Exept when postfix cannot "kill" some processes and consider freeze's
                          > process as killed...

                          That is nonsense,

                          Postfix NEVER freezes a process. If you freeze processes by hand,
                          then you are interfering with the mail system's operation in an
                          unsupported manner.

                          Sorry, Postfix is not immune against operator incompetence.

                          Wietse
                        • Huby franck
                          ... I ve tried with the defaults And with a limit of 50 for the smtp and the relay in the master.cf. In the twice my server freeze. For monitoring i ve do :
                          Message 12 of 25 , Sep 29, 2006
                          • 0 Attachment
                            Le vendredi 29 septembre 2006 à 07:43 -0400, Wietse Venema a écrit :
                            > Huby franck:
                            > > > > when the server overload :
                            > > > > - running up than 1'000 smtp+smtpd processes.
                            >
                            > That is not possible with the DEFAULT settings which allow no more
                            > than 100 of each service type.
                            >
                            > Undo your Postfix modifications, do "postfix reload", and demonstrate
                            > that the process count exceeds the configured count.
                            >
                            > Wietse
                            >
                            I've tried with the defaults
                            And with a limit of 50 for the smtp and the relay in the master.cf.
                            In the twice my server freeze.

                            For monitoring i've do :
                            while 1
                            do
                            ps aux | grep smtp | wc -l
                            sleep 1
                            done

                            The last value it return was 1'000 and there my server wont respond
                            any-more.

                            at the same time In a top with options : delay at 1s, user postfix :
                            the load average is go up to 240 and all processes listed whered smtp

                            At the same time rpsysinfo of my server return the same value of load
                            average.

                            I use the 2.1.5-9 version off postfix because i've troubles with
                            installing a backport of 2.3.3 in the debian we use.

                            I apologies that's the kernel (2.4.32 grsec) is not correctly working
                            with the process lists and return wrong values to postfix when postfix
                            trie to kill the smtps process.

                            Regards
                            --
                            Franck Huby
                            Développeur Informatique
                            HOSPIMEDIA
                            T. : + 33 (0)3 20 32 52 32
                            F. : + 33 (0)3 20 32 62 35
                            www.hospimedia.fr www.staffsante.fr
                          • Wietse Venema
                            Huby franck: [ Charset UTF-8 unsupported, converting... ] ... You ve got a seriously broken kernel. Postfix will not create a process that exceeds the
                            Message 13 of 25 , Sep 29, 2006
                            • 0 Attachment
                              Huby franck:
                              [ Charset UTF-8 unsupported, converting... ]
                              > Le vendredi 29 septembre 2006 ? 07:43 -0400, Wietse Venema a ?crit :
                              > > Huby franck:
                              > > > > > when the server overload :
                              > > > > > - running up than 1'000 smtp+smtpd processes.
                              > >
                              > > That is not possible with the DEFAULT settings which allow no more
                              > > than 100 of each service type.
                              > >
                              > > Undo your Postfix modifications, do "postfix reload", and demonstrate
                              > > that the process count exceeds the configured count.
                              > >
                              > > Wietse
                              > >
                              > I've tried with the defaults
                              > And with a limit of 50 for the smtp and the relay in the master.cf.
                              > In the twice my server freeze.
                              >
                              > For monitoring i've do :
                              > while 1
                              > do
                              > ps aux | grep smtp | wc -l
                              > sleep 1
                              > done
                              >
                              > The last value it return was 1'000 and there my server wont respond
                              > any-more.

                              You've got a seriously broken kernel. Postfix will not
                              create a process that exceeds the per-class process limit.

                              Look at the actual status of those processes. Are they
                              running, terminated, zombies or what?

                              Wietse
                            • Huby franck
                              ... I don t ......! Postfix NEVER freezes a process : how do you explain escalation of smtp process over the limit defined in the master.cf ? ... No ! I let
                              Message 14 of 25 , Sep 29, 2006
                              • 0 Attachment
                                Le vendredi 29 septembre 2006 à 09:04 -0400, Wietse Venema a écrit :
                                > Huby franck:
                                > > Le vendredi 29 septembre 2006 ? 07:43 -0400, Wietse Venema a ?crit :
                                > > > Huby franck:
                                > > > > > > when the server overload :
                                > > > > > > - running up than 1'000 smtp+smtpd processes.
                                > > >
                                > > > That is not possible with the DEFAULT settings which allow no more
                                > > > than 100 of each service type.
                                > > >
                                > > Exept when postfix cannot "kill" some processes and consider freeze's
                                > > process as killed...
                                >
                                > That is nonsense,
                                >
                                > Postfix NEVER freezes a process. If you freeze processes by hand,
                                I don't ......!

                                "Postfix NEVER freezes a process" : how do you explain escalation of
                                smtp process over the limit defined in the master.cf ?

                                > then you are interfering with the mail system's operation in an
                                > unsupported manner.
                                No ! I let postfix do it's job. The mails are send by cron scripting and
                                nobody has acces to the server in that sort of manner !

                                I just report what i've see through a ssh connexion.

                                >
                                > Sorry, Postfix is not immune against operator incompetence.
                                Whaooo !

                                Afflicted to be an imbecile in your eyes.
                                I sought a just little assistance.


                                >
                                > Wietse
                                >
                                --
                                Franck Huby
                                Développeur Informatique
                                HOSPIMEDIA
                                T. : + 33 (0)3 20 32 52 32
                                F. : + 33 (0)3 20 32 62 35
                                www.hospimedia.fr www.staffsante.fr
                              • lst_hoe01@kwsoft.de
                                ... What is the destination?? Always the same or many different hosts?? You are running way to many processes and by the settings you have shown this is not
                                Message 15 of 25 , Sep 29, 2006
                                • 0 Attachment
                                  Zitat von Huby franck <franck.huby@...>:

                                  > Le vendredi 29 septembre 2006 à 13:47 +0200, lst_hoe01@... a
                                  > écrit :
                                  >> Zitat von Huby franck <franck.huby@...>:
                                  >>
                                  >> > Hello,
                                  >> >
                                  >> > We use postfix as MTA to send mails informations to our customers.
                                  >> >
                                  >> > We send 2'000 ~ 4'000 mails per day.
                                  >> >
                                  >> > Recently our debian server fall regularly by overload and the processes
                                  >> > that make this overload are always smtp/smtpd.
                                  >> >
                                  >> > Load average of our server can go up to 245 when we send the
                                  >> > informations mails .... normally our server didnt support more than 8 in
                                  >> > load average.... so we need to hard-reboot this server 2~3 times per day
                                  >> > for sending all our mails ...
                                  >> >
                                  >> > I've tried to perform an optimisation of postfix configuration but it
                                  >> > does not work.
                                  >> > I've tried the Postfix Performance Tuning show on the postfix website.
                                  >> > But after tunning postfix don't let me send mails (unique or mass).
                                  >> >
                                  >> > is there anybody's got an idea ?
                                  >>
                                  >>
                                  >>
                                  >> What is in the logs?????
                                  > in the syslog : nothing else relay denied from others mta. (in mass yep
                                  > see above an example but stop to be logged when overload starts).
                                  >
                                  > in mail.log : nothing else ordinary work of postfix (ininteruptive logs
                                  > around the faillure time)
                                  >
                                  > in mail.err : nothing around the overload time (blackhole around the
                                  > boot time)
                                  >
                                  > in mail.info : Blackhole about 3 minutes before the boot time (the exact
                                  > duration of the last overload this morning at 08:16 AM)
                                  >
                                  > in mail.warn : nothing else user passwords faillures... but not at the
                                  > overload time
                                  >
                                  > and there's no "postfix" named logs.
                                  >
                                  > server is generally not able to write logs when it overloads..
                                  >
                                  >>
                                  >> Regards
                                  >>
                                  >> Andreas
                                  >>
                                  >>
                                  >>
                                  >
                                  > Syslog infos :
                                  >
                                  > Sep 29 08:10:03 [..] postfix/smtp[22607]: 525AF75AA9: host [..][..]
                                  > refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                                  > connections
                                  > Sep 29 08:10:04 [..] postfix/smtp[1221]: 334F575AA9: host [..][..]
                                  > refused to talk to me: 421 <[..][..]>: Client host rejected: too many
                                  > connections

                                  What is the destination?? Always the same or many different hosts??
                                  You are running way to many processes and by the settings you have
                                  shown this is not possible with a sane OS. Find out whats broken on
                                  this machine (maybe the GRE extensions you have mentioned) or install
                                  postfix on a working OS.

                                  Regards

                                  Andreas
                                • Uwe Dippel
                                  ... I can confirm that 2.1.5-9 is the version on Debian Sarge. ... I don t understand. 2.4.27-10 would be the kernel of Sarge. Before things escalate, I can
                                  Message 16 of 25 , Sep 29, 2006
                                  • 0 Attachment
                                    Huby franck wrote:

                                    > I use the 2.1.5-9 version off postfix because i've troubles with
                                    > installing a backport of 2.3.3 in the debian we use.

                                    I can confirm that 2.1.5-9 is the version on Debian Sarge.

                                    > I apologies that's the kernel (2.4.32 grsec) is not correctly working
                                    > with the process lists and return wrong values to postfix when postfix
                                    > trie to kill the smtps process.

                                    I don't understand. 2.4.27-10 would be the kernel of Sarge.
                                    Before things escalate, I can only offer my help on the matter:
                                    How could I emulate your situation on plain Sarge, in order to reach a
                                    point of overload like you describe ? (I probably don't have the network
                                    resources to saturate the system, though.)

                                    Maybe I'm off, but at least, let us exclude a mistake on the side of
                                    Debian-packaging. The box is a PIII-300, with 256 MB of RAM. Compared to
                                    yours, it should die fast. Let's see; tell me what to do ... !


                                    Uwe
                                  • /dev/rob0
                                    ... Most of us here are far below Wietse s level, so the best thing to do IMO is to accept it and listen and learn. ... I didn t read the whole thread in
                                    Message 17 of 25 , Sep 29, 2006
                                    • 0 Attachment
                                      On Friday 29 September 2006 08:17, Huby franck wrote:
                                      > Le vendredi 29 septembre 2006 à 09:04 -0400, Wietse Venema a écrit :
                                      > > Sorry, Postfix is not immune against operator incompetence.
                                      >
                                      > Whaooo !
                                      >
                                      > Afflicted to be an imbecile in your eyes.

                                      Most of us here are far below Wietse's level, so the best thing to do
                                      IMO is to accept it and listen and learn.

                                      > I sought a just little assistance.

                                      I didn't read the whole thread in detail, but I did see the references
                                      to your grsec-patched kernel. I strongly suspect grsec to be the
                                      culprit. If you don't know what you're doing with things like SELinux
                                      or grsecurity, the best thing to do is to disable it until you have
                                      time to learn it.
                                      --
                                      Offlist mail to this address is discarded unless
                                      "/dev/rob0" or "not-spam" is in Subject: header
                                    • Bryan Irvine
                                      ... what the hell is grsec? (sorry I m a bsd snob) I d start there. Is there a generic debian kernel lying around that you can boot with and
                                      Message 18 of 25 , Sep 29, 2006
                                      • 0 Attachment
                                        <snip>
                                        > I apologies that's the kernel (2.4.32 grsec) is not correctly working
                                        > with the process lists and return wrong values to postfix when postfix
                                        > trie to kill the smtps process.
                                        <snip>

                                        what the hell is grsec? (sorry I'm a bsd snob) I'd start there. Is
                                        there a generic debian kernel lying around that you can boot with and
                                        try again?
                                      • Ralf Hildebrandt
                                        ... So kernel level stuff that prevents certain operations commonly used by exploits etc. -- Ralf Hildebrandt (Ralf.Hildebrandt@charite.de)
                                        Message 19 of 25 , Sep 30, 2006
                                        • 0 Attachment
                                          * Bryan Irvine <sparctacus@...>:

                                          > what the hell is grsec?

                                          So kernel level stuff that prevents certain operations commonly used
                                          by exploits etc.

                                          --
                                          Ralf Hildebrandt (Ralf.Hildebrandt@...) spamtrap@...
                                          Postfix - Einrichtung, Betrieb und Wartung Tel. +49 (0)30-450 570-155
                                          http://www.postfix-buch.com
                                          Why you can't find your system administrators:
                                          is talking to his manager
                                        • /dev/rob0
                                          ... IOW, it breaks everything. :) -- Offlist mail to this address is discarded unless /dev/rob0 or not-spam is in Subject: header
                                          Message 20 of 25 , Sep 30, 2006
                                          • 0 Attachment
                                            On Saturday 30 September 2006 02:18, Ralf Hildebrandt wrote:
                                            > * Bryan Irvine <sparctacus@...>:
                                            > > what the hell is grsec?
                                            >
                                            > So kernel level stuff that prevents certain operations commonly
                                            > used by exploits etc.

                                            IOW, it breaks everything. :)
                                            --
                                            Offlist mail to this address is discarded unless
                                            "/dev/rob0" or "not-spam" is in Subject: header
                                          • Ralf Hildebrandt
                                            ... Yes, didn t I say that? -- Ralf Hildebrandt (Ralf.Hildebrandt@charite.de) spamtrap@charite.de Postfix - Einrichtung, Betrieb und Wartung
                                            Message 21 of 25 , Sep 30, 2006
                                            • 0 Attachment
                                              * /dev/rob0 <rob0@...>:

                                              > > > what the hell is grsec?
                                              > >
                                              > > So kernel level stuff that prevents certain operations commonly
                                              > > used by exploits etc.
                                              >
                                              > IOW, it breaks everything. :)

                                              Yes, didn't I say that?

                                              --
                                              Ralf Hildebrandt (Ralf.Hildebrandt@...) spamtrap@...
                                              Postfix - Einrichtung, Betrieb und Wartung Tel. +49 (0)30-450 570-155
                                              http://www.postfix-buch.com
                                              "It's always nice to see USA set the edgy standards. First for
                                              freedom, then for the police state."
                                            • mouss
                                              ... Nice try. Let me try too: # ps -aux | grep smtp ... /usr/pkg/sbin/clamsmtpd -p /var/run/clamsmtpd.pid ... Find a better way to count your postfix
                                              Message 22 of 25 , Oct 1, 2006
                                              • 0 Attachment
                                                Huby franck wrote:
                                                >>
                                                > I've tried with the defaults
                                                > And with a limit of 50 for the smtp and the relay in the master.cf.
                                                > In the twice my server freeze.
                                                >
                                                > For monitoring i've do :
                                                > while 1
                                                > do
                                                > ps aux | grep smtp | wc -l
                                                >

                                                Nice try. Let me try too:

                                                # ps -aux | grep smtp
                                                ... /usr/pkg/sbin/clamsmtpd -p /var/run/clamsmtpd.pid
                                                ...

                                                Find a better way to count your postfix processes...
                                                Try grep "^postfix" if these processes run as postfix, and no other
                                                processes run as postfix.
                                              • mouss
                                                ... Explain what? we didn t see any proof that this happens. ps aux | grep local | wc -l doesn t give the number of local delivery agent processes.
                                                Message 23 of 25 , Oct 1, 2006
                                                • 0 Attachment
                                                  Huby franck wrote:
                                                  > "Postfix NEVER freezes a process" : how do you explain escalation of
                                                  > smtp process over the limit defined in the master.cf ?
                                                  >

                                                  Explain what? we didn't see any proof that this happens.

                                                  ps aux | grep local | wc -l

                                                  doesn't give the number of local delivery agent processes.
                                                • Victor Duchovni
                                                  ... This will count both smtp and smtpd processes. It will also count smtp processes for both the relay and the smtp transports, which in combination
                                                  Message 24 of 25 , Oct 1, 2006
                                                  • 0 Attachment
                                                    On Sun, Oct 01, 2006 at 02:20:50PM +0200, mouss wrote:

                                                    > Huby franck wrote:
                                                    > >>
                                                    > >I've tried with the defaults
                                                    > >And with a limit of 50 for the smtp and the relay in the master.cf.
                                                    > >In the twice my server freeze.
                                                    > >
                                                    > >For monitoring i've do :
                                                    > >while 1
                                                    > >do
                                                    > >ps aux | grep smtp | wc -l
                                                    > >
                                                    >

                                                    This will count both "smtp" and "smtpd" processes. It will also count
                                                    "smtp" processes for both the "relay" and the "smtp" transports, which
                                                    in combination can exceed the individual process limits for either.

                                                    A better matching rule is required (that looks at the arguments of
                                                    the "smtp" server to discriminate between the "smtp" and "relay"
                                                    transports (the second has a "-n relay" argument).

                                                    --
                                                    Viktor.

                                                    Disclaimer: off-list followups get on-list replies or get ignored.
                                                    Please do not ignore the "Reply-To" header.

                                                    To unsubscribe from the postfix-users list, visit
                                                    http://www.postfix.org/lists.html or click the link below:
                                                    <mailto:majordomo@...?body=unsubscribe%20postfix-users>

                                                    If my response solves your problem, the best way to thank me is to not
                                                    send an "it worked, thanks" follow-up. If you must respond, please put
                                                    "It worked, thanks" in the "Subject" so I can delete these quickly.
                                                  • Geert Hendrickx
                                                    ... Or pgrep -x smtp , or pgrep -u postfix , that works at least on NetBSD. Geert
                                                    Message 25 of 25 , Oct 1, 2006
                                                    • 0 Attachment
                                                      On Sun, Oct 01, 2006 at 02:20:50PM +0200, mouss wrote:
                                                      > Huby franck wrote:
                                                      > >>
                                                      > >I've tried with the defaults
                                                      > >And with a limit of 50 for the smtp and the relay in the master.cf.
                                                      > >In the twice my server freeze.
                                                      > >
                                                      > >For monitoring i've do :
                                                      > >while 1
                                                      > >do
                                                      > >ps aux | grep smtp | wc -l
                                                      > >
                                                      >
                                                      > Nice try. Let me try too:
                                                      >
                                                      > # ps -aux | grep smtp
                                                      > ... /usr/pkg/sbin/clamsmtpd -p /var/run/clamsmtpd.pid
                                                      > ...
                                                      >
                                                      > Find a better way to count your postfix processes...
                                                      > Try grep "^postfix" if these processes run as postfix, and no other
                                                      > processes run as postfix.

                                                      Or "pgrep -x smtp", or "pgrep -u postfix", that works at least on NetBSD.

                                                      Geert
                                                    Your message has been successfully submitted and would be delivered to recipients shortly.