Loading ...
Sorry, an error occurred while loading the content.
 

Re: clamsmtpd: couldn't bind to address: 10025: Address already in use

Expand Messages
  • Wolfgang Paul Rauchholz
    To all, thank you very much for your input. The error was that when I installed clamsmtpd via its src.rpm which finally started-up automatically the clamsmtpd
    Message 1 of 6 , Sep 4, 2006
      To all, thank you very much for your input.
      The error was that when I installed clamsmtpd via its src.rpm which finally started-up automatically the clamsmtpd daemon which was (auto)blocking itself.

      Salu2, Wolfgang

      On 9/4/06, Mihira Fernando <mihiratheace@...> wrote:
      Wolfgang Paul Rauchholz wrote:
      > I set up a server with postfix, dovecot and spamassassin under CentOS. That
      > works.
      > But no that I am trying to add clamAV I get 2 erros i am not able to fix.
      >
      > the 1st one is related to clamsmtpd. I followd a howto to setup clamsmtpd.
      [snip]

      To get Clamsmtpd running with Postfix :

      clamsmtpd.conf
      --------------------------
      # The address to send scanned mail to.
      # This option is required unless TransparentProxy is enabled
      OutAddress: 10026

      # Address to listen on (defaults to all local addresses on port 10025)
      Listen: 127.0.0.1:10025

      main.cf
      -------------------------
      content_filter = clsmtp:[127.0.0.1]:10025
      receive_override_options = no_address_mappings


      master.cf
      --------------------------
      clsmtp unix - - - - 16 smtp
               -o smtp_data_done_timeout=2400
               -o smtp_send_xforward_command=yes


      localhost:10026 inet n - - - - smtpd
               -o content_filter=
               -o local_recipient_maps=
               -o relay_recipient_maps=
               -o smtpd_restriction_classes=
               -o
      receive_override_options=no_unknown_recipient_checks,no_header_body_checks
               -o smtpd_helo_restrictions=
               -o smtpd_client_restrictions=
               -o smtpd_sender_restrictions=
               -o smtpd_recipient_restricions=permit_mynetworks,reject
               -o mynetworks=127.0.0.0/8


      The settings should be similar to those.
      --
      Random Quotes From Megas XLR
      Coop: You see? The mysteries of the Universe are revealed when you break
      stuff.
      Jamie: When in doubt, blow up a planet.
      Kiva: It's an 80 foot robot, if we can't see it, absolutely it's not here.
      Glorft Technician: Unnecessary use of force in capturing the Earthers
      has been approved.


    Your message has been successfully submitted and would be delivered to recipients shortly.