Loading ...
Sorry, an error occurred while loading the content.
 

Re: Telnet to localhost works, to IP Address does not

Expand Messages
  • James Brown
    Noel, you are an absolute genius! Sure enough, Apple had added a section at the end of main.cf: # THE FOLLOWING DEFAULTS ARE SET BY APPLE # # bind to localhost
    Message 1 of 3 , Jul 31, 2006
      Noel, you are an absolute genius!

      Sure enough, Apple had added a section at the end of main.cf:

      # THE FOLLOWING DEFAULTS ARE SET BY APPLE
      #
      # bind to localhost only
      #
      #inet_interfaces = all

      # turn off relaying for local subnet
      #
      mynetworks_style = host

      # mydomain_fallback: optional domain to use if mydomain is not set and
      # myhostname is not fully qualified.  It is ignored if neither are true.
      #
      mydomain_fallback = bordo.com.au

      # The mailbox_size_limit parameter controls the maximal size of a
      # mailbox or maildir file (in fact, it limits the size of any file
      # that is written to upon local delivery) The default is 50 MBytes.
      # This limit must not be set smaller than the message size limit.
      #
      mailbox_size_limit = 0

      #smtpd_tls_key_file =

      If I comment out these lines it works fine. I have spent so long trying to figure this out. I can't believe how quickly you solved it!

      Thanks heaps,

      James.


      On 31/07/2006, at 4:50 PM, Noel Jones wrote:

      At 01:43 AM 7/31/2006, James Brown wrote:
      postconf -n shows:

      inet_interfaces = localhost

      Obviously the probem is that inet_interfaces = localhost. But in
      main.cf I have:

      inet_interfaces = all


      Very likely you have more than one inet_interfaces line in main.cf.
      If a parameter is set multiple times, postfix will use the last setting.  postconf will always show the setting used by postfix.

      You can try
      # postconf -e inet_interfaces=all

      -- 
      Noel Jones 


    Your message has been successfully submitted and would be delivered to recipients shortly.
    »
    «