Loading ...
Sorry, an error occurred while loading the content.

postfix 2.3; smtp_sasl_password_maps doesn't work with user@domain.com fields

Expand Messages
  • est_seg@o2.pl
    Hi, I have compiled postfix-2.3-20060611 version. I use smtp_sasl_password_maps parameter and in this file I use something like this: user01@domain.com
    Message 1 of 2 , Jul 1 2:56 AM
    • 0 Attachment
      Hi,

      I have compiled postfix-2.3-20060611 version. I use
      smtp_sasl_password_maps parameter and in this file I use something like
      this:

      user01@... user01:pass01
      user02@... user02:pass02

      and what smtp client do:

      ... smtp_sasl_passwd_lookup: host `domain.com' no auth info found ...

      If I insert field "domain.com user01:pass01" than it works, but I need
      AUTH per user, not per domain.

      For me it doesn't work at all. My parameters in main.cf:

      smtp_sasl_auth_enable = yes
      smtp_sasl_mechanism_filter = plain, login
      smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
      smtp_sasl_security_options = noanonymous
      smtp_sender_dependent_authentication = yes


      and I also do
      # postmap /etc/postfix/sasl_passwd
      # postfix reload

      Is it my fault or is it bug ?
    • est_seg@o2.pl
      Ok it was my fault, postfix was linked with old libraries ... now it works fine :))))) btw, now I use postfix 2.3 rc1 Best Regards!
      Message 2 of 2 , Jul 1 4:33 AM
      • 0 Attachment
        Ok it was my fault, postfix was linked with old libraries ... now it
        works fine :)))))
        btw, now I use postfix 2.3 rc1




        Best Regards!
      Your message has been successfully submitted and would be delivered to recipients shortly.