Loading ...
Sorry, an error occurred while loading the content.

Re: non-existent service type ...

Expand Messages
  • LDB
    ... Not being argumentative but I was trying to tell you I have already done that but I will do it again ... I did postsuper -r and here is the result ...
    Message 1 of 11 , Apr 2, 2006
    • 0 Attachment
      Wietse Venema wrote:
      > LDB:
      >> Wietse Venema wrote:
      >>> LDB:
      >>>> postfix/qmgr[21213]: warning: connect to transport spam-check: Connection refused
      >
      > [mail remembers that it needs to be filtered]
      >
      >> Yep, exactly .... funny thing though.. there is nothing in the queue which makes
      >> this issue even stranger. I have restart postfix and everything and it still
      >> just shows up.
      >
      > Stop arguing with the expert.
      >
      > Do "postsuper -r" or stop complaining.
      >
      > Wietse
      >

      Not being argumentative but I was trying to tell you I have already done that
      but I will do it again ...


      I did "postsuper -r" and here is the result ...

      /etc/postfix # postsuper -r
      postsuper: option requires an argument -- r
      postsuper: fatal: usage: postsuper [-c config_dir] [-d queue_id (delete)] [-h
      queue_id (hold)] [-H queue_id (un-hold)] [-p (purge temporary files)] [-r
      queue_id (requeue)] [-s (structure fix)] [-v (verbose)] [queue...]



      Then I did a "postsuper -r ALL", I still get same message.


      This is version, postfix-2.2.5-5.
    • Victor Duchovni
      ... Then you are still using that content filter setting for at least the pickup service, either via main.cf or master.cf. -- Viktor. Disclaimer: off-list
      Message 2 of 11 , Apr 2, 2006
      • 0 Attachment
        On Sun, Apr 02, 2006 at 10:27:47AM -0400, LDB wrote:

        >
        > Then I did a "postsuper -r ALL", I still get same message.

        Then you are still using that content filter setting for at least
        the pickup service, either via main.cf or master.cf.

        --
        Viktor.

        Disclaimer: off-list followups get on-list replies or get ignored.
        Please do not ignore the "Reply-To" header.

        To unsubscribe from the postfix-users list, visit
        http://www.postfix.org/lists.html or click the link below:
        <mailto:majordomo@...?body=unsubscribe%20postfix-users>

        If my response solves your problem, the best way to thank me is to not
        send an "it worked, thanks" follow-up. If you must respond, please put
        "It worked, thanks" in the "Subject" so I can delete these quickly.
      • LDB
        ... No they are not. trust me ... I have greped through /etc/postfix/* .. It is cool .. I am just going to let it go since it is not doing realy harm. It is
        Message 3 of 11 , Apr 2, 2006
        • 0 Attachment
          Victor Duchovni wrote:
          > On Sun, Apr 02, 2006 at 10:27:47AM -0400, LDB wrote:
          >
          >> Then I did a "postsuper -r ALL", I still get same message.
          >
          > Then you are still using that content filter setting for at least
          > the pickup service, either via main.cf or master.cf.
          >

          No they are not. trust me ... I have greped through /etc/postfix/* ..

          It is cool .. I am just going to let it go since it is not doing realy harm. It
          is just annoying...


          Thanks,

          LDB
        • Victor Duchovni
          ... I am afraid that I must trust your logs over your anecdotal reports. If a message resolves to a particular transport via the address class default, a
          Message 4 of 11 , Apr 2, 2006
          • 0 Attachment
            On Sun, Apr 02, 2006 at 12:14:37PM -0400, LDB wrote:

            > Victor Duchovni wrote:
            > >On Sun, Apr 02, 2006 at 10:27:47AM -0400, LDB wrote:
            > >
            > >>Then I did a "postsuper -r ALL", I still get same message.
            > >
            > >Then you are still using that content filter setting for at least
            > >the pickup service, either via main.cf or master.cf.
            > >
            >
            > No they are not. trust me ... I have greped through /etc/postfix/* ..

            I am afraid that I must trust your logs over your anecdotal reports.
            If a message resolves to a particular transport via the address class
            default, a transport table entry or content_filter, then you have
            configured that transport for the address class, in the transport table
            or as content filter.

            > It is cool .. I am just going to let it go since it is not doing realy
            > harm. It is just annoying...

            The logs don't lie. You have not looked hard enough.

            --
            Viktor.

            Disclaimer: off-list followups get on-list replies or get ignored.
            Please do not ignore the "Reply-To" header.

            To unsubscribe from the postfix-users list, visit
            http://www.postfix.org/lists.html or click the link below:
            <mailto:majordomo@...?body=unsubscribe%20postfix-users>

            If my response solves your problem, the best way to thank me is to not
            send an "it worked, thanks" follow-up. If you must respond, please put
            "It worked, thanks" in the "Subject" so I can delete these quickly.
          • Matt Fretwell
            On Sun, 02 Apr 2006 12:14:37 -0400 ... Then post the output of postconf -n and your master.cf. It must be specified somewhere if it is still being logged after
            Message 5 of 11 , Apr 2, 2006
            • 0 Attachment
              On Sun, 02 Apr 2006 12:14:37 -0400
              LDB wrote:

              > Victor Duchovni wrote:
              > > On Sun, Apr 02, 2006 at 10:27:47AM -0400, LDB wrote:
              > >
              > >> Then I did a "postsuper -r ALL", I still get same message.
              > >
              > > Then you are still using that content filter setting for at least
              > > the pickup service, either via main.cf or master.cf.
              > >
              >
              > No they are not. trust me ... I have greped through /etc/postfix/* ..
              >
              > It is cool .. I am just going to let it go since it is not doing
              > realy harm. It is just annoying...


              Then post the output of postconf -n and your master.cf. It must be
              specified somewhere if it is still being logged after a reload and a
              postsuper -r.


              Matt
            • LDB
              ... Yes, you are correct. I have not looked hard enough. LDB
              Message 6 of 11 , Apr 2, 2006
              • 0 Attachment
                Victor Duchovni wrote:
                > On Sun, Apr 02, 2006 at 12:14:37PM -0400, LDB wrote:
                >
                >> Victor Duchovni wrote:
                >>> On Sun, Apr 02, 2006 at 10:27:47AM -0400, LDB wrote:
                >>>
                >>>> Then I did a "postsuper -r ALL", I still get same message.
                >>> Then you are still using that content filter setting for at least
                >>> the pickup service, either via main.cf or master.cf.
                >>>
                >> No they are not. trust me ... I have greped through /etc/postfix/* ..
                >
                > I am afraid that I must trust your logs over your anecdotal reports.
                > If a message resolves to a particular transport via the address class
                > default, a transport table entry or content_filter, then you have
                > configured that transport for the address class, in the transport table
                > or as content filter.
                >
                >> It is cool .. I am just going to let it go since it is not doing realy
                >> harm. It is just annoying...
                >
                > The logs don't lie. You have not looked hard enough.
                >

                Yes, you are correct. I have not looked hard enough.



                LDB
              • Gary V
                ... My personal experience in this situation: after you requeue the mail (for example): postsuper -r ALL and have waited long enough for the message(s) in
                Message 7 of 11 , Apr 2, 2006
                • 0 Attachment
                  > >
                  > > Then I did a "postsuper -r ALL", I still get same message.
                  >
                  >Then you are still using that content filter setting for at least
                  >the pickup service, either via main.cf or master.cf.
                  >
                  >--
                  > Viktor.
                  >

                  My personal experience in this situation: after you requeue the mail (for
                  example):
                  postsuper -r ALL

                  and have waited long enough for the message(s) in question to be delivered
                  (no longer queued), under certain circumstances qmgr may continue to log the
                  error message. Stop and start qmgr with:
                  postfix stop
                  postfix start

                  I had the OP try this and it did solve the problem. I have seen this
                  behavior before:

                  http://marc.theaimsgroup.com/?l=postfix-users&m=112889574429767&w=2

                  Gary V

                  _________________________________________________________________
                  Is your PC infected? Get a FREE online computer virus scan from McAfee´┐Ż
                  Security. http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963
                Your message has been successfully submitted and would be delivered to recipients shortly.