Loading ...
Sorry, an error occurred while loading the content.
 

Re: Double email received

Expand Messages
  • mouss
    ... make sure to disable address rewrite either before or after the filter. See the FILTER README. ... This is not very helpful. If you can t post your logs,
    Message 1 of 4 , Mar 31, 2006
      Lonely Wolf wrote:
      > -----BEGIN PGP SIGNED MESSAGE-----
      > Hash: SHA1
      >
      > mouss ha scritto:
      >
      >> If you can't provide complete informations, it will be hard to guess.
      >>
      >> A good start is
      >> http://www.postfix.org/DEBUG_README.html#mail
      >>
      >> a common misconfiguration is when virtual aliases are expanded twice
      >> (before and after a content filter).
      >>
      >
      > Oh, you're right, i'm sorry :/
      >
      > I've already read DEBUG_README but i haven't found anything that can
      > help me.
      >
      > So, main results from my postconf -n
      >
      > alias_maps = hash:/etc/aliases
      > command_directory = /usr/sbin
      > config_directory = /etc/postfix
      > daemon_directory = /usr/libexec/postfix
      > debug_peer_level = 2
      > disable_vrfy_command = yes
      > header_checks = regexp:/etc/postfix/myheader_checks
      > myhostname = $myhostname
      > mynetworks = $mynetworks
      > mailq_path = /usr/bin/mailq
      > manpage_directory = /usr/local/man
      >
      > ..
      > mynetworks_style = class
      > newaliases_path = /usr/bin/newaliases
      > queue_directory = /var/spool/postfix
      > readme_directory = no
      > relayhost =
      > sample_directory = /etc/postfix
      > .. (restriction rules)
      > virtual_alias_domains = domain1.org,domain2.org
      > virtual_alias_maps = hash:/etc/postfix/myValias
      >
      > the myValias file:
      >
      > user1@... account1-name
      > u.ser1@... account1-name
      >
      > user2@... account2-name
      > u.ser2@... account2-name
      >
      > ..
      >
      > (dot in "u.ser" means name.surname :P)
      >
      > - From my master.cf
      >
      > # ==========================================================================
      > # service type private unpriv chroot wakeup maxproc command + args
      > # (yes) (yes) (yes) (never) (100)
      > # ==========================================================================
      > smtp inet n - n - - smtpd
      > -o content_filter=filter:dummy
      >
      > ...
      > I've only added this when i installed Postfix
      >
      > filter unix - n n - 10 pipe
      > flags=Rq user=filth argv=/usr/local/anomy/filter.sh -f ${sender} --
      > ${recipient}
      >

      make sure to disable address rewrite either before or after the filter.
      See the FILTER README.


      > mmmm...
      > in maillog i see twice smtpd connection...

      This is not very helpful. If you can't post your logs, we can't see what
      happened, and can hardly help. post the logs for these connections.
      you can munge private infos, but do so coherently.
    Your message has been successfully submitted and would be delivered to recipients shortly.