Loading ...
Sorry, an error occurred while loading the content.

RE: postfix chroot problem (Solved!)

Expand Messages
  • Paul Bliss
    SO my issue was that the fstab had two mount instructions for the partition that contains postfix s chroot. One was good, the other had noexec specified.
    Message 1 of 1 , Feb 28, 2006
    • 0 Attachment
      SO my issue was that the fstab had two mount instructions for the partition that contains postfix's chroot.
      One was good, the other had "noexec" specified.
      Sometimes it's the little things.

      Thank you very very much Viktor and everyone for your help!
      -paul

      > -----Original Message-----
      > From: owner-postfix-users@...
      > [mailto:owner-postfix-users@...]On Behalf Of Victor Duchovni
      > Sent: Tuesday, February 28, 2006 9:49 AM
      > To: postfix-users@...
      > Subject: Re: postfix chroot problem
      >
      >
      > On Tue, Feb 28, 2006 at 09:15:16AM -0500, Paul Bliss wrote:
      >
      > > Sorry that my question was not propperly formatted before.
      > Here's another shot at it.
      > >
      > >
      > > ERROR MESSAGE:
      > > ******
      > > Feb 23 13:03:41 [postfix/smtp] warning: no MX host for
      > mechno.com has a valid A record
      > > Feb 23 13:03:41 [postfix/smtp] ECC4240EB8:
      > to=<pbliss@...>, relay=none, delay=1, status=bounced
      > ([mail.jojosarfo.org]: Name o
      > > r service not known)
      > > ******
      > >
      > > This is what it logged when I attempted when I tried to
      > send mail to pbliss@..., but yielded similar results
      > for any outgoing mail.
      > > To me, this indicates that the system is able to look up
      > the MX record, but when it attempts to look up the A record
      > of the resulting MX record, it fails.
      >
      > This is correct, the MX lookup yields results, but the hosts
      > in question
      > have no A records in DNS. One difference between the MX
      > lookups and the
      > subsequent "A" lookups, is that the "A" lookups don't disable
      > the domain
      > search list. So with:
      >
      > example.com. IN MX 0 host.example.com
      >
      > and
      >
      > /etc/resolv.conf:
      > search example.net example.org
      > nameserver 127.0.0.1
      >
      > The "A" lookups will be:
      >
      > host.example.com.example.net. IN A ?
      > host.example.com.example.org. IN A ?
      > host.example.com. IN A ?
      >
      > Perhaps your search path in the chroot jail lists domains
      > which don't work
      > (lookups return SERVFAIL rather than NXDOMAIN). Does the resolv.conf
      > in chroot jail match /etc/resolv.conf, is the chroot jail resolv.conf
      > world-readable?
      >
      > > smtp started working correctly, though, when I turned off
      > the 'chroot'
      > > option in master.cf
      >
      > So DNS A lookups work outside the chroot jail, see above.
      >
      > > --main.cf non-default parameters--
      >
      > No smtp_host_lookup override...
      >
      > > --master.cf--
      > > smtp unix - - - - - smtp
      > > relay unix - - - - - smtp
      >
      > No master.cf "-o" options.
      >
      > > -- end of postfinger output --
      > >
      > >
      > > Once again, I appeciate your time immensely and hope that
      > you can help me to shed light on my problem.
      >
      > If all else fails, write a test program that chroots into the Postfix
      > jail, drops root privs (becomes "postfix") and does DNS lookups... Do
      > "A" lookups with RES_DEFNAMES and without RES_DEFNAMES, do
      > "MX" lookups
      > without RES_DEFNAMES. Report the results.
      >
      > --
      > Viktor.
      >
      > Disclaimer: off-list followups get on-list replies or get ignored.
      > Please do not ignore the "Reply-To" header.
      >
      > To unsubscribe from the postfix-users list, visit
      > http://www.postfix.org/lists.html or click the link below:
      > <mailto:majordomo@...?body=unsubscribe%20postfix-users>
      >
      > If my response solves your problem, the best way to thank me is to not
      > send an "it worked, thanks" follow-up. If you must respond, please put
      > "It worked, thanks" in the "Subject" so I can delete these quickly.
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.