Loading ...
Sorry, an error occurred while loading the content.

Re: postfix read timeouts to specific relay host

Expand Messages
  • John Mendenhall
    Wietse, ... Ah ha! You are awesome! Apparently, when I was having problems with a specific relay client, I uncommented the timeout line under the relay
    Message 1 of 8 , Jan 31, 2006
    • 0 Attachment
      Wietse,

      > > > John Mendenhall:
      > > > > Jan 31 15:05:24 calvin postfix/smtp[5530]: D2B4D10076: to=<XXXX@...>, relay=none, delay=8, status=deferred (connect to blvd.com[69.63.196.113]: read timeout)
      > > >
      > > > Why do you override the default SMTP client timeout settings
      > > > with a limit of only 8 seconds?
      > >
      > > I don't override the default SMTP client timeout settings
      > > anywhere in main.cf, and I don't see it listed in postconf -n
      > > output.
      > >
      > > I ran postconf -d and I don't see any client timeout
      > > values.
      > >
      > > Where else might this be set where postconf -n would not
      > > show it? What is the exact parameter name?
      >
      > look in master.cf

      Ah ha! You are awesome!

      Apparently, when I was having problems with a specific
      relay client, I uncommented the timeout line under the
      relay process in the original standard master.cf file.
      I have since created a special process for a problematic
      client. I failed to fix the main relay process line.
      Of course, this affected all relay clients. Problem solved.

      Thank you! Thank you! Thank you!

      Just as a side question, is there a quick analogous
      command like postconf that displays the master.cf configurations?
      Perhaps even a per delivery transport *set* of configurations,
      so we can quickly see all the *local* settings, the *relay*
      settings, etc.

      JohnM

      --
      John Mendenhall
      john@...
      surf utopia
      internet services
    • Wietse Venema
      ... No. The master.cf -o name=value stuff had to be added as an afterthought; they are not well supported by other tools. Wietse
      Message 2 of 8 , Feb 1, 2006
      • 0 Attachment
        John Mendenhall:
        > Wietse,
        >
        > > > > John Mendenhall:
        > > > > > Jan 31 15:05:24 calvin postfix/smtp[5530]: D2B4D10076: to=<XXXX@...>, relay=none, delay=8, status=deferred (connect to blvd.com[69.63.196.113]: read timeout)
        > > > >
        > > > > Why do you override the default SMTP client timeout settings
        > > > > with a limit of only 8 seconds?
        > > >
        > > > I don't override the default SMTP client timeout settings
        > > > anywhere in main.cf, and I don't see it listed in postconf -n
        > > > output.
        > > >
        > > > I ran postconf -d and I don't see any client timeout
        > > > values.
        > > >
        > > > Where else might this be set where postconf -n would not
        > > > show it? What is the exact parameter name?
        > >
        > > look in master.cf
        >
        > Ah ha! You are awesome!
        >
        > Apparently, when I was having problems with a specific
        > relay client, I uncommented the timeout line under the
        > relay process in the original standard master.cf file.
        > I have since created a special process for a problematic
        > client. I failed to fix the main relay process line.
        > Of course, this affected all relay clients. Problem solved.
        >
        > Thank you! Thank you! Thank you!
        >
        > Just as a side question, is there a quick analogous
        > command like postconf that displays the master.cf configurations?
        > Perhaps even a per delivery transport *set* of configurations,
        > so we can quickly see all the *local* settings, the *relay*
        > settings, etc.

        No. The master.cf "-o name=value" stuff had to be added as an
        afterthought; they are not well supported by other tools.

        Wietse
      Your message has been successfully submitted and would be delivered to recipients shortly.