Loading ...
Sorry, an error occurred while loading the content.
 

postfix read timeouts to specific relay host

Expand Messages
  • John Mendenhall
    I am running postfix 2.2.8. I am having problems sending to an SMTP server for which my server acts as a backup MX server. The domains in question are listed
    Message 1 of 8 , Jan 31, 2006
      I am running postfix 2.2.8. I am having problems sending
      to an SMTP server for which my server acts as a backup MX
      server. The domains in question are listed in the relay_domains
      file.

      Here are the various log entries I am seeing:

      Jan 31 15:05:19 calvin postfix/smtp[7173]: connect to blvd.com[69.63.196.113]: read timeout (port 25)
      Jan 31 15:05:19 calvin postfix/smtp[7173]: B7C5610073: to=<hostmast@...>, relay=none, delay=17, status=deferred (connect to blvd.com[69.63.196.113]: read timeout)

      Jan 31 15:05:24 calvin postfix/smtp[5530]: connect to blvd.com[69.63.196.113]: read timeout (port 25)
      Jan 31 15:05:24 calvin postfix/smtp[5530]: D2B4D10076: to=<lori@...>, relay=none, delay=8, status=deferred (connect to blvd.com[69.63.196.113]: read timeout)

      Jan 31 15:11:15 calvin postfix/qmgr[3969]: B7C5610073: to=<hostmast@...>, relay=none, delay=373, status=deferred (delivery temporarily suspended: connect to blvd.com[69.63.196.113]: read timeout)

      On the remote end, they are running sendmail (a very
      old version, 8.9.3 I think). Their log shows the following:

      Jan 31 14:37:53 ns sendmail[1145]: NOQUEUE: Null connection from a.mx.surfutopia.net [69.63.196.98]
      Jan 31 14:46:04 ns sendmail[1292]: NOQUEUE: Null connection from a.mx.surfutopia.net [69.63.196.98]
      Jan 31 14:46:04 ns sendmail[1293]: NOQUEUE: Null connection from a.mx.surfutopia.net [69.63.196.98]

      Here are the results of postconf -n:

      -----
      calvin:postfix.net {231} postconf -n
      alias_database = hash:/etc/postfix/aliases
      alias_maps = hash:/etc/postfix/aliases
      allow_percent_hack = no
      allow_untrusted_routing = no
      append_at_myorigin = yes
      body_checks = regexp:/etc/postfix/body_checks
      bounce_size_limit = 65536
      command_directory = /usr/local/sbin
      config_directory = /etc/postfix
      daemon_directory = /usr/local/libexec/postfix
      debug_peer_level = 2
      disable_vrfy_command = yes
      empty_address_recipient = MAILER-DAEMON
      header_checks = regexp:/etc/postfix/block255 regexp:/etc/postfix/header_checks
      header_size_limit = 32768
      home_mailbox = maildir/inbox/
      html_directory = no
      mail_owner = _postfix
      mailq_path = /usr/local/sbin/mailq
      manpage_directory = /usr/local/man
      masquerade_classes = envelope_sender, envelope_recipient, header_sender, header_recipient
      masquerade_domains = $mydomain
      masquerade_exceptions = root,mailer-daemon
      message_size_limit = 8388608
      minimal_backoff_time = 250s
      mydestination = /etc/postfix/mydestination
      mynetworks = /etc/postfix/mynetworks
      mynetworks_style = host
      myorigin = $mydomain
      newaliases_path = /usr/bin/newaliases
      queue_directory = /var/spool/postfix
      queue_run_delay = 250s
      readme_directory = /usr/local/share/doc/postfix/readme
      relay_destination_concurrency_limit = 5
      relay_domains = /etc/postfix/relay_domains
      relay_recipient_maps = hash:/etc/postfix/relay_recipients
      resolve_dequoted_address = no
      sample_directory = /etc/postfix/samples
      sendmail_path = /usr/local/sbin/sendmail
      setgid_group = _postdrop
      smtpd_data_restrictions = reject_unauth_pipelining permit
      smtpd_error_sleep_time = 1s
      smtpd_hard_error_limit = 20
      smtpd_helo_required = yes
      smtpd_recipient_limit = 128
      smtpd_recipient_restrictions = reject_invalid_hostname reject_non_fqdn_sender reject_non_fqdn_recipient reject_unknown_sender_domain reject_unknown_recipient_domain permit_mynetworks reject_unauth_destination check_client_access hash:/etc/postfix/access check_helo_access hash:/etc/postfix/access check_sender_access regexp:/etc/postfix/sender_regexp check_recipient_access regexp:/etc/postfix/recipient_regexp check_sender_access hash:/etc/postfix/access_usernames check_recipient_access hash:/etc/postfix/access_usernames reject_non_fqdn_hostname reject_rhsbl_client blackhole.securitysage.com reject_rhsbl_sender blackhole.securitysage.com reject_rbl_client zombie.dnsbl.sorbs.net reject_rbl_client relays.ordb.org reject_rbl_client opm.blitzed.org reject_rbl_client list.dsbl.org reject_rbl_client sbl-xbl.spamhaus.org reject_rbl_client dnsbl.njabl.org reject_rbl_client cbl.abuseat.org reject_rbl_client relays.visi.com permit
      smtpd_reject_unlisted_recipient = yes
      smtpd_reject_unlisted_sender = yes
      smtpd_soft_error_limit = 10
      smtpd_timeout = 180
      strict_rfc821_envelopes = yes
      swap_bangpath = no
      transport_maps = hash:/etc/postfix/transport
      unknown_local_recipient_reject_code = 450
      virtual_alias_domains = /etc/postfix/virtual-alias-domains
      virtual_alias_maps = hash:/etc/postfix/virtual-alias-maps
      virtual_gid_maps = static:1024
      virtual_mailbox_base = /mail/virtual
      virtual_mailbox_domains = /etc/postfix/virtual-mailbox-domains
      virtual_mailbox_limit = 33554432
      virtual_mailbox_maps = hash:/etc/postfix/virtual-mailbox-maps
      virtual_minimum_uid = 1024
      virtual_uid_maps = static:1024
      -----

      Physically, these two machines are hanging off the
      same switch in the same cabinet. No router between
      them.

      Please let me know where I can look next to get this
      working between these two servers.

      Thanks in advance for any pointers or assistance
      provided. And, as usual, if I am missing some
      needed information, please let me know and I'll send it out.

      Thanks.

      JohnM

      --
      John Mendenhall
      john@...
      surf utopia
      internet services
    • Wietse Venema
      ... Why do you override the default SMTP client timeout settings with a limit of only 8 seconds? Wietse
      Message 2 of 8 , Jan 31, 2006
        John Mendenhall:
        > Jan 31 15:05:24 calvin postfix/smtp[5530]: D2B4D10076: to=<XXXX@...>, relay=none, delay=8, status=deferred (connect to blvd.com[69.63.196.113]: read timeout)

        Why do you override the default SMTP client timeout settings
        with a limit of only 8 seconds?

        Wietse
      • John Mendenhall
        Wietse, ... I don t override the default SMTP client timeout settings anywhere in main.cf, and I don t see it listed in postconf -n output. I ran postconf -d
        Message 3 of 8 , Jan 31, 2006
          Wietse,

          > John Mendenhall:
          > > Jan 31 15:05:24 calvin postfix/smtp[5530]: D2B4D10076: to=<XXXX@...>, relay=none, delay=8, status=deferred (connect to blvd.com[69.63.196.113]: read timeout)
          >
          > Why do you override the default SMTP client timeout settings
          > with a limit of only 8 seconds?

          I don't override the default SMTP client timeout settings
          anywhere in main.cf, and I don't see it listed in postconf -n
          output.

          I ran postconf -d and I don't see any client timeout
          values.

          Where else might this be set where postconf -n would not
          show it? What is the exact parameter name?

          Thank you very much.

          JohnM

          --
          John Mendenhall
          john@...
          surf utopia
          internet services
        • John Mendenhall
          Wietse, ... I may be mistaken, but I thought the delay=nnnn section of the line above is displaying how old the message is, or something like that, not any
          Message 4 of 8 , Jan 31, 2006
            Wietse,

            > John Mendenhall:
            > > Jan 31 15:05:24 calvin postfix/smtp[5530]: D2B4D10076: to=<XXXX@...>, relay=none, delay=8, status=deferred (connect to blvd.com[69.63.196.113]: read timeout)
            >
            > Why do you override the default SMTP client timeout settings
            > with a limit of only 8 seconds?

            I may be mistaken, but I thought the delay=nnnn section of the
            line above is displaying how old the message is, or something
            like that, not any sort of timeout setting. Please correct me
            if I am wrong.

            JohnM

            --
            John Mendenhall
            john@...
            surf utopia
            internet services
          • Wietse Venema
            ... The time spent while Postfix tries to connect is ALWAYS less than or equal to the time spent in the queue. Wietse
            Message 5 of 8 , Jan 31, 2006
              John Mendenhall:
              > Wietse,
              >
              > > John Mendenhall:
              > > > Jan 31 15:05:24 calvin postfix/smtp[5530]: D2B4D10076: to=<XXXX@...>, relay=none, delay=8, status=deferred (connect to blvd.com[69.63.196.113]: read timeout)
              > >
              > > Why do you override the default SMTP client timeout settings
              > > with a limit of only 8 seconds?
              >
              > I may be mistaken, but I thought the delay=nnnn section of the
              > line above is displaying how old the message is, or something
              > like that, not any sort of timeout setting. Please correct me
              > if I am wrong.

              The time spent while Postfix tries to connect is ALWAYS less
              than or equal to the time spent in the queue.

              Wietse
            • Wietse Venema
              ... look in master.cf Wietse
              Message 6 of 8 , Jan 31, 2006
                John Mendenhall:
                > Wietse,
                >
                > > John Mendenhall:
                > > > Jan 31 15:05:24 calvin postfix/smtp[5530]: D2B4D10076: to=<XXXX@...>, relay=none, delay=8, status=deferred (connect to blvd.com[69.63.196.113]: read timeout)
                > >
                > > Why do you override the default SMTP client timeout settings
                > > with a limit of only 8 seconds?
                >
                > I don't override the default SMTP client timeout settings
                > anywhere in main.cf, and I don't see it listed in postconf -n
                > output.
                >
                > I ran postconf -d and I don't see any client timeout
                > values.
                >
                > Where else might this be set where postconf -n would not
                > show it? What is the exact parameter name?

                look in master.cf

                Wietse
              • John Mendenhall
                Wietse, ... Ah ha! You are awesome! Apparently, when I was having problems with a specific relay client, I uncommented the timeout line under the relay
                Message 7 of 8 , Jan 31, 2006
                  Wietse,

                  > > > John Mendenhall:
                  > > > > Jan 31 15:05:24 calvin postfix/smtp[5530]: D2B4D10076: to=<XXXX@...>, relay=none, delay=8, status=deferred (connect to blvd.com[69.63.196.113]: read timeout)
                  > > >
                  > > > Why do you override the default SMTP client timeout settings
                  > > > with a limit of only 8 seconds?
                  > >
                  > > I don't override the default SMTP client timeout settings
                  > > anywhere in main.cf, and I don't see it listed in postconf -n
                  > > output.
                  > >
                  > > I ran postconf -d and I don't see any client timeout
                  > > values.
                  > >
                  > > Where else might this be set where postconf -n would not
                  > > show it? What is the exact parameter name?
                  >
                  > look in master.cf

                  Ah ha! You are awesome!

                  Apparently, when I was having problems with a specific
                  relay client, I uncommented the timeout line under the
                  relay process in the original standard master.cf file.
                  I have since created a special process for a problematic
                  client. I failed to fix the main relay process line.
                  Of course, this affected all relay clients. Problem solved.

                  Thank you! Thank you! Thank you!

                  Just as a side question, is there a quick analogous
                  command like postconf that displays the master.cf configurations?
                  Perhaps even a per delivery transport *set* of configurations,
                  so we can quickly see all the *local* settings, the *relay*
                  settings, etc.

                  JohnM

                  --
                  John Mendenhall
                  john@...
                  surf utopia
                  internet services
                • Wietse Venema
                  ... No. The master.cf -o name=value stuff had to be added as an afterthought; they are not well supported by other tools. Wietse
                  Message 8 of 8 , Feb 1, 2006
                    John Mendenhall:
                    > Wietse,
                    >
                    > > > > John Mendenhall:
                    > > > > > Jan 31 15:05:24 calvin postfix/smtp[5530]: D2B4D10076: to=<XXXX@...>, relay=none, delay=8, status=deferred (connect to blvd.com[69.63.196.113]: read timeout)
                    > > > >
                    > > > > Why do you override the default SMTP client timeout settings
                    > > > > with a limit of only 8 seconds?
                    > > >
                    > > > I don't override the default SMTP client timeout settings
                    > > > anywhere in main.cf, and I don't see it listed in postconf -n
                    > > > output.
                    > > >
                    > > > I ran postconf -d and I don't see any client timeout
                    > > > values.
                    > > >
                    > > > Where else might this be set where postconf -n would not
                    > > > show it? What is the exact parameter name?
                    > >
                    > > look in master.cf
                    >
                    > Ah ha! You are awesome!
                    >
                    > Apparently, when I was having problems with a specific
                    > relay client, I uncommented the timeout line under the
                    > relay process in the original standard master.cf file.
                    > I have since created a special process for a problematic
                    > client. I failed to fix the main relay process line.
                    > Of course, this affected all relay clients. Problem solved.
                    >
                    > Thank you! Thank you! Thank you!
                    >
                    > Just as a side question, is there a quick analogous
                    > command like postconf that displays the master.cf configurations?
                    > Perhaps even a per delivery transport *set* of configurations,
                    > so we can quickly see all the *local* settings, the *relay*
                    > settings, etc.

                    No. The master.cf "-o name=value" stuff had to be added as an
                    afterthought; they are not well supported by other tools.

                    Wietse
                  Your message has been successfully submitted and would be delivered to recipients shortly.