Loading ...
Sorry, an error occurred while loading the content.

Expand Messages
  • Dimitris Zilaskos
    Hi , If the mail from: line is like X Y @Z.COM , postfix delivers the message to the normal recipient , to Y@Z.COM , and sends a bounce to X@Z.COM :
    Message 1 of 14 , Jan 1, 2006
    • 0 Attachment
      Hi ,

      If the mail from: line is like "X Y"@... , postfix delivers
      the message to the normal recipient , to Y@... , and sends a bounce to
      X@... :

      Diagnostic-Code: X-Postfix; invalid recipient syntax: "--@..."

      contrary to just delivering the message to its recipient(s). I do not have
      recipient delimiter set.
      I am running postfix 2.0.6-14 on RHEL3 compatible OS.
      Any ideas on how to solve this?

      Best regards ,

      --
      ============================================================================

      Dimitris Zilaskos

      Department of Physics @ Aristotle University of Thessaloniki , Greece
      PGP key : http://tassadar.physics.auth.gr/~dzila/pgp_public_key.asc
      http://egnatia.ee.auth.gr/~dzila/pgp_public_key.asc
      MD5sum : de2bd8f73d545f0e4caf3096894ad83f pgp_public_key.asc
      ============================================================================
    • Dimitris Zilaskos
      forgot to put a subject , sorry. -- ============================================================================ Dimitris Zilaskos Department of Physics @
      Message 2 of 14 , Jan 1, 2006
      • 0 Attachment
        forgot to put a subject , sorry.


        --
        ============================================================================

        Dimitris Zilaskos

        Department of Physics @ Aristotle University of Thessaloniki , Greece
        PGP key : http://tassadar.physics.auth.gr/~dzila/pgp_public_key.asc
        http://egnatia.ee.auth.gr/~dzila/pgp_public_key.asc
        MD5sum : de2bd8f73d545f0e4caf3096894ad83f pgp_public_key.asc
        ============================================================================
      • Wietse Venema
        ... This is incorrect. See session and logging below. Wietse SMTP session: ============= 220 spike.porcupine.org ESMTP Postfix (2.3-20051229) EHLO
        Message 3 of 14 , Jan 1, 2006
        • 0 Attachment
          Dimitris Zilaskos:
          >
          > Hi ,
          >
          > If the mail from: line is like "X Y"@... , postfix delivers
          > the message to the normal recipient , to Y@... , and sends a bounce to
          > X@... :
          >
          > Diagnostic-Code: X-Postfix; invalid recipient syntax: "--@..."
          >
          > contrary to just delivering the message to its recipient(s). I do not have
          > recipient delimiter set.
          > I am running postfix 2.0.6-14 on RHEL3 compatible OS.
          > Any ideas on how to solve this?

          This is incorrect. See session and logging below.

          Wietse

          SMTP session:
          =============

          220 spike.porcupine.org ESMTP Postfix (2.3-20051229)
          EHLO spike.porcupine.org
          250-spike.porcupine.org
          250-PIPELINING
          250-SIZE 20240000
          250-ETRN
          250-ENHANCEDSTATUSCODES
          250-8BITMIME
          250 DSN
          MAIL FROM:<"wietse venema"@...>
          250 2.1.0 Ok
          RCPT TO:<wietse@...>
          250 2.1.5 Ok
          DATA
          354 End data with <CR><LF>.<CR><LF>
          From:<"wietse venema"@...>
          To:<wietse@...>
          Subject: test

          asd
          .
          250 2.0.0 Ok: queued as D745CBC191

          Logging:
          ========

          Jan 1 21:24:10 spike postfix/smtpd[58788]: D745CBC191: client=spike.porcupine.org[168.100.189.2]
          Jan 1 21:24:16 spike postfix/cleanup[59175]: D745CBC191: message-id=<20060102022410.D745CBC191@...>
          Jan 1 21:24:16 spike postfix/qmgr[53452]: D745CBC191: from=<wietse venema@...>, size=398, nrcpt=1 (queue active)
          Jan 1 21:24:16 spike postfix/local[59125]: D745CBC191: to=<wietse@...>, relay=local, delay=6.7, delays=6.7/0.01/0/0.05, dsn=2.0.0, status=sent (delivered to command: umask 077; exec /usr/local/bin/filter)
          Jan 1 21:24:16 spike postfix/qmgr[53452]: D745CBC191: removed
        • mouss
          ... maybe a warning should be added to people who run mail through a shell command ($var may be interpreted as multiple args if it contains spaces).
          Message 4 of 14 , Jan 2, 2006
          • 0 Attachment
            Wietse Venema a écrit :
            > Dimitris Zilaskos:
            >
            >> Hi ,
            >>
            >> If the mail from: line is like "X Y"@... , postfix delivers
            >>the message to the normal recipient , to Y@... , and sends a bounce to
            >>X@... :
            >>
            >>Diagnostic-Code: X-Postfix; invalid recipient syntax: "--@..."
            >>
            >>contrary to just delivering the message to its recipient(s). I do not have
            >>recipient delimiter set.
            >> I am running postfix 2.0.6-14 on RHEL3 compatible OS.
            >> Any ideas on how to solve this?
            >
            >
            > This is incorrect. See session and logging below.
            >

            maybe a warning should be added to people who run mail through a shell
            command ($var may be interpreted as multiple args if it contains spaces).
          • Len Conrad
            ... From: Ralf Hildebrandt Reply-To: postfix-users@postfix.org Date: Fri, 1 May 2009 20:56:15 +0200 ... 1. my email client
            Message 5 of 14 , May 1, 2009
            • 0 Attachment
              ---------- Original Message ----------------------------------
              From: Ralf Hildebrandt <Ralf.Hildebrandt@...>
              Reply-To: postfix-users@...
              Date: Fri, 1 May 2009 20:56:15 +0200

              >* Len Conrad <lconrad@...>:
              >> postmap -q "67.218.188" mysql:/usr/local/etc/postfix/mysql-mta_clients_reactive_b.cf
              >> 554 mta_client_reactive_b
              >>
              >> postmap -q "67.218.188.4" mysql:/usr/local/etc/postfix/mysql-mta_clients_reactive_b.cf
              >> ... no data
              >>
              >> man 5 access seems to make no distinction between .map and SQL tables:
              >>
              >> HOST NAME/ADDRESS PATTERNS
              >>
              >> With lookups from indexed files such as DB or DBM, or from networked
              >> tables such as NIS, LDAP or SQL, the following lookup patterns are
              >> examined in the order as listed
              >>
              >> Subnetworks are matched by repeatedly truncating the last
              >> ".octet" from the remote IPv4 host address string until a match
              >> is found in the access table, or until further truncation is not
              >> possible.
              >
              >So where is the problem now?

              1. my email client discarded my wonderful Subject: line

              2. The problem is that a query for 67.218.188.4 is not matched by an entry of 67.218.188. This works in hash:.map tables, so why doesn't it work in SQL tables? iow, how to block a Class C with SQL table?

              Len
            • Ralf Hildebrandt
              ... Your client is Imail? Their servers are crap so why should the client be better :) ... It works just the same Postfix performs the lookups: 67.218.188.4
              Message 6 of 14 , May 1, 2009
              • 0 Attachment
                * Len Conrad <lconrad@...>:

                > 1. my email client discarded my wonderful Subject: line

                Your client is Imail? Their servers are crap so why should the client
                be better :)

                > 2. The problem is that a query for 67.218.188.4 is not matched by an
                > entry of 67.218.188. This works in hash:.map tables, so why doesn't it
                > work in SQL tables? iow, how to block a Class C with SQL table?

                It works just the same

                Postfix performs the lookups:

                67.218.188.4
                67.218.188
                67.218
                67

                against the map. Try query logging.

                --
                Ralf Hildebrandt
                Postfix - Einrichtung, Betrieb und Wartung Tel. +49 (0)30-450 570-155
                http://www.computerbeschimpfung.de
                Next thing you know, someone will nail 95 patches to the door, then
                register postfixreformation.org. Hmmm, no, on further thought,
                religious zeal is better suited to other MTA's anyway. As are the 95
                patches.
              • Will
                ... This seems to indicate that you are communicating with a Sendmail server, not a Postfix server...
                Message 7 of 14 , Jan 26, 2013
                • 0 Attachment
                  On 01/27/2013 12:41 AM, Dibyendra Hyoju wrote:
                  > 220 library.net.np <http://library.net.np> ESMTP Sendmail
                  > 8.14.3/8.14.3/Debian-9.4; Sun, 27 Jan 2013 00:31:43 -0600; (No UCE/UBE)
                  > logging access from: localhost(OK)-localhost [127.0.0.1]

                  This seems to indicate that you are communicating with a Sendmail
                  server, not a Postfix server...
                • Dibyendra Hyoju
                  Thanks Will for your response. Yes, I restarted the remote machine and postfix is working now. However, I am not getting email. Is this because of
                  Message 8 of 14 , Jan 26, 2013
                  • 0 Attachment
                    Thanks Will for your response. Yes, I restarted the remote machine and postfix is working now. However, I am not getting email. Is this because of configuration?

                    I configured the file as follows for the IP: 50.57.179.51. Please suggest if the following configuration is incorrect.

                    #mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
                    mynetworks = 127.0.0.0/8, 50.57.179.0/24

                    Any help would be appreciated.

                    Thanks!

                    Dibyendra Hyoju


                    On Sun, Jan 27, 2013 at 1:08 PM, Will <will@...> wrote:
                    On 01/27/2013 12:41 AM, Dibyendra Hyoju wrote:
                    220 library.net.np <http://library.net.np> ESMTP Sendmail

                    8.14.3/8.14.3/Debian-9.4; Sun, 27 Jan 2013 00:31:43 -0600; (No UCE/UBE)
                    logging access from: localhost(OK)-localhost [127.0.0.1]

                    This seems to indicate that you are communicating with a Sendmail server, not a Postfix server...


                  • James Griffin
                    ... As pointed out by Will, the program listening on port 25 for smtpd connections is Sendmail version 8.14. This is, I imagine, the default MTA installed on a
                    Message 9 of 14 , Jan 26, 2013
                    • 0 Attachment
                      * Will <will@...> [2013-01-27 01:23:31 -0600]:

                      > On 01/27/2013 12:41 AM, Dibyendra Hyoju wrote:
                      > >220 library.net.np <http://library.net.np> ESMTP Sendmail
                      > >8.14.3/8.14.3/Debian-9.4; Sun, 27 Jan 2013 00:31:43 -0600; (No UCE/UBE)
                      > >logging access from: localhost(OK)-localhost [127.0.0.1]
                      >
                      > This seems to indicate that you are communicating with a Sendmail
                      > server, not a Postfix server...

                      As pointed out by Will, the program listening on port 25 for smtpd
                      connections is Sendmail version 8.14. This is, I imagine, the
                      default MTA installed on a Debian system which from the output of
                      your telnet session indicates you're using.

                      When you installed Postfix was it from the Debian apt repositories?
                      It should have made the necessary changes to you system to make
                      Postfix the local MTA; for example, on some systems, like OpenBSD
                      which I use, Sendmail is disabled by editing the file /etc/mailer.conf
                      which points programs to the postfix binaries had that been the
                      MTA I wanted to install. Also, Sendmail is disabled by adding
                      sendmail=NO in /etc/rc.conf.local and adding a similar line for
                      postfix but setting "YES" so it's the postfix binaries that are
                      started at system boot time. So the point here being, that you
                      need to disable Sendmail and enable Postfix.

                      I don't use Linux, and never have, so I'm not sure on the method
                      Debian uses to change the MTA. Check the Debian documentation and
                      mailing list archives to see how to achieve that.

                      Also, the main.cf snippets you provided showing sasl configuration
                      are for smtp, i.e. outgoing - perhaps you meant to set up sasl
                      auth settings for incoming, i.e. smtpd

                      The best thing do now is to check the Debian docs to find out how
                      to change your MTA to Postfix and disable Sendmail. Then double
                      check if it's incoming or outgoing sasl auth you're trying to
                      achieve and post your postfix configuration to this list using the
                      output of the postconf -n command and explain in more detail what
                      it is you're having difficulty with.

                      --
                      Primary Key: 4096R/1D31DC38 2011-12-03
                      Key Fingerprint: A4B9 E875 A18C 6E11 F46D B788 BEE6 1251 1D31 DC38
                    • Geoff Shang
                      ... FWIW, Debian s default MTA is Exim. Geoff.
                      Message 10 of 14 , Jan 27, 2013
                      • 0 Attachment
                        On Sun, 27 Jan 2013, James Griffin wrote:

                        > As pointed out by Will, the program listening on port 25 for smtpd
                        > connections is Sendmail version 8.14. This is, I imagine, the
                        > default MTA installed on a Debian system which from the output of
                        > your telnet session indicates you're using.

                        FWIW, Debian's default MTA is Exim.

                        Geoff.
                      • Dibyendra Hyoju
                        Hi James, Thanks for your response. ... I have uninstalled sendmail from the system. root@library:/home/madan# dpkg -l | grep sendmail
                        Message 11 of 14 , Jan 27, 2013
                        • 0 Attachment
                          Hi James,

                          Thanks for your response.

                          On Sun, Jan 27, 2013 at 1:41 PM, James Griffin <jmz.griffin@...> wrote:
                          * Will <will@...> [2013-01-27 01:23:31 -0600]:

                          > On 01/27/2013 12:41 AM, Dibyendra Hyoju wrote:
                          > >220 library.net.np <http://library.net.np> ESMTP Sendmail
                          > >8.14.3/8.14.3/Debian-9.4; Sun, 27 Jan 2013 00:31:43 -0600; (No UCE/UBE)
                          > >logging access from: localhost(OK)-localhost [127.0.0.1]
                          >
                          > This seems to indicate that you are communicating with a Sendmail
                          > server, not a Postfix server...

                          I have uninstalled sendmail from the system.
                          root@library:/home/madan# dpkg -l | grep sendmail
                          root@library:/home/madan#
                           
                          Postfix seems to be working but it's not sending email, maybe because of the configurations?

                          root@library:/home/madan# telnet localhost 25
                          Trying 127.0.0.1...
                          Connected to localhost.
                          Escape character is '^]'.
                          220 library.net.np ESMTP Postfix (Debian/GNU)
                          mail from:speedymailer2011@...
                          250 2.1.0 Ok
                          rcpt to:dibyendra@...
                          250 2.1.5 Ok
                          data
                          354 End data with <CR><LF>.<CR><LF>
                          subject:tst
                          testing from shibb
                          .
                          250 2.0.0 Ok: queued as AFD841C927
                          quit
                          221 2.0.0 Bye
                          Connection closed by foreign host.


                           As pointed out by Will, the program listening on port 25 for smtpd
                           connections is Sendmail version 8.14. This is, I imagine, the
                           default MTA installed on a Debian system which from the output of
                           your telnet session indicates you're using.

                           When you installed Postfix was it from the Debian apt repositories?

                          Yes, i did from Debian apt repositories.

                           It should have made the necessary changes to you system to make
                           Postfix the local MTA; for example, on some systems, like OpenBSD
                           which I use, Sendmail is disabled by editing the file /etc/mailer.conf
                           which points programs to the postfix binaries had that been the
                           MTA I wanted to install. Also, Sendmail is disabled by adding
                           sendmail=NO in /etc/rc.conf.local and adding a similar line for
                           postfix but setting "YES" so it's the postfix binaries that are
                           started at system boot time. So the point here being, that you
                           need to disable Sendmail and enable Postfix.

                          I did dpkg -l | grep exim but no result, that means exim is not installed as well.  The configuration mynetworks = 127.0.0.0/8, 192.168.0.0/24 in main.cf works in my local machine. What would be the configuration for the IP: 50.57.179.51?

                          Thanks,
                          Dibyendra

                           I don't use Linux, and never have, so I'm not sure on the method
                           Debian uses to change the MTA. Check the Debian documentation and
                           mailing list archives to see how to achieve that.

                           Also, the main.cf snippets you provided showing sasl configuration
                           are for smtp, i.e. outgoing - perhaps you meant to set up sasl
                           auth settings for incoming, i.e. smtpd

                           The best thing do now is to check the Debian docs to find out how
                           to change your MTA to Postfix and disable Sendmail. Then  double
                           check if it's incoming or outgoing sasl auth you're trying to
                           achieve and post your postfix configuration to this list using the
                           output of the postconf -n command and explain in more detail what
                           it is you're having difficulty with.

                          --
                          Primary Key: 4096R/1D31DC38 2011-12-03
                          Key Fingerprint: A4B9 E875 A18C 6E11 F46D  B788 BEE6 1251 1D31 DC38

                        • Stan Hoeppner
                          ... Postfix queued the message. Given the sender and recipient addresses you used, it would appear you might be an open relay, which you obviously don t want
                          Message 12 of 14 , Jan 27, 2013
                          • 0 Attachment
                            On 1/27/2013 4:21 AM, Dibyendra Hyoju wrote:

                            > Postfix seems to be working but it's not sending email, maybe because of
                            > the configurations?
                            >
                            > root@library:/home/madan# telnet localhost 25
                            > Trying 127.0.0.1...
                            > Connected to localhost.
                            > Escape character is '^]'.
                            > 220 library.net.np ESMTP Postfix (Debian/GNU)
                            > mail from:speedymailer2011@...
                            > 250 2.1.0 Ok
                            > rcpt to:dibyendra@...
                            > 250 2.1.5 Ok
                            > data
                            > 354 End data with <CR><LF>.<CR><LF>
                            > subject:tst
                            > testing from shibb
                            > .
                            > 250 2.0.0 Ok: queued as AFD841C927
                            > quit
                            > 221 2.0.0 Bye
                            > Connection closed by foreign host.

                            Postfix queued the message. Given the sender and recipient addresses
                            you used, it would appear you might be an open relay, which you
                            obviously don't want to be. Check your logs to see if Postfix attempted
                            delivery of this msg to gmail.com. And fix your configuration so
                            Postfix won't relay mail to arbitrary domains.

                            --
                            Stan
                          • Dibyendra Hyoju
                            Hi Stan, I checked the log and I found out that the email was not sent because of authentication issues. But, I checked the /etc/postfix/sasl_passwd and the
                            Message 13 of 14 , Jan 28, 2013
                            • 0 Attachment
                              Hi Stan,

                              I checked the log and I found out that the email was not sent because of authentication issues. But, I checked the /etc/postfix/sasl_passwd and the username and password is correct. I copied the same info into my local machine and it's working fine. The log contains following information:

                              Jan 28 03:24:35 library postfix/qmgr[6359]: D98DA1C940: from=<speedymailer2011@...>, size=356, nrcpt=1 (queue active)
                              Jan 28 03:24:36 library postfix/smtp[6361]: D98DA1C940: SASL authentication failed; server smtp.gmail.com[173.194.64.108] said: 535-5.7.1 Please log in with your web browser and then try again. Learn more at?535 5.7.1 https://support.google.com/mail/bin/answer.py?answer=78754 7sm7386969obu.4 - gsmtp
                              Jan 28 03:24:37 library postfix/smtp[6361]: D98DA1C940: to=<dibyendra@...>, relay=smtp.gmail.com[173.194.64.109]:587, delay=6464, delays=6462/0.08/1.1/0, dsn=4.7.1, status=deferred (SASL authentication failed; server smtp.gmail.com[173.194.64.109] said: 535-5.7.1 Please log in with your web browser and then try again. Learn more at?535 5.7.1 https://support.google.com/mail/bin/answer.py?answer=78754 ow7sm5796998obc.20 - gsmtp)

                              Any suggestions will be appreciated. Thank you.


                              Dibyendra Hyoju


                              On Sun, Jan 27, 2013 at 4:35 PM, Stan Hoeppner <stan@...> wrote:
                              On 1/27/2013 4:21 AM, Dibyendra Hyoju wrote:

                              > Postfix seems to be working but it's not sending email, maybe because of
                              > the configurations?
                              >
                              > root@library:/home/madan# telnet localhost 25
                              > Trying 127.0.0.1...
                              > Connected to localhost.
                              > Escape character is '^]'.
                              > 220 library.net.np ESMTP Postfix (Debian/GNU)
                              > mail from:speedymailer2011@...
                              > 250 2.1.0 Ok
                              > rcpt to:dibyendra@...
                              > 250 2.1.5 Ok
                              > data
                              > 354 End data with <CR><LF>.<CR><LF>
                              > subject:tst
                              > testing from shibb
                              > .
                              > 250 2.0.0 Ok: queued as AFD841C927
                              > quit
                              > 221 2.0.0 Bye
                              > Connection closed by foreign host.

                              Postfix queued the message.  Given the sender and recipient addresses
                              you used, it would appear you might be an open relay, which you
                              obviously don't want to be.  Check your logs to see if Postfix attempted
                              delivery of this msg to gmail.com.  And fix your configuration so
                              Postfix won't relay mail to arbitrary domains.

                              --
                              Stan



                            • Stan Hoeppner
                              ... Why are you attempting to authenticate with Google? Are you trying to have Google deliver all of your outbound mail? I.e. you are using Google as your
                              Message 14 of 14 , Jan 28, 2013
                              • 0 Attachment
                                On 1/28/2013 3:30 AM, Dibyendra Hyoju wrote:
                                > Hi Stan,
                                >
                                > I checked the log and I found out that the email was not sent because of
                                > authentication issues. But, I checked the /etc/postfix/sasl_passwd and the
                                > username and password is correct. I copied the same info into my local
                                > machine and it's working fine. The log contains following information:
                                >
                                > Jan 28 03:24:35 library postfix/qmgr[6359]: D98DA1C940: from=<
                                > speedymailer2011@...>, size=356, nrcpt=1 (queue active)
                                > Jan 28 03:24:36 library postfix/smtp[6361]: D98DA1C940: SASL authentication
                                > failed; server smtp.gmail.com[173.194.64.108] said: 535-5.7.1 Please log in
                                > with your web browser and then try again. Learn more at?535 5.7.1
                                > https://support.google.com/mail/bin/answer.py?answer=78754 7sm7386969obu.4
                                > - gsmtp
                                > Jan 28 03:24:37 library postfix/smtp[6361]: D98DA1C940: to=<
                                > dibyendra@...>, relay=smtp.gmail.com[173.194.64.109]:587, delay=6464,
                                > delays=6462/0.08/1.1/0, dsn=4.7.1, status=deferred (SASL authentication
                                > failed; server smtp.gmail.com[173.194.64.109] said: 535-5.7.1 Please log in
                                > with your web browser and then try again. Learn more at?535 5.7.1
                                > https://support.google.com/mail/bin/answer.py?answer=78754ow7sm5796998obc.20
                                > - gsmtp)
                                >
                                > Any suggestions will be appreciated. Thank you.

                                Why are you attempting to authenticate with Google? Are you trying to
                                have Google deliver all of your outbound mail? I.e. you are using
                                Google as your ISP WRT mail delivery? By default Postfix servers
                                deliver all mail directly to the destination domain MX.

                                --
                                Stan


                                >
                                > Dibyendra Hyoju
                                >
                                >
                                > On Sun, Jan 27, 2013 at 4:35 PM, Stan Hoeppner <stan@...>wrote:
                                >
                                >> On 1/27/2013 4:21 AM, Dibyendra Hyoju wrote:
                                >>
                                >>> Postfix seems to be working but it's not sending email, maybe because of
                                >>> the configurations?
                                >>>
                                >>> root@library:/home/madan# telnet localhost 25
                                >>> Trying 127.0.0.1...
                                >>> Connected to localhost.
                                >>> Escape character is '^]'.
                                >>> 220 library.net.np ESMTP Postfix (Debian/GNU)
                                >>> mail from:speedymailer2011@...
                                >>> 250 2.1.0 Ok
                                >>> rcpt to:dibyendra@...
                                >>> 250 2.1.5 Ok
                                >>> data
                                >>> 354 End data with <CR><LF>.<CR><LF>
                                >>> subject:tst
                                >>> testing from shibb
                                >>> .
                                >>> 250 2.0.0 Ok: queued as AFD841C927
                                >>> quit
                                >>> 221 2.0.0 Bye
                                >>> Connection closed by foreign host.
                                >>
                                >> Postfix queued the message. Given the sender and recipient addresses
                                >> you used, it would appear you might be an open relay, which you
                                >> obviously don't want to be. Check your logs to see if Postfix attempted
                                >> delivery of this msg to gmail.com. And fix your configuration so
                                >> Postfix won't relay mail to arbitrary domains.
                              Your message has been successfully submitted and would be delivered to recipients shortly.