Loading ...
Sorry, an error occurred while loading the content.
 

Re: How do I eliminate these bounces?

Expand Messages
  • mouss
    ... you can. just don t set it to void (which means any address is valid). If you don t need local , then it s even better to avoid it at once:
    Message 1 of 30 , Jan 1, 2006
      CN a écrit :
      > On Fri, 30 Dec 2005 14:55:28 +0100, Magnus Bäck wrote:
      >
      >>>That happens to be the default in my system.
      >>># postconf -d | grep local_reci
      >>>local_recipient_maps =
      >>>
      >>>What should it be?
      >>
      >>I guess
      >>
      >> local_recipient_maps = unix:passwd.byname, $alias_maps
      >>
      >>should work in Postfix 1.1 as well.
      >
      >
      > Thank you, Magnus! If I do not want mail for users (accounts) on the local unix,
      > but only for those in my $alias_maps, then can it be just
      > local_recipient_maps = $alias_maps

      you can. just don't set it to "void" (which means any address is valid).

      If you don't need "local", then it's even better to avoid it at once:

      local_recipient_maps = hash:$dir/empty

      (where empty is an empty hash file) and use virtual aliases and/or
      transports to implement the few "local" tasks that you need.

      you may want to handle foo@[ip] addresses as they are considered local
      however you set mydestination. you should accept mail to postmaster@[ip]
      to allow people to contact you in case of serious problems, and possibly
      reject all the rest.

      > One of the very old user names has become a spam magnet, and I want mail for
      > that to be rejected.
      >

      just add a check_recipient_access to either reject or redirect to a spam
      trap. Don't redirect to a spam trap if the address is still used to
      opt-in in one or more marketing lists. spam traps must be protected
      against misuse. We don't like some DNSBLs that rely on traps mostly
      because of lack of trust in their trap protection.
    • Simone Nanni
      Hi everybody, a veeeery little question.... Can i set per-user message_size_limit in a MySQL table?? (in a virtual domain......) Thanx a lot in advance! Simone
      Message 2 of 30 , Jun 28, 2006
        Hi everybody,
        a veeeery little question....
        Can i set per-user message_size_limit in a MySQL table?? (in a virtual domain......)
        Thanx a lot in advance!
         
         
        Simone Nanni
        ICT Technician
        A.O.U. Policlinico Tor Vergata
        Viale Oxford, 81
        00133 - Roma - RM - Italy
        Tel: 06/20900081
        Fax: 06/20900080
        Mail: simone.nanni@...
      • Magnus Bäck
        On Wednesday, June 28, 2006 at 13:32 CEST, ... SMTP does not permit this. How would you handle multi-recipient mail with different recipients having different
        Message 3 of 30 , Jun 28, 2006
          On Wednesday, June 28, 2006 at 13:32 CEST,
          Simone Nanni <simone.nanni@...> wrote:

          > a veeeery little question....
          > Can i set per-user message_size_limit in a MySQL table?? (in a virtual
          > domain......)

          SMTP does not permit this. How would you handle multi-recipient mail
          with different recipients having different limits? The actual size of
          the message is not known until it's too late.

          This has been discussed before, see the archives.

          --
          Magnus Bäck
          magnus@...
        • mouss
          ... not clear if user means as sender or as recipient. I guess he wants both. but if he only needs per sender limit, he could use a policy service in the
          Message 4 of 30 , Jun 28, 2006
            Magnus Bäck wrote:
            > On Wednesday, June 28, 2006 at 13:32 CEST,
            > Simone Nanni <simone.nanni@...> wrote:
            >
            >
            >> a veeeery little question....
            >> Can i set per-user message_size_limit in a MySQL table?? (in a virtual
            >> domain......)
            >>
            >
            > SMTP does not permit this. How would you handle multi-recipient mail
            > with different recipients having different limits? The actual size of
            > the message is not known until it's too late.
            >
            > This has been discussed before, see the archives.
            >
            >
            not clear if "user" means as sender or as recipient. I guess he wants both.
            but if he only needs per sender limit, he could use a policy service in
            the data done stage.
          • Simon Schelkshorn
            Hi there, I added a second listener in my master.cf. For this listener I added the option message_size_limit=20480000 to increase the maximum size for emails
            Message 5 of 30 , Jun 9, 2009
              Hi there,

              I added a second listener in my master.cf. For this listener I added
              the option message_size_limit=20480000 to increase the maximum size
              for emails sent via this additional listener.

              192.168.xxx.xxx:25 inet n - n - - smtpd -o content_filter=
              -o message_size_limit=20480000

              When I now connect to the server it correctly notifies me about the
              maximum message size.

              vs100:/home/simon # telnet 192.168.xxx.xxx 25
              Trying 192.168.xxx.xxx...
              Connected to 192.168.xxx.xxx.
              Escape character is '^]'.
              220 mail2.example.com ESMTP Postfix
              EHLO mail1.example.com
              250-mail2.example.com
              250-PIPELINING
              250-SIZE 20480000
              250-VRFY
              250-ETRN
              250 8BITMIME
              quit
              221 Bye
              Connection closed by foreign host.

              Sending a message larger than the default size of 10MB still results
              in an error message.

              552 Error: message too large

              The message size after BASE64 encoding was approx. 14MB.

              Can anyone point me into the right direction, what I'm doing wrong?

              BR,
              Simon
            • Truth Seeker
              i feel like you have to add the following in main.cf (not in master.cf) message_size_limit = 20480000 for me this is working fine... and have the same size
              Message 6 of 30 , Jun 9, 2009
                i feel like you have to add the following in main.cf (not in master.cf)

                message_size_limit = 20480000

                for me this is working fine... and have the same size limit


                -
                --
                ---
                Always try to find truth!!!

                -


                --- On Tue, 6/9/09, Simon Schelkshorn <simon@...> wrote:

                > From: Simon Schelkshorn <simon@...>
                > Subject: message_size_limit
                > To: "postfix users" <postfix-users@...>
                > Date: Tuesday, June 9, 2009, 8:24 PM
                > Hi there,
                >
                > I added a second listener in my master.cf. For this
                > listener I added
                > the option message_size_limit=20480000 to increase the
                > maximum size
                > for emails sent via this additional listener.
                >
                > 192.168.xxx.xxx:25   
                >    inet    n   
                >    -       n 
                >      -   
                >    -       smtpd -o
                > content_filter=
                >                
                >         -o message_size_limit=20480000
                >
                > When I now connect to the server it correctly notifies me
                > about the
                > maximum message size.
                >
                > vs100:/home/simon # telnet 192.168.xxx.xxx 25
                > Trying 192.168.xxx.xxx...
                > Connected to 192.168.xxx.xxx.
                > Escape character is '^]'.
                > 220 mail2.example.com ESMTP Postfix
                > EHLO mail1.example.com
                > 250-mail2.example.com
                > 250-PIPELINING
                > 250-SIZE 20480000
                > 250-VRFY
                > 250-ETRN
                > 250 8BITMIME
                > quit
                > 221 Bye
                > Connection closed by foreign host.
                >
                > Sending a message larger than the default size of 10MB
                > still results
                > in an error message.
                >
                > 552 Error: message too large
                >
                > The message size after BASE64 encoding was approx. 14MB.
                >
                > Can anyone point me into the right direction, what I'm
                > doing wrong?
                >
                > BR,
                > Simon
                >
                >
              • Wietse Venema
                ... You can t change the size limit for the SMTP server alone. It must be a main.cf setting. Wietse
                Message 7 of 30 , Jun 9, 2009
                  Simon Schelkshorn:
                  > Hi there,
                  >
                  > I added a second listener in my master.cf. For this listener I added
                  > the option message_size_limit=20480000 to increase the maximum size
                  > for emails sent via this additional listener.

                  You can't change the size limit for the SMTP server alone.
                  It must be a main.cf setting.

                  Wietse
                • Magnus Bäck
                  On Tuesday, June 09, 2009 at 19:37 CEST, ... Specifically, message_size_limit is enforced by cleanup(8). Adding another cleanup(8) service with a different
                  Message 8 of 30 , Jun 9, 2009
                    On Tuesday, June 09, 2009 at 19:37 CEST,
                    Wietse Venema <wietse@...> wrote:

                    > Simon Schelkshorn:
                    >
                    > > I added a second listener in my master.cf. For this listener I added
                    > > the option message_size_limit=20480000 to increase the maximum size
                    > > for emails sent via this additional listener.
                    >
                    > You can't change the size limit for the SMTP server alone.
                    > It must be a main.cf setting.

                    Specifically, message_size_limit is enforced by cleanup(8). Adding
                    another cleanup(8) service with a different message_size_limit and
                    choosing it for this particular smtpd(8) with cleanup_service_name
                    should work.

                    --
                    Magnus Bäck
                    magnus@...
                  • Wietse Venema
                    ... But wait, there is more... The queue manager and the delivery agents can be affected, too. Depending on how mail gets into Postfix, recipient records may
                    Message 9 of 30 , Jun 9, 2009
                      Magnus Bäck:
                      > On Tuesday, June 09, 2009 at 19:37 CEST,
                      > Wietse Venema <wietse@...> wrote:
                      >
                      > > Simon Schelkshorn:
                      > >
                      > > > I added a second listener in my master.cf. For this listener I added
                      > > > the option message_size_limit=20480000 to increase the maximum size
                      > > > for emails sent via this additional listener.
                      > >
                      > > You can't change the size limit for the SMTP server alone.
                      > > It must be a main.cf setting.
                      >
                      > Specifically, message_size_limit is enforced by cleanup(8). Adding
                      > another cleanup(8) service with a different message_size_limit and
                      > choosing it for this particular smtpd(8) with cleanup_service_name
                      > should work.

                      But wait, there is more...

                      The queue manager and the delivery agents can be affected, too.
                      Depending on how mail gets into Postfix, recipient records may be
                      sitting at the end of a queue file, and when a delivery agent (or
                      queue manager) tries to mark a recipient as "done" they get into
                      trouble when their "message size limit" setting is too small.

                      That was one of the bugs that was introduced by the VDA patch,


                      Wietse
                    • Simon Schelkshorn
                      Hi, thanks for your fast reply. @Truth Seeker: I added the message_size_limit statement to the definition in master.cf as I intended to increase the message
                      Message 10 of 30 , Jun 11, 2009
                        Hi,

                        thanks for your fast reply.

                        @Truth Seeker: I added the message_size_limit statement to the
                        definition in master.cf as I intended to increase the message size
                        only for mail sent from my local users and not for all messages.


                        > > > You can't change the size limit for the SMTP server alone.
                        > > > It must be a main.cf setting.
                        > >
                        > > Specifically, message_size_limit is enforced by cleanup(8). Adding
                        > > another cleanup(8) service with a different message_size_limit and
                        > > choosing it for this particular smtpd(8) with cleanup_service_name
                        > > should work.
                        >
                        > But wait, there is more...
                        >
                        > The queue manager and the delivery agents can be affected, too.
                        > Depending on how mail gets into Postfix, recipient records may be
                        > sitting at the end of a queue file, and when a delivery agent (or
                        > queue manager) tries to mark a recipient as "done" they get into
                        > trouble when their "message size limit" setting is too small.
                        >
                        > That was one of the bugs that was introduced by the VDA patch,


                        Thanks Magnus for showing a way on how to achieve what I was trying
                        to get and thanks Wietse for pointing out, that there may be some
                        other problems with it.

                        So I decided to go with the "save" configuration and increased the
                        general message size in main.cf.


                        Simon
                      • Victor Duchovni
                        ... Your main.cf message_size_limit must be the *largest* value that you allow for any source or recipient. Then in master.cf you can reduce the main.cf in
                        Message 11 of 30 , Jun 11, 2009
                          On Thu, Jun 11, 2009 at 04:08:16PM +0200, Simon Schelkshorn wrote:

                          > Hi,
                          >
                          > thanks for your fast reply.
                          >
                          > @Truth Seeker: I added the message_size_limit statement to the
                          > definition in master.cf as I intended to increase the message size
                          > only for mail sent from my local users and not for all messages.

                          Your main.cf message_size_limit must be the *largest* value that you
                          allow for any source or recipient. Then in master.cf you can reduce
                          the main.cf in smtpd/cleanup as appropriate. Do NOT reduce the
                          message size limit in the queue manager or delivery agents.

                          --
                          Viktor.

                          Disclaimer: off-list followups get on-list replies or get ignored.
                          Please do not ignore the "Reply-To" header.

                          To unsubscribe from the postfix-users list, visit
                          http://www.postfix.org/lists.html or click the link below:
                          <mailto:majordomo@...?body=unsubscribe%20postfix-users>

                          If my response solves your problem, the best way to thank me is to not
                          send an "it worked, thanks" follow-up. If you must respond, please put
                          "It worked, thanks" in the "Subject" so I can delete these quickly.
                        • James
                          I set message_size_limit = 0 in main.conf and postfix started ok but I wasn t getting mail so I read the docs. It said mailbox_size_limit must be larger than
                          Message 12 of 30 , Jan 16, 2011
                            I set message_size_limit = 0 in main.conf and postfix started ok but I
                            wasn't getting mail so I read the docs.

                            It said mailbox_size_limit must be larger than message_size_limit so I
                            set it to It said
                            mailbox_size_limit = 0 and I got mail. :-)

                            The goal was to be able to receive messages of any size.
                            I'm not sure if that works but at least I get mail again.
                          • Jeroen Geilman
                            ... Apparently you manage a complex email system from the vantage point of an end user with a mailbox that is never big enough. This is not a concern for an
                            Message 13 of 30 , Jan 17, 2011
                              On 1/16/11 6:33 PM, James wrote:
                              > I set message_size_limit = 0 in main.conf and postfix started ok but I
                              > wasn't getting mail so I read the docs.
                              >
                              > It said mailbox_size_limit must be larger than message_size_limit so I
                              > set it to It said
                              > mailbox_size_limit = 0 and I got mail. :-)
                              >
                              > The goal was to be able to receive messages of any size.
                              > I'm not sure if that works but at least I get mail again.

                              Apparently you manage a complex email system from the vantage point of
                              an end user with a mailbox that is never big enough.

                              This is not a concern for an administrator responsible for 50000 mailboxes.

                              You don't want unlimited "anything" happening on your mail server, in
                              general.


                              --
                              J.
                            • Grant
                              Is message_size_limit still valid? All of the references I can find to it online are very old. Is there another postfix directive I should use to set the
                              Message 14 of 30 , Feb 13, 2014
                                Is message_size_limit still valid? All of the references I can find
                                to it online are very old. Is there another postfix directive I
                                should use to set the maximum upload size for roundcube?

                                - Grant
                              • Noel Jones
                                ... Yes, it s still valid. That feature hasn t changed in a long time so it doesn t get much discussion, but it still works just fine. -- Noel Jones
                                Message 15 of 30 , Feb 13, 2014
                                  On 2/13/2014 7:58 PM, Grant wrote:
                                  > Is message_size_limit still valid? All of the references I can find
                                  > to it online are very old. Is there another postfix directive I
                                  > should use to set the maximum upload size for roundcube?
                                  >
                                  > - Grant
                                  >

                                  Yes, it's still valid. That feature hasn't changed in a long time
                                  so it doesn't get much discussion, but it still works just fine.



                                  -- Noel Jones
                                • Viktor Dukhovni
                                  ... Postfix configuration parameters don t capriciously disappear. If they are obsoleted, they become the basis for the default settings of any new improved
                                  Message 16 of 30 , Feb 13, 2014
                                    On Thu, Feb 13, 2014 at 05:58:20PM -0800, Grant wrote:

                                    > Is message_size_limit still valid? All of the references I can find
                                    > to it online are very old. Is there another postfix directive I
                                    > should use to set the maximum upload size for roundcube?

                                    Postfix configuration parameters don't capriciously disappear. If
                                    they are obsoleted, they become the basis for the default settings
                                    of any new improved parameters.

                                    The definitive status of each setting can be found at:

                                    http://www.postfix.org/postconf.5.html#<parameter_name>

                                    in your case:

                                    http://www.postfix.org/postconf.5.html#message_size_limit

                                    The oldest Postfix release I have in my git repo is postfix-beta-19990122.
                                    Not surprisingly, this parameter was already present. Wietse likely
                                    has older postfix sources somewhere, but it is hard to imagine an
                                    MTA without a message size limit parameter, so this probably goes
                                    back to the very first alpha release.

                                    --
                                    Viktor.
                                  • Grant
                                    ... Got it, thank you. - Grant
                                    Message 17 of 30 , Feb 15, 2014
                                      >> Is message_size_limit still valid? All of the references I can find
                                      >> to it online are very old. Is there another postfix directive I
                                      >> should use to set the maximum upload size for roundcube?
                                      >
                                      > Postfix configuration parameters don't capriciously disappear. If
                                      > they are obsoleted, they become the basis for the default settings
                                      > of any new improved parameters.
                                      >
                                      > The definitive status of each setting can be found at:
                                      >
                                      > http://www.postfix.org/postconf.5.html#<parameter_name>
                                      >
                                      > in your case:
                                      >
                                      > http://www.postfix.org/postconf.5.html#message_size_limit
                                      >
                                      > The oldest Postfix release I have in my git repo is postfix-beta-19990122.
                                      > Not surprisingly, this parameter was already present. Wietse likely
                                      > has older postfix sources somewhere, but it is hard to imagine an
                                      > MTA without a message size limit parameter, so this probably goes
                                      > back to the very first alpha release.


                                      Got it, thank you.

                                      - Grant
                                    Your message has been successfully submitted and would be delivered to recipients shortly.