Loading ...
Sorry, an error occurred while loading the content.

Re: anvil with snapshot 1229 ?

Expand Messages
  • Wietse Venema
    ... Logged 3:23 (203 seconds) after the connection starts. smtpd terminates after 100s idle time, and anvil terminates 100s after smtpd disconnects from it.
    Message 1 of 5 , Dec 31, 2005
    • 0 Attachment
      J.D. Bronson:
      > Dec 30 15:05:57 cheyenne postfix/anvil[1595]: statistics: max
      > connection rate 1/1800s for (smtp:64.140.235.198) at Dec 30 15:02:34

      Logged 3:23 (203 seconds) after the connection starts. smtpd
      terminates after 100s idle time, and anvil terminates 100s
      after smtpd disconnects from it.

      > Dec 30 15:16:00 cheyenne postfix/anvil[1606]: statistics: max
      > connection rate 1/1800s for (smtp:64.140.235.198) at Dec 30 15:12:37

      Same deal here.

      This "problem" happens only on servers that have no remote connection
      for more than 200 seconds. Otherwise the anvil server will keep
      running.

      This could be fixed by not having anvil terminate after 100s idle
      time. See untested patch below.

      But since this is an overload protection mechanism, I don't worry
      too much about systems that are idle for hundreds of seconds.

      Wietse

      *** ./anvil.c- Wed Oct 12 15:52:51 2005
      --- ./anvil.c Sat Dec 31 14:04:46 2005
      ***************
      *** 937,942 ****
      --- 937,948 ----
      * Do not limit the number of client requests.
      */
      var_use_limit = 0;
      +
      + /*
      + * Don't exit before the sampling interval ends.
      + */
      + if (var_idle_limit < var_anvil_time_unit)
      + var_idle_limit = var_anvil_time_unit;
      }

      /* main - pass control to the multi-threaded skeleton */
    Your message has been successfully submitted and would be delivered to recipients shortly.