Loading ...
Sorry, an error occurred while loading the content.

message_size_limit

Expand Messages
  • suneel cumar
    Hi All, Am looking into a tool for per user message_size_limit feature. I tried with Policyd for the limiting feature but finds uncomfortable. Is any body
    Message 1 of 30 , Dec 29, 2005
    • 0 Attachment
      Hi All,

      Am looking into  a tool  for per user message_size_limit feature.

      I tried with Policyd for the limiting feature but finds uncomfortable.

      Is any body suggest that message_size_limit has maps feature to limit users and can be applied on each individual ID's


      Every suggestion will help a lot for me.

      Looking for a positive suggestions .



      Regards,
      Suneel




      Yahoo! Shopping
      Find Great Deals on Holiday Gifts at Yahoo! Shopping
    • Magnus Bäck
      On Friday, December 30, 2005 at 05:21 CET, ... Because of how SMTP works, there is no robust solution for this. Think about multi-recipient messages where
      Message 2 of 30 , Dec 29, 2005
      • 0 Attachment
        On Friday, December 30, 2005 at 05:21 CET,
        suneel cumar <suneelcumar@...> wrote:

        > Am looking into a tool for per user message_size_limit feature.

        Because of how SMTP works, there is no robust solution for this. Think
        about multi-recipient messages where different recipients have different
        size limits. Think about the announced message size limit in the EHLO
        reply. This has been discussed many times before, so search the archives
        if you're not convinced.

        [...]

        --
        Magnus Bäck
        magnus@...
      • Mihira Fernando
        ... Makes you wonder how Exchange manages to do this though.. Mihira. -- Random Quotes From Megas XLR Coop: You see? The mysteries of the Universe are revealed
        Message 3 of 30 , Dec 29, 2005
        • 0 Attachment
          On Fri, 30 Dec 2005 13:12:10 +0700, Magnus Bäck <magnus@...> wrote:

          > On Friday, December 30, 2005 at 05:21 CET,
          > suneel cumar <suneelcumar@...> wrote:
          >
          >> Am looking into a tool for per user message_size_limit feature.
          >
          > Because of how SMTP works, there is no robust solution for this. Think
          > about multi-recipient messages where different recipients have different
          > size limits. Think about the announced message size limit in the EHLO
          > reply. This has been discussed many times before, so search the archives
          > if you're not convinced.

          Makes you wonder how Exchange manages to do this though..

          Mihira.

          --
          Random Quotes From Megas XLR
          Coop: You see? The mysteries of the Universe are revealed when you break
          stuff.
          Jamie: When in doubt, blow up a planet.
          Kiva: It's an 80 foot robot, if we can't see it, absolutely it's not here.
          Glorft Technician: Unnecessary use of force in capturing the Earthers has
          been approved.
        • Magnus Bäck
          On Friday, December 30, 2005 at 07:16 CET, ... Presumably by bouncing the message after it has been accepted, and this is of course possible with Postfix as
          Message 4 of 30 , Dec 29, 2005
          • 0 Attachment
            On Friday, December 30, 2005 at 07:16 CET,
            Mihira Fernando <mihiratheace@...> wrote:

            > On Fri, 30 Dec 2005 13:12:10 +0700, Magnus Bäck <magnus@...> wrote:
            >
            > > Because of how SMTP works, there is no robust solution for this.
            > > Think about multi-recipient messages where different recipients have
            > > different size limits. Think about the announced message size limit
            > > in the EHLO reply. This has been discussed many times before, so
            > > search the archives if you're not convinced.
            >
            > Makes you wonder how Exchange manages to do this though..

            Presumably by bouncing the message after it has been accepted, and this
            is of course possible with Postfix as well if you have a delivery agent
            capable of it.

            --
            Magnus Bäck
            magnus@...
          • CN
            My daily report shows a few bounces everyday; I wish to make these rejects instead. daily report: local 4 unknown user: xyz 1 unknown user: office
            Message 5 of 30 , Dec 29, 2005
            • 0 Attachment
              My daily report shows a few bounces everyday; I wish to make these rejects instead.
              daily report:
              local
              4 unknown user: "xyz"
              1 unknown user: "office"
              mail1.techradium.com[66.193.244.25]
              1 5.1.3 Syntax error in address

              mail_version = 1.1.11

              part of postconf -n:
              disable_vrfy_command = yes
              local_recipient_maps =
              mydestination = $myhostname, localhost.$mydomain, $mydomain
              mydomain = abc.com
              myhostname = hhh.abc.com
              mynetworks = 192.168.1.0/24, 127.0.0.0/8
              myorigin = $mydomain
              relay_domains = $mydestination, a.com, b.org
              smtpd_client_restrictions = permit_mynetworks,reject_unknown_client,check_client_access hash:/etc/postfix/access,reject_maps_rbl
              smtpd_delay_reject = no
              smtpd_helo_required = yes
              smtpd_helo_restrictions = reject_invalid_hostname,reject_unknown_hostname,reject_non_fqdn_hostname
              smtpd_recipient_restrictions = reject_non_fqdn_sender, reject_non_fqdn_recipient, reject_unknown_sender_domain, reject_unknown_recipient_domain, permit_mynetworks, reject_invalid_hostname, reject_non_fqdn_hostname, reject_unauth_pipelining, reject_unauth_destination, check_helo_access hash:/etc/postfix/helo_access, reject_maps_rbl
              virtual_maps = hash:/etc/postfix/virtual

              /etc/postfix/access: (part of it)
              xyz@... 450 obsolete address

              How should I change the above so that all 3 bounces can be made rejects? I have tried to read up the docs, but still in the dard :)

              Cordially, Chacko
            • Magnus Bäck
              On Friday, December 30, 2005 at 07:40 CET, ... Show complete log entries for these cases. You can skip the last one since it isn t Postfix generating that
              Message 6 of 30 , Dec 29, 2005
              • 0 Attachment
                On Friday, December 30, 2005 at 07:40 CET,
                CN <t4chacko@...> wrote:

                > My daily report shows a few bounces everyday; I wish to make these
                > rejects instead.
                > daily report:
                > local
                > 4 unknown user: "xyz"
                > 1 unknown user: "office"
                > mail1.techradium.com[66.193.244.25]
                > 1 5.1.3 Syntax error in address

                Show complete log entries for these cases. You can skip the last one
                since it isn't Postfix generating that bounce.

                > mail_version = 1.1.11

                That's really old.

                > part of postconf -n:
                > disable_vrfy_command = yes
                > local_recipient_maps =

                An empty local_recipient_maps will disable validation of local
                recipients, which most probably is the reason for the first two
                types of bounces in the list above.

                > mydestination = $myhostname, localhost.$mydomain, $mydomain
                > mydomain = abc.com
                > myhostname = hhh.abc.com
                > mynetworks = 192.168.1.0/24, 127.0.0.0/8
                > myorigin = $mydomain
                > relay_domains = $mydestination, a.com, b.org
                > smtpd_client_restrictions = permit_mynetworks,reject_unknown_client,check_client_access hash:/etc/postfix/access,reject_maps_rbl
                > smtpd_delay_reject = no

                Are you sure you know what you're doing when you alter
                smtpd_delay_reject like that?

                > smtpd_helo_required = yes
                > smtpd_helo_restrictions = reject_invalid_hostname,reject_unknown_hostname,reject_non_fqdn_hostname
                > smtpd_recipient_restrictions = reject_non_fqdn_sender, reject_non_fqdn_recipient, reject_unknown_sender_domain, reject_unknown_recipient_domain, permit_mynetworks, reject_invalid_hostname, reject_non_fqdn_hostname, reject_unauth_pipelining, reject_unauth_destination, check_helo_access hash:/etc/postfix/helo_access, reject_maps_rbl

                Why repeat reject_maps_rbl again?

                > virtual_maps = hash:/etc/postfix/virtual
                >
                > /etc/postfix/access: (part of it)
                > xyz@... 450 obsolete address

                Listing an email address in an access map used with check_client_access
                is useless. And why reject obsolete addresses with a temporary reject
                code? Is the address likely to become active very soon, or what?

                Do not start new discussion topics by replying to old messages.

                [...]

                --
                Magnus Bäck
                magnus@...
              • CN
                Magnus, The answers to most of your question is the obvious: I do not quite know what I am doing :( Sorry. ... 1.1.11 is the highest version I can get as rpm
                Message 7 of 30 , Dec 29, 2005
                • 0 Attachment
                  Magnus,
                  The answers to most of your question is the obvious: I do not quite know what I am doing :( Sorry.

                  On Fri, 30 Dec 2005 07:58:08 +0100, Magnus Bäck wrote:

                  > > mail_version = 1.1.11
                  >
                  > That's really old.
                  1.1.11 is the highest version I can get as rpm on the particular version of the linux I am running, not much choice until I move to another box.

                  > > local_recipient_maps =
                  >
                  > An empty local_recipient_maps will disable validation of local
                  > recipients, which most probably is the reason for the first two
                  > types of bounces in the list above.

                  That happens to be the default in my system.
                  # postconf -d | grep local_reci
                  local_recipient_maps =

                  What should it be?

                  > > smtpd_client_restrictions = permit_mynetworks,reject_unknown_client,check_client_access hash:/etc/postfix/access,reject_maps_rbl
                  > > smtpd_delay_reject = no
                  >
                  > Are you sure you know what you're doing when you alter
                  > smtpd_delay_reject like that?

                  No, I will revert to the default...

                  > > smtpd_helo_required = yes
                  > > smtpd_helo_restrictions = reject_invalid_hostname,reject_unknown_hostname,reject_non_fqdn_hostname
                  > > smtpd_recipient_restrictions = reject_non_fqdn_sender, reject_non_fqdn_recipient, reject_unknown_sender_domain, reject_unknown_recipient_domain, permit_mynetworks, reject_invalid_hostname, reject_non_fqdn_hostname, reject_unauth_pipelining, reject_unauth_destination, check_helo_access hash:/etc/postfix/helo_access, reject_maps_rbl
                  >
                  > Why repeat reject_maps_rbl again?

                  Which one should I keep, the one client_restrictions, or the that in recipiet_ ?

                  > > virtual_maps = hash:/etc/postfix/virtual
                  > >
                  > > /etc/postfix/access: (part of it)
                  > > xyz@... 450 obsolete address
                  >
                  > Listing an email address in an access map used with check_client_access
                  > is useless. And why reject obsolete addresses with a temporary reject
                  > code? Is the address likely to become active very soon, or what?

                  What code should I use? No, it is not likely to become active soon at all.

                  Thank you for your help!

                • suneel cumar
                  looking to restrict outbound mails wherein people use to send mails outside network. We need to block the mesg_size_limit based on thier rolls. Can we achieve
                  Message 8 of 30 , Dec 29, 2005
                  • 0 Attachment
                    looking to restrict outbound mails wherein people use to send mails outside network. We need to block the mesg_size_limit based on thier rolls.

                    Can we achieve this by making groups. And define certain limitation to each group and make users to fall amoung these groups.

                    Only to the senders originating from local setup.

                    Suneel.

                    Magnus Bäck <magnus@...> wrote:
                    On Friday, December 30, 2005 at 07:16 CET,
                    Mihira Fernando wrote:

                    > On Fri, 30 Dec 2005 13:12:10 +0700, Magnus Bäck wrote:
                    >
                    > > Because of how SMTP works, there is no robust solution for this.
                    > > Think about multi-recipient messages where different recipients have
                    > > different size limits. Think about the announced message size limit
                    > > in the EHLO reply. This has been discussed many times before, so
                    > > search the archives if you're not convinced.
                    >
                    > Makes you wonder how Exchange manages to do this though..

                    Presumably by bouncing the message after it has been accepted, and this
                    is of course possible with Postfix as well if you have a delivery agent
                    capable of it.

                    --
                    Magnus Bäck
                    magnus@...


                    Yahoo! Shopping
                    Find Great Deals on Holiday Gifts at Yahoo! Shopping
                  • Cami
                    ... Policyd can restrict outgoing mail size on a per-user basis. Cami
                    Message 9 of 30 , Dec 30, 2005
                    • 0 Attachment
                      suneel cumar wrote:
                      > looking to restrict outbound mails wherein people use to send mails
                      > outside network. We need to block the mesg_size_limit based on thier rolls.
                      >
                      > Can we achieve this by making groups. And define certain limitation to
                      > each group and make users to fall amoung these groups.
                      >
                      > Only to the senders originating from local setup.

                      Policyd can restrict outgoing mail size on a per-user basis.

                      Cami
                    • Magnus Bäck
                      On Friday, December 30, 2005 at 08:48 CET, ... Ah, message size limit depending on the *sender*. That s doable. ... If you don t like policyd, you can create a
                      Message 10 of 30 , Dec 30, 2005
                      • 0 Attachment
                        On Friday, December 30, 2005 at 08:48 CET,
                        suneel cumar <suneelcumar@...> wrote:

                        > looking to restrict outbound mails wherein people use to send mails
                        > outside network. We need to block the mesg_size_limit based on thier
                        > rolls.

                        Ah, message size limit depending on the *sender*. That's doable.

                        > Can we achieve this by making groups. And define certain limitation
                        > to each group and make users to fall amoung these groups.
                        >
                        > Only to the senders originating from local setup.

                        If you don't like policyd, you can create a custom policy server that
                        fits your needs perfectly. A policy server in some form is your only
                        option.

                        Stop top-posting.

                        --
                        Magnus Bäck
                        magnus@...
                      • Magnus Bäck
                        On Friday, December 30, 2005 at 08:30 CET, ... [...] ... I guess local_recipient_maps = unix:passwd.byname, $alias_maps should work in Postfix 1.1 as well. ...
                        Message 11 of 30 , Dec 30, 2005
                        • 0 Attachment
                          On Friday, December 30, 2005 at 08:30 CET,
                          CN <t4chacko@...> wrote:

                          > On Fri, 30 Dec 2005 07:58:08 +0100, Magnus Bäck wrote:

                          [...]

                          > > An empty local_recipient_maps will disable validation of local
                          > > recipients, which most probably is the reason for the first two
                          > > types of bounces in the list above.
                          >
                          > That happens to be the default in my system.
                          > # postconf -d | grep local_reci
                          > local_recipient_maps =
                          >
                          > What should it be?

                          I guess

                          local_recipient_maps = unix:passwd.byname, $alias_maps

                          should work in Postfix 1.1 as well.

                          > > Why repeat reject_maps_rbl again?
                          >
                          > Which one should I keep, the one client_restrictions, or the that in
                          > recipiet_ ?

                          The restrictions are processed in order, so the answer depends on what
                          order is necessary for your policy. DNSBL lookups are relatively expensive,
                          so it's a good idea to put them rather late in the restriction list.
                          Putting it in smtpd_recipient_restrictions is fine.

                          > > Listing an email address in an access map used with
                          > > check_client_access is useless. And why reject obsolete
                          > > addresses with a temporary reject code? Is the address
                          > > likely to become active very soon, or what?
                          >
                          > What code should I use? No, it is not likely to become
                          > active soon at all.

                          550 is the permanent error code that corresponds to 450.

                          --
                          Magnus Bäck
                          magnus@...
                        • CN
                          ... Thank you, Magnus! If I do not want mail for users (accounts) on the local unix, but only for those in my $alias_maps, then can it be just
                          Message 12 of 30 , Dec 30, 2005
                          • 0 Attachment
                            On Fri, 30 Dec 2005 14:55:28 +0100, Magnus Bäck wrote:
                            > > That happens to be the default in my system.
                            > > # postconf -d | grep local_reci
                            > > local_recipient_maps =
                            > >
                            > > What should it be?
                            >
                            > I guess
                            >
                            > local_recipient_maps = unix:passwd.byname, $alias_maps
                            >
                            > should work in Postfix 1.1 as well.

                            Thank you, Magnus! If I do not want mail for users (accounts) on the local unix,
                            but only for those in my $alias_maps, then can it be just
                            local_recipient_maps = $alias_maps
                            One of the very old user names has become a spam magnet, and I want mail for
                            that to be rejected.

                            Cordially, Chacko
                          • Sandy Drobic
                            ... There are probably compiled rpm packages of newer postfix versions available for your distribution. Why don t you test it on a separate little pc with your
                            Message 13 of 30 , Dec 30, 2005
                            • 0 Attachment
                              CN wrote:
                              > Magnus,
                              > The answers to most of your question is the obvious: I do not quite know what I am doing :( Sorry.
                              >
                              > On Fri, 30 Dec 2005 07:58:08 +0100, Magnus Bäck wrote:
                              >
                              >
                              >>>mail_version = 1.1.11
                              >>
                              >>That's really old.
                              >
                              > 1.1.11 is the highest version I can get as rpm on the particular version of the linux I am running, not
                              > much choice until I move to another box.
                              >

                              There are probably compiled rpm packages of newer postfix versions
                              available for your distribution. Why don't you test it on a separate
                              little pc with your distribution?

                              >>>local_recipient_maps =
                              >>
                              >>An empty local_recipient_maps will disable validation of local
                              >>recipients, which most probably is the reason for the first two
                              >>types of bounces in the list above.
                              >
                              >
                              > That happens to be the default in my system.
                              > # postconf -d | grep local_reci
                              > local_recipient_maps =
                              >
                              > What should it be?

                              This depends on where the users are stored. Are they system users in
                              passwd? Then it should be
                              local_recipient_maps = unix:passwd.byname $alias_maps

                              For details please see: http://www.postfix.org/LOCAL_RECIPIENT_README.html

                              >
                              >
                              >>>smtpd_client_restrictions = permit_mynetworks,reject_unknown_client,check_client_access
                              >
                              > hash:/etc/postfix/access,reject_maps_rbl
                              >
                              >>>smtpd_delay_reject = no
                              >>
                              >>Are you sure you know what you're doing when you alter
                              >>smtpd_delay_reject like that?
                              >
                              >
                              > No, I will revert to the default...
                              >
                              >
                              >>>smtpd_helo_required = yes
                              >>>smtpd_helo_restrictions =
                              >
                              > reject_invalid_hostname,reject_unknown_hostname,reject_non_fqdn_hostname
                              >
                              >>>smtpd_recipient_restrictions = reject_non_fqdn_sender, reject_non_fqdn_recipient,
                              >
                              > reject_unknown_sender_domain, reject_unknown_recipient_domain, permit_mynetworks,
                              > reject_invalid_hostname, reject_non_fqdn_hostname, reject_unauth_pipelining,
                              > reject_unauth_destination, check_helo_access hash:/etc/postfix/helo_access, reject_maps_rbl
                              >
                              >>Why repeat reject_maps_rbl again?
                              >
                              >
                              > Which one should I keep, the one client_restrictions, or the that in recipiet_ ?
                              >

                              It is easier to keep the one in smtpd_recipient_restrictions, you can see
                              the order in which the restrictions are applied easier.

                              >>>virtual_maps = hash:/etc/postfix/virtual
                              >>>
                              >>>/etc/postfix/access: (part of it)
                              >>>xyz@... 450 obsolete address
                              >>
                              >>Listing an email address in an access map used with check_client_access
                              >>is useless. And why reject obsolete addresses with a temporary reject
                              >>code? Is the address likely to become active very soon, or what?
                              >
                              >
                              > What code should I use? No, it is not likely to become active soon at all.

                              550 or 554 would be appropriate.

                              Sandy
                            • mouss
                              ... you can. just don t set it to void (which means any address is valid). If you don t need local , then it s even better to avoid it at once:
                              Message 14 of 30 , Jan 1, 2006
                              • 0 Attachment
                                CN a écrit :
                                > On Fri, 30 Dec 2005 14:55:28 +0100, Magnus Bäck wrote:
                                >
                                >>>That happens to be the default in my system.
                                >>># postconf -d | grep local_reci
                                >>>local_recipient_maps =
                                >>>
                                >>>What should it be?
                                >>
                                >>I guess
                                >>
                                >> local_recipient_maps = unix:passwd.byname, $alias_maps
                                >>
                                >>should work in Postfix 1.1 as well.
                                >
                                >
                                > Thank you, Magnus! If I do not want mail for users (accounts) on the local unix,
                                > but only for those in my $alias_maps, then can it be just
                                > local_recipient_maps = $alias_maps

                                you can. just don't set it to "void" (which means any address is valid).

                                If you don't need "local", then it's even better to avoid it at once:

                                local_recipient_maps = hash:$dir/empty

                                (where empty is an empty hash file) and use virtual aliases and/or
                                transports to implement the few "local" tasks that you need.

                                you may want to handle foo@[ip] addresses as they are considered local
                                however you set mydestination. you should accept mail to postmaster@[ip]
                                to allow people to contact you in case of serious problems, and possibly
                                reject all the rest.

                                > One of the very old user names has become a spam magnet, and I want mail for
                                > that to be rejected.
                                >

                                just add a check_recipient_access to either reject or redirect to a spam
                                trap. Don't redirect to a spam trap if the address is still used to
                                opt-in in one or more marketing lists. spam traps must be protected
                                against misuse. We don't like some DNSBLs that rely on traps mostly
                                because of lack of trust in their trap protection.
                              • Simone Nanni
                                Hi everybody, a veeeery little question.... Can i set per-user message_size_limit in a MySQL table?? (in a virtual domain......) Thanx a lot in advance! Simone
                                Message 15 of 30 , Jun 28, 2006
                                • 0 Attachment
                                  Hi everybody,
                                  a veeeery little question....
                                  Can i set per-user message_size_limit in a MySQL table?? (in a virtual domain......)
                                  Thanx a lot in advance!
                                   
                                   
                                  Simone Nanni
                                  ICT Technician
                                  A.O.U. Policlinico Tor Vergata
                                  Viale Oxford, 81
                                  00133 - Roma - RM - Italy
                                  Tel: 06/20900081
                                  Fax: 06/20900080
                                  Mail: simone.nanni@...
                                • Magnus Bäck
                                  On Wednesday, June 28, 2006 at 13:32 CEST, ... SMTP does not permit this. How would you handle multi-recipient mail with different recipients having different
                                  Message 16 of 30 , Jun 28, 2006
                                  • 0 Attachment
                                    On Wednesday, June 28, 2006 at 13:32 CEST,
                                    Simone Nanni <simone.nanni@...> wrote:

                                    > a veeeery little question....
                                    > Can i set per-user message_size_limit in a MySQL table?? (in a virtual
                                    > domain......)

                                    SMTP does not permit this. How would you handle multi-recipient mail
                                    with different recipients having different limits? The actual size of
                                    the message is not known until it's too late.

                                    This has been discussed before, see the archives.

                                    --
                                    Magnus Bäck
                                    magnus@...
                                  • mouss
                                    ... not clear if user means as sender or as recipient. I guess he wants both. but if he only needs per sender limit, he could use a policy service in the
                                    Message 17 of 30 , Jun 28, 2006
                                    • 0 Attachment
                                      Magnus Bäck wrote:
                                      > On Wednesday, June 28, 2006 at 13:32 CEST,
                                      > Simone Nanni <simone.nanni@...> wrote:
                                      >
                                      >
                                      >> a veeeery little question....
                                      >> Can i set per-user message_size_limit in a MySQL table?? (in a virtual
                                      >> domain......)
                                      >>
                                      >
                                      > SMTP does not permit this. How would you handle multi-recipient mail
                                      > with different recipients having different limits? The actual size of
                                      > the message is not known until it's too late.
                                      >
                                      > This has been discussed before, see the archives.
                                      >
                                      >
                                      not clear if "user" means as sender or as recipient. I guess he wants both.
                                      but if he only needs per sender limit, he could use a policy service in
                                      the data done stage.
                                    • Simon Schelkshorn
                                      Hi there, I added a second listener in my master.cf. For this listener I added the option message_size_limit=20480000 to increase the maximum size for emails
                                      Message 18 of 30 , Jun 9, 2009
                                      • 0 Attachment
                                        Hi there,

                                        I added a second listener in my master.cf. For this listener I added
                                        the option message_size_limit=20480000 to increase the maximum size
                                        for emails sent via this additional listener.

                                        192.168.xxx.xxx:25 inet n - n - - smtpd -o content_filter=
                                        -o message_size_limit=20480000

                                        When I now connect to the server it correctly notifies me about the
                                        maximum message size.

                                        vs100:/home/simon # telnet 192.168.xxx.xxx 25
                                        Trying 192.168.xxx.xxx...
                                        Connected to 192.168.xxx.xxx.
                                        Escape character is '^]'.
                                        220 mail2.example.com ESMTP Postfix
                                        EHLO mail1.example.com
                                        250-mail2.example.com
                                        250-PIPELINING
                                        250-SIZE 20480000
                                        250-VRFY
                                        250-ETRN
                                        250 8BITMIME
                                        quit
                                        221 Bye
                                        Connection closed by foreign host.

                                        Sending a message larger than the default size of 10MB still results
                                        in an error message.

                                        552 Error: message too large

                                        The message size after BASE64 encoding was approx. 14MB.

                                        Can anyone point me into the right direction, what I'm doing wrong?

                                        BR,
                                        Simon
                                      • Truth Seeker
                                        i feel like you have to add the following in main.cf (not in master.cf) message_size_limit = 20480000 for me this is working fine... and have the same size
                                        Message 19 of 30 , Jun 9, 2009
                                        • 0 Attachment
                                          i feel like you have to add the following in main.cf (not in master.cf)

                                          message_size_limit = 20480000

                                          for me this is working fine... and have the same size limit


                                          -
                                          --
                                          ---
                                          Always try to find truth!!!

                                          -


                                          --- On Tue, 6/9/09, Simon Schelkshorn <simon@...> wrote:

                                          > From: Simon Schelkshorn <simon@...>
                                          > Subject: message_size_limit
                                          > To: "postfix users" <postfix-users@...>
                                          > Date: Tuesday, June 9, 2009, 8:24 PM
                                          > Hi there,
                                          >
                                          > I added a second listener in my master.cf. For this
                                          > listener I added
                                          > the option message_size_limit=20480000 to increase the
                                          > maximum size
                                          > for emails sent via this additional listener.
                                          >
                                          > 192.168.xxx.xxx:25   
                                          >    inet    n   
                                          >    -       n 
                                          >      -   
                                          >    -       smtpd -o
                                          > content_filter=
                                          >                
                                          >         -o message_size_limit=20480000
                                          >
                                          > When I now connect to the server it correctly notifies me
                                          > about the
                                          > maximum message size.
                                          >
                                          > vs100:/home/simon # telnet 192.168.xxx.xxx 25
                                          > Trying 192.168.xxx.xxx...
                                          > Connected to 192.168.xxx.xxx.
                                          > Escape character is '^]'.
                                          > 220 mail2.example.com ESMTP Postfix
                                          > EHLO mail1.example.com
                                          > 250-mail2.example.com
                                          > 250-PIPELINING
                                          > 250-SIZE 20480000
                                          > 250-VRFY
                                          > 250-ETRN
                                          > 250 8BITMIME
                                          > quit
                                          > 221 Bye
                                          > Connection closed by foreign host.
                                          >
                                          > Sending a message larger than the default size of 10MB
                                          > still results
                                          > in an error message.
                                          >
                                          > 552 Error: message too large
                                          >
                                          > The message size after BASE64 encoding was approx. 14MB.
                                          >
                                          > Can anyone point me into the right direction, what I'm
                                          > doing wrong?
                                          >
                                          > BR,
                                          > Simon
                                          >
                                          >
                                        • Wietse Venema
                                          ... You can t change the size limit for the SMTP server alone. It must be a main.cf setting. Wietse
                                          Message 20 of 30 , Jun 9, 2009
                                          • 0 Attachment
                                            Simon Schelkshorn:
                                            > Hi there,
                                            >
                                            > I added a second listener in my master.cf. For this listener I added
                                            > the option message_size_limit=20480000 to increase the maximum size
                                            > for emails sent via this additional listener.

                                            You can't change the size limit for the SMTP server alone.
                                            It must be a main.cf setting.

                                            Wietse
                                          • Magnus Bäck
                                            On Tuesday, June 09, 2009 at 19:37 CEST, ... Specifically, message_size_limit is enforced by cleanup(8). Adding another cleanup(8) service with a different
                                            Message 21 of 30 , Jun 9, 2009
                                            • 0 Attachment
                                              On Tuesday, June 09, 2009 at 19:37 CEST,
                                              Wietse Venema <wietse@...> wrote:

                                              > Simon Schelkshorn:
                                              >
                                              > > I added a second listener in my master.cf. For this listener I added
                                              > > the option message_size_limit=20480000 to increase the maximum size
                                              > > for emails sent via this additional listener.
                                              >
                                              > You can't change the size limit for the SMTP server alone.
                                              > It must be a main.cf setting.

                                              Specifically, message_size_limit is enforced by cleanup(8). Adding
                                              another cleanup(8) service with a different message_size_limit and
                                              choosing it for this particular smtpd(8) with cleanup_service_name
                                              should work.

                                              --
                                              Magnus Bäck
                                              magnus@...
                                            • Wietse Venema
                                              ... But wait, there is more... The queue manager and the delivery agents can be affected, too. Depending on how mail gets into Postfix, recipient records may
                                              Message 22 of 30 , Jun 9, 2009
                                              • 0 Attachment
                                                Magnus Bäck:
                                                > On Tuesday, June 09, 2009 at 19:37 CEST,
                                                > Wietse Venema <wietse@...> wrote:
                                                >
                                                > > Simon Schelkshorn:
                                                > >
                                                > > > I added a second listener in my master.cf. For this listener I added
                                                > > > the option message_size_limit=20480000 to increase the maximum size
                                                > > > for emails sent via this additional listener.
                                                > >
                                                > > You can't change the size limit for the SMTP server alone.
                                                > > It must be a main.cf setting.
                                                >
                                                > Specifically, message_size_limit is enforced by cleanup(8). Adding
                                                > another cleanup(8) service with a different message_size_limit and
                                                > choosing it for this particular smtpd(8) with cleanup_service_name
                                                > should work.

                                                But wait, there is more...

                                                The queue manager and the delivery agents can be affected, too.
                                                Depending on how mail gets into Postfix, recipient records may be
                                                sitting at the end of a queue file, and when a delivery agent (or
                                                queue manager) tries to mark a recipient as "done" they get into
                                                trouble when their "message size limit" setting is too small.

                                                That was one of the bugs that was introduced by the VDA patch,


                                                Wietse
                                              • Simon Schelkshorn
                                                Hi, thanks for your fast reply. @Truth Seeker: I added the message_size_limit statement to the definition in master.cf as I intended to increase the message
                                                Message 23 of 30 , Jun 11, 2009
                                                • 0 Attachment
                                                  Hi,

                                                  thanks for your fast reply.

                                                  @Truth Seeker: I added the message_size_limit statement to the
                                                  definition in master.cf as I intended to increase the message size
                                                  only for mail sent from my local users and not for all messages.


                                                  > > > You can't change the size limit for the SMTP server alone.
                                                  > > > It must be a main.cf setting.
                                                  > >
                                                  > > Specifically, message_size_limit is enforced by cleanup(8). Adding
                                                  > > another cleanup(8) service with a different message_size_limit and
                                                  > > choosing it for this particular smtpd(8) with cleanup_service_name
                                                  > > should work.
                                                  >
                                                  > But wait, there is more...
                                                  >
                                                  > The queue manager and the delivery agents can be affected, too.
                                                  > Depending on how mail gets into Postfix, recipient records may be
                                                  > sitting at the end of a queue file, and when a delivery agent (or
                                                  > queue manager) tries to mark a recipient as "done" they get into
                                                  > trouble when their "message size limit" setting is too small.
                                                  >
                                                  > That was one of the bugs that was introduced by the VDA patch,


                                                  Thanks Magnus for showing a way on how to achieve what I was trying
                                                  to get and thanks Wietse for pointing out, that there may be some
                                                  other problems with it.

                                                  So I decided to go with the "save" configuration and increased the
                                                  general message size in main.cf.


                                                  Simon
                                                • Victor Duchovni
                                                  ... Your main.cf message_size_limit must be the *largest* value that you allow for any source or recipient. Then in master.cf you can reduce the main.cf in
                                                  Message 24 of 30 , Jun 11, 2009
                                                  • 0 Attachment
                                                    On Thu, Jun 11, 2009 at 04:08:16PM +0200, Simon Schelkshorn wrote:

                                                    > Hi,
                                                    >
                                                    > thanks for your fast reply.
                                                    >
                                                    > @Truth Seeker: I added the message_size_limit statement to the
                                                    > definition in master.cf as I intended to increase the message size
                                                    > only for mail sent from my local users and not for all messages.

                                                    Your main.cf message_size_limit must be the *largest* value that you
                                                    allow for any source or recipient. Then in master.cf you can reduce
                                                    the main.cf in smtpd/cleanup as appropriate. Do NOT reduce the
                                                    message size limit in the queue manager or delivery agents.

                                                    --
                                                    Viktor.

                                                    Disclaimer: off-list followups get on-list replies or get ignored.
                                                    Please do not ignore the "Reply-To" header.

                                                    To unsubscribe from the postfix-users list, visit
                                                    http://www.postfix.org/lists.html or click the link below:
                                                    <mailto:majordomo@...?body=unsubscribe%20postfix-users>

                                                    If my response solves your problem, the best way to thank me is to not
                                                    send an "it worked, thanks" follow-up. If you must respond, please put
                                                    "It worked, thanks" in the "Subject" so I can delete these quickly.
                                                  • James
                                                    I set message_size_limit = 0 in main.conf and postfix started ok but I wasn t getting mail so I read the docs. It said mailbox_size_limit must be larger than
                                                    Message 25 of 30 , Jan 16, 2011
                                                    • 0 Attachment
                                                      I set message_size_limit = 0 in main.conf and postfix started ok but I
                                                      wasn't getting mail so I read the docs.

                                                      It said mailbox_size_limit must be larger than message_size_limit so I
                                                      set it to It said
                                                      mailbox_size_limit = 0 and I got mail. :-)

                                                      The goal was to be able to receive messages of any size.
                                                      I'm not sure if that works but at least I get mail again.
                                                    • Jeroen Geilman
                                                      ... Apparently you manage a complex email system from the vantage point of an end user with a mailbox that is never big enough. This is not a concern for an
                                                      Message 26 of 30 , Jan 17, 2011
                                                      • 0 Attachment
                                                        On 1/16/11 6:33 PM, James wrote:
                                                        > I set message_size_limit = 0 in main.conf and postfix started ok but I
                                                        > wasn't getting mail so I read the docs.
                                                        >
                                                        > It said mailbox_size_limit must be larger than message_size_limit so I
                                                        > set it to It said
                                                        > mailbox_size_limit = 0 and I got mail. :-)
                                                        >
                                                        > The goal was to be able to receive messages of any size.
                                                        > I'm not sure if that works but at least I get mail again.

                                                        Apparently you manage a complex email system from the vantage point of
                                                        an end user with a mailbox that is never big enough.

                                                        This is not a concern for an administrator responsible for 50000 mailboxes.

                                                        You don't want unlimited "anything" happening on your mail server, in
                                                        general.


                                                        --
                                                        J.
                                                      • Grant
                                                        Is message_size_limit still valid? All of the references I can find to it online are very old. Is there another postfix directive I should use to set the
                                                        Message 27 of 30 , Feb 13, 2014
                                                        • 0 Attachment
                                                          Is message_size_limit still valid? All of the references I can find
                                                          to it online are very old. Is there another postfix directive I
                                                          should use to set the maximum upload size for roundcube?

                                                          - Grant
                                                        • Noel Jones
                                                          ... Yes, it s still valid. That feature hasn t changed in a long time so it doesn t get much discussion, but it still works just fine. -- Noel Jones
                                                          Message 28 of 30 , Feb 13, 2014
                                                          • 0 Attachment
                                                            On 2/13/2014 7:58 PM, Grant wrote:
                                                            > Is message_size_limit still valid? All of the references I can find
                                                            > to it online are very old. Is there another postfix directive I
                                                            > should use to set the maximum upload size for roundcube?
                                                            >
                                                            > - Grant
                                                            >

                                                            Yes, it's still valid. That feature hasn't changed in a long time
                                                            so it doesn't get much discussion, but it still works just fine.



                                                            -- Noel Jones
                                                          • Viktor Dukhovni
                                                            ... Postfix configuration parameters don t capriciously disappear. If they are obsoleted, they become the basis for the default settings of any new improved
                                                            Message 29 of 30 , Feb 13, 2014
                                                            • 0 Attachment
                                                              On Thu, Feb 13, 2014 at 05:58:20PM -0800, Grant wrote:

                                                              > Is message_size_limit still valid? All of the references I can find
                                                              > to it online are very old. Is there another postfix directive I
                                                              > should use to set the maximum upload size for roundcube?

                                                              Postfix configuration parameters don't capriciously disappear. If
                                                              they are obsoleted, they become the basis for the default settings
                                                              of any new improved parameters.

                                                              The definitive status of each setting can be found at:

                                                              http://www.postfix.org/postconf.5.html#<parameter_name>

                                                              in your case:

                                                              http://www.postfix.org/postconf.5.html#message_size_limit

                                                              The oldest Postfix release I have in my git repo is postfix-beta-19990122.
                                                              Not surprisingly, this parameter was already present. Wietse likely
                                                              has older postfix sources somewhere, but it is hard to imagine an
                                                              MTA without a message size limit parameter, so this probably goes
                                                              back to the very first alpha release.

                                                              --
                                                              Viktor.
                                                            • Grant
                                                              ... Got it, thank you. - Grant
                                                              Message 30 of 30 , Feb 15, 2014
                                                              • 0 Attachment
                                                                >> Is message_size_limit still valid? All of the references I can find
                                                                >> to it online are very old. Is there another postfix directive I
                                                                >> should use to set the maximum upload size for roundcube?
                                                                >
                                                                > Postfix configuration parameters don't capriciously disappear. If
                                                                > they are obsoleted, they become the basis for the default settings
                                                                > of any new improved parameters.
                                                                >
                                                                > The definitive status of each setting can be found at:
                                                                >
                                                                > http://www.postfix.org/postconf.5.html#<parameter_name>
                                                                >
                                                                > in your case:
                                                                >
                                                                > http://www.postfix.org/postconf.5.html#message_size_limit
                                                                >
                                                                > The oldest Postfix release I have in my git repo is postfix-beta-19990122.
                                                                > Not surprisingly, this parameter was already present. Wietse likely
                                                                > has older postfix sources somewhere, but it is hard to imagine an
                                                                > MTA without a message size limit parameter, so this probably goes
                                                                > back to the very first alpha release.


                                                                Got it, thank you.

                                                                - Grant
                                                              Your message has been successfully submitted and would be delivered to recipients shortly.