Loading ...
Sorry, an error occurred while loading the content.

293208Re: problem, pass bad header thru amavis and dont quarantine them

Expand Messages
  • Marko Weber | ZBF
    May 17, 2013
    • 0 Attachment
      Hi Patrick,
      i did it like described in your blog. (bit changed for my structure)

      @local_domains_maps = (
      ".$mydomain",
      read_hash('/etc/postfix/lookups/hash/virtual_domains_amavis')
      ); # list of all local domains
      #
      ### weber stop

      the result in logfile is now:


      May 17 09:57:05 mail amavis[15982]: (15982-01) Passed CLEAN
      {RelayedInbound}, [xxx.xxx.xxxx] <m.weber@_____.de> -> <weber@_____.de>,
      Message-ID: <zarafa.5195e2d0.0427.2379669854c2b919@...>, mail_id:
      5Gj-xCw2MAvK, Hits: -, size: 2449, queued_as: 4C5B4368DCA, 65 ms


      marko



      Am 2013-05-17 00:20, schrieb Patrick Ben Koetter:
      > Marko,
      >
      > * Marko Weber | ZBF <weber@...>:
      > hello,
      >
      > i set in amavid.conf : $final_bad_header_destiny = D_PASS;
      >
      > but in logs i see this lines;
      >
      > May 16 23:22:11 mail amavis[15703]: (15703-13) Passed BAD-HEADER-1
      > {RelayedOpenRelay,Quarantined}, [***.***.***.***] <apache@***.de> ->
      > <rcpt@...>,<kontakt@___.de>, quarantine: h/badh-hee7b1_sjayQ,
      > Message-ID: <20130516212213.9F4ED1606A5E@webserver-____>, mail_id:
      > hee7b1_sjayQ, Hits: -, size: 644270, queued_as: 066EE368DC9, 181 ms
      >
      > i want bad header mails to passed thru without quarantining, is my
      > setting above wrong?
      >
      > Forwarding (D_PASS) tells amavis where to route a message to. It does
      > not
      > tell amavis if it should quarantine a message or not. Routing and
      > quarantine
      > are configured separately from each other and Forwarding and Storing
      > into
      > Quarantine may take place at the same time.
      >
      > If you set the following, quarantine for bad headers should be
      > disabled:
      >
      > $bad_header_quarantine_method = undef;
      >
      > BTW: Your log indicates (RelayedOpenRelay) amavis isn't configured
      > correctly
      > to tell message directions. Take a look at
      > <http://sys4.de/de/blog/2013/02/15/e-mail-content-policies-mit-amavis/>
      > and
      > fix your setup.
      >
      > p@rick
    • Show all 3 messages in this topic