Loading ...
Sorry, an error occurred while loading the content.

291556Re: Support for MDB in postfix 2.10?

Expand Messages
  • Patrick Lists
    Feb 25, 2013
    • 0 Attachment
      On 02/25/2013 07:19 PM, Wietse Venema wrote:
      > FYI, in order to maintain Postfix in a meaningful manner I need to
      > know what the library will look like on OTHER people's systems.
      > Therefore I will wait until there is a package for a mainstream
      > LINUX or *BSD distribution that OTHER people can install by typing
      > one or two commands.

      Got it. I'll see what it takes to get this RPM included in Fedora and
      EPEL. If accepted that would cover Fedora, RHEL and CentOS.

      > Howard's Postfix client code from a few months ago requires mdb.h
      > and libmdb.*. On the other hand your SRPM appears to install lmdb.h
      > and liblmdb.*. Is this the beginning of a Babylonian confusion?
      > What names will real systems use?

      Judging from the git commit log, on Nov 12, 2012 the "l" was added due
      to a naming conflict with other mdb* packages. See commit:

      http://www.openldap.org/devel/gitweb.cgi?p=openldap.git;a=commitdiff;h=13f3bcd59c2055d53e4759b0c3356b001eca44b0


      So the correct name is lmdb (liblmdb.so and lmdb.h).

      Regards,
      Patrick
    • Show all 20 messages in this topic