Loading ...
Sorry, an error occurred while loading the content.

291072Re: 25-th port is not opened

Expand Messages
  • arsen.shnurkov
    Feb 2, 2013
    • 0 Attachment
      # postfix -v start
      postfix: name_mask: ipv4
      postfix: inet_addr_local: configured 5 IPv4 addresses
      
      # ps -e | grep master
      #
      
      
      > Is this pipe character really there? It should not be.
      no, it's artefact from mail, there is no such pipe characted in config
      > You do NOT want verbose logs. Remove the -v.
      ok, will do that later
      >> Logs are empty > This is what you must fix first.
      What should I check? I tried to write test messages and they go to log without troubles: # logger -p mail.warn "Mail warining" # logger -p mail.info "Mail info" # logger -p mail.error "Mail error" # cat /var/log/mail/mail.log Feb 2 20:08:25 test154 nobody: Mail warining Feb 2 20:08:32 test154 nobody: Mail info Feb 2 20:08:39 test154 nobody: Mail error
      > Did you delete it?
      No
      > Try restarting the syslogd.
      Did that before.
      > "postconf -n" is strongly preferred here.
      # postconf -n command_directory = /usr/sbin config_directory = /etc/postfix daemon_directory = /usr/lib64/postfix data_directory = /var/lib/postfix debug_peer_level = 2 debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin ddd $daemon_directory/$process_name $process_id & sleep 5 default_destination_concurrency_limit = 10 home_mailbox = .maildir/ html_directory = /usr/share/doc/postfix-2.6.5/html inet_interfaces = all inet_protocols = ipv4 local_destination_concurrency_limit = 2 mail_owner = postfix mailq_path = /usr/bin/mailq manpage_directory = /usr/share/man mydestination = localhost mydomain = mydomain.ru myhostname = mydomain.ru mynetworks = 192.168.0.0/24, 192.168.1.0/24, 192.168.2.0/24, 192.168.3.0/24, 127.0.0.0/8 newaliases_path = /usr/bin/newaliases queue_directory = /var/spool/postfix readme_directory = /usr/share/doc/postfix-2.6.5/readme sample_directory = /etc/postfix sendmail_path = /usr/sbin/sendmail setgid_group = postdrop unknown_local_recipient_reject_code = 550 virtual_gid_maps = mysql:/etc/postfix/mysql/mysql-virtual-gid.cf virtual_mailbox_base = /home/vmail virtual_mailbox_domains = mysql:/etc/postfix/mysql/mysql-virtual-domains.cf virtual_mailbox_maps = mysql:/etc/postfix/mysql/mysql-virtual-maps.cf virtual_uid_maps = mysql:/etc/postfix/mysql/mysql-virtual-uid.cf
      > Until you get the logs working there is little else we can say here.
      I think that syslog-ng works properly. It's postfix who doesn't start.
      > How about a simple test to see if it running, ps  -A | grep master
      no, it isn't running: # ps  -A | grep master #
      > have you checked the mail log, and or the syslog to see if there is a problem with postfix.
      nothing new in these logs
    • Show all 9 messages in this topic