Loading ...
Sorry, an error occurred while loading the content.
 

Problem using the Stack Prefab

Expand Messages
  • brownalan2000@yahoo.com
    I can t find a formal description of the format that the prefabs expect the data file to be in. It appears I have to derive the format from the examples given
    Message 1 of 2 , Nov 26, 2001
      I can't find a formal description of the format that the prefabs
      expect the data file to be in. It appears I have to derive the
      format from the examples given or by interrogating the script. Is
      that so?

      My specific problem is that I can't get the stack prefab to work with
      small values. It is leaving gaps between the verious parts of the
      stack.

      My data is...

      40 5 0 3 0 4 0
      41 4 0 4 0 = =
      42 3 0 = = 8 0
      43 3 0 3 0 3 0
      44 5 0 2 0 4 0

      and I get the oddest gaps in each stack between the various colours.
      But when I change the 3 to a 4 in the top row, then all appears well.

      Any hints or answers would be greatly appreciated...

      cheers
      alan
    • Stephen C. Grubb
      Alan, You found a bug. Stacked bars are drawn incorrectly when the plotting area minima is non-zero. This is now fixed and the fix will be present in the
      Message 2 of 2 , Nov 27, 2001
        Alan,

        You found a bug. Stacked bars are drawn incorrectly when
        the plotting area minima is non-zero. This is now fixed
        and the fix will be present in the next release.

        A source code fix is available immediately at:
        http://ploticus.sourceforge.net/doc/Versions.html

        Thanks for finding this problem!

        I will also review the prefab docs with regard to data formats.

        -Steve

        On Tue, 27 Nov 2001 brownalan2000@... wrote:

        > I can't find a formal description of the format that the prefabs
        > expect the data file to be in. It appears I have to derive the
        > format from the examples given or by interrogating the script. Is
        > that so?
        >
        > My specific problem is that I can't get the stack prefab to work with
        > small values. It is leaving gaps between the verious parts of the
        > stack.
        >
        > My data is...
        >
        > 40 5 0 3 0 4 0
        > 41 4 0 4 0 = =
        > 42 3 0 = = 8 0
        > 43 3 0 3 0 3 0
        > 44 5 0 2 0 4 0
        >
        > and I get the oddest gaps in each stack between the various colours.
        > But when I change the 3 to a 4 in the top row, then all appears well.
        >
        > Any hints or answers would be greatly appreciated...
        >
        > cheers
        > alan
        >
        >
        >
        > To unsubscribe from this group, send an email to:
        > ploticus-unsubscribe@yahoogroups.com
        >
        >
        >
        > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
        >
        >
        >

        Note: ploticus home page is moving to http://ploticus.sourceforge.net !
        Please access that location from now on!

        Stephen C. Grubb scg@...
        Scientific Software Engineer, The Jackson Laboratory
        600 Main Street Bar Harbor, Maine 04609 USA
      Your message has been successfully submitted and would be delivered to recipients shortly.