Loading ...
Sorry, an error occurred while loading the content.

Win32 - Cannot open ploticus config file

Expand Messages
  • Kay Wrobel
    Hi. I m on a Windows 7 machine and in the process of setting up Ploticus for CGI. I have a very basic problem which happens on the command line. Say you copied
    Message 1 of 3 , Feb 10 12:42 PM
    • 0 Attachment
      Hi.

      I'm on a Windows 7 machine and in the process of setting up Ploticus for
      CGI. I have a very basic problem which happens on the command line.
      Say you copied pl.exe to C:\Users\myuser\www and you also put a pl.cnf
      file there with following content:
      > projectroot: "C:\Users\myuser\www\plscripts"
      > option: -debug
      > option: -maxrows 16000
      Now open a command prompt (unelevated or elevated doesn't matter), cd to
      \Users\myuser\www. Then type:
      > set PLOTICUS_CONFIG="C:\Users\myuser\www\pl.cnf"
      And now simply run pl.exe. You get following response:
      > pl: 1250: warning: cannot open config file ("C:\Users\myuser\www\pl.cnf")
      > pl: error 15060: Cannot open ploticus config file
      > ("C:\Users\myuser\www\pl.cnf")
      > usage: pl scriptfile [options] ...or... pl -prefab prefabname [options]
      > ploticus 2.41-Mar2009 (win32). This build can produce: PS EPS SVG GIF
      > Copyright 1998-2008 Steve Grubb, http://ploticus.sourceforge.net
      This is a problem. I have gotten IIS configured enough to be able to run
      the pl.exe in a virtual directory, but I keep getting this error.
      Without the proper setting, pl.exe won't be able to find my scripts.

      Any help is greatly appreciated. Thanks.
      The information in this e-mail is confidential and is intended solely for the addressee(s). Access to this email by anyone else is unauthorized. If you are not an intended recipient, you may not print, save or otherwise store the e-mail or any of the contents thereof in electronic or physical form, nor copy, use or disseminate the information contained in the email. If you are not an intended recipient, please notify the sender of this email immediately.

      This electronic message transmission contains information from the sender that may be proprietary, confidential and/or privileged. If you are not the intended recipient, be aware that any disclosure, copying or distribution or use of the contents of this information is prohibited. If you have received this electronic transmission in error, please notify the sender immediately by replying to the address listed in the "From:" field.
    • Steve Grubb
      Hello... I haven t yet tried ploticus on windows 7. Not sure what s going on... ploticus seems to be trying to open the correct pathname based on the error
      Message 2 of 3 , Feb 16 9:54 AM
      • 0 Attachment
        Hello... I haven't yet tried ploticus on windows 7.  Not sure what's going on... ploticus seems to be trying to open the correct pathname based on the error message.  I don't know too much about win7 beyond what I need to use it as a desktop... Are your file and dir access permissions all wide open?  Is "c:\users\myuser\www" a real pathname (as opposed to a "presentation" path name).

        Anyone have any other ideas?

        Steve


        On Fri, Feb 10, 2012 at 3:42 PM, Kay Wrobel <kwrobel@...> wrote:
         

        Hi.

        I'm on a Windows 7 machine and in the process of setting up Ploticus for
        CGI. I have a very basic problem which happens on the command line.
        Say you copied pl.exe to C:\Users\myuser\www and you also put a pl.cnf
        file there with following content:
        > projectroot: "C:\Users\myuser\www\plscripts"
        > option: -debug
        > option: -maxrows 16000
        Now open a command prompt (unelevated or elevated doesn't matter), cd to
        \Users\myuser\www. Then type:
        > set PLOTICUS_CONFIG="C:\Users\myuser\www\pl.cnf"
        And now simply run pl.exe. You get following response:
        > pl: 1250: warning: cannot open config file ("C:\Users\myuser\www\pl.cnf")
        > pl: error 15060: Cannot open ploticus config file
        > ("C:\Users\myuser\www\pl.cnf")
        > usage: pl scriptfile [options] ...or... pl -prefab prefabname [options]
        > ploticus 2.41-Mar2009 (win32). This build can produce: PS EPS SVG GIF
        > Copyright 1998-2008 Steve Grubb, http://ploticus.sourceforge.net
        This is a problem. I have gotten IIS configured enough to be able to run
        the pl.exe in a virtual directory, but I keep getting this error.
        Without the proper setting, pl.exe won't be able to find my scripts.

        Any help is greatly appreciated. Thanks.
        The information in this e-mail is confidential and is intended solely for the addressee(s). Access to this email by anyone else is unauthorized. If you are not an intended recipient, you may not print, save or otherwise store the e-mail or any of the contents thereof in electronic or physical form, nor copy, use or disseminate the information contained in the email. If you are not an intended recipient, please notify the sender of this email immediately.

        This electronic message transmission contains information from the sender that may be proprietary, confidential and/or privileged. If you are not the intended recipient, be aware that any disclosure, copying or distribution or use of the contents of this information is prohibited. If you have received this electronic transmission in error, please notify the sender immediately by replying to the address listed in the "From:" field.


      • Kay Wrobel
        Steve, It s really weird. I have since integrated the Ploticus system call into my ASP.NET aspx page and setting environment variables programatically using
        Message 3 of 3 , Feb 16 10:03 AM
        • 0 Attachment
          Steve,
          It's really weird. I have since integrated the Ploticus system call into my ASP.NET aspx page and setting environment variables programatically using ProcessStartInfo.EnvironmentVariables seems to work fine.

          In the config file, I have refrained from using double-quotes, which works now. I may post a working example in the future, if my company allows my to share the source code. Permissions will have to be set on the Ploticus binary directory as well as the tmpdir and projectroot directories. So far I have been using Visual Studios integrated web server as well as IIS 7 which uses my user to access the web application root. For a full-blown production, one would most certainly have to add permission for the AppPool in use, e.g. "IIS AppPool\DefaultAppPool".

          Thanks, anyway.

          Kay Wrobel

          MIS Associate
          Hawk Electronics, Inc.
          800-THE-HAWK
          800-843-4295
          kwrobel@...

          On 02/16/2012 11:54 AM, Steve Grubb wrote:  

          Hello... I haven't yet tried ploticus on windows 7.  Not sure what's going on... ploticus seems to be trying to open the correct pathname based on the error message.  I don't know too much about win7 beyond what I need to use it as a desktop... Are your file and dir access permissions all wide open?  Is "c:\users\myuser\www" a real pathname (as opposed to a "presentation" path name).

          Anyone have any other ideas?

          Steve


          On Fri, Feb 10, 2012 at 3:42 PM, Kay Wrobel <kwrobel@...> wrote:
           

          Hi.

          I'm on a Windows 7 machine and in the process of setting up Ploticus for
          CGI. I have a very basic problem which happens on the command line.
          Say you copied pl.exe to C:\Users\myuser\www and you also put a pl.cnf
          file there with following content:
          > projectroot: "C:\Users\myuser\www\plscripts"
          > option: -debug
          > option: -maxrows 16000
          Now open a command prompt (unelevated or elevated doesn't matter), cd to
          \Users\myuser\www. Then type:
          > set PLOTICUS_CONFIG="C:\Users\myuser\www\pl.cnf"
          And now simply run pl.exe. You get following response:
          > pl: 1250: warning: cannot open config file ("C:\Users\myuser\www\pl.cnf")
          > pl: error 15060: Cannot open ploticus config file
          > ("C:\Users\myuser\www\pl.cnf")
          > usage: pl scriptfile [options] ...or... pl -prefab prefabname [options]
          > ploticus 2.41-Mar2009 (win32). This build can produce: PS EPS SVG GIF
          > Copyright 1998-2008 Steve Grubb, http://ploticus.sourceforge.net
          This is a problem. I have gotten IIS configured enough to be able to run
          the pl.exe in a virtual directory, but I keep getting this error.
          Without the proper setting, pl.exe won't be able to find my scripts.

          Any help is greatly appreciated. Thanks.
          The information in this e-mail is confidential and is intended solely for the addressee(s). Access to this email by anyone else is unauthorized. If you are not an intended recipient, you may not print, save or otherwise store the e-mail or any of the contents thereof in electronic or physical form, nor copy, use or disseminate the information contained in the email. If you are not an intended recipient, please notify the sender of this email immediately.

          This electronic message transmission contains information from the sender that may be proprietary, confidential and/or privileged. If you are not the intended recipient, be aware that any disclosure, copying or distribution or use of the contents of this information is prohibited. If you have received this electronic transmission in error, please notify the sender immediately by replying to the address listed in the "From:" field.


          The information in this e-mail is confidential and is intended solely for the addressee(s). Access to this email by anyone else is unauthorized. If you are not an intended recipient, you may not print, save or otherwise store the e-mail or any of the contents thereof in electronic or physical form, nor copy, use or disseminate the information contained in the email.  If you are not an intended recipient,  please notify the sender of this email immediately.
          
          This electronic message transmission contains information from the sender that may be proprietary, confidential and/or privileged. If you are not the intended recipient, be aware that any disclosure, copying or distribution or use of the contents of this information is prohibited. If you have received this electronic transmission in error, please notify the sender immediately by replying to the address listed in the "From:" field. 
          
        Your message has been successfully submitted and would be delivered to recipients shortly.