Loading ...
Sorry, an error occurred while loading the content.

Re: space in name

Expand Messages
  • iloveindiepop
    I m having this same problem. How can I merge that bugfix in my ploticus installation?
    Message 1 of 4 , Feb 7, 2011
    • 0 Attachment
      I'm having this same problem.

      How can I merge that bugfix in my ploticus installation?

      --- In ploticus@yahoogroups.com, Steve Grubb <stevegrubb@...> wrote:
      >
      > Hello Travis,
      >
      > this is a ploticus bug that was introduced in version 2.41... the fix was
      > posted here: http://ploticus.sourceforge.net/doc/news.html (see 12 May
      > 2009 entry).
      >
      > It sounds like you are using the ploticus that is included in your os
      > distribution... perhaps ubuntu bundled a patched or earlier version.
      >
      > Steve
      >
      > On Wed, Jun 23, 2010 at 6:47 PM, Travis Bear <travis_bear@...> wrote:
      >
      > >
      > >
      > > Hi,
      > >
      > > I have a bash shell command to generate ploticus graphs. With the bash in
      > > current version of ubuntu (4.1.5(1)), the labels include space, as intended.
      > > With the bash centos (3.2.25(1)), I'm only getting the first word in the
      > > label. Is there something I'm doing incorrectly? Here is the bash command:
      > >
      > > ploticus -prefab stack \
      > > data=$CSV_FILE.thin \
      > >
      > > delim=comma \
      > > xnumeric=yes \
      > > stackarea=yes \
      > > color=dullyellow \
      > >
      > > color2=red \
      > >
      > > -png \
      > > -o $GRAPH_DIR/$HOSTNAME.sar.disk.$DISK.throughput.png \
      > >
      > > "title=$HOSTNAME $DISK throughput (sar data)" \
      > >
      > > "rectangle=$X1 $Y1 $X2 $Y2" \
      > >
      > > x=1 \
      > > "xgrid= color=gray(0.9) width=0.5" \
      > >
      > > "xlbl=elapsed time (seconds)" \
      > >
      > > y=$SAR_READ_COLUMN \
      > >
      > > pointsym=none \
      > > name="512b sectors read/sec" \
      > > "ygrid= color=gray(0.9) width=0.5" \
      > >
      > > y2=$SAR_WRITE_COLUMN \
      > >
      > > pointsym2=none \
      > > "legend=2.5 1.4" \
      > > name2="512b sectors written/sec"
      > >
      > > The "name" and "name2" values are only "512" and not "512b sectors
      > > written/sec" when the graph is generated on centos. On Ubuntu the names are
      > > generated as expected.
      > >
      > > Thanks!
      > >
      > >
      > > -Travis
      > >
      > >
      > >
      > >
      > >
      > >
      >
    • Steve Grubb
      Hello... if you built your ploticus from source code you simply follow the instructions given there on the bug fixes page and recompile it. Those using
      Message 2 of 4 , Feb 10, 2011
      • 0 Attachment
        Hello... if you built your ploticus from source code you simply follow the instructions given there on the bug fixes page and recompile it.

        Those using pre-compiled binaries (likely your situation) cannot load the fixes individually.  Your only option would be to get the source code and build it, but you'd need 'gcc' and 'make' on your system... more than I can help you with from here.

        I need to find time to get a new ploticus release together... hopefully before too much longer.

        Thanks,

        Steve


        On Tue, Feb 8, 2011 at 2:12 AM, iloveindiepop <rtulisi@...> wrote:
         

        I'm having this same problem.

        How can I merge that bugfix in my ploticus installation?



        --- In ploticus@yahoogroups.com, Steve Grubb <stevegrubb@...> wrote:
        >
        > Hello Travis,
        >
        > this is a ploticus bug that was introduced in version 2.41... the fix was
        > posted here: http://ploticus.sourceforge.net/doc/news.html (see 12 May
        > 2009 entry).
        >
        > It sounds like you are using the ploticus that is included in your os
        > distribution... perhaps ubuntu bundled a patched or earlier version.
        >
        > Steve
        >
        > On Wed, Jun 23, 2010 at 6:47 PM, Travis Bear <travis_bear@...> wrote:
        >
        > >
        > >
        > > Hi,
        > >
        > > I have a bash shell command to generate ploticus graphs. With the bash in
        > > current version of ubuntu (4.1.5(1)), the labels include space, as intended.
        > > With the bash centos (3.2.25(1)), I'm only getting the first word in the
        > > label. Is there something I'm doing incorrectly? Here is the bash command:
        > >
        > > ploticus -prefab stack \
        > > data=$CSV_FILE.thin \
        > >
        > > delim=comma \
        > > xnumeric=yes \
        > > stackarea=yes \
        > > color=dullyellow \
        > >
        > > color2=red \
        > >
        > > -png \
        > > -o $GRAPH_DIR/$HOSTNAME.sar.disk.$DISK.throughput.png \
        > >
        > > "title=$HOSTNAME $DISK throughput (sar data)" \
        > >
        > > "rectangle=$X1 $Y1 $X2 $Y2" \
        > >
        > > x=1 \
        > > "xgrid= color=gray(0.9) width=0.5" \
        > >
        > > "xlbl=elapsed time (seconds)" \
        > >
        > > y=$SAR_READ_COLUMN \
        > >
        > > pointsym=none \
        > > name="512b sectors read/sec" \
        > > "ygrid= color=gray(0.9) width=0.5" \
        > >
        > > y2=$SAR_WRITE_COLUMN \
        > >
        > > pointsym2=none \
        > > "legend=2.5 1.4" \
        > > name2="512b sectors written/sec"
        > >
        > > The "name" and "name2" values are only "512" and not "512b sectors
        > > written/sec" when the graph is generated on centos. On Ubuntu the names are
        > > generated as expected.
        > >
        > > Thanks!
        > >
        > >
        > > -Travis
        > >
        > >
        > >
        > >
        > >
        > >
        >


      Your message has been successfully submitted and would be delivered to recipients shortly.