Loading ...
Sorry, an error occurred while loading the content.

Re: [ploticus] Re: Having problems setting font

Expand Messages
  • Steve Grubb
    Hello John....... the usual approach (which requires gcc or similar) is to take the standard source code distribution and edit the Makefile... the Makefile
    Message 1 of 8 , May 14, 2010
    • 0 Attachment
      Hello John....... the usual approach (which requires gcc or similar) is to take the standard source code distribution and edit the Makefile... the Makefile contains step-by-step instructions and it shouldn't be that hard... then build the software.

      I'm not aware of any precompiled binaries available anywhere that have truetype enabled.

      You've probably already seen it but here's the man page for ploticus fonts:
      http://ploticus.sourceforge.net/doc/fonts.html

      Steve


      On Thu, May 13, 2010 at 11:01 AM, johnkorbphoto <john@...> wrote:
       

      Hi Steve,

      No, I downloaded the distribution and installed it.

      Is there a distribution available with the truetype font capability enabled available for download?

      Thanks,

      John



      --- In ploticus@yahoogroups.com, Steve Grubb <stevegrubb@...> wrote:
      >
      > John, ploticus' ability to use truetype fonts has to be configured when
      > ploticus is built... see the Makefile. Did you configure your version for
      > truetype fonts?
      >
      > Steve
      >
      >
      > On Fri, Apr 16, 2010 at 6:59 PM, johnkorbphoto <johnkorbphoto@...>wrote:

      >
      > >
      > >
      > > Hi,
      > >
      > > I'm running Ploticus in a Linux environment.
      > >
      > > I've installed the "liberation" font set and now I'm trying to use one of
      > > the fonts. The fonts are in the directory:
      > >
      > > /usr/share/fonts/liberation
      > >
      > > For GDFONTPATH:
      > >
      > > set GDFONTPATH=/usr/share/fonts/liberation
      > > export GDFONTPATH=/usr/share/fonts/liberation
      > >
      > > and then in my Ploticus script, near the top of the script I have:
      > >
      > > #proc areadef
      > > title: % CPU Utilization
      > > titledetails: size=24 align=C adjust=0.0,0.2 font=LiberationSerif-Regular
      > > rectangle: 1 1 8 4
      > > xscaletype: time hh:mm:ss
      > > xrange: 00:00:00 23:59:59
      > > yrange: 0 100
      > > frame: color=xAFAFAF width=1.0
      > >
      > > Please note that the "titledetails" line may wrap here, but is all on one
      > > line in the script.
      > >
      > > The actual font file name is:
      > >
      > > /usr/share/fonts/liberation/LiberationSerif-Regular.ttf
      > >
      > > When I run my script, the font used is the default, mono-space font, not
      > > the desired font.
      > >
      > > What am I doing wrong?
      > >
      > > Thanks!
      > >
      > > John
      > >
      > >
      > >
      >


    • johnkorbphoto
      Hi Steve, I ll see if I can get the powers that be to authorize the installation of the gcc compiler. That should be fun! I wonder how many human sacrifices
      Message 2 of 8 , May 14, 2010
      • 0 Attachment
        Hi Steve,

        I'll see if I can get the powers that be to authorize the installation of the gcc compiler. That should be fun! I wonder how many human sacrifices and tons of gold that will require... (LOL)

        Are there any other options that I might want to enable or compile in while I'm going through this?

        Thanks!

        John

        --- In ploticus@yahoogroups.com, Steve Grubb <stevegrubb@...> wrote:
        >
        > Hello John....... the usual approach (which requires gcc or similar) is to
        > take the standard source code distribution and edit the Makefile... the
        > Makefile contains step-by-step instructions and it shouldn't be that hard...
        > then build the software.
        >
        > I'm not aware of any precompiled binaries available anywhere that have
        > truetype enabled.
        >
        > You've probably already seen it but here's the man page for ploticus fonts:
        > http://ploticus.sourceforge.net/doc/fonts.html
        >
        > Steve
        >
        >
        > On Thu, May 13, 2010 at 11:01 AM, johnkorbphoto <john@...>wrote:
        >
        > >
        > >
        > > Hi Steve,
        > >
        > > No, I downloaded the distribution and installed it.
        > >
        > > Is there a distribution available with the truetype font capability enabled
        > > available for download?
        > >
        > > Thanks,
        > >
        > > John
        > >
        > >
        > > --- In ploticus@yahoogroups.com <ploticus%40yahoogroups.com>, Steve Grubb
        > > <stevegrubb@> wrote:
        > > >
        > > > John, ploticus' ability to use truetype fonts has to be configured when
        > > > ploticus is built... see the Makefile. Did you configure your version for
        > > > truetype fonts?
        > > >
        > > > Steve
        > > >
        > > >
        > > > On Fri, Apr 16, 2010 at 6:59 PM, johnkorbphoto <johnkorbphoto@>wrote:
        > >
        > > >
        > > > >
        > > > >
        > > > > Hi,
        > > > >
        > > > > I'm running Ploticus in a Linux environment.
        > > > >
        > > > > I've installed the "liberation" font set and now I'm trying to use one
        > > of
        > > > > the fonts. The fonts are in the directory:
        > > > >
        > > > > /usr/share/fonts/liberation
        > > > >
        > > > > For GDFONTPATH:
        > > > >
        > > > > set GDFONTPATH=/usr/share/fonts/liberation
        > > > > export GDFONTPATH=/usr/share/fonts/liberation
        > > > >
        > > > > and then in my Ploticus script, near the top of the script I have:
        > > > >
        > > > > #proc areadef
        > > > > title: % CPU Utilization
        > > > > titledetails: size=24 align=C adjust=0.0,0.2
        > > font=LiberationSerif-Regular
        > > > > rectangle: 1 1 8 4
        > > > > xscaletype: time hh:mm:ss
        > > > > xrange: 00:00:00 23:59:59
        > > > > yrange: 0 100
        > > > > frame: color=xAFAFAF width=1.0
        > > > >
        > > > > Please note that the "titledetails" line may wrap here, but is all on
        > > one
        > > > > line in the script.
        > > > >
        > > > > The actual font file name is:
        > > > >
        > > > > /usr/share/fonts/liberation/LiberationSerif-Regular.ttf
        > > > >
        > > > > When I run my script, the font used is the default, mono-space font,
        > > not
        > > > > the desired font.
        > > > >
        > > > > What am I doing wrong?
        > > > >
        > > > > Thanks!
        > > > >
        > > > > John
        > > > >
        > > > >
        > > > >
        > > >
        > >
        > >
        > >
        >
      • dbwiddis
        Hi Steve. Hopping onto a recent thread that seems to be similar to my issue. I am trying to install the Mediawiki EasyTimeline extension, which uses ploticus.
        Message 3 of 8 , Jul 28, 2010
        • 0 Attachment
          Hi Steve. Hopping onto a recent thread that seems to be similar to my issue.

          I am trying to install the Mediawiki EasyTimeline extension, which uses ploticus. I'm installing on a remote linux server with only local user rights. I've got everything working but the fonts. Despite my attempts to use ttf fonts, all I'm getting is the default 'ascii' font.

          Installation instructions for the extension direct me to use the FreeSans.ttf file and set GDFONTPATH, which I've done, to no avail.

          The message below indicates I need to compile ploticus with ttf configured, but I do not understand how to do this: the Makefile (2.41) does not mention ttf anywhere. The only mention of fonts appears to be in installing my own GD library -- which looks a bit daunting at the moment, and I'm not sure that's the right way to go.

          How exactly does one configure the Makefile to enable use of the FreeSans.ttf file?

          Dan

          --- In ploticus@yahoogroups.com, Steve Grubb <stevegrubb@...> wrote:
          >
          > John, ploticus' ability to use truetype fonts has to be configured when
          > ploticus is built... see the Makefile. Did you configure your version for
          > truetype fonts?
          >
          > Steve
          >
          >
          > On Fri, Apr 16, 2010 at 6:59 PM, johnkorbphoto <johnkorbphoto@...>wrote:
          >
          > >
          > >
          > > Hi,
          > >
          > > I'm running Ploticus in a Linux environment.
          > >
          > > I've installed the "liberation" font set and now I'm trying to use one of
          > > the fonts. The fonts are in the directory:
          > >
          > > /usr/share/fonts/liberation
          > >
          > > For GDFONTPATH:
          > >
          > > set GDFONTPATH=/usr/share/fonts/liberation
          > > export GDFONTPATH=/usr/share/fonts/liberation
          > >
          > > and then in my Ploticus script, near the top of the script I have:
          > >
          > > #proc areadef
          > > title: % CPU Utilization
          > > titledetails: size=24 align=C adjust=0.0,0.2 font=LiberationSerif-Regular
          > > rectangle: 1 1 8 4
          > > xscaletype: time hh:mm:ss
          > > xrange: 00:00:00 23:59:59
          > > yrange: 0 100
          > > frame: color=xAFAFAF width=1.0
          > >
          > > Please note that the "titledetails" line may wrap here, but is all on one
          > > line in the script.
          > >
          > > The actual font file name is:
          > >
          > > /usr/share/fonts/liberation/LiberationSerif-Regular.ttf
          > >
          > > When I run my script, the font used is the default, mono-space font, not
          > > the desired font.
          > >
          > > What am I doing wrong?
          > >
          > > Thanks!
          > >
          > > John
          > >
          > >
          > >
          >
        • Steve Grubb
          Hello Dan, grep FreeType2 in the Makefile FreeType2 is the package that utilizes the .ttf fonts. Steve
          Message 4 of 8 , Aug 2, 2010
          • 0 Attachment
            Hello Dan,

            grep FreeType2 in the Makefile

            FreeType2 is the package that utilizes the .ttf fonts.

            Steve


            On Wed, Jul 28, 2010 at 4:44 PM, dbwiddis <widdis@...> wrote:
             

            Hi Steve. Hopping onto a recent thread that seems to be similar to my issue.

            I am trying to install the Mediawiki EasyTimeline extension, which uses ploticus. I'm installing on a remote linux server with only local user rights. I've got everything working but the fonts. Despite my attempts to use ttf fonts, all I'm getting is the default 'ascii' font.

            Installation instructions for the extension direct me to use the FreeSans.ttf file and set GDFONTPATH, which I've done, to no avail.

            The message below indicates I need to compile ploticus with ttf configured, but I do not understand how to do this: the Makefile (2.41) does not mention ttf anywhere. The only mention of fonts appears to be in installing my own GD library -- which looks a bit daunting at the moment, and I'm not sure that's the right way to go.

            How exactly does one configure the Makefile to enable use of the FreeSans.ttf file?

            Dan

            --- In ploticus@yahoogroups.com, Steve Grubb <stevegrubb@...> wrote:
            >
            > John, ploticus' ability to use truetype fonts has to be configured when
            > ploticus is built... see the Makefile. Did you configure your version for
            > truetype fonts?
            >
            > Steve
            >
            >
            > On Fri, Apr 16, 2010 at 6:59 PM, johnkorbphoto <johnkorbphoto@...>wrote:
            >
            > >
            > >
            > > Hi,
            > >
            > > I'm running Ploticus in a Linux environment.
            > >
            > > I've installed the "liberation" font set and now I'm trying to use one of
            > > the fonts. The fonts are in the directory:
            > >
            > > /usr/share/fonts/liberation
            > >
            > > For GDFONTPATH:
            > >
            > > set GDFONTPATH=/usr/share/fonts/liberation
            > > export GDFONTPATH=/usr/share/fonts/liberation
            > >
            > > and then in my Ploticus script, near the top of the script I have:
            > >
            > > #proc areadef
            > > title: % CPU Utilization
            > > titledetails: size=24 align=C adjust=0.0,0.2 font=LiberationSerif-Regular
            > > rectangle: 1 1 8 4
            > > xscaletype: time hh:mm:ss
            > > xrange: 00:00:00 23:59:59
            > > yrange: 0 100
            > > frame: color=xAFAFAF width=1.0
            > >
            > > Please note that the "titledetails" line may wrap here, but is all on one
            > > line in the script.
            > >
            > > The actual font file name is:
            > >
            > > /usr/share/fonts/liberation/LiberationSerif-Regular.ttf
            > >
            > > When I run my script, the font used is the default, mono-space font, not
            > > the desired font.
            > >
            > > What am I doing wrong?
            > >
            > > Thanks!
            > >
            > > John
            > >
            > >
            > >
            >


          • Daniel B. Widdis
            Since posting the below, I ve learned a bit more and come to a few more dead ends. - Steve s reply below indicates that ttf ability must be configured
            Message 5 of 8 , Aug 2, 2010
            • 0 Attachment

              Since posting the below, I’ve learned a bit more and come to a few more dead ends.

               

              -          Steve’s reply below indicates that ttf ability must be configured when ploticus is built

              -          The man page for fonts at http://ploticus.sourceforge.net/doc/fonts.html says “For more information on building ploticus to use FreeType2, see ./src/FreeType2 and ./src/Makefile.”  However, there is no file FreeType2 in the src directory (current download 2.41 from the sourceforge site).

              -          The Makefile “Setting 2” section seems to be the appropriate place to indicate one’s GD configuration.  I am attempting to use “Option 4” to “use your own GD resource with FreeType2 fonts enabled”.  I have 4 of the 5 required libraries:  lpng, lz, ljpeg, and lfreetype.  I do not have the lgd library, which would require root permission on my server to install.  I could request that it be installed, but….

              -          The download page for the latest GD (http://www.libgd.org/Downloads) has a big red warning at the top that PHP users may not need this.  In fact, our server has php 5.3.2 installed, which includes its own portions of the GD library. 

               

              So in summary, I have PHP with GD version 2.0.34 bundled, but no “lgd” library with which to compile ploticus.  I could compile using local files if I could figure out the right ones to include that would let me avoid using the –lgd option in the Makefile.  Any help here?

               

              --

              Dan

               

              From: ploticus@yahoogroups.com [mailto:ploticus@yahoogroups.com] On Behalf Of dbwiddis
              Sent: Wednesday, July 28, 2010 1:44 PM
              To: ploticus@yahoogroups.com
              Subject: [ploticus] Re: Having problems setting font

               

               

              Hi Steve. Hopping onto a recent thread that seems to be similar to my issue.

              I am trying to install the Mediawiki EasyTimeline extension, which uses ploticus. I'm installing on a remote linux server with only local user rights. I've got everything working but the fonts. Despite my attempts to use ttf fonts, all I'm getting is the default 'ascii' font.

              Installation instructions for the extension direct me to use the FreeSans.ttf file and set GDFONTPATH, which I've done, to no avail.

              The message below indicates I need to compile ploticus with ttf configured, but I do not understand how to do this: the Makefile (2.41) does not mention ttf anywhere. The only mention of fonts appears to be in installing my own GD library -- which looks a bit daunting at the moment, and I'm not sure that's the right way to go.

              How exactly does one configure the Makefile to enable use of the FreeSans.ttf file?

              Dan

              --- In ploticus@yahoogroups.com, Steve Grubb <stevegrubb@...> wrote:

              >
              > John, ploticus' ability to use truetype fonts has to be configured when
              > ploticus is built... see the Makefile. Did you configure your version for
              > truetype fonts?
              >
              > Steve
              >
              >
              > On Fri, Apr 16, 2010 at 6:59 PM, johnkorbphoto
              <johnkorbphoto@...>wrote:
              >
              > >
              > >
              > > Hi,
              > >
              > > I'm running Ploticus in a Linux environment.
              > >
              > > I've installed the "liberation" font set and now I'm trying
              to use one of
              > > the fonts. The fonts are in the directory:
              > >
              > > /usr/share/fonts/liberation
              > >
              > > For GDFONTPATH:
              > >
              > > set GDFONTPATH=/usr/share/fonts/liberation
              > > export GDFONTPATH=/usr/share/fonts/liberation
              > >
              > > and then in my Ploticus script, near the top of the script I have:
              > >
              > > #proc areadef
              > > title: % CPU Utilization
              > > titledetails: size=24 align=C adjust=0.0,0.2
              font=LiberationSerif-Regular
              > > rectangle: 1 1 8 4
              > > xscaletype: time hh:mm:ss
              > > xrange: 00:00:00 23:59:59
              > > yrange: 0 100
              > > frame: color=xAFAFAF width=1.0
              > >
              > > Please note that the "titledetails" line may wrap here, but
              is all on one
              > > line in the script.
              > >
              > > The actual font file name is:
              > >
              > > /usr/share/fonts/liberation/LiberationSerif-Regular.ttf
              > >
              > > When I run my script, the font used is the default, mono-space font,
              not
              > > the desired font.
              > >
              > > What am I doing wrong?
              > >
              > > Thanks!
              > >
              > > John
              > >
              > >
              > >
              >

            Your message has been successfully submitted and would be delivered to recipients shortly.