Loading ...
Sorry, an error occurred while loading the content.
 

Scat prefab, autow and corr

Expand Messages
  • mackieandme
    Hi Steve, When I use the scat prefab and autow=yes, the pearson coefficient vars disappear from the plot. If I remove autow=yes, they pop back up. I tried
    Message 1 of 3 , Feb 13, 2009
      Hi Steve,
      When I use the scat prefab and autow=yes, the pearson coefficient vars disappear from the
      plot.

      If I remove autow=yes, they pop back up. I tried fiddling with the scat prefab, but didn't get
      far as autow is processed in pl core and not in the scat script.

      Any suggestions?

      Joel
    • Stephen Grubb
      Hello Joel, I tried to reproduce this by going into pltestsuite, editing testpf_scat, and adding autow=yes to the scat3 example, and I still see the
      Message 2 of 3 , Feb 18, 2009
        Hello Joel, I tried to reproduce this by going into pltestsuite, editing testpf_scat, and adding autow=yes to the scat3 example, and I still see the correlation info in green in the lower right.

        I suspect that in your case autow is widening the plot quite a bit and maybe the correlation info is being pushed off the "edge"... try adding a -pagesize 12,12 arg to the command line (see the -pagesize description on pl(1) man page ... and/or try adjusting the plot area location eg. adding command line parameter "rectangle=1 2 5 6" ... autow will override the given width but this would adjust it upward.

        Or maybe it's being covered up somehow.

        -Steve
        ________________________________________
        From: ploticus@yahoogroups.com [ploticus@yahoogroups.com] On Behalf Of mackieandme [mackieandme@...]
        Sent: Friday, February 13, 2009 11:47 AM
        To: ploticus@yahoogroups.com
        Subject: [ploticus] Scat prefab, autow and corr

        Hi Steve,
        When I use the scat prefab and autow=yes, the pearson coefficient vars disappear from the
        plot.

        If I remove autow=yes, they pop back up. I tried fiddling with the scat prefab, but didn't get
        far as autow is processed in pl core and not in the scat script.

        Any suggestions?

        Joel
      • Joel Natividad
        Hi Steve, pagesize fixed it alright. But I ended up modifying the scat.pl prefab to just show the vars on the leftside of the chart so it will work everytime
        Message 3 of 3 , Feb 21, 2009
          Hi Steve,
          pagesize fixed it alright. But I ended up modifying the scat.pl prefab to just show the vars
          on the leftside of the chart so it will work everytime regardless of the autow setting.

          Thanks again,
          Joel

          --- In ploticus@yahoogroups.com, Stephen Grubb <Stephen.Grubb@...> wrote:
          >
          > Hello Joel, I tried to reproduce this by going into pltestsuite, editing testpf_scat, and
          adding autow=yes to the scat3 example, and I still see the correlation info in green in the
          lower right.
          >
          > I suspect that in your case autow is widening the plot quite a bit and maybe the
          correlation info is being pushed off the "edge"... try adding a -pagesize 12,12 arg to the
          command line (see the -pagesize description on pl(1) man page ... and/or try adjusting
          the plot area location eg. adding command line parameter "rectangle=1 2 5 6" ... autow
          will override the given width but this would adjust it upward.
          >
          > Or maybe it's being covered up somehow.
          >
          > -Steve
          > ________________________________________
          > From: ploticus@yahoogroups.com [ploticus@yahoogroups.com] On Behalf Of
          mackieandme [mackieandme@...]
          > Sent: Friday, February 13, 2009 11:47 AM
          > To: ploticus@yahoogroups.com
          > Subject: [ploticus] Scat prefab, autow and corr
          >
          > Hi Steve,
          > When I use the scat prefab and autow=yes, the pearson coefficient vars disappear from
          the
          > plot.
          >
          > If I remove autow=yes, they pop back up. I tried fiddling with the scat prefab, but didn't
          get
          > far as autow is processed in pl core and not in the scat script.
          >
          > Any suggestions?
          >
          > Joel
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.