Loading ...
Sorry, an error occurred while loading the content.

Re: building v 2.33 on Mac OS X 10.5

Expand Messages
  • aswiens
    Fixed. I was not including the -lgd flag when compiling the example (api_examp.c). --Andy ... libploticus.dylib ... on
    Message 1 of 2 , Jun 18, 2008
    • 0 Attachment
      Fixed. I was not including the -lgd flag when compiling the example (api_examp.c).

      --Andy

      --- In ploticus@yahoogroups.com, "aswiens" <awiens@...> wrote:
      >
      > Hi,
      >
      > Hopefully someone here will know the answer to this. I'm trying to build
      libploticus.dylib
      > (with png, jpeg, freetype, etc.) on a MBP with Leopard. It is created with no errors
      (using:
      > make -f Makefile_api), but when I try to run pltestsuite/api_examp, I get the following:
      >
      > dyld: Symbol not found: _gdFontLarge
      > Referenced from: /usr/local/lib/libploticus.dylib
      > Expected in: flat namespace
      >
      > Trace/BPT trap
      >
      > I am assuming that the proper libraries are not being found & linked at runtime. So, I've
      > tried including the directory with all the libraries (/usr/local/lib) in
      > DYLD_FALLBACK_LIBRARY_PATH. Unfortunately this doesn't fix the problem. Any ideas
      on
      > what I should try next?
      >
      > I should also mention that I am able to create a properly functioning pl executable with
      > the same capabilities(png, jpeg, freetype, etc.). This makes me think the supporting
      > libraries are installed correctly. Also, I'm using version 2.33 so that I can use rploticus
      > (not sure if the older version is required, but it is specifically mentioned in the rploticus
      > code).
      >
      > Thanks for any help you can offer!
      >
      > --Andy
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.