Loading ...
Sorry, an error occurred while loading the content.
 

Error 12040 Can anyone help?

Expand Messages
  • Neil Jones
    This command ploticus -prefab chron data=data14 x=1 y=2 datefmt=yy/mm/dd xinc= 1 month stubfmt=M xyears=yyyy yrange= 0 25 barwidth=line
    Message 1 of 2 , May 1, 2007
      This command
      ploticus -prefab chron data=data14 x=1 y=2 datefmt=yy/mm/dd
      xinc="1 month" stubfmt=M xyears=yyyy yrange="0 25" barwidth=line
      color=red title="# hits per day" omitweekends=yes

      Gives this error

      pl error 12040: X Display not properly identified. Set DISPLAY=
      Segmentation fault

      Can anyone help by telling me what is wrong and how to fix it please.


      Neil Jones
      Neil@...
    • Joshua Simons
      By default, Ploticus is trying to use X Windows to display your graph. If you are running X, then you need to define the DISPLAY environment variable to
      Message 2 of 2 , May 3, 2007
        By default, Ploticus is trying to use X Windows to display your graph.
        If you are running X, then you need to define the DISPLAY environment
        variable to properly describe your screen. Typically, this would be of
        the form host:0.0. If you are using csh, you would issue this command:

        % setenv DISPLAY host:0.0

        where 'host' is the name of the machine that is running the X server.

        What you might try instead is generating a GIF or other image file as
        output instead of using X. To do this, add "-gif" (without quotes) to your
        command line.

        As an aside, Ploticus should not segfault--that does seem to be a bug.

        Josh Simons


        On May 1, 2007, at 5:25 AM, Neil Jones wrote:


        This command
        ploticus -prefab chron data=data14 x=1 y=2 datefmt=yy/mm/dd
        xinc="1 month" stubfmt=M xyears=yyyy yrange="0 25" barwidth=line
        color=red title="# hits per day" omitweekends=yes

        Gives this error

        pl error 12040: X Display not properly identified. Set DISPLAY=
        Segmentation fault

        Can anyone help by telling me what is wrong and how to fix it please.

        Neil Jones
        Neil@nwjones.demon.co.uk


      Your message has been successfully submitted and would be delivered to recipients shortly.