Loading ...
Sorry, an error occurred while loading the content.

BUG in 2.30 - no imagemap output is produced (-gif and -png)

Expand Messages
  • Stephen C. Grubb
    Today I noticed a fairly tragic bug in ploticus 2.30.. when using pl -gif ... -csmap ... pl -png ... -csmap ... pl -gif ... -map ... pl -png ... -map ... NO
    Message 1 of 2 , Oct 29, 2004
    • 0 Attachment
      Today I noticed a fairly tragic bug in ploticus 2.30.. when using

      pl -gif ... -csmap ...
      pl -png ... -csmap ...
      pl -gif ... -map ...
      pl -png ... -map ...

      NO MAP OUTPUT is produced!!!! This occurs on all platforms when creating
      GIF/PNG/JPEG images, regardless of whether -mapfile is specified or not.
      Someone a while back mentioned their complete confusion in generating
      image maps.. perhaps this contributed to the problem. I'm surprised
      nobody has said anything.. isn't anyone generating image maps out there?

      SVG is unaffected, and libploticus/Makefile_api are unaffected.

      The problem is in the Makefile... -DPLOTICUS must be in effect during the
      compilation of grgd.c .. The fix is to edit src/Makefile, adding
      -DPLOTICUS to line ~ 288:

      gd13files:
      $(CC) -c grgd.c -DGD13 -DPLOTICUS -I./gd13 -o grgd13.o

      .......... and to line ~ 294:

      gd16files:
      $(CC) -c grgd.c -DGD16 -DPLOTICUS -I./ -I./gd16 -o grgd16.o


      I guess the reason this slipped thru is that my quality control suite
      doesn't run an example that generates an image map.. will fix this. I do a
      lot of work with image maps regularly here, but almost all of it is
      generated via libploticus, not the pl command.


      Appologies!


      Steve
    • Robert Chin
      good catch Stephen : ) ________________________________ From: Stephen C. Grubb [mailto:scg@jax.org] Sent: Friday, October 29, 2004 10:35 AM To:
      Message 2 of 2 , Oct 29, 2004
      • 0 Attachment
        good catch Stephen  : )


        From: Stephen C. Grubb [mailto:scg@...]
        Sent: Friday, October 29, 2004 10:35 AM
        To: ploticus@yahoogroups.com
        Subject: [POSSIBLE SPAM: ][ploticus] BUG in 2.30 - no imagemap output is produced (-gif and -png)

        Today I noticed a fairly tragic bug in ploticus 2.30.. when using

        pl -gif ... -csmap ...
        pl -png ... -csmap ...
        pl -gif ... -map ...
        pl -png ... -map ...

        NO MAP OUTPUT is produced!!!!  This occurs on all platforms when creating
        GIF/PNG/JPEG images, regardless of whether -mapfile is specified or not.
        Someone a while back mentioned their complete confusion in generating
        image maps.. perhaps this contributed to the problem.  I'm surprised
        nobody has said anything.. isn't anyone generating image maps out there?

        SVG is unaffected, and libploticus/Makefile_api are unaffected.

        The problem is in the Makefile... -DPLOTICUS must be in effect during the
        compilation of grgd.c .. The fix is to edit src/Makefile, adding
        -DPLOTICUS to line ~ 288:

        gd13files:
              $(CC) -c grgd.c -DGD13 -DPLOTICUS -I./gd13 -o grgd13.o

        .......... and to line ~ 294:

        gd16files:
              $(CC) -c grgd.c -DGD16 -DPLOTICUS -I./ -I./gd16 -o grgd16.o


        I guess the reason this slipped thru is that my quality control suite
        doesn't run an example that generates an image map.. will fix this. I do a
        lot of work with image maps regularly here, but almost all of it is
        generated via libploticus, not the pl command.


        Appologies!


        Steve


      Your message has been successfully submitted and would be delivered to recipients shortly.