Loading ...
Sorry, an error occurred while loading the content.

2037Re: offset x axis, postscript issue

Expand Messages
  • beribboned
    Oct 3, 2007
    • 0 Attachment
      --- In ploticus@yahoogroups.com, "Stephen C. Grubb" <scg@...> wrote:

      > For me to be able to address your concern (2) you'd need to send my
      your
      > data file and exact prefab command used, then I would try to
      reproduce the
      > problem here. Thanks,
      >
      > Steve

      echo -e "10 12\n12 15\n14 17\n16 18\n" | pl -prefab lines data=stdin
      x=1 y=2 xstubdet="size=16" ystubdet="size=10" -ps -o test.ps

      it is a constant 2 unit error as function of xstubdet="size=N"
      for N>12

      N stub1 stub2
      10 62.96 62.96
      12 60.96 60.96
      14 60.96 58.96
      16 58.96 56.96
      18 56.96 54.96
      20 54.96 52.96
      24 50.96 48.96
      28 46.96 44.96
      36 38.96 36.96
      ... where stub1 and stub2 are the y-coord from the
      postscrpt output.

      and thanks. I have found no better program for journal-grade
      plot creation. (even wrote one myself and yours is WAY better).


      > > 2) (lines prefab) The first x stub (at least in postscipt
      rendering)
      > > is too high ... on my graph from above, the postscript says:
      > >
      > > -310.00 92.96 mv 864.00 (16) cent
      > > (16) sh
      > > ...
      > > -254.53 90.96 mv 864.00 (20) cent
      > > (20) sh
      > > ...
      > > -199.07 90.96 mv 864.00 (24) cent
      > > (24) sh
      > >
      > > for the 16 20 and 24 stubs. The 92.26 is the culprit.
      > >
      > >
      >
      >
      > Stephen C. Grubb scg@... x-6633
      > Scientific Software Engineer, The Jackson Laboratory
      > 600 Main Street Bar Harbor, Maine 04609 USA
      >
    • Show all 3 messages in this topic