Loading ...
Sorry, an error occurred while loading the content.

2035Re: [ploticus] offset x axis, postscript issue

Expand Messages
  • Stephen C. Grubb
    Oct 2, 2007
    • 0 Attachment
      Hi,

      you can do what you describe in (1) by writing a script and using

      #proc axis
      selflocatingstubs: .....

      See http://ploticus.sourceforge.net/doc/axis.html


      For me to be able to address your concern (2) you'd need to send my your
      data file and exact prefab command used, then I would try to reproduce the
      problem here. Thanks,

      Steve


      On Fri, 28 Sep 2007, beribboned wrote:

      > 1) (lines prefab) I have data with x values of 16 to 40 in increments
      > of 4. I want to avoid the point for x=16 being drawn on the y-axis
      > line. I could use xrange="12 40" but then the x-stub of 12 is drawn.
      > I could use xrange="15 40" but then there are no stubs exactly under
      > my plotted points. I have fiddled with xnearest, stubrange but they
      > seem to be ignored in the prefab. Is there a way to do something
      > like: xrange="15 40" xstubs="follow" which would mean ONLY put
      > stubs/ticks at positions where data exist? Or, maybe move the entire
      > x axis a little to the right (so the x axis and y axis do not
      > intersect).
      >
      > 2) (lines prefab) The first x stub (at least in postscipt rendering)
      > is too high ... on my graph from above, the postscript says:
      >
      > -310.00 92.96 mv 864.00 (16) cent
      > (16) sh
      > ...
      > -254.53 90.96 mv 864.00 (20) cent
      > (20) sh
      > ...
      > -199.07 90.96 mv 864.00 (24) cent
      > (24) sh
      >
      > for the 16 20 and 24 stubs. The 92.26 is the culprit.
      >
      >


      Stephen C. Grubb scg@... x-6633
      Scientific Software Engineer, The Jackson Laboratory
      600 Main Street Bar Harbor, Maine 04609 USA
    • Show all 3 messages in this topic