Loading ...
Sorry, an error occurred while loading the content.

greek chars not displayed in php4

Expand Messages
  • smaist1@yahoo.com
    Hello everyone, The setup: linux RedHat 6.1, apache 1.3.12, php4.0/3pl1. Site located in a shared hosting environemt. The problem: Scripts that have .php
    Message 1 of 7 , Jul 10, 2001
    View Source
    • 0 Attachment
      Hello everyone,

      The setup:

      linux RedHat 6.1, apache 1.3.12, php4.0/3pl1. Site located in a shared
      hosting environemt.

      The problem:
      Scripts that have .php extension do not display properly greek chars
      under Netscape 4.75 - works fine under MS explorer 5.x.

      The Netscape behavior is the same (does not display properly) under
      linux or Windows.

      Whan I say properly, I mean it is not readable, I can see the text but
      it is the extended ascii chars we all know. I have attempted to adjust
      the fonts/char set in Netscape w/o success. The Mime types are set
      properly in Apache. (httpd.conf)

      .html files are displayed properly. If I take the same .html and give
      it a .php extension i loose the greek chars.

      Any ideas ?

      Efxaristo...

      Stelios
    • yavor shahpasov
      I m anly assuming here but if you can see the text in IE then your problem lies in the netscape configuration, I ve always had problems setting up Netscape to
      Message 2 of 7 , Jul 10, 2001
      View Source
      • 0 Attachment
        I'm anly assuming here but if you can see the text in IE then your
        problem lies in the netscape configuration, I've always had problems
        setting up Netscape to work with foreign chars in Linux. Try a couple of
        other brousers before you look for a problem in PHP settings (opera
        konqueror or a newer version of netscape / mozilla)

        -----Original Message-----
        From: smaist1@... [mailto:smaist1@...]
        Sent: Tuesday, July 10, 2001 12:51 PM
        To: php_greek@yahoogroups.com
        Subject: [php_greek] greek chars not displayed in php4


        Hello everyone,

        The setup:

        linux RedHat 6.1, apache 1.3.12, php4.0/3pl1. Site located in a shared
        hosting environemt.

        The problem:
        Scripts that have .php extension do not display properly greek chars
        under Netscape 4.75 - works fine under MS explorer 5.x.

        The Netscape behavior is the same (does not display properly) under
        linux or Windows.

        Whan I say properly, I mean it is not readable, I can see the text but
        it is the extended ascii chars we all know. I have attempted to adjust
        the fonts/char set in Netscape w/o success. The Mime types are set
        properly in Apache. (httpd.conf)

        .html files are displayed properly. If I take the same .html and give
        it a .php extension i loose the greek chars.

        Any ideas ?

        Efxaristo...

        Stelios



        -
        Ãéá íá äéáãñáöåßôå áðü ôç ëßóôá, óôåßëôå Ýíá email óôï:
        To unsubscribe from this group, send an email to:

        php_greek-unsubscribe@yahoogroups.com



        Your use of Yahoo! Groups is subject to
        http://docs.yahoo.com/info/terms/
      • Panayotis Vryonis
        Since plain html pages are displayed corectly, we could safely assume that your browser is properly configured. On the server side now... There are two ways to
        Message 3 of 7 , Jul 10, 2001
        View Source
        • 0 Attachment
          Since plain html pages are displayed corectly,
          we could safely assume that your browser is properly
          configured.

          On the server side now...

          There are two ways to set up the character set. One is using
          the http headers. I guess that configuring the apache to
          send a "Content-Type: text/html; charset=iso-8859-7" is only
          useful for .html pages. From PHP you can either edit php.ini
          (look for "charset"), or manually send the right header using
          header("Content-Type: text/html; charset=iso-8859-7")
          (BEFORE SENDING ANY HTML!!!).
          You may check the http headers that are sent to your browser
          using "curl -i <url>" or "wget -s <url>".

          An "simpler" way is to use the HTML meta tags.
          (<meta HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-7">)

          I do not know what happens if you both send HTTP headers and HTML meta tags
          that conflict, I guess it's up to the browser to decide... :-)

          Panayotis.

          smaist1@... wrote:

          > Hello everyone,
          >
          > The setup:
          >
          > linux RedHat 6.1, apache 1.3.12, php4.0/3pl1. Site located in a shared
          > hosting environemt.
          >
          > The problem:
          > Scripts that have .php extension do not display properly greek chars
          > under Netscape 4.75 - works fine under MS explorer 5.x.
          >
          > The Netscape behavior is the same (does not display properly) under
          > linux or Windows.
          >
          > Whan I say properly, I mean it is not readable, I can see the text but
          > it is the extended ascii chars we all know. I have attempted to adjust
          > the fonts/char set in Netscape w/o success. The Mime types are set
          > properly in Apache. (httpd.conf)
          >
          > .html files are displayed properly. If I take the same .html and give
          > it a .php extension i loose the greek chars.
          >
          > Any ideas ?
          >
          > Efxaristo...
          >
          > Stelios
          >
          >
          >
          > -
          > Για να διαγραφείτε από τη λίστα, στείλτε ένα email στο:
          > To unsubscribe from this group, send an email to:
          >
          > php_greek-unsubscribe@yahoogroups.com
          >
          >
          >
          > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
          >
          >
          >
          >



          --
          yassou.net: be there before you go!
          http://www.yassou.net/
        • Stelios Maistros
          Thank you Yavor, for the suggestion. I will try it. However..I certainly cannot make the same suggestion to my potential users...right ? ...
          Message 4 of 7 , Jul 10, 2001
          View Source
          • 0 Attachment
            Thank you Yavor, for the suggestion. I will try it.

            However..I certainly cannot make the same suggestion
            to my potential users...right ?

            --- yavor shahpasov <yavo@...> wrote:
            > I'm anly assuming here but if you can see the text
            > in IE then your
            > problem lies in the netscape configuration, I've
            > always had problems
            > setting up Netscape to work with foreign chars in
            > Linux. Try a couple of
            > other brousers before you look for a problem in PHP
            > settings (opera
            > konqueror or a newer version of netscape / mozilla)
            >
            > -----Original Message-----
            > From: smaist1@... [mailto:smaist1@...]
            > Sent: Tuesday, July 10, 2001 12:51 PM
            > To: php_greek@yahoogroups.com
            > Subject: [php_greek] greek chars not displayed in
            > php4
            >
            >
            > Hello everyone,
            >
            > The setup:
            >
            > linux RedHat 6.1, apache 1.3.12, php4.0/3pl1. Site
            > located in a shared
            > hosting environemt.
            >
            > The problem:
            > Scripts that have .php extension do not display
            > properly greek chars
            > under Netscape 4.75 - works fine under MS explorer
            > 5.x.
            >
            >
            >


            __________________________________________________
            Do You Yahoo!?
            Get personalized email addresses from Yahoo! Mail
            http://personal.mail.yahoo.com/
          • yavor shahpasov
            in fear to sound silly the charset=??? is only used for the browser to autodetect the charset, if you mannually change the charset in the browser you
            Message 5 of 7 , Jul 10, 2001
            View Source
            • 0 Attachment
              in fear to sound silly the charset=??? is only used for the browser to
              autodetect the charset, if you mannually change the charset in the
              browser you automatically disregard this value.

              To Stelios: maybe it's a good idea to attach a sample of your page to
              see if i get the same effect.

              yavor
            • Panayotis Vryonis
              ... NO! At least not always. Netscape 4.7x for Linux, for example, will use the character set indecated by the web page despite your defaults... (Of course you
              Message 6 of 7 , Jul 10, 2001
              View Source
              • 0 Attachment
                yavor shahpasov wrote:

                > in fear to sound silly the charset=??? is only used for the browser to
                > autodetect the charset, if you mannually change the charset in the
                > browser you automatically disregard this value.


                NO! At least not always. Netscape 4.7x for Linux, for example,
                will use the character set indecated by the web page despite
                your defaults... (Of course you can change the fonts, so that
                it uses an iso-8859-7 font for the Western encoding etc.

                Panayotis.


                --
                yassou.net: be there before you go!
                http://www.yassou.net/
              • Stelios Maistros
                I used Panayiot s suggestion (header, etc) and it seems to work. Question remains, why does it work or why is is a problem in the first place ? Under php3 I
                Message 7 of 7 , Jul 10, 2001
                View Source
                • 0 Attachment
                  I used Panayiot's suggestion (header, etc) and it
                  seems to work.

                  Question remains, why does it work or why is is a
                  problem in the first place ?

                  Under php3 I never had to do such a work around. Also,
                  I have not looked deep into php4 yet, but there is no
                  .ini file, at least not in my home SUSE 6.4 linux
                  system. I cannot imagine that I will be able to edit
                  the .ini of the provider ....:-)

                  Panayioti, thank you. Will let everyone know how it
                  goes as I dig deeper...

                  --- Panayotis Vryonis <vrypan@...> wrote:
                  >
                  > useful for .html pages. From PHP you can either edit
                  > php.ini
                  > (look for "charset"), or manually send the right
                  > header using
                  > header("Content-Type: text/html;
                  > charset=iso-8859-7")
                  > (BEFORE SENDING ANY HTML!!!).


                  __________________________________________________
                  Do You Yahoo!?
                  Get personalized email addresses from Yahoo! Mail
                  http://personal.mail.yahoo.com/
                Your message has been successfully submitted and would be delivered to recipients shortly.