Loading ...
Sorry, an error occurred while loading the content.

Re: [php_greek] simple problem , but still a problem

Expand Messages
  • Andreas Giannakoulopoulos
    Hello, An o kwdikas tou gallery.php einai akribhs einai anoixto to IMG tag.
    Message 1 of 6 , Mar 4, 2004
    • 0 Attachment
      Hello,
      An o kwdikas tou gallery.php einai akribhs einai anoixto to IMG tag.
      <img src="../gallerypics/Arxitektoniki/thumb/arx01th.jpg"
      anti
      <img src="../gallerypics/Arxitektoniki/thumb/arx01th.jpg">

      bests,
      Andreas

      ----- Original Message -----
      From: "Nikos Karavias" <p01048@...>
      To: <php_greek@yahoogroups.com>
      Sent: Thursday, March 04, 2004 2:49 PM
      Subject: [php_greek] simple problem , but still a problem


      > Καλησπέρα ,
      >
      > θέλω να φτιάξω ένα απλό photo-gallery μόνο με php το οποίο να λειτουργεί
      με
      > τον εξής απλό τρόπο : θα υπάρχει μια σελιδα gallery.php η οποία θα έχει τα
      > thumbails του gallery και όταν κάποιος κλικάρει κάποιο thumb αυτό θα τον
      > στέλνει σε μια σελίδα show.php με παράμετρο ?name=το όνομα του pic που
      > αντιστοιχεί στο thumb.
      >
      > gallery.php
      > <a href="show.php?name=arx01.jpg"><img
      > src="../gallerypics/Arxitektoniki/thumb/arx01th.jpg" </a>
      > <a href="show.php?name=arx02.jpg"><img
      > src="../gallerypics/Arxitektoniki/thumb/arx02th.jpg" </a>
      >
      >
      > show.php
      > <html>
      > <body>
      > <?php
      > $picname = $_GET['name'];
      > $path = "../gallerypics/Arxitektoniki/".$picname;
      > ?>
      > <img src="<?php $path ?>">
      > </body>
      > </html>
      >
      > To πρόβλημα είναι πως ενώ το $path είναι σωστό κάθε φορά δεν εμφανίζεται η
      > εικόνα. Κάνοντας view source κατά την λειτουργία της σελίδας παρατήρησα
      πως
      > το tag <img... δεν δέχεται τον php κώδικά μου.Παραθέτω το source της
      σελίδας
      > κατά την εκτέλεσή της:
      >
      > <body>
      > /gallery/gallerypics/Arxitektoniki/arx01.jpg <img src="">
      > </body>
      >
      > Όπως βλεπετε o php κώδικας για κάποιο λόγο μεταφέρεται έξω από το
      ζητούμενο
      > HTML tag.
      > Έχω την υποψία πως μπορεί να οφείλεται κάποια ρύθμιση στο php.ini ωστόσο
      δεν
      > είμαι σίγουρος.
      >
      > Ευχαριστώ για τον χρόνο σας.
      >
      >
      >
      >
      >
      > --
      > Ελληνική PHP mailing list
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
      >
      >
    • Dimitrios Botsis
      Δεν υπάρχει τέτοια ρύθμιση στο php.ini. Ο κώδικας PHP δεν μπορεί να μεταφέρεται έξω απ τα PHP
      Message 2 of 6 , Mar 4, 2004
      • 0 Attachment
        Δεν υπάρχει τέτοια ρύθμιση στο php.ini.
        Ο κώδικας PHP δεν μπορεί να μεταφέρεται έξω απ'τα
        PHP tags.
        Έλεγξε τα εξής :
        1) Αν όλα τα PHP tags που έχει είναι ΟΚ (<?...?>)
        2) Αν όλα τα εισαγωγικά που ανοίγεις στο αρχείο σου (κώδικας)
        συνοδεύονται από τα αντίστοιχά τους, για το κλείσιμο.
        3) Δοκίμασε αντί για <img src="<?php $path ?>"> που είναι βέβαια σωστό,
        το : <img src="<?=$path?>">.
        Αυτός ο κώδικας (όπως και ο δικός σου βέβαια) πρέπει να δουλεύουν σίγουρα

        Καλή τύχη

        ----- Original Message -----
        From: "Nikos Karavias" <p01048@...>
        To: <php_greek@yahoogroups.com>
        Sent: Thursday, March 04, 2004 2:49 PM
        Subject: [php_greek] simple problem , but still a problem


        > Καλησπέρα ,
        >
        > θέλω να φτιάξω ένα απλό photo-gallery μόνο με php το οποίο να λειτουργεί με
        > τον εξής απλό τρόπο : θα υπάρχει μια σελιδα gallery.php η οποία θα έχει τα
        > thumbails του gallery και όταν κάποιος κλικάρει κάποιο thumb αυτό θα τον
        > στέλνει σε μια σελίδα show.php με παράμετρο ?name=το όνομα του pic που
        > αντιστοιχεί στο thumb.
        >
        > gallery.php
        > <a href="show.php?name=arx01.jpg"><img
        > src="../gallerypics/Arxitektoniki/thumb/arx01th.jpg" </a>
        > <a href="show.php?name=arx02.jpg"><img
        > src="../gallerypics/Arxitektoniki/thumb/arx02th.jpg" </a>
        >
        >
        > show.php
        > <html>
        > <body>
        > <?php
        > $picname = $_GET['name'];
        > $path = "../gallerypics/Arxitektoniki/".$picname;
        > ?>
        > <img src="<?php $path ?>">
        > </body>
        > </html>
        >
        > To πρόβλημα είναι πως ενώ το $path είναι σωστό κάθε φορά δεν εμφανίζεται η
        > εικόνα. Κάνοντας view source κατά την λειτουργία της σελίδας παρατήρησα πως
        > το tag <img... δεν δέχεται τον php κώδικά μου.Παραθέτω το source της σελίδας
        > κατά την εκτέλεσή της:
        >
        > <body>
        > /gallery/gallerypics/Arxitektoniki/arx01.jpg <img src="">
        > </body>
        >
        > Όπως βλεπετε o php κώδικας για κάποιο λόγο μεταφέρεται έξω από το ζητούμενο
        > HTML tag.
        > Έχω την υποψία πως μπορεί να οφείλεται κάποια ρύθμιση στο php.ini ωστόσο δεν
        > είμαι σίγουρος.
        >
        > Ευχαριστώ για τον χρόνο σας.
        >
        >
        >
        >
        >
        > --
        > Ελληνική PHP mailing list
        > Yahoo! Groups Links
        >
        >
        >
        >
        >
      • Vassilis Perantzakis
        Η γραμμή πρέπει να γίνει ... From: Nikos Karavias
        Message 3 of 6 , Mar 4, 2004
        • 0 Attachment
          Η γραμμή <img src="<?php $path ?>">

          πρέπει να γίνει <img src="<?php echo $path; ?>">

          -----Original Message-----
          From: Nikos Karavias [mailto:p01048@...]
          Sent: Thursday, March 04, 2004 2:50 PM
          To: php_greek@yahoogroups.com
          Subject: [php_greek] simple problem , but still a problem

          Καλησπέρα ,

          θέλω να φτιάξω ένα απλό photo-gallery μόνο με php το οποίο να λειτουργεί
          με
          τον εξής απλό τρόπο : θα υπάρχει μια σελιδα gallery.php η οποία θα έχει
          τα
          thumbails του gallery και όταν κάποιος κλικάρει κάποιο thumb αυτό θα τον
          στέλνει σε μια σελίδα show.php με παράμετρο ?name=το όνομα του pic που
          αντιστοιχεί στο thumb.

          gallery.php
          <a href="show.php?name=arx01.jpg"><img
          src="../gallerypics/Arxitektoniki/thumb/arx01th.jpg" </a>
          <a href="show.php?name=arx02.jpg"><img
          src="../gallerypics/Arxitektoniki/thumb/arx02th.jpg" </a>


          show.php
          <html>
          <body>
          <?php
          $picname = $_GET['name'];
          $path = "../gallerypics/Arxitektoniki/".$picname;
          ?>
          <img src="<?php $path ?>">
          </body>
          </html>

          To πρόβλημα είναι πως ενώ το $path είναι σωστό κάθε φορά δεν εμφανίζεται
          η
          εικόνα. Κάνοντας view source κατά την λειτουργία της σελίδας παρατήρησα
          πως
          το tag <img... δεν δέχεται τον php κώδικά μου.Παραθέτω το source της
          σελίδας
          κατά την εκτέλεσή της:

          <body>
          /gallery/gallerypics/Arxitektoniki/arx01.jpg <img src="">
          </body>

          Όπως βλεπετε o php κώδικας για κάποιο λόγο μεταφέρεται έξω από το
          ζητούμενο
          HTML tag.
          Έχω την υποψία πως μπορεί να οφείλεται κάποια ρύθμιση στο php.ini ωστόσο
          δεν
          είμαι σίγουρος.

          Ευχαριστώ για τον χρόνο σας.




          ------------------------ Yahoo! Groups Sponsor ---------------------~-->
          Buy Ink Cartridges or Refill Kits for your HP, Epson, Canon or Lexmark
          Printer at MyInks.com. Free s/h on orders $50 or more to the US &
          Canada.
          http://www.c1tracking.com/l.asp?cid=5511
          http://us.click.yahoo.com/mOAaAA/3exGAA/qnsNAA/9rHolB/TM
          ---------------------------------------------------------------------~->

          --
          Ελληνική PHP mailing list
          Yahoo! Groups Links
        • Nikos Karavias
          Πράγματι είχα ξεχάσει το echo. Χαζό λάθος. Ευχαριστώ ... From: Vassilis Perantzakis To:
          Message 4 of 6 , Mar 4, 2004
          • 0 Attachment
            Πράγματι είχα ξεχάσει το echo.
            Χαζό λάθος.
            Ευχαριστώ
            ----- Original Message -----
            From: "Vassilis Perantzakis" <vaspervnp@...>
            To: <php_greek@yahoogroups.com>
            Sent: Thursday, March 04, 2004 3:22 PM
            Subject: RE: [php_greek] simple problem , but still a problem


            > Η γραμμή <img src="<?php $path ?>">
            >
            > πρέπει να γίνει <img src="<?php echo $path; ?>">
            >
            > -----Original Message-----
            > From: Nikos Karavias [mailto:p01048@...]
            > Sent: Thursday, March 04, 2004 2:50 PM
            > To: php_greek@yahoogroups.com
            > Subject: [php_greek] simple problem , but still a problem
            >
            > Καλησπέρα ,
            >
            > θέλω να φτιάξω ένα απλό photo-gallery μόνο με php το οποίο να λειτουργεί
            > με
            > τον εξής απλό τρόπο : θα υπάρχει μια σελιδα gallery.php η οποία θα έχει
            > τα
            > thumbails του gallery και όταν κάποιος κλικάρει κάποιο thumb αυτό θα τον
            > στέλνει σε μια σελίδα show.php με παράμετρο ?name=το όνομα του pic που
            > αντιστοιχεί στο thumb.
            >
            > gallery.php
            > <a href="show.php?name=arx01.jpg"><img
            > src="../gallerypics/Arxitektoniki/thumb/arx01th.jpg" </a>
            > <a href="show.php?name=arx02.jpg"><img
            > src="../gallerypics/Arxitektoniki/thumb/arx02th.jpg" </a>
            >
            >
            > show.php
            > <html>
            > <body>
            > <?php
            > $picname = $_GET['name'];
            > $path = "../gallerypics/Arxitektoniki/".$picname;
            > ?>
            > <img src="<?php $path ?>">
            > </body>
            > </html>
            >
            > To πρόβλημα είναι πως ενώ το $path είναι σωστό κάθε φορά δεν εμφανίζεται
            > η
            > εικόνα. Κάνοντας view source κατά την λειτουργία της σελίδας παρατήρησα
            > πως
            > το tag <img... δεν δέχεται τον php κώδικά μου.Παραθέτω το source της
            > σελίδας
            > κατά την εκτέλεσή της:
            >
            > <body>
            > /gallery/gallerypics/Arxitektoniki/arx01.jpg <img src="">
            > </body>
            >
            > Όπως βλεπετε o php κώδικας για κάποιο λόγο μεταφέρεται έξω από το
            > ζητούμενο
            > HTML tag.
            > Έχω την υποψία πως μπορεί να οφείλεται κάποια ρύθμιση στο php.ini ωστόσο
            > δεν
            > είμαι σίγουρος.
            >
            > Ευχαριστώ για τον χρόνο σας.
            >
            >
            >
            >
            >
            > --
            > Ελληνική PHP mailing list
            > Yahoo! Groups Links
            >
            >
            >
            >
            >
            >
            >
            > --
            > Ελληνική PHP mailing list
            > Yahoo! Groups Links
            >
            >
            >
            >
          • Vassilis Perantzakis
            Συνηθισμένα πράγματα... που να δεις τι ξεχνά εγώ.. :-) Βασίλης. PS: www.eaxies.gr Username: test Password: test
            Message 5 of 6 , Mar 4, 2004
            • 0 Attachment
              Συνηθισμένα πράγματα... που να δεις τι ξεχνά εγώ.. :-)

              Βασίλης.

              PS: www.eaxies.gr
              Username: test
              Password: test
              ένα καταπληκτικό site όλο σε PHP/Javascript.. δείτε τι μπορεί να
              φτιαχτεί....

              -----Original Message-----
              From: Nikos Karavias [mailto:p01048@...]
              Sent: Thursday, March 04, 2004 4:41 PM
              To: php_greek@yahoogroups.com
              Subject: Re: [php_greek] simple problem , but still a problem

              Πράγματι είχα ξεχάσει το echo.
              Χαζό λάθος.
              Ευχαριστώ
              ----- Original Message -----
              From: "Vassilis Perantzakis" <vaspervnp@...>
              To: <php_greek@yahoogroups.com>
              Sent: Thursday, March 04, 2004 3:22 PM
              Subject: RE: [php_greek] simple problem , but still a problem


              > Η γραμμή <img src="<?php $path ?>">
              >
              > πρέπει να γίνει <img src="<?php echo $path; ?>">
              >
              > -----Original Message-----
              > From: Nikos Karavias [mailto:p01048@...]
              > Sent: Thursday, March 04, 2004 2:50 PM
              > To: php_greek@yahoogroups.com
              > Subject: [php_greek] simple problem , but still a problem
              >
              > Καλησπέρα ,
              >
              > θέλω να φτιάξω ένα απλό photo-gallery μόνο με php το οποίο να
              λειτουργεί
              > με
              > τον εξής απλό τρόπο : θα υπάρχει μια σελιδα gallery.php η οποία θα
              έχει
              > τα
              > thumbails του gallery και όταν κάποιος κλικάρει κάποιο thumb αυτό θα
              τον
              > στέλνει σε μια σελίδα show.php με παράμετρο ?name=το όνομα του pic που
              > αντιστοιχεί στο thumb.
              >
              > gallery.php
              > <a href="show.php?name=arx01.jpg"><img
              > src="../gallerypics/Arxitektoniki/thumb/arx01th.jpg" </a>
              > <a href="show.php?name=arx02.jpg"><img
              > src="../gallerypics/Arxitektoniki/thumb/arx02th.jpg" </a>
              >
              >
              > show.php
              > <html>
              > <body>
              > <?php
              > $picname = $_GET['name'];
              > $path = "../gallerypics/Arxitektoniki/".$picname;
              > ?>
              > <img src="<?php $path ?>">
              > </body>
              > </html>
              >
              > To πρόβλημα είναι πως ενώ το $path είναι σωστό κάθε φορά δεν
              εμφανίζεται
              > η
              > εικόνα. Κάνοντας view source κατά την λειτουργία της σελίδας
              παρατήρησα
              > πως
              > το tag <img... δεν δέχεται τον php κώδικά μου.Παραθέτω το source της
              > σελίδας
              > κατά την εκτέλεσή της:
              >
              > <body>
              > /gallery/gallerypics/Arxitektoniki/arx01.jpg <img src="">
              > </body>
              >
              > Όπως βλεπετε o php κώδικας για κάποιο λόγο μεταφέρεται έξω από το
              > ζητούμενο
              > HTML tag.
              > Έχω την υποψία πως μπορεί να οφείλεται κάποια ρύθμιση στο php.ini
              ωστόσο
              > δεν
              > είμαι σίγουρος.
              >
              > Ευχαριστώ για τον χρόνο σας.
              >
              >
              >
              >
              >
              > --
              > Ελληνική PHP mailing list
              > Yahoo! Groups Links
              >
              >
              >
              >
              >
              >
              >
              > --
              > Ελληνική PHP mailing list
              > Yahoo! Groups Links
              >
              >
              >
              >




              --
              Ελληνική PHP mailing list
              Yahoo! Groups Links
            Your message has been successfully submitted and would be delivered to recipients shortly.