Loading ...
Sorry, an error occurred while loading the content.

Re: Problems in getting greek data from ORACLE by using PHP

Expand Messages
  • roccos6969
    Thanks, but I m speaking about PHP script not-used by apache but directly from command line. I launch it in this way: php script.php and I see the wrong
    Message 1 of 5 , Dec 6, 2001
    • 0 Attachment
      Thanks,
      but I'm speaking about PHP script not-used by apache but directly
      from command line.

      I launch it in this way: php script.php
      and I see the wrong results (the greek chars are not displayed in the
      correct way, I've just ?????)

      I tried to add the meta you suggested and see the page from the web
      by using apache. No good results :-(

      Cristiano

      --- In php_greek@y..., "Philip Serefoglou" <rapid@w...> wrote:
      > Try to use :
      >
      > <meta http-equiv="Content-Type" content="text/html;
      > charset=windows-1253">
      >
      > I think that this migth be the problem ....
      >
      > You can write in Greek ....
      >
      >
      >
      > Cu,
      > Rapid-eraser
      >
      > On Thu, 06 Dec 2001 11:11:53 -0000
      > "roccos6969" <roccos6969@y...> wrote:
      > -->*This message was transferred with a trial version of
      > -->CommuniGate(tm) Pro*
      > -->Hi,
      > -->I'm trying to get some data from a table in Oracle by
      > -->using PHP.
      > -->The table contains greek words (I can see them by using
      > -->a greek-
      > -->configurated PC).
      > -->But when I run my simple PHP script the chars are not
      > -->shown (I can
      > -->see just ????? or ###### or things like that)
      > -->
      > -->What kind of configuration I missed?
      > -->What kind of variables should I set?
      > -->
      > -->The code is:
      > -->-----
      > -->$conn = ocilogon("PS", "password", $ORACLE_SID);
      > -->$statement = ociparse($conn, "SELECT LLN_NODE_NAME_GR
      > -->FROM
      > -->LEASED_LINE_NODE ORDER BY LLN_NODE_NAME_GR");
      > -->ociexecute($statement);
      > -->
      > -->while (OCIFetchInto($statement,&$data_curs)) {
      > -->
      > --> echo $data_curs[0]\n";
      > -->}
      > -->
      > -->OCIFreeStatement($statement);
      > -->OCILogoff ($conn);
      > -->-----
      > -->
      > -->Thank you in advance,
      > -->Cristiano
      > -->
      > -->
      > -->
      > -->
      > -->------------------------ Yahoo! Groups Sponsor
      > -->
      > -->-
      > -->Ãéá íá äéáãñáöåßôå áðü ôç ëßóôá, óôåßëôå Ýíá email óôï:
      > -->To unsubscribe from this group, send an email to:
      > -->
      > -->php_greek-unsubscribe@y...
      > -->
      > -->
      > -->
      > -->Your use of Yahoo! Groups is subject to
      > -->http://docs.yahoo.com/info/terms/
      > -->
      > -->
    • roccos6969
      As I answered to another reply I m not using the php for web pages but just as a script from command line. I call it in this way: php script.php The results
      Message 2 of 5 , Dec 6, 2001
      • 0 Attachment
        As I answered to another reply I'm not using the php for web pages
        but just as a script from command line.

        I call it in this way: php script.php
        The results are not OK.

        I'm using a greek PC from which I can see greek chars.
        For example if I use SQLPLUS and I perform the same SELECT I see the
        right chars!

        Cristiano



        --- In php_greek@y..., aris tzafalia <tzafalia@y...> wrote:
        > is the document encoding set to greek in the page that
        > displays the data?
        >
        >
        > --- roccos6969 <roccos6969@y...> wrote: > Hi,
        > > I'm trying to get some data from a table in Oracle
        > > by using PHP.
        > > The table contains greek words (I can see them by
        > > using a greek-
        > > configurated PC).
        > > But when I run my simple PHP script the chars are
        > > not shown (I can
        > > see just ????? or ###### or things like that)
        > >
        > > What kind of configuration I missed?
        > > What kind of variables should I set?
        > >
        > > The code is:
        > > -----
        > > $conn = ocilogon("PS", "password", $ORACLE_SID);
        > > $statement = ociparse($conn, "SELECT
        > > LLN_NODE_NAME_GR FROM
        > > LEASED_LINE_NODE ORDER BY LLN_NODE_NAME_GR");
        > > ociexecute($statement);
        > >
        > > while (OCIFetchInto($statement,&$data_curs)) {
        > >
        > > echo $data_curs[0]\n";
        > > }
        > >
        > > OCIFreeStatement($statement);
        > > OCILogoff ($conn);
        > > -----
        > >
        > > Thank you in advance,
        > > Cristiano
        > >
        > >
        > >
        > >
        >
        > ________________________________________________________________
        > Nokia 5510 looks weird sounds great.
        > Go to http://uk.promotions.yahoo.com/nokia/ discover and win it!
        > The competition ends 16 th of December 2001.
      Your message has been successfully submitted and would be delivered to recipients shortly.