Loading ...
Sorry, an error occurred while loading the content.

Re: [perseus_SDR] Alternative VAC?

Expand Messages
  • Roberto Zinelli
    Alberto, I also tried and i have the same result, very strange BUT......... In my test setup: Perseus tuned to 10100 RTTY, software HDSDR with the
    Message 1 of 15 , Apr 18, 2013
    • 0 Attachment
      Alberto, I also  tried and i have the same result,  very strange BUT.........

      In my test setup:  Perseus tuned to 10100 RTTY, software HDSDR with the sound-card output  to  "VB-Audio Point" .

      SeaTTY input "VB-Audio Point". No signal at SeattY.

      Then i started "audio Repeater", a tool from VCABLE, don't care wot you select as wave in but select VB-Audio as wave out then start.
      The Seatty show signal incoming.....now stop the Audio Repeater end close it.  Seatty continues to operate!

      Stop and then start HDSDR  (F2) and again the signal at SeaTTY disappear.   seems that VB-Audio not open in output  automatically.


      What you think about ? 

      73 IW4ENS
      Roberto




      On Wed, Apr 17, 2013 at 11:27 PM, Alberto I2PHD <i2phd@...> wrote:
       

      On 4/16/2013 2:58 PM, Johan H. Bodin wrote:

      here's a new virtual audio cable:
      
        http://vb-audio.pagesperso-orange.fr/Cable/index.htm
      
      It would be interesting to try it with Perseus but, unfortunately, Perseus' VAC
      connection seems to be hardcoded to Muzychenko's VAC only.

      Johan,

         have you actually tried that VBcable ? I installed it and tried to send the output of Winrad to Argo,
      as I do normally with VAC. Argo did not receive anything...  switching back to VAC, all resumed working
      normally... the control panel of VBaudio reported that the output channel was opened at 48 kHz, 16 bit,
      which are the correct values for Argo, and the input channel was opened at 12 kHz, 24 bit, the correct
      values for Winrad, so the two programs somehow talked to VBaudio.  The problem was that audio data
      were not received by Argo...

      --
      73 Alberto I2PHD


    • DirkCL
      ... Hi Jurgen, Thanks for the tip, but if resampling is supposed to be the problem, how do you explain that it can work perfectly for say, one hour, and then
      Message 2 of 15 , Apr 18, 2013
      • 0 Attachment
        --- In perseus_SDR@yahoogroups.com, "Jurgen Bartels" <jurgenb2@...> wrote:
        >
        > > I would like an alternative to VAC as well. I'm sure it's fine for
        > > standard "listening" , but for audio streams carrying digital data it
        > > works far from perfect and frequently looses/interrupts/corrupts(?) the
        > > audio data. (and yes, I have a registered copy of VAC)
        >
        > I never observed that. I feed Speclab via DRM-mode and don't see any
        > spectral disturbances. You must prevent VAC from resampling, by setting in
        > and out-SR to 32500 S/s
        >

        Hi Jurgen,

        Thanks for the tip, but if resampling is supposed to be the problem, how do you explain that it can work perfectly for say, one hour, and then suddenly cause the glitch I described? Also note that the phenomenon was reported for a wide variety of hardware and OS-versions.

        Regards - Dirk
      • Alberto I2PHD
        ... Well, I tried that, but no luck.... I started, as i my previous message, both Winrad and Argo, trying to connect them with VB-Audio. This is the Control
        Message 3 of 15 , Apr 18, 2013
        • 0 Attachment
          On 4/18/2013 3:13 PM, Roberto Zinelli wrote:


          Alberto, I also  tried and i have the same result,  very strange BUT.........

          In my test setup:  Perseus tuned to 10100 RTTY, software HDSDR with the sound-card output  to  "VB-Audio Point" .

          SeaTTY input "VB-Audio Point". No signal at SeattY.

          Then i started "audio Repeater", a tool from VCABLE, don't care wot you select as wave in but select VB-Audio as wave out then start.
          The Seatty show signal incoming.....now stop the Audio Repeater end close it.  Seatty continues to operate!

          Stop and then start HDSDR  (F2) and again the signal at SeaTTY disappear.   seems that VB-Audio not open in output  automatically.


          Well, I tried that, but no luck....
          I started, as i my previous message, both Winrad and Argo, trying to connect them with VB-Audio.
          This is the Control Panel of VB-Audio :

          https://dl.dropboxusercontent.com/u/15089947/vbcable3.gif

          Then started the Audio Repeater from the VAC package, as shown here :

          https://dl.dropboxusercontent.com/u/15089947/vbcable1.gif

          But clicking on "Start" gave this error message :

          https://dl.dropboxusercontent.com/u/15089947/vbcable2.gif

          --
          73 Alberto I2PHD
        • Roberto Zinelli
          Yes, my be the vb-cable is not perfect. About your test the difference is my audio repeater version 1.20
          Message 4 of 15 , Apr 18, 2013
          • 0 Attachment
            Yes, my be the vb-cable is not perfect.

            About your test the difference is my audio repeater version 1.20



            No problem, VAC work fine

            73 IW4ENS
            Roberto


            On Thu, Apr 18, 2013 at 11:45 PM, Alberto I2PHD <i2phd@...> wrote:
             

            On 4/18/2013 3:13 PM, Roberto Zinelli wrote:


            Alberto, I also  tried and i have the same result,  very strange BUT.........

            In my test setup:  Perseus tuned to 10100 RTTY, software HDSDR with the sound-card output  to  "VB-Audio Point" .

            SeaTTY input "VB-Audio Point". No signal at SeattY.

            Then i started "audio Repeater", a tool from VCABLE, don't care wot you select as wave in but select VB-Audio as wave out then start.
            The Seatty show signal incoming.....now stop the Audio Repeater end close it.  Seatty continues to operate!

            Stop and then start HDSDR  (F2) and again the signal at SeaTTY disappear.   seems that VB-Audio not open in output  automatically.


            Well, I tried that, but no luck....
            I started, as i my previous message, both Winrad and Argo, trying to connect them with VB-Audio.
            This is the Control Panel of VB-Audio :

            https://dl.dropboxusercontent.com/u/15089947/vbcable3.gif

            Then started the Audio Repeater from the VAC package, as shown here :

            https://dl.dropboxusercontent.com/u/15089947/vbcable1.gif

            But clicking on "Start" gave this error message :

            https://dl.dropboxusercontent.com/u/15089947/vbcable2.gif

            --
            73 Alberto I2PHD


          • Jurgen Bartels
            Hi Dirk, ... I assumed spectral distortions, the same that I initially oberserved here when using Speclab. After setting in/out SR to 31250 those disapeared
            Message 5 of 15 , Apr 18, 2013
            • 0 Attachment
              Hi Dirk,

              > Thanks for the tip, but if resampling is supposed to be the problem, how do
              > you explain that it can work perfectly for say, one hour, and then suddenly
              > cause the glitch I described? Also note that the phenomenon was reported for a
              > wide variety of hardware and OS-versions.

              I assumed spectral distortions, the same that I initially oberserved here when
              using Speclab. After setting in/out SR to 31250 those disapeared entirely.

              In your case it seems that after a while there is a buffer overrun or another
              hickup that causes a brief loss of samples. The reason I don't know of course.
              What I meant to say is, that VAC works flawlessly here when set to 31250 /
              31250

              In my case there was another problem: The output-audio of SpecLab showed buffer
              overuns, causing brief clicks. The reason: The soundcard fetches samples from
              SpecLab at its own rate, that might be a slightly different than the
              Perseus-VAC-delivered rate. Once I enabled SpecLab's audio resampler the
              problem was gone.


              Jurgen Bartels Suellwarden, N. Germany
              Ant. hor: 29-45MHz 7-el, 45-87MHz 11-el, FM 15.11, Band-3:13-el, UHF:48-el
              TV: Winradio G305 / Fly2000 + video noise filter & variable IF BW
              FM: Downconverter + Perseus + Speclab as WFM demod.
              MW: 300m Bev 260°, 30 x 4m EWE 320° with JB-terminator, Winradio & Perseus
              http://zeiterfassung.3sdesign.de/station_list.htm
            Your message has been successfully submitted and would be delivered to recipients shortly.