Loading ...
Sorry, an error occurred while loading the content.

Installing GuiTest with ppm on perl 5.6.x and 5.8.x

Expand Messages
  • pkaluski
    Hi, Since I have observed that some people have problems installing GuiTest using ppm I would like to share with you some of my observations: When you use ppm
    Message 1 of 1 , Mar 1, 2004
    • 0 Attachment
      Hi,
      Since I have observed that some people have problems installing
      GuiTest using ppm I would like to share with you some of my
      observations:

      When you use ppm to install perl modules, there are two levels, on
      which versions incompatibility is detected:
      1. Module_name.ppd file. This file is included in zip files added to
      "Files" section in this yahoo group. If you have a look at the file
      win32-guitest.ppd, attached to Win32-GuiTest--setfocus-1.50.zip you
      will find the following tag:

      ARCHITECTURE NAME="MSWin32-x86-multi-thread"

      I don't know what are the details of naming convention, but that means
      that this package can be installed on perl 5.6.x, and cannot be
      installed on perl 5.8.x. If you try to install it on perl 5.8.x you
      will get "Error: no suitable installation target found for package
      Win32-GuiTest" as mentioned in post 349.
      If you want the package to be installed on perl 5.8.x you have to
      modify the tag as follows:

      ARCHITECTURE NAME="MSWin32-x86-multi-thread-5.8"


      BUT....

      2. The package should be compiled with the correct version of perl. If
      it's not, then changing the ppd file will allow you to install the
      package, but you will get runtime error that some core perl dlls
      cannot be found, once you run the script.

      Hope that helps
      -Piotr
    Your message has been successfully submitted and would be delivered to recipients shortly.