Loading ...
Sorry, an error occurred while loading the content.

Multiple keystroke question

Expand Messages
  • Rick
    Hello folks, silly question but one I m stuck on. I m using: use Win32::GuiTest qw/SendKeys/; SendKeys( (^%{DELETE}) ); To atempt to send a ctrl-alt-del to a
    Message 1 of 2 , May 2, 2003
    • 0 Attachment
      Hello folks, silly question but one I'm stuck on.

      I'm using:

      use Win32::GuiTest qw/SendKeys/;
      SendKeys("(^%{DELETE})");

      To atempt to send a ctrl-alt-del to a locked NT server. I have an
      application that needs the server to be unlocked before I can start
      it running (and send more keys to _it_). I can put the script into
      the scheduler on the server, but on both the NT server and the XP
      Pro workstation I have, the (^%{DELETE}) does nothing.

      Is this just impossible?

      Thanks.

      Rick
    • Ernesto Guisado
      Hi, I think you re right in that you cannot send the CTRL+ALT+DEL sequence from a program. Probably a feature they designed in for security reasons? If you
      Message 2 of 2 , May 10, 2003
      • 0 Attachment
        Hi,

        I think you're right in that you cannot send the CTRL+ALT+DEL
        sequence from a program. Probably a feature they designed in for
        security reasons?

        If you "own" the server, there are some registry settings you can use
        to make the server logon automatically after a reboot:

        http://www.winguides.com/registry/display.php/13/

        That way the server is always ready to run your script.

        Regards,
        Ernesto.

        --- In perlguitest@yahoogroups.com, "Rick" <rick.gerdes@t...> wrote:
        > Hello folks, silly question but one I'm stuck on.
        >
        > I'm using:
        >
        > use Win32::GuiTest qw/SendKeys/;
        > SendKeys("(^%{DELETE})");
        >
        > To atempt to send a ctrl-alt-del to a locked NT server. I have an
        > application that needs the server to be unlocked before I can start
        > it running (and send more keys to _it_). I can put the script into
        > the scheduler on the server, but on both the NT server and the XP
        > Pro workstation I have, the (^%{DELETE}) does nothing.
        >
        > Is this just impossible?
        >
        > Thanks.
        >
        > Rick
      Your message has been successfully submitted and would be delivered to recipients shortly.