Loading ...
Sorry, an error occurred while loading the content.

netscape problem !!!

Expand Messages
  • Aman Raheja
    Hi all I have created a cgi-perl script for a web-site. I am using cookies and mysql for database on a Linux box. When my page is called in IE, it works great,
    Message 1 of 3 , Apr 1, 2002
    • 0 Attachment
      Hi all
      I have created a cgi-perl script for a web-site. I am using cookies and
      mysql for database on a Linux box.
      When my page is called in IE, it works great, but Netscape throws out the
      whole HTML code.
      Now, if I copy this code and save it in a file as xyz.html, it works perfect
      in Netscape. I think if the HTML code had been imperfect it would have the
      same problem, but that's not the case.
      Please help
      Thank you
      Aman

      _________________________________________________________________
      Chat with friends online, try MSN Messenger: http://messenger.msn.com
    • b_harnish
      ... It could be that you re not printing the HTTP headers in your CGI script, or any number of other things. Please post some code. Thanks for
      Message 2 of 3 , Apr 1, 2002
      • 0 Attachment
        --- In perl-beginner@y..., "Aman Raheja" <amancgiperl@h...> wrote:
        > Hi all
        > I have created a cgi-perl script for a web-site. I am using cookies and
        > mysql for database on a Linux box.
        > When my page is called in IE, it works great, but Netscape throws out the
        > whole HTML code.
        > Now, if I copy this code and save it in a file as xyz.html, it works perfect
        > in Netscape. I think if the HTML code had been imperfect it would have the
        > same problem, but that's not the case.
        > Please help
        > Thank you
        > Aman

        It could be that you're not printing the HTTP headers in your CGI script, or any number of other things. Please post some code.

        <sarcasm>Thanks for including your code, it made finding the error very easy.</sarcasm>
        - Brian
      • Jenda Krynicky
        From: Aman Raheja ... Is the content-type you send right? You do not send the page as text/plain, do you? MSIE ignores what the
        Message 3 of 3 , Apr 2, 2002
        • 0 Attachment
          From: "Aman Raheja" <amancgiperl@...>

          > Hi all
          > I have created a cgi-perl script for a web-site. I am using cookies
          > and mysql for database on a Linux box. When my page is called in IE,
          > it works great, but Netscape throws out the whole HTML code. Now, if I
          > copy this code and save it in a file as xyz.html, it works perfect in
          > Netscape. I think if the HTML code had been imperfect it would have
          > the same problem, but that's not the case. Please help Thank you Aman

          Is the content-type you send right? You do not send the page as
          text/plain, do you?

          MSIE ignores what the server says and if it sees anything that
          resembles HTML it tries to render it, while Netscape believes the
          server.

          Jenda

          =========== Jenda@... == http://Jenda.Krynicky.cz ==========
          There is a reason for living. There must be. I've seen it somewhere.
          It's just that in the mess on my table ... and in my brain
          I can't find it.
          --- me
        Your message has been successfully submitted and would be delivered to recipients shortly.