Loading ...
Sorry, an error occurred while loading the content.

problems after upgraded perl

Expand Messages
  • Chan, Raymond
    Dear All, I have installed perl 5.004, DBI and MySQL-DBD on a Linux server. All the web-based MySQL systems are running properly. Since I have to develop
    Message 1 of 2 , Feb 28, 2002
    • 0 Attachment
      Dear All,


      I have installed perl 5.004, DBI and MySQL-DBD on a Linux server.
      All the web-based MySQL systems are running properly.
      Since I have to develop web-based oracle system, I need to install
      oracle-DBD.
      But when I tried to install oracle-DBD, it said that I need to have newer
      version of DBI.
      When I tried to install DBI 1.21, it said that I need to have Perl
      5.005.003.
      Finally, I successfully installed Perl 5.005.03.

      Now, the problem is that the old perl 5.004 was installed in
      /usr/local/bin/perl.
      But I installed the new version 5.005.03 in /usr/bin/perl. For those
      existing MySQL systems,
      if I changed the compiler from #!/usr/local/bin/perl' to '#!/usr/bin/perl,
      I got internal server error messages. If I still use #!/usr/local/bin/perl
      as the compiler,
      they can still be running properly. I want to ask :

      1. can I just upgrade the perl version to 5.005.03 and keep the existing
      libarary, DBI, MySQL-DBD and everything ?
      If yes, should I just reinstall it and overwrite the old verion
      '/usr/local/bin/perl' ?

      2. if no, can I install newer DBI 1.21 and oracle-DBD for the new perl
      5.005.03 to use
      so that when I develop oracle systems in the future, use the new perl
      #!/usr/bin/perl.
      But for those existing MySQL systems, just keep using the old perl
      #!/usr/local/bin/perl ?
      But if I install newer DBI 1.21, will it affect the library of the
      existing MySQL-DBD ?
      That is, can it be like this :

      ==============================================================
      old perl 5.004 -> /usr/local/bin/perl -> old DBI -> MySQL-DBD -> MySQL
      systems
      ==============================================================
      new perl 5.005.03 -> /usr/bin/perl -> new DBI 1.21 -> Oracle-DBD -> Oracle
      systems
      ==============================================================

      or two versions of perl must be sharing the same set of DBI library ? Thank
      you very much!


      Regards,
      Raymond

      --
      WORLDCOM. THE BEST COMMUNICATION SERVICES IN THE WORLD.
      -- Based on World Communications Association 2001 Award
      For more information, visit www.worldcom.com/asiapacfic
      -----------------------------------------------------------------
      This communication contains information which is confidential and
      may also be privileged. It is for the exclusive use of the
      intended recipient(s). If you are not the intended recipient(s),
      please note that any distribution, copying or use of this
      communication or the information in it is strictly prohibited.
      If you have received this communication in error, please notify
      the sender immediately and then destroy any copies of it.
    • BMW_Bloke
      ... Latest version is 5.6. Why not upgrade to that?
      Message 2 of 2 , Mar 1, 2002
      • 0 Attachment
        --- In perl-beginner@y..., "Chan, Raymond" <chan.raymond@w...> wrote:
        > I have installed perl 5.004, DBI and MySQL-DBD on a Linux server.

        Latest version is 5.6. Why not upgrade to that?
      Your message has been successfully submitted and would be delivered to recipients shortly.