Loading ...
Sorry, an error occurred while loading the content.

Installing DBI and DBD::mysql Modules on Red Hat Linux 7.1

Expand Messages
  • Denny Malloy
    Hi, The install instructions say you have to make sure the following RPM s are installed. mysql perl_DBI perl-DBD-MySQL I was able to get the RPM s for Mysql
    Message 1 of 5 , Feb 1, 2002
    • 0 Attachment
      Hi,

      The install instructions say you have to make sure the following RPM's are
      installed.
      mysql
      perl_DBI
      perl-DBD-MySQL

      I was able to get the RPM's for Mysql and it is working fine. I searched
      Mysql and Red Hat Linux web sites for the perl-DBI and perl-DBD-MySQL RPM
      files. I only found the .tar.gz module files on mysql so I am trying to
      install them.

      It appears that the DBI module installed correctly (No Errors Anyway) but
      when I run Makefile.pm to install the DBD::mysql module I get the following
      errors:
      Can't locate loadable object for module DBI in @INC
      Can't locate Data/ShowTable.pm in @INC

      After installing the DBI module do I have to copy anything into the @INC
      library?

      This is the first time I have tried to install a module on a UNIX/Linux
      machine and I am not sure if I am doing it correctly.

      TIA

      Denny Malloy
    • Ricardo Valfreixo
      Heya, you have this wonderfull tool called CPAN :) on a sheel do perl -eshell -MCPAN then @ the prompt intall DBI or install any_module_available_on_CPAN
      Message 2 of 5 , Feb 1, 2002
      • 0 Attachment
        Heya,

        you have this wonderfull tool called CPAN :)

        on a sheel do

        perl -eshell -MCPAN

        then @ the prompt

        intall DBI

        or install any_module_available_on_CPAN

        www.cpan.org for more info :)


        Have fun.. the perl way :)


        Vx

        =============Original Message==============
        Friday, February 01, 2002, 2:08:45 PM, you wrote:

        DM> Hi,

        DM> The install instructions say you have to make sure the following RPM's are
        DM> installed.
        DM> mysql
        DM> perl_DBI
        DM> perl-DBD-MySQL

        DM> I was able to get the RPM's for Mysql and it is working fine. I searched
        DM> Mysql and Red Hat Linux web sites for the perl-DBI and perl-DBD-MySQL RPM
        DM> files. I only found the .tar.gz module files on mysql so I am trying to
        DM> install them.

        DM> It appears that the DBI module installed correctly (No Errors Anyway) but
        DM> when I run Makefile.pm to install the DBD::mysql module I get the following
        DM> errors:
        DM> Can't locate loadable object for module DBI in @INC
        DM> Can't locate Data/ShowTable.pm in @INC

        DM> After installing the DBI module do I have to copy anything into the @INC
        DM> library?

        DM> This is the first time I have tried to install a module on a UNIX/Linux
        DM> machine and I am not sure if I am doing it correctly.

        DM> TIA

        DM> Denny Malloy


        DM> Unsubscribing info is here: http://help.yahoo.com/help/us/groups/groups-32.html

        DM> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/




        --
        Peace,
        Ricardo 'Vx' Valfreixo mailto:valfreixo@...
      • Denny Malloy
        Thanks Ricardo, That makes it a lot easier. I reinstalled the DBI module using CPAN module and everything worked great! When I tried installing DBD::mysql it
        Message 3 of 5 , Feb 1, 2002
        • 0 Attachment
          Thanks Ricardo,

          That makes it a lot easier. I reinstalled the DBI module using CPAN module
          and everything worked great!

          When I tried installing DBD::mysql it blows up. Following is one of the
          errors.
          DBI object version 1.201 does not match $DBI::VERSION 1.18 at
          /usr/lib/perl5/5.6.0/i386-linux/DynaLoader.pm.

          Do I need to uninstall and then reinstall this module? If so how?
          thanks,


          Heya,

          you have this wonderfull tool called CPAN :)

          on a sheel do

          perl -eshell -MCPAN

          then @ the prompt

          intall DBI

          or install any_module_available_on_CPAN

          www.cpan.org for more info :)


          Have fun.. the perl way :)


          Vx

          =============Original Message==============
          Friday, February 01, 2002, 2:08:45 PM, you wrote:
        • Ricardo Valfreixo
          Heya, hmm i think there is a update feature.. ou verify.. don t remember.. lemme look for it.. i ll get that one back at you in 5 Vx =============Original
          Message 4 of 5 , Feb 1, 2002
          • 0 Attachment
            Heya,

            hmm i think there is a update feature.. ou verify..

            don't remember.. lemme look for it.. i'll get that one back at you
            in 5

            Vx

            =============Original Message==============
            Friday, February 01, 2002, 3:23:06 PM, you wrote:

            DM> Thanks Ricardo,

            DM> That makes it a lot easier. I reinstalled the DBI module using CPAN module
            DM> and everything worked great!

            DM> When I tried installing DBD::mysql it blows up. Following is one of the
            DM> errors.
            DM> DBI object version 1.201 does not match $DBI::VERSION 1.18 at
            DM> /usr/lib/perl5/5.6.0/i386-linux/DynaLoader.pm.

            DM> Do I need to uninstall and then reinstall this module? If so how?
            DM> thanks,


            DM> Heya,

            DM> you have this wonderfull tool called CPAN :)

            DM> on a sheel do

            DM> perl -eshell -MCPAN

            DM> then @ the prompt

            DM> intall DBI

            DM> or install any_module_available_on_CPAN

            DM> www.cpan.org for more info :)


            DM> Have fun.. the perl way :)


            DM> Vx

            DM> =============Original Message==============
            DM> Friday, February 01, 2002, 2:08:45 PM, you wrote:


            DM> Unsubscribing info is here: http://help.yahoo.com/help/us/groups/groups-32.html

            DM> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/




            --
            Peace,
            Ricardo 'Vx' Valfreixo mailto:valfreixo@...
          • Ricardo Valfreixo
            Heya, ok, you can force an install, therefore overwriting the previous module.. i usualy only code.. and ask the admin (BOFH) to install and update the
            Message 5 of 5 , Feb 1, 2002
            • 0 Attachment
              Heya,

              ok, you can force an install, therefore overwriting the previous
              module.. i usualy only code.. and ask the admin (BOFH) to install
              and update the packages.. i only intall on NT/2000 machines.. for
              my tests and stuff...

              The main CPAN help is @ http://www.perldoc.com/perl5.6.1/lib/CPAN.html

              You can find a lot of info there.. and hopefully someone more
              experienced that i am will see this post and complete my info/goof
              of ehe :)


              Vx



              =============Original Message==============
              Friday, February 01, 2002, 3:31:55 PM, you wrote:

              RV> Heya,

              RV> hmm i think there is a update feature.. ou verify..

              RV> don't remember.. lemme look for it.. i'll get that one back at you
              RV> in 5

              RV> Vx

              RV> =============Original Message==============
              RV> Friday, February 01, 2002, 3:23:06 PM, you wrote:

              DM>> Thanks Ricardo,

              DM>> That makes it a lot easier. I reinstalled the DBI module using CPAN module
              DM>> and everything worked great!

              DM>> When I tried installing DBD::mysql it blows up. Following is one of the
              DM>> errors.
              DM>> DBI object version 1.201 does not match $DBI::VERSION 1.18 at
              DM>> /usr/lib/perl5/5.6.0/i386-linux/DynaLoader.pm.

              DM>> Do I need to uninstall and then reinstall this module? If so how?
              DM>> thanks,


              DM>> Heya,

              DM>> you have this wonderfull tool called CPAN :)

              DM>> on a sheel do

              DM>> perl -eshell -MCPAN

              DM>> then @ the prompt

              DM>> intall DBI

              DM>> or install any_module_available_on_CPAN

              DM>> www.cpan.org for more info :)


              DM>> Have fun.. the perl way :)


              DM>> Vx

              DM>> =============Original Message==============
              DM>> Friday, February 01, 2002, 2:08:45 PM, you wrote:


              DM>> Unsubscribing info is here: http://help.yahoo.com/help/us/groups/groups-32.html

              DM>> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/







              --
              Peace,
              Ricardo 'Vx' Valfreixo mailto:valfreixo@...
            Your message has been successfully submitted and would be delivered to recipients shortly.