Loading ...
Sorry, an error occurred while loading the content.
 

Re: [PBML] activeperl/apache/win95 problems

Expand Messages
  • Bompa
    ... But have you configured Apache? Do you have lines similar to this: AddHandler cgi-script .cgi .pl ScriptAlias /cgi-bin/ C:/Apache/cgi-bin/ I m no Apache
    Message 1 of 3 , Dec 2, 2001
      keslerdan@... wrote:
      >
      > Hi everybody.
      > I have installed recently the above configuration and I can't get
      > things to work form me. Anyone has any idea? The Apache seems to be
      > working fine. When I'm calling an html file I get the expected
      > results. But when I'm calling a .pl file, in the same directory, what
      > I'm getting is the source code of that file and not it's expected
      > product...
      > I have edited the registry to point the .pl to my activeperl perl.exe
      > to look like this:
      > REGEDIT4
      >
      > [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\W3SVC\Parameters
      > \Script Map]
      > ".pl"="e:\\Perl\\bin\\Perl.exe %s %s"
      > ".cgi"="e:\\perl\\bin\\perl.exe %s %s"


      But have you configured Apache? Do you have lines similar to this:


      AddHandler cgi-script .cgi .pl
      ScriptAlias /cgi-bin/ "C:/Apache/cgi-bin/"


      I'm no Apache guru, but I'd say look into those.

      Bompa






      --

      http://www.pureperl.org
      http://www.afreeirc.net
    • keslerdan@yahoo.com
      Thanks a lot Bompa! It turns out that my AddHandler cgi-script .cgi .pl line was missing the .pl in it... Danny. ... be ... what ... perl.exe ...
      Message 2 of 3 , Dec 3, 2001
        Thanks a lot Bompa!
        It turns out that my AddHandler cgi-script .cgi .pl
        line was missing the .pl in it...
        Danny.
        --- In perl-beginner@y..., Bompa <bompa@t...> wrote:
        >
        >
        > keslerdan@y... wrote:
        > >
        > > Hi everybody.
        > > I have installed recently the above configuration and I can't get
        > > things to work form me. Anyone has any idea? The Apache seems to
        be
        > > working fine. When I'm calling an html file I get the expected
        > > results. But when I'm calling a .pl file, in the same directory,
        what
        > > I'm getting is the source code of that file and not it's expected
        > > product...
        > > I have edited the registry to point the .pl to my activeperl
        perl.exe
        > > to look like this:
        > > REGEDIT4
        > >
        > >
        [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\W3SVC\Parameters
        > > \Script Map]
        > > ".pl"="e:\\Perl\\bin\\Perl.exe %s %s"
        > > ".cgi"="e:\\perl\\bin\\perl.exe %s %s"
        >
        >
        > But have you configured Apache? Do you have lines similar to this:
        >
        >
        > AddHandler cgi-script .cgi .pl
        > ScriptAlias /cgi-bin/ "C:/Apache/cgi-bin/"
        >
        >
        > I'm no Apache guru, but I'd say look into those.
        >
        > Bompa
        >
        >
        >
        >
        >
        >
        > --
        >
        > http://www.pureperl.org
        > http://www.afreeirc.net
      Your message has been successfully submitted and would be delivered to recipients shortly.