Loading ...
Sorry, an error occurred while loading the content.

Re: [PBML] Problems using

Expand Messages
  • Tom Barron
    ... What happens when you send the script output to a file and have your browser load the file? Does it behave the same? What if you have your browser load
    Message 1 of 2 , Jul 12, 2000
    • 0 Attachment
      capela@... wrote:
      >
      > I´m using sript to create an HTML document (a form, for example)
      >
      > I can send HTML tags to browser normally.
      >
      > But, when I use <img src = "xxxx.GIF">, instead of showing the image
      > inside the browser, it´s calling an external program (ACDSee, in
      > this
      > case) to show the image.
      >
      > Whats going wrong ?

      What happens when you send the script output to a file and have your
      browser load the file? Does it behave the same?

      What if you have your browser load xxxx.GIF directly?

      In any case, this sounds more like a browser or HTML problem than a perl
      question. You might be able to get more help on a list oriented to
      those topics.

      Tom
    • capela@usa.com
      ... example) ... image ... in ... perl ... Thanks Tom, But let me explain better : 1- My test environment is : NT Workstaion + Sambar Server 4.1 + Perl v
      Message 2 of 2 , Jul 12, 2000
      • 0 Attachment
        --- In perl-beginner@egroups.com, Tom Barron <tbarron@m...> wrote:
        > capela@u... wrote:
        > >
        > > I´m using sript to create an HTML document (a form, for
        example)
        > >
        > > I can send HTML tags to browser normally.
        > >
        > > But, when I use <img src = "xxxx.GIF">, instead of showing the
        image
        > > inside the browser, it´s calling an external program (ACDSee,
        in
        > > this
        > > case) to show the image.
        > >
        > > Whats going wrong ?
        >
        > What happens when you send the script output to a file and have your
        > browser load the file? Does it behave the same?
        >
        > What if you have your browser load xxxx.GIF directly?
        >
        > In any case, this sounds more like a browser or HTML problem than a
        perl
        > question. You might be able to get more help on a list oriented to
        > those topics.
        >
        > Tom


        Thanks Tom,

        But let me explain better :

        1- My test environment is : "NT Workstaion" + "Sambar Server 4.1" +
        "Perl v 5.6.0 from Active State"

        2- I have made an HTML test page with "Personal FrontPage",
        containing
        a simple form and an image at bottom

        3- When I try to open this html page directly, it works fine, showing
        the form AND the image

        4- I cut and paste these html codes into my script

        5- I just call the script (ex: URL =
        "http://10.100.100.152/cgi-bin/rpident.pl"), and the error occurs, I
        mean, part of the form is shown, but when it would show the image, it
        call the ACDSee to do that ! And, if I "View > Page Source", the code
        looks ok.

        6- If I go to another machine, and call my script, the problem
        still happens... But does not call a external program. Thats why I
        think its a Perl problem.

        7- I´m trying to use Apache (for NT), and the problem still
        persists.
        But, instead of calling "ACDSee", it just shows nothing (just a broke
        image symbol).

        Thats a weird behave : Why the browser (or script) is calling an
        external program ?

        Hope that explains better my problem.

        Thank ya.

        [Marcello Capelati.]
      Your message has been successfully submitted and would be delivered to recipients shortly.