Loading ...
Sorry, an error occurred while loading the content.

Re: [PBML] MD5.pm

Expand Messages
  • Gary Taylor
    Man that is strange, I came up with the same error late last night when I installed PDFLib. Except that my error indicated that perl was searching in
    Message 1 of 12 , Aug 3, 2001
    • 0 Attachment
      Man that is strange, I came up with the same error late last night when I
      installed PDFLib. Except that my error indicated that perl was searching in
      perl5/5.00503, which I have installed, however I have upgraded (I thought) to
      perl5.6.1. When I run the version I get:
      perl -v

      This is perl, v5.6.1 built for i686-linux
      Copyright 1987-2001, Larry Wall

      When I try my script, (which requires at least perl5.5), I get:

      Use of uninitialized value at ./hello.cgi line 5.
      Can't locate PDFLib.pm in @INC (@INC
      contains: /usr/lib/perl5/5.00503/i386-linux /usr/lib/perl5/5.00503
      /usr/lib/perl5/site_perl/5.005/i386-linux /usr/lib/perl5/site_perl/5.005
      .) at ./hello.cgi line 6.
      BEGIN failed--compilation aborted at ./hello.cgi line 6.


      I do have PDFLib.pm at
      /usr/local/lib/perl5/site_perl/5.6.1/PDFLib.pm
      And as far as I can tell PDFLib is properly installed.

      My GUESS is that I could symbolic link the older perl files to the new ones,
      but I could be all wrong, and would prefer to have everyone tell me I'm wrong
      before I screw up my entire perl. Also, I'm not sure of which files to
      link. Are there any howtos or articles out there discussing this problem.
      Any help apperciated.

      Gary



      Evan James Dembskey wrote:

      > Hi,
      >
      > I am busy writing a small mail client using Mail::POP3Client. However,
      > whenever I try to execute my script I get this error:
      >
      > Can't locate MD5.pm in @INC (@INC contains:
      > /usr/local/lib/perl5/alpha-dec_osf/5.00401 /usr/local/lib/perl5
      > /usr/local/lib/perl5/si
      >
      > What does this mean, and how can I fix it?
      >
      > I am running:
      >
      > {trm6}{evan}>perl -V
      > Summary of my perl5 (5.0 patchlevel 4 subversion 1) configuration:
      > Platform:
      > osname=dec_osf, osvers=4.0, archname=alpha-dec_osf
      > uname='osf1 osfwork199 v4.0 878 alpha '
      > hint=recommended, useposix=true, d_sigaction=define
      > bincompat3=y useperlio= d_sfio=
      > Compiler:
      > cc='cc', optimize='-O4', gccversion=
      > cppflags='-std -D_INTRINSICS -D__LANGUAGE_C__'
      > ccflags ='-std -D_INTRINSICS -D__LANGUAGE_C__'
      > stdchar='unsigned char', d_stdstdio=define, usevfork=false
      > voidflags=15, castflags=0, d_casti32=define, d_castneg=define
      > intsize=4, alignbytes=8, usemymalloc=y, randbits=15
      > Linker and Libraries:
      > ld='ld', ldflags =' -L/usr/local/lib'
      > libpth=/usr/local/lib /usr/shlib /shlib /lib /usr/lib /usr/ccs/lib
      > libs=-lnet -ldbm -ldb -lm
      > libc=/usr/shlib/libc.so, so=so
      > useshrplib=true, libperl=libperl.so
      > Dynamic Linking:
      > dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=,
      > cdlflags=' -Wl,-rpath,/usr/local/lib/perl5/alpha-dec_osf/5.00401/CORE'
      > cccdlflags='-call_shared', lddlflags='-shared -expect_unresolved
      > "*" -O4 -msym -s -L/usr/local/lib'
      >
      > Characteristics of this binary (from libperl):
      > Built under dec_osf
      > Compiled at Apr 22 1998 12:31:11
      > @INC:
      > /usr/local/lib/perl5/alpha-dec_osf/5.00401
      > /usr/local/lib/perl5
      > /usr/local/lib/perl5/site_perl/alpha-dec_osf
      > /usr/local/lib/perl5/site_perl
      >
      > Regards,
      >
      > Evan
      >
      >
      >
      >
      > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
    • Andrew Plumb
      install this module:http://www.cpan.org/authors/id/G/GA/GAAS/Digest-MD5-2.14.tar.gzit contains md5.pm .... maybe something in your mail client includes a
      Message 2 of 12 , Aug 3, 2001
      • 0 Attachment
        install this module:

        http://www.cpan.org/authors/id/G/GA/GAAS/Digest-MD5-2.14.tar.gz

        it contains md5.pm .... maybe something in your mail client includes
        a module which requires md5.

        techplumb.

        ----- Original Message -----
        From: Evan James Dembskey <evan@...>
        To: Perl-Beginner <perl-beginner@yahoogroups.com>
        Sent: Friday, August 03, 2001 7:30 PM
        Subject: [PBML] MD5.pm


        > Hi,
        >
        >
        > I am busy writing a small mail client using Mail::POP3Client. However,
        > whenever I try to execute my script I get this error:
        >
        > Can't locate MD5.pm in @INC (@INC contains:
        > /usr/local/lib/perl5/alpha-dec_osf/5.00401 /usr/local/lib/perl5
        > /usr/local/lib/perl5/si
        >
        > What does this mean, and how can I fix it?
        >
        > I am running:
        >
        > {trm6}{evan}>perl -V
        > Summary of my perl5 (5.0 patchlevel 4 subversion 1) configuration:
        > Platform:
        > osname=dec_osf, osvers=4.0, archname=alpha-dec_osf
        > uname='osf1 osfwork199 v4.0 878 alpha '
        > hint=recommended, useposix=true, d_sigaction=define
        > bincompat3=y useperlio= d_sfio=
        > Compiler:
        > cc='cc', optimize='-O4', gccversion=
        > cppflags='-std -D_INTRINSICS -D__LANGUAGE_C__'
        > ccflags ='-std -D_INTRINSICS -D__LANGUAGE_C__'
        > stdchar='unsigned char', d_stdstdio=define, usevfork=false
        > voidflags=15, castflags=0, d_casti32=define, d_castneg=define
        > intsize=4, alignbytes=8, usemymalloc=y, randbits=15
        > Linker and Libraries:
        > ld='ld', ldflags =' -L/usr/local/lib'
        > libpth=/usr/local/lib /usr/shlib /shlib /lib /usr/lib /usr/ccs/lib
        > libs=-lnet -ldbm -ldb -lm
        > libc=/usr/shlib/libc.so, so=so
        > useshrplib=true, libperl=libperl.so
        > Dynamic Linking:
        > dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=,
        > cdlflags=' -Wl,-rpath,/usr/local/lib/perl5/alpha-dec_osf/5.00401/CORE'
        > cccdlflags='-call_shared', lddlflags='-shared -expect_unresolved
        > "*" -O4 -msym -s -L/usr/local/lib'
        >
        >
        > Characteristics of this binary (from libperl):
        > Built under dec_osf
        > Compiled at Apr 22 1998 12:31:11
        > @INC:
        > /usr/local/lib/perl5/alpha-dec_osf/5.00401
        > /usr/local/lib/perl5
        > /usr/local/lib/perl5/site_perl/alpha-dec_osf
        > /usr/local/lib/perl5/site_perl
        >
        >
        > Regards,
        >
        > Evan
        >
        >
        >
        >
        >
        > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
        >


        _________________________________________________________
        Do You Yahoo!?
        Get your free @... address at http://mail.yahoo.com
      • jonathansamuel@yahoo.com
        Or if md5.pm already exists on his machine he could place at the top of his script: use lib /insert/path/to/md5.pm/here ; However I agree that the most likely
        Message 3 of 12 , Aug 3, 2001
        • 0 Attachment
          Or if md5.pm already exists on his machine he could place at the top
          of his script:

          use lib '/insert/path/to/md5.pm/here';

          However I agree that the most likely problem is simply that md5.pm
          has not been installed at all on the machine.


          --- In perl-beginner@y..., "Andrew Plumb" <techplumb@y...> wrote:
          > install this module:
          >
          > http://www.cpan.org/authors/id/G/GA/GAAS/Digest-MD5-2.14.tar.gz
          >
          > it contains md5.pm .... maybe something in your mail client includes
          > a module which requires md5.
          >
          > techplumb.
          >
          > ----- Original Message -----
          > From: Evan James Dembskey <evan@t...>
          > To: Perl-Beginner <perl-beginner@y...>
          > Sent: Friday, August 03, 2001 7:30 PM
          > Subject: [PBML] MD5.pm
          >
          >
          > > Hi,
          > >
          > >
          > > I am busy writing a small mail client using Mail::POP3Client.
          However,
          > > whenever I try to execute my script I get this error:
          > >
          > > Can't locate MD5.pm in @INC (@INC contains:
          > > /usr/local/lib/perl5/alpha-dec_osf/5.00401 /usr/local/lib/perl5
          > > /usr/local/lib/perl5/si
          > >
          > > What does this mean, and how can I fix it?
          > >
          > > I am running:
          > >
          > > {trm6}{evan}>perl -V
          > > Summary of my perl5 (5.0 patchlevel 4 subversion 1) configuration:
          > > Platform:
          > > osname=dec_osf, osvers=4.0, archname=alpha-dec_osf
          > > uname='osf1 osfwork199 v4.0 878 alpha '
          > > hint=recommended, useposix=true, d_sigaction=define
          > > bincompat3=y useperlio= d_sfio=
          > > Compiler:
          > > cc='cc', optimize='-O4', gccversion=
          > > cppflags='-std -D_INTRINSICS -D__LANGUAGE_C__'
          > > ccflags ='-std -D_INTRINSICS -D__LANGUAGE_C__'
          > > stdchar='unsigned char', d_stdstdio=define, usevfork=false
          > > voidflags=15, castflags=0, d_casti32=define, d_castneg=define
          > > intsize=4, alignbytes=8, usemymalloc=y, randbits=15
          > > Linker and Libraries:
          > > ld='ld', ldflags =' -L/usr/local/lib'
          > >
          libpth=/usr/local/lib /usr/shlib /shlib /lib /usr/lib /usr/ccs/lib
          > > libs=-lnet -ldbm -ldb -lm
          > > libc=/usr/shlib/libc.so, so=so
          > > useshrplib=true, libperl=libperl.so
          > > Dynamic Linking:
          > > dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=,
          > > cdlflags=' -Wl,-rpath,/usr/local/lib/perl5/alpha-
          dec_osf/5.00401/CORE'
          > > cccdlflags='-call_shared', lddlflags='-shared -
          expect_unresolved
          > > "*" -O4 -msym -s -L/usr/local/lib'
          > >
          > >
          > > Characteristics of this binary (from libperl):
          > > Built under dec_osf
          > > Compiled at Apr 22 1998 12:31:11
          > > @INC:
          > > /usr/local/lib/perl5/alpha-dec_osf/5.00401
          > > /usr/local/lib/perl5
          > > /usr/local/lib/perl5/site_perl/alpha-dec_osf
          > > /usr/local/lib/perl5/site_perl
          > >
          > >
          > > Regards,
          > >
          > > Evan
          > >
          > >
          > >
          > >
          > >
          > > Your use of Yahoo! Groups is subject to
          http://docs.yahoo.com/info/terms/
          > >
          >
          >
          > _________________________________________________________
          > Do You Yahoo!?
          > Get your free @... address at http://mail.yahoo.com
        • Evan James Dembskey
          Hi, Thanks. I have installed the module from http://www.cpan.org/authors/id/G/GA/GAAS/Digest-MD5-2.14.tar.gz but now I get: Can t find loadable object for
          Message 4 of 12 , Aug 6, 2001
          • 0 Attachment
            Hi,

            Thanks. I have installed the module from
            http://www.cpan.org/authors/id/G/GA/GAAS/Digest-MD5-2.14.tar.gz but now I
            get:

            Can't find loadable object for module Digest::MD5 in @INC
            (/usr/local/lib/perl5/alpha-dec_osf/5.00401 /usr/local/lib/perl5 /usr/loc0

            How do I fic this problem?


            Regards,

            Evan


            > install this module:
            >
            > http://www.cpan.org/authors/id/G/GA/GAAS/Digest-MD5-2.14.tar.gz
            >
            > it contains md5.pm .... maybe something in your mail client includes
            > a module which requires md5.
            >
            > techplumb.
            >
            > ----- Original Message -----
            > From: Evan James Dembskey <evan@...>

            > Subject: [PBML] MD5.pm
            >
            >
            > > Hi,
            > >
            > >
            > > I am busy writing a small mail client using Mail::POP3Client. However,
            > > whenever I try to execute my script I get this error:
            > >
            > > Can't locate MD5.pm in @INC (@INC contains:
            > > /usr/local/lib/perl5/alpha-dec_osf/5.00401 /usr/local/lib/perl5
            > > /usr/local/lib/perl5/si
            > >
            > > What does this mean, and how can I fix it?
          • Andrew Plumb
            ?? Sorry, I m no expert..... I think MD5.pm requires the Digest module. Not sure if this will solve it though..... give it a try.... unless advised otherwise
            Message 5 of 12 , Aug 6, 2001
            • 0 Attachment
              ??
              Sorry, I'm no expert.....
              I think MD5.pm requires the Digest module. Not sure if
              this will solve it though..... give it a try....
              unless advised otherwise by someone on this list who IS
              an expert in perl stuff...

              http://www.cpan.org/authors/id/G/GA/GAAS/Digest-1.00.tar.gz

              Anyone else have ideas ?



              ----- Original Message -----
              From: Evan James Dembskey <evan@...>
              To: <perl-beginner@yahoogroups.com>
              Sent: Monday, August 06, 2001 6:00 PM
              Subject: RE: [PBML] MD5.pm


              > Hi,
              >
              > Thanks. I have installed the module from
              > http://www.cpan.org/authors/id/G/GA/GAAS/Digest-MD5-2.14.tar.gz but now I
              > get:
              >
              > Can't find loadable object for module Digest::MD5 in @INC
              > (/usr/local/lib/perl5/alpha-dec_osf/5.00401 /usr/local/lib/perl5 /usr/loc0
              >
              > How do I fic this problem?
              >
              >
              > Regards,
              >
              > Evan
              >
              >
              > > install this module:
              > >
              > > http://www.cpan.org/authors/id/G/GA/GAAS/Digest-MD5-2.14.tar.gz
              > >
              > > it contains md5.pm .... maybe something in your mail client includes
              > > a module which requires md5.
              > >
              > > techplumb.
              > >
              > > ----- Original Message -----
              > > From: Evan James Dembskey <evan@...>
              >
              > > Subject: [PBML] MD5.pm
              > >
              > >
              > > > Hi,
              > > >
              > > >
              > > > I am busy writing a small mail client using Mail::POP3Client. However,
              > > > whenever I try to execute my script I get this error:
              > > >
              > > > Can't locate MD5.pm in @INC (@INC contains:
              > > > /usr/local/lib/perl5/alpha-dec_osf/5.00401 /usr/local/lib/perl5
              > > > /usr/local/lib/perl5/si
              > > >
              > > > What does this mean, and how can I fix it?
              >
              >
              >
              >
              >
              > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
              >


              _________________________________________________________
              Do You Yahoo!?
              Get your free @... address at http://mail.yahoo.com
            • Evan James Dembskey
              Hi, Thanks again. I have installed the digest module, and now I get: Can t locate object method hexhash via package MD5 at
              Message 6 of 12 , Aug 6, 2001
              • 0 Attachment
                Hi,


                Thanks again. I have installed the digest module, and now I get:


                Can't locate object method "hexhash" via package "MD5" at
                /usr/local/lib/perl5/site_perl/Mail/POP3Client.pm line 384, <GEN0> chunk


                Heheh! What now?


                > I think MD5.pm requires the Digest module. Not sure if
                > this will solve it though..... give it a try....
                > unless advised otherwise by someone on this list who IS
                > an expert in perl stuff...
                >
                > http://www.cpan.org/authors/id/G/GA/GAAS/Digest-1.00.tar.gz



                Regards,

                Evan
              • Andrew Plumb
                http://www.cpan.org/authors/id/G/GA/GAAS/Digest-HMAC-1.01.tar.gz?----- Original Message ----- From: Evan James Dembskey To:
                Message 7 of 12 , Aug 6, 2001
                • 0 Attachment
                  http://www.cpan.org/authors/id/G/GA/GAAS/Digest-HMAC-1.01.tar.gz

                  ?


                  ----- Original Message -----
                  From: Evan James Dembskey <evan@...>
                  To: <perl-beginner@yahoogroups.com>
                  Sent: Monday, August 06, 2001 7:30 PM
                  Subject: RE: [PBML] MD5.pm


                  > Hi,
                  >
                  >
                  > Thanks again. I have installed the digest module, and now I get:
                  >
                  >
                  > Can't locate object method "hexhash" via package "MD5" at
                  > /usr/local/lib/perl5/site_perl/Mail/POP3Client.pm line 384, <GEN0> chunk
                  >
                  >
                  > Heheh! What now?
                  >
                  >
                  > > I think MD5.pm requires the Digest module. Not sure if
                  > > this will solve it though..... give it a try....
                  > > unless advised otherwise by someone on this list who IS
                  > > an expert in perl stuff...
                  > >
                  > > http://www.cpan.org/authors/id/G/GA/GAAS/Digest-1.00.tar.gz
                  >
                  >
                  >
                  > Regards,
                  >
                  > Evan
                  >
                  >
                  >
                  >
                  >
                  > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                  >


                  _________________________________________________________
                  Do You Yahoo!?
                  Get your free @... address at http://mail.yahoo.com
                • Evan James Dembskey
                  ... Added that and had to add Digest-SHA1-2.00.tar.gz too, and I still get: Can t locate object method hexhash via package MD5 at
                  Message 8 of 12 , Aug 6, 2001
                  • 0 Attachment
                    > http://www.cpan.org/authors/id/G/GA/GAAS/Digest-HMAC-1.01.tar.gz
                    >
                    > ?


                    Added that and had to add Digest-SHA1-2.00.tar.gz too, and I still
                    get:



                    Can't locate object method "hexhash" via package "MD5" at
                    /usr/local/lib/perl5/site_perl/Mail/POP3Client.pm line 384, <GEN0> chunk .


                    Regards,

                    Evan
                  • Andrew Plumb
                    well, I m out of ideas then.... anyone else ??I m sure when I installed it on my Linux system a while ago, I didn t have any probs...what functions are
                    Message 9 of 12 , Aug 6, 2001
                    • 0 Attachment
                      well, I'm out of ideas then.... anyone else ??


                      I'm sure when I installed it on my Linux system
                      a while ago, I didn't have any probs...

                      what functions are you calling ?

                      techplumb.


                      ----- Original Message -----
                      From: Evan James Dembskey <evan@...>

                      > > http://www.cpan.org/authors/id/G/GA/GAAS/Digest-HMAC-1.01.tar.gz
                      > >
                      > > ?
                      >
                      >
                      > Added that and had to add Digest-SHA1-2.00.tar.gz too, and I still
                      > get:
                      >
                      >
                      >
                      > Can't locate object method "hexhash" via package "MD5" at
                      > /usr/local/lib/perl5/site_perl/Mail/POP3Client.pm line 384, <GEN0> chunk .
                      >
                      >
                      > Regards,
                      >
                      > Evan



                      _________________________________________________________
                      Do You Yahoo!?
                      Get your free @... address at http://mail.yahoo.com
                    • Daniel Gardner
                      http://www.cpan.org/authors/id/GAAS/MD5-2.02.tar.gz From the README: This module is depreciated. Please use Digest::MD5 instead. This module (MD5.pm) is just
                      Message 10 of 12 , Aug 6, 2001
                      • 0 Attachment
                        http://www.cpan.org/authors/id/GAAS/MD5-2.02.tar.gz

                        From the README:

                        This module is depreciated. Please use Digest::MD5 instead.

                        This module (MD5.pm) is just a thin wrapper around the Digest::MD5
                        module. It is provided so that legacy code that rely on the old
                        interface continue to work with the speed benefit of the new module.

                        You will need perl version 5.004 or better to install this module.
                        The Digest::MD5 module must be installed.



                        AP> well, I'm out of ideas then.... anyone else ??


                        AP> I'm sure when I installed it on my Linux system
                        AP> a while ago, I didn't have any probs...

                        AP> what functions are you calling ?

                        AP> techplumb.


                        AP> ----- Original Message -----
                        AP> From: Evan James Dembskey <evan@...>

                        >> > http://www.cpan.org/authors/id/G/GA/GAAS/Digest-HMAC-1.01.tar.gz
                        >> >
                        >> > ?
                        >>
                        >>
                        >> Added that and had to add Digest-SHA1-2.00.tar.gz too, and I still
                        >> get:
                        >>
                        >>
                        >>
                        >> Can't locate object method "hexhash" via package "MD5" at
                        >> /usr/local/lib/perl5/site_perl/Mail/POP3Client.pm line 384, <GEN0> chunk .
                        >>
                        >>
                        >> Regards,
                        >>
                        >> Evan




                        AP> _________________________________________________________

                        AP> Do You Yahoo!?

                        AP> Get your free @... address at http://mail.yahoo.com







                        AP> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                      • Evan James Dembskey
                        Hi, I have used this module, but still get the same error. Evan
                        Message 11 of 12 , Aug 7, 2001
                        • 0 Attachment
                          Hi,


                          I have used this module, but still get the same error.


                          Evan



                          > http://www.cpan.org/authors/id/GAAS/MD5-2.02.tar.gz
                          >
                          > From the README:
                          >
                          > This module is depreciated. Please use Digest::MD5 instead.
                          >
                          > This module (MD5.pm) is just a thin wrapper around the Digest::MD5
                          > module. It is provided so that legacy code that rely on the old
                          > interface continue to work with the speed benefit of the new module.
                          >
                          > You will need perl version 5.004 or better to install this module.
                          > The Digest::MD5 module must be installed.
                        • imacat
                          ... From: Gary Taylor To: Sent: Friday, August 03, 2001 10:49 PM Subject: Re: [PBML] MD5.pm ... last night
                          Message 12 of 12 , Aug 7, 2001
                          • 0 Attachment
                            ----- Original Message -----
                            From: "Gary Taylor" <1@...>
                            To: <perl-beginner@yahoogroups.com>
                            Sent: Friday, August 03, 2001 10:49 PM
                            Subject: Re: [PBML] MD5.pm


                            > Man that is strange, I came up with the same error late
                            last night when I
                            > installed PDFLib. Except that my error indicated that
                            perl was searching in
                            > perl5/5.00503, which I have installed, however I have
                            upgraded (I thought) to
                            > perl5.6.1. When I run the version I get:
                            > perl -v
                            >
                            > This is perl, v5.6.1 built for i686-linux
                            > Copyright 1987-2001, Larry Wall
                            >
                            > When I try my script, (which requires at least perl5.5), I
                            get:
                            >
                            > Use of uninitialized value at ./hello.cgi line 5.
                            > Can't locate PDFLib.pm in @INC (@INC
                            > contains: /usr/lib/perl5/5.00503/i386-linux
                            /usr/lib/perl5/5.00503
                            > /usr/lib/perl5/site_perl/5.005/i386-linux
                            /usr/lib/perl5/site_perl/5.005
                            > .) at ./hello.cgi line 6.
                            > BEGIN failed--compilation aborted at ./hello.cgi line 6.
                            >
                            >
                            > I do have PDFLib.pm at
                            > /usr/local/lib/perl5/site_perl/5.6.1/PDFLib.pm
                            > And as far as I can tell PDFLib is properly installed.


                            1.Your perl 5.6.1 was installed at /usr/local
                            2.Your perl 5.00503 (distributed with your linux) is at /usr
                            3./usr/bin is listed before /usr/local/bin in your path
                            So when you run perl -v, it looks for the @INC of your old
                            perl, which is hardcoded into it's binary. The new @INC is
                            hardcoded in your new perl in the /usr/local/bin/perl, but
                            it never runs.

                            Solution:
                            1.Reinstall your perl at /usr.
                            2.List /usr/local/bin before /usr/bin in your path.
                            3.Specify that your want to run /usr/local/bin/perl at the
                            first line of your perl program.
                            #!/usr/local/bin/perl

                            Best regards,
                            imacat ^_*'
                            imacat@...

                            <<Woman's Voice>> News: http://www.wov.idv.tw/
                            Tavern IMACAT's: http://www.imacat.idv.tw/
                            Previous NTU Palm BBS Les board: telnet 140.112.1.6
                          Your message has been successfully submitted and would be delivered to recipients shortly.