Loading ...
Sorry, an error occurred while loading the content.

Math-Pari install

Expand Messages
  • Dukelow, Don
    I m trying to install Math-Pari-2.010800 Perl module. When I run the perl Makefile.PL command I get the following errors. I can t find the pari library
    Message 1 of 1 , Jan 26, 2009
    • 0 Attachment
      I'm trying to install Math-Pari-2.010800 Perl module. When I run the "perl Makefile.PL" command I get the following errors. I can't find the pari library version 2.1.7. The oldest I can find is version 2.3.0. Even then when I do a "make all" command I get the errors

      cc: Warning: -xarch=v9 is deprecated, use -m64 to create 64-bit programs
      "/home/dciproj/tmp/pm/pari-2.3.0/src/gp/highlvl.c", line 34: undefined symbol: DL_DFLT_NAME
      "/home/dciproj/tmp/pm/pari-2.3.0/src/gp/highlvl.c", line 34: warning: improper pointer/integer combination: op "="

      anyway. Can anyone help me eighter find pari 2.1.7 or tell me how to get Math-Pari-2.010800 installed? I'm doing this to get Perl::SSH to work cleanly,

      perl Makefile.PL paridir=/home/dciproj/tmp/pm/pari-2.3.4 CC=cc Configure
      Setting up Math::Pari with Perl 5.010000 on solaris version 2.8;
      cc=cc, gccversion=, ccflags='-D_REENTRANT -xarch=v9 -DUSE_SITECUSTOMIZE -DPRIVLIB_LAST_IN_INC -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
      ld=cc, ldflags=' -xarch=v9 -L/opt/SUNWspro/prod/lib/v9 -L/usr/lib/sparcv9 -L/usr/ccs/lib/sparcv9 ', optimize='-O'.
      Found GP/PARI build directory in /home/dciproj/tmp/pm/pari-2.3.4
      (integer-formatted version 2003004).

      ### Math::Pari support of GP/PARI library version 2.3.* should be
      ### considered cursory only. One may need to downgrade to 2.1.7,
      ### or run Makefile.PL with option machine=none if the tests fail.

      ### The test t/55_intnum.t takes a very long time to complete.

      ### The following subtests are known to fail:

      ### t/55_intnum.t 51 2 3.92% 12 50
      ### t/55_ploth.t 34 1 2.94% 4
      ### t/55_program.t 37 1 2.70% 2

      Found /home/dciproj/tmp/pm/pari-2.3.4/Osolaris-sparcv9/paricfg.h, copying it to libPARI...
      Checking if your kit is complete...
      Looks good
      ...Processor of family `port' detected
      ...I will use portable assembler-less build
      sh: as: not found
      sh: as: not found
      ...Assembler is not GNU assembler
      Writing Makefile for Math::PARI::libPARI
      Writing Makefile for Math::Pari
      wnpsitsl:/home/dciproj/tmp/pm/Math-Pari-2.010800 $ ^D

      script done on Mon Jan 26 09:32:43 2009
      -----
      Don Dukelow
      HP/GM GSC33 License Team
      Tel: 810-728-3388
      e-mail: dukelow@...
    Your message has been successfully submitted and would be delivered to recipients shortly.